Support » Allgemeine Fragen » Https und permalink

  • Gelöst akarinmagic

    (@akarinmagic)


    Hallo zusammen,
    ich wollte auf https umstellen. Also habe ich erstmal die Adressen in den Allgemeinen Einstellungen umgestellt.
    Dann musste ich mich neu Anmelden.
    Dann habe ich die Permalinks auf Beitragsname eingestellt und Änderung speichern gedrückt.
    Alle Links in den Posts habe ich dann auch auf https umgestellt.

    Jetzt komme ich auf die Startseite. Wenn ich die Seite mit https://Domain.de/Beitragsseite aufrufe, kommt ein 404 Page not found. Wenn ich allerdings die Seite über https://Domain.de/?p=3 aufrufe, wird die Seite angezeigt.

    .htaccess gelöscht – Permalinks nochmal gespeichert. Nichts hat geholfen.

    Die Seite befindet sich in meinem Netzwerk und ist von Außen nicht erreichbar.

    Sobald ich alles auf http umstelle geht es wieder.

    Auf der Suche nach einer Lösung habe ich leider nichts gefunden.

    • Dieses Thema wurde geändert vor 1 Woche, 5 Tage von akarinmagic.
Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Thread-Ersteller akarinmagic

    (@akarinmagic)

    Die Seite befindet sich nur in meinem Netzwerk

    Moderator Bego Mario Garde

    (@pixolin)

    Wurde vor den Änderungen ein SSL-Zertifikat eingerichtet?
    Ist das ein von dir selbst administrierter Server? Apache2/nginx?

    Auch ein Bericht zur Website wäre hilfreich: Geh bitte auf Werkzeuge > Website-Zustand > Bericht, klick auf den Button und füge den Bericht mit Strg-V unverändert in deine Antwort ein.

    Hast du versucht, die Plugins vorübergehend zu deaktivieren?

    Thread-Ersteller akarinmagic

    (@akarinmagic)

    Also das SSL-Zertifikat ist eingerichtet.

    Es ist halt komisch, dass die Seite nicht über den postnamen erreichbar ist.
    Bericht:

    Version	5.8.1
    Sprache der Website	de_DE
    Benutzersprache	de_DE
    Zeitzone	Europe/Berlin
    Homepage-URL	https://***.myfritz.net/wp
    Website-URL	https://***.myfritz.net/wp
    Permalink-Struktur	/%postname%/
    Verwendet diese Website HTTPS?	Ja
    Ist dies eine Multisite?	Nein
    Kann sich jeder auf dieser Website registrieren?	Nein
    Ist diese Website für Suchmaschinen ausgeschlossen?	Ja
    Standard-Kommentarstatus	Geschlossen
    Umgebungstyp	production
    Anzahl der Benutzer	3
    Verbindung mit WordPress.org	WordPress.org ist erreichbar
    
    Server-Architektur	Linux 5.10.60+ armv6l
    Webserver	Apache/2.4.25 (Raspbian) OpenSSL/1.0.2u
    PHP-Version	7.3.29-1~deb10u1 (Unterstützt keine 64bit-Werte)
    PHP-SAPI	apache2handler
    Maximale PHP-Eingabe-Variablen (max_input_vars)	1000
    Maximale PHP-Ausführungszeit (max_execution_time)	30
    PHP-Speicher-Limit (memory_limit)	128M
    PHP-Speicher-Limit (nur für Administrator-Ansichten)	256M
    Maximale Eingabe-Zeit (max_input_time)	60
    Maximale Dateigröße beim Upload (upload_max_filesize)	2M
    Maximale Größe der PHP-Post-Daten (post_max_size)	8M
    cURL-Version	7.64.0 OpenSSL/1.1.1d
    Ist SUHOSIN installiert?	Nein
    Ist die Imagick-Bibliothek verfügbar?	Nein
    Werden sprechende Permalinks unterstützt?	Ja
    .htaccess-Regeln	Deine .htaccess-Datei enthält nur die WordPress-Core-Funktionen.


    Moderationshinweis: Ich habe die URL zu deiner Website verfremdet, weil im Gegensatz zu deinem ersten Beitrag die Website durchaus für andere erreichbar war.

    Moderator Bego Mario Garde

    (@pixolin)

    Das ist zwar nicht der Bericht, um den ich gebeten hatte, aber … egal.

    Soviel ich aus den Daten rauslesen kann, verwendest du einen selbst aufgesetzten Raspberry Pi mit Apache2-Webserver? Damit die Umschreibung der Pretty Permalinks funktioniert, muss in der Konfiguration des Virtual Hosts für die verschlüsselte Verbindung (findest du unter /etc/apache2/sites-enabled/ eingetragen sein, dass die Serverkonfiguration durch eine .htaccess überschrieben werden darf:

    <Directory "/var/www/html/">
    allow from all
    Options -Indexes
    AllowOverride All
    </Directory>

    Nach der Anpassung musst du den Webserver neu starten (sudo systemctl restart apche2). Danach sollten die Permalinks funktionieren.

    Thread-Ersteller akarinmagic

    (@akarinmagic)

    Danke das wars. AllowOverride None stand bei mir in der default-SSL.

    • Diese Antwort wurde geändert vor 1 Woche, 5 Tage von akarinmagic.
    Moderator Bego Mario Garde

    (@pixolin)

    Prima, Danke für die Rückmeldung.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)