Support » Allgemeine Fragen » ich kann keine Beiträge mehr schreiben

  • Gelöst dosuja

    (@dosuja)


    Guten Morgen,

    nachdem ich gestern versucht habe, ein Plugin zu updaten bzw. neu zu installieren, das Google Analytics im Dashboard integriert, kann ich keine Beiträge mehr schreiben.
    Wenn ich einen neuen Beitrag schreiben möchte, kommt folgende Fehlermeldung:

    object from empty value in /homepages/32/d442754367/htdocs/dietestfamilie.de/wp-admin/includes/post.php on line 713

    supplied for foreach() in /homepages/32/d442754367/htdocs/dietestfamilie.de/wp-content/plugins/wordpress-seo/admin/metabox/class-metabox.php on line 1038

    Nur der Titel lässt sich eintragen, darunter die Meldung:

    Du bearbeitest gerade die Seite, die deine letzten Beiträge anzeigt.

    Und man kann keinen weiteren Text pflegen.

    Oben genannte Google Analytics Plugins habe ich wieder deaktiviert und gelöscht.

    Site Health zeigt folgende Probleme an, die ich nicht verstehe:

    2 Critical issues

    The REST API is one way WordPress, and other applications, communicate with the server. One example is the block editor screen, which relies on this to display, and save, your posts and pages.

    The REST API request failed due to an error.
    Error: [] cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received

    Loopback requests are used to run scheduled events, and are also used by the built-in editors for themes and plugins to verify code stability.

    The loopback request to your site failed, this means features relying on them are not currently working as expected.
    Error encountered: (0) cURL error 28: Operation timed out after 10000 milliseconds with 0 bytes received

    Bin über jede Hilfe dankbar!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 54)
  • bei File Integrity wird mir das vorgeschlagen:

    It appears as if some files may have been modified.
    One possible reason for this may be that your installation contains translated versions. An easy way to clear this is to reinstall WordPress. Don’t worry. This will only affect WordPress‘ own files, not your themes, plugins or uploaded media.

    /homepages/32/d442754367/htdocs/dietestfamilie.de/wp-includes/version.php

    Hallo,
    wenn du dich noch anmelden kannst, kannst du das das Plugin über das Dashboard unter Plugins > Installierte Plugins deaktivieren.
    Wenn das nicht mehr geht, dann ist in dem nachfolgenden Link genauer beschrieben, wie man plugins deaktiviert, wenn man keinen Zugriff mehr auf das dashboard hat.
    Also: Per FTP änderst du den Namen des Plugin – Ordners, der das Problem verursacht
    (z. B. \wp-content\plugins\das_ist_der_Ordner in \wp-content\plugins\_das_ist_der_Ordner) – ich habe hier vor dem Namen des Ordners einen Unterstrich gesetzt.
    Hier könnte das der Ordner mit dem Namen „wordpress-seo“ sein. Danach solltest du dich wieder anmelden können. Allerdings werden dann einige Dinge auf der Webseite nicht mehr so funktionieren wie vorher, weil das Plugin ja dann deaktiviert ist.
    Hier noch ein zusätzlicher Link mit einer Beschreibung zum Umbenennen eines Plugin-Ordners per FTP.
    Viele Grüße
    Hans-Gerd

    Vielen Dank für die schnelle Antwort!

    Ich habe Yoast SEA deaktiviert, jetzt kommt nur noch diese Fehlermeldung:

    object from empty value in /homepages/32/d442754367/htdocs/dietestfamilie.de/wp-admin/includes/post.php on line 713

    Auch wenn ich Bilder hochladen möchte kommt eine Fehlermeldung:

    Feuerwear_Kulturbeutel_Henry_23_Rot_Einsatz_Outdoor_Banner_Small_2.1.jpg Der Beitrag konnte nicht in die Datenbank eingefügt werden

    dann lag es eher nicht an YOAST SEO (das habe ich übrigens auch auf mehreren Seiten ohne Probleme im Einsatz).
    Deaktiviere doch mal das Plugin, dass

    Google Analytics im Dashboard integriert

    Sollte das nicht klappen, kannst du ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Zusätzlich ist als theme (falls vorhanden) twenty nineteen aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Zunächst sind dann alle Plugins deaktiviert. Aktiviere dann Plugin für Plugin im Problembenhandlungsmodus und schaue anschließend, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise das Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu auch mal die Informationen in dem Beitrag Health Check durch.
    Du findest unter „Info“ einen Bericht zur Website und kannst den Bericht über den Button „Bericht in die Zwischenablage kopieren“ und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, wo das Problem liegt.

    Sämtliche Plugins für Google Analytics habe ich bereits deaktiviert und deinstalliert, der Fehler kommt trotzdem :/

    Hier die Health Check Infos:

    
    ### wp-core ###
    
    version: 5.3.2
    site_language: de_DE
    user_language: de_DE
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 4
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/32/d442754367/htdocs/dietestfamilie.de
    wordpress_size: 115,62 MB (121241537 bytes)
    uploads_path: /homepages/32/d442754367/htdocs/dietestfamilie.de/wp-content/uploads
    uploads_size: 3,36 GB (3606658981 bytes)
    themes_path: /homepages/32/d442754367/htdocs/dietestfamilie.de/wp-content/themes
    themes_size: 3,85 MB (4037321 bytes)
    plugins_path: /homepages/32/d442754367/htdocs/dietestfamilie.de/wp-content/plugins
    plugins_size: 101,77 MB (106717085 bytes)
    database_size: 1,10 GB (1180271282 bytes)
    total_size: 4,67 GB (5018926206 bytes)
    
    ### wp-active-theme ###
    
    name: Xin Magazine (xin-magazine)
    version: 1.0.9
    author: XinThemes
    author_website: http://www.xinthemes.com/
    parent_theme: none
    theme_features: post-thumbnails, automatic-feed-links, post-formats, editor-style, custom-background, custom-header, menus, widgets
    theme_path: /homepages/32/d442754367/htdocs/dietestfamilie.de/wp-content/themes/xin-magazine
    
    ### wp-themes-inactive (2) ###
    
    Twenty Fourteen: version: 2.7, author: WordPress-Team
    Twenty Twenty: version: 1.1, author: WordPress-Team
    
    ### wp-mu-plugins (2) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.0
    WP Migrate DB Compatibility: version: 1.2, author: Delicious Brains
    
    ### wp-plugins-active (25) ###
    
    AccessPress Social Counter: version: 1.8.7, author: AccessPress Themes
    Antispam Bee: version: 2.9.1, author: pluginkollektiv
    blogfoster Insights: version: 1.0.7, author: blogfoster
    Broken Link Checker: version: 1.11.11, author: ManageWP
    Cachify: version: 2.2.4, author: pluginkollektiv
    Contact Form 7: version: 5.1.6, author: Takayuki Miyoshi
    Display Posts: version: 3.0.2, author: Bill Erickson
    EWWW Image Optimizer: version: 5.2.1, author: Exactly WWW
    Health Check & Troubleshooting: version: 1.4.2, author: The WordPress.org community
    MailPoet 3 (New): version: 3.45.1, author: MailPoet
    MailPoet 3 Premium (New): version: 3.0.81, author: MailPoet
    Remove IP: version: 0.1, author: guido
    SEO Smart Links: version: 3.0.1, author: Vladimir Prelovac
    Simple 301 Redirects: version: 1.07, author: Scott Nellé
    Simple Giveaways: version: 2.29.0, author: Igor Benic
    Widget Logic: version: 5.10.4, author: WPChef
    WordPress Database Backup: version: 2.3.3, author: Austin Matzko
    WP-Optimize - Clean, Compress, Cache: version: 3.0.16, author: David Anderson, Ruhani Rabin, Team Updraft
    Wp Cookie Choice: version: 1.1.0, author: Marcus Franke
    WP GDPR: version: 2.1.1, author: AppSaloon
    WP GDPR Compliance: version: 1.5.2, author: Van Ons
    WP Migrate DB: version: 1.0.11, author: Delicious Brains
    WP Page Numbers: version: 0.5, author: Jens Törnell
    Yet Another Related Posts Plugin: version: 5.1.2, author: YARPP
    Yoast SEO: version: 13.0, author: Team Yoast
    
    ### wp-plugins-inactive (1) ###
    
    W3 Total Cache: version: 0.13.1, author: BoldGrid
    
    ### wp-media ###
    
    image_editor: EWWWIO_GD_Editor
    imagick_module_version: Not available
    imagemagick_version: Not available
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.0-ui20007.037-uiabi1-infong-amd64 x86_64
    httpd_software: Apache
    php_version: 7.3.14 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50000
    memory_limit: -1
    max_input_time: -1
    upload_max_size: 64M
    php_post_max_size: 64M
    curl_version: 7.38.0 OpenSSL/1.0.1t
    suhosin: false
    imagick_availability: false
    server-headers: unknown
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.5.60-0+deb7u1-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/32/d442754367/htdocs/dietestfamilie.de/wp-content
    WP_PLUGIN_DIR: /homepages/32/d442754367/htdocs/dietestfamilie.de/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: -1
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Einige Dinge, die mir aufgefallen sind:

    • Du hast offensichtlich zwei Plugins zur DSGVO. Eins reicht
    • W3 Total Cache ist zwar inaktiv, kann aber trotzdem noch Probleme bereiten, siehe z. B. hier
    • 25 aktive Plugins ist auch nicht gerade wenig. Brauchst du die Plugins wirklich alle?
    • Hast du keine Sicherung erstellt ? – Das ist insbesondere vor einem Update immer sinnvoll
    • Deaktiviere mal cachify testweise

    Ich hatte dir in meiner vorherigen Antwort geschrieben, dass im Problembenhandlungsmodus erst mal alle Plugins deaktiviert sind und die Plugins dann Plugin für Plugin aktiviert werden sollten. Also nicht nur die Google Analytics Plugins. Das scheinst du aber noch nicht gemacht zu haben.

    Habe den Problembehandlungsmodus leider noch nicht zum Laufen bekommen.
    Bin jetzt erst einmal unterwegs und schaue mir das heute Nachmittag noch mal an.
    Vielen Dank schon mal!

    kein Problem – hier ein screenshot dazu:
    Website-Zustand-TESTSEITE-aachenerkinder-de-W

    Du bearbeitest gerade die Seite, die deine letzten Beiträge anzeigt.
    Und man kann keinen weiteren Text pflegen.

    Dazu noch rasch ein Hinweis: Wenn du im Customizer unter Startseiten-Einstellungen festgelegt hast, dass eine bestimmte Seite (z.B. „Blog“, „Aktuelles“, „News“, …) die Beiträge anzeigen soll und eine andere Seite („Home“) als Startseite verwendet werden soll, kannst du die Beitragsseite nicht mit eigenen Inhalten füllen. Statt dessen wird diese Seite als Platzhalter verwendet, der die Beiträge in chronologischer Reihenfolge auflisten soll. Dass du auf dieser Seite keinen weiteren Text einfügen kannst, ist also völlig korrekt.

    Irgendwie klappt das mit dem Troubleshooting Modus auch nicht 🙁

    Troubleshooting mode

    When troubleshooting issues on your site, you are likely to be told to disable all plugins and switch to the default theme. Understandably, you do not wish to do so as it may affect your site visitors, leaving them with lost functionality.

    By enabling the Troubleshooting Mode, all plugins will appear inactive and your site will switch to the default theme only for you. All other users will see your site as usual.

    A Troubleshooting Mode menu is added to your admin bar, which will allow you to enable plugins individually, switch back to your current theme, and disable Troubleshooting Mode.

    Please note, that due to how Must Use plugins work, any such plugin will not be disabled for the troubleshooting session.

    Wenn ich auf dem Button darunter klicke (Enable Troubleshooting Mode), passiert nichts, ich komme auf das Dashboard zurück und alles ist wie vorher.

    Hallo,
    hast du den Hinweis von @pixolin gelesen?
    Ansonsten gehst du am besten folgendermaßen vor:

    • Lade den Ordner plugins per FTP auf deinen lokalen Rechner.
    • Benenne auf dem Server per FTP den Ordner plugins um in plugins_old.
    • Dann legst du einen Ordner plugins wieder neu an.
    • Jetzt testest du mal, ob du dich wieder anmelden kannst und auf das dashboard zugreifen kannst.
    • Dann kopierst du aus dem Ordner plugins_old auf dem lokalen Rechner einzeln die jeweiligen Ordner wieder in den Ordner plugins auf dem Server.
    • Nachdem du jeweils einen Ordner kopierst hast, prüfst du, ob das Problem immer noch besteht.
    • Sollte es funktionieren, kopierst du den nächsten Ordner. Sollte es nicht funktionieren, löschst du den gerade kopierten Ordner wieder. Das ist dann das plugin, das Probleme macht.
    • Danach setzt du den Vorgang (Schritt 5. – 7.) solange fort, bis du alle Ordner kopiert hast.
    • Allerdings ist während dieser Prozedur deine Seite relativ desolat. Daher solltest du vorher auf jeden Fall eine gute Sicherung erstellen.
      Viele Grüße
      Hans-Gerd

    Irgendwie klappt das mit dem Troubleshooting Modus auch nicht 🙁

    Doch, klappt tadellos – du musst ihn nur dann auch einsetzen.

    Geh doch erst einmal auf Aktualisierungen und aktualisiere die Übersetzung für das Plugin. Dann bekommst du die Texte auf Deutsch und es wird vielleicht verständlicher.

    Wenn bei einer WordPress-Website ein Fehler auftritt, versuchen wir zunächst einmal, die Fehlerquelle einzugrenzen. Da WordPress selbst millionenfach eingesetzt und von sehr vielen erfahrenen ProgramerInnen entwickelt wird, ist die Wahrscheinlichkeit, dass der Fehler von WordPress verursacht wird, eher gering. Bei Plugins, die vielleicht nur von ganz wenigen Nutzern verwendet und manchmal von einem einzigen Entwickler programmiert wurden, ist die Wahrscheinlichkeit recht hoch. Deshalb ist der erste Schritt, alle Plugins zu deaktivieren, zu testen, ob das Problem weiterhin besteht und sie dann einzeln wieder zu aktivieren, bis der Fehler wieder auftaucht. So lässt sich im Ausschlußverfahren herausfinden, welches Plugin Probleme bereitet und die Website wiederherstellen.

    Weil das manuell etwas mühsam ist, hat das Support-Team das Plugin Health Check entwickelt (aufgepasst: bitte das richtige nehmen es gibt mehrere „Healthcheck“-Plugins, aber nur eins vom Support-Team). Aktivierst du den Problembehandlungsmodus sind – nur für dich! die Besucher deiner Website bekommen davon nichts mit – alle Plugins deaktiviert. Du kannst dann testen, ob das Problem weiter besteht (in deinem Fall: neue Beiträge schreiben) und die Plugins dann einzeln wieder aktivieren.

    „Von nix kommt nix“ sagt man im Rheinland. Nur den Problembehandlungsmodus aktivieren bringt nichts, du musst auch testen. Oder du machst es eben auf die klassische Art, wie sie Hans-Gerd ausführlich beschrieben hat: Plugins manuell deaktivieren, testen, wieder aktivieren … Ist nur ein wenig mühsamer.

    Noch mal zum Verständnis:

    Wenn ich auf dem Button darunter klicke (Enable Troubleshooting Mode), passiert nichts, ich komme auf das Dashboard zurück und alles ist wie vorher.

    Schau mal in das Menü links im Dashboard, bevor du auf diesen Button klickst und schau mal in das Menü, nachdem du auf diesen Button geklickt hast. Siehst du da wirklich keinen Unterschied? – z. B. wesentlich weniger Menüpunkte?
    Oben in der Leiste müssten dann folgende Menüpunkte stehen:
    problembehandlungsmodus
    … und diese Optionen siehst du auch nicht?
    Das hier hatte ich dir auch schon geschrieben: „Lies dir dazu auch mal die Informationen in dem Beitrag Health Check durch.“

    Da ist ja mein Problem – dieses Menü oben oder in der Seite habe ich nicht, wenn ich in den „Troubleshootingmode“ gehe. Es sieht alles genau aus wie vorher. Wenn ich wieder auf Site Health gehe, steht da wieder der Button „Enable ..“, ohne dass ich irgendwas gemacht habe (auf der Beschreibung von Site Health hatte ich mir die Anleitung durchgelesen und bei mir sieht das Plugin völlig anders aus).
    Wie kann ich einen Screeenshot hochladen? Auf meiner Seite kann ich keine Bilder mehr hochladen.
    Ich habe jedes Plugin einzeln einmal deaktiviert, getestet ob ich einen neuen Beitrag erstellen kann (+neu > Beitrag) und jedes Mal kommt derselbe Fehler.
    Ein paar Plugins habe ich deaktiviert und gelöscht, jetzt zeigt Site Health mir als Status „gut“ an und die beiden kritischen Fehler sind weg.

    
    ### wp-core ###
    
    version: 5.3.2
    site_language: de_DE
    user_language: de_DE
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 4
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/32/d442754367/htdocs/dietestfamilie.de
    wordpress_size: 112,91 MB (118392997 bytes)
    uploads_path: /homepages/32/d442754367/htdocs/dietestfamilie.de/wp-content/uploads
    uploads_size: 3,36 GB (3606658981 bytes)
    themes_path: /homepages/32/d442754367/htdocs/dietestfamilie.de/wp-content/themes
    themes_size: 3,85 MB (4037321 bytes)
    plugins_path: /homepages/32/d442754367/htdocs/dietestfamilie.de/wp-content/plugins
    plugins_size: 59,52 MB (62407552 bytes)
    database_size: 1,08 GB (1162943918 bytes)
    total_size: 4,61 GB (4954440769 bytes)
    
    ### wp-active-theme ###
    
    name: Xin Magazine (xin-magazine)
    version: 1.0.9
    author: XinThemes
    author_website: http://www.xinthemes.com/
    parent_theme: none
    theme_features: post-thumbnails, automatic-feed-links, post-formats, editor-style, custom-background, custom-header, menus, widgets
    theme_path: /homepages/32/d442754367/htdocs/dietestfamilie.de/wp-content/themes/xin-magazine
    
    ### wp-themes-inactive (2) ###
    
    Twenty Fourteen: version: 2.7, author: WordPress-Team
    Twenty Twenty: version: 1.1, author: WordPress-Team
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.0
    
    ### wp-plugins-active (16) ###
    
    Antispam Bee: version: 2.9.1, author: pluginkollektiv
    blogfoster Insights: version: 1.0.7, author: blogfoster
    Cachify: version: 2.2.4, author: pluginkollektiv
    Contact Form 7: version: 5.1.6, author: Takayuki Miyoshi
    Display Posts: version: 3.0.2, author: Bill Erickson
    Health Check & Troubleshooting: version: 1.4.2, author: The WordPress.org community
    MailPoet 3 (New): version: 3.45.1, author: MailPoet
    MailPoet 3 Premium (New): version: 3.0.81, author: MailPoet
    Remove IP: version: 0.1, author: guido
    Simple 301 Redirects: version: 1.07, author: Scott Nellé
    Simple Giveaways: version: 2.29.0, author: Igor Benic
    WordPress Database Backup: version: 2.3.3, author: Austin Matzko
    WP-Optimize - Clean, Compress, Cache: version: 3.0.16, author: David Anderson, Ruhani Rabin, Team Updraft
    Wp Cookie Choice: version: 1.1.0, author: Marcus Franke
    WP GDPR Compliance: version: 1.5.2, author: Van Ons
    Yet Another Related Posts Plugin: version: 5.1.2, author: YARPP
    
    ### wp-plugins-inactive (1) ###
    
    Yoast SEO: version: 13.0, author: Team Yoast
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.0-ui20007.037-uiabi1-infong-amd64 x86_64
    httpd_software: Apache
    php_version: 7.3.14 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50000
    memory_limit: -1
    max_input_time: -1
    upload_max_size: 64M
    php_post_max_size: 64M
    curl_version: 7.38.0 OpenSSL/1.0.1t
    suhosin: false
    imagick_availability: false
    server-headers: 
    	content-type: text/html; charset=UTF-8
    	date: Sat, 15 Feb 2020 20:46:57 GMT
    	server: Apache
    	x-powered-by: PHP/7.3.14
    	expires: Wed, 11 Jan 1984 05:00:00 GMT
    	cache-control: no-cache, must-revalidate, max-age=0
    	link: <https://www.dietestfamilie.de/wp-json/>; rel="https://api.w.org/"
    	content-encoding: gzip
    	vary: Accept-Encoding
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.5.60-0+deb7u1-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/32/d442754367/htdocs/dietestfamilie.de/wp-content
    WP_PLUGIN_DIR: /homepages/32/d442754367/htdocs/dietestfamilie.de/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: -1
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Hier ist beschrieben, wie du hier Bilder einfügst.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 54)