• Gelöst ewuk

    (@ewuk)


    Als Beginner in WP arbeite ich mich langsam durch WP, daher habe ich noch einige Fragen an erfahrene WP-Nutzer.
    1. Wie können alle identischen Fotos auf den Seiten (außer der Willkommenseite)
    gelöscht werden. Ich bin mir nicht mehr sicher, wie ich diese dort platziert habe.
    2. wie können hochgeladene Foto in Seiten positioniert und von der Größe her verändert werden?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 12 Antworten – 1 bis 12 (von insgesamt 12)
  • Wie können alle identischen Fotos auf den Seiten (außer der Willkommenseite) gelöscht werden.

    Ich verstehe die Frage nicht. Kannst du ein konkretes Beispiel nennen?

    wie können hochgeladene Foto in Seiten positioniert und von der Größe her verändert werden?

    Wenn du im Beitragseditor einen Bild-Block eingefügt und ein Bild hochgeladen oder aus der Mediathek verwendet hast, bekommst du für den Bild-Block eine Formatierungsleiste mit einem Positionierungs-Icon (1). Hier kannst du zum Beispiel angeben, dass das Bild linksbündig ausgerichtet werden soll (2), wobei hier natürlich auch die Größe des Bildes eine Rolle spielt. Die kannst du in der Sidebar entweder die vom Theme/deinen Media-Einstellungen definierten Größen verwenden (3), die Abmessung in Pixeln (4) oder die Bildgröße in Prozent (5) festlegen.

    Screenshot Bild-Block im Editor
    (zum Vergrößern anklicken)

    Thread-Starter ewuk

    (@ewuk)

    Danke erstmal.

    Bei Anklicken des Menu „wiss. Werdegang“ oder „Küppers-Systemdenken“ mit Untermenu-Seiten erscheint ein kleiner Rechteckrahmen mit „?“, wo noch vor ca. 2 h ein Foto erkennbar war!? Warum das Foto nun nicht mehr zu sehen ist, ist rätselhaft.
    Auf jeden Fall sollen alle diese „?“ mit ´Rahmen gelöscht werden, aber wie?

    Gruß UK

    Auf der Seite „Wissenschaftlicher Werdegang“ wurde ein Foto ukSpruch.jpg als Beitragsbild angegeben, dass aber auf dem Server nicht mehr vorhanden ist. Vielleicht hast du es nachträglich aus der Mediathek gelöscht?

    Im Rheinwerkverlag sind übrigens gerade ganz tolle Bücher in Neuauflage erschienen, die den Einstieg sicher einfacher machen:

    • Einstieg in WordPress 6, Peter Müller, 4. Auflage 2022, ISBN 978-3-8362-8664-0
    • WordPress 6 Das umfassende Handbuch, Richard Eisenmenger, Florian Brinkmann, 2. Auflage, ISBN 978-3-8362-8805-7

    Dort werden Einsteiger-Fragen wie z.B. die Nutzung des Bild-Blocks oder die Verwendung von Beitragsbildern anschaulich erklärt.

    Thread-Starter ewuk

    (@ewuk)

    Es stimmt, das Foto wurde gelöscht – aber wqie wird der Platzhalter
    von den Seiten gelöscht?

    Gruß UK

    Hallo,
    schau mal bitte unter Seiten > Alle Seiten bei der entsprechenden Seite nach, ob du da nicht noch einen Image-Block eingefügt hast.

    Sonst könnte das ggfs. auch an dem vielleicht von dir geänderten (Seiten-)Template liegen, siehe unter Design > Editor (Beta) > Templates > Seite.

    Übrigens verwendest du offensichtlich das Plugin Gutenberg. Das Plugin „Gutenberg“ solltest du nicht installieren. Leider gibt es allgemein ein wenig Verwirrung: In der Regel wird der Block-Editor auch als Gutenberg bezeichnet. Das ist so nicht korrekt, weil es zusätzlich ein Gutenberg-Plugin gibt. Dieses Plugin bietet bestimmte Funktionen an, die man als experimentell betrachten kann. Daher sollte man das Plugin nicht auf Produktivseiten einsetzen. Der Block-Editor ist dagegen der Standard-Editor von WordPress und steht ab der Version 5.0 automatisch als Editor zur Verfügung. Das war nicht immer klar und (nicht nur) deswegen gibt es so viele negative Bewertungen für das Gutenberg-Plugin.

    Viele Grüße
    Hans-Gerd

    Thread-Starter ewuk

    (@ewuk)

    Danke Hans-Gert,

    werde in den nächten Tagen alles prüfen. Es geht langsam voran.

    Gruß Udo

    Thread-Starter ewuk

    (@ewuk)

    Ich präzisiere mein Problem nochmals:

    Außer der Header-Seite sind auf allen weiteren Seiten identische Bild-Rahmen mit (?). Vorher waren dort identische Bilder platziert. Das Bild wurde unter „Medien“ gelöscht, daher sehe ich jetzt die Rahmen mit (?).
    Mir fehlt der entscheidende Hinweis bzw. der konkrete Schritt für Schritt Weg,
    die leeren Bildrahmen zu löschen.

    Gruß UK

    Ob du einen „Bildrahmen mit (?)“ angezeigt bekommst, hängt erst einmal vom Browser ab, mit dem du die Webseite anschaust. Firefox zeigt nur den Alternativtext „Beitragsbild“, Chrome immerhin ein Icon „Kaputtes Bild“.

    WordPress speichert den Inhalt der Webseiten und die zugehörigen Einstellungen (wie z.B. das Beitragsbild) in der Datenbank, während Bild-Dateien physisch im Verzeichnis wp-content/uploads gespeichert werden. Löschst du nun ein Bild aus dem Verzeichnis wp-content/uploads, ändert sich nicht gleichzeitig der Eintrag in der Datenbank. Die Webseite enthält also immer noch den Code, um ein Bild auszugeben, nur ist eben dieses Bild nicht mehr verfügbar. Resultat ist, dass der Alternativtext oder ein Icon für das fehlende Bild angezeigt wird.

    Um das zu korrgieren, musst du die Seite oder den Beitrag ändern. Du gehst ins Menü Seiten/Beiträge, bearbeitest die in Frage kommende Seite, klickst bei Beitragsbild auf entfernen und aktualisierst die Seite/den Beitrag in der Datenbank.

    Übrigens erleichtert es die Hilfe hier im Support-Forum, wenn du auf Vorschläge oder Rückfragen (z.B. von Hans-Gerd, ob du einen Image-Block eingefügt hast) zumindest eingehst. 😉

    Da du mit das Block-Theme Twenty Twenty Two nutzt, kannst du zum Entfernen des Beitragsbilds auch das Template ändern:

    1. Menü Design > Editor (Beta) aufrufen.
    2. WordPress-Logo oben links anklicken.
    3. Unter Editor Menüpunkt Templates anklicken.
    4. Template „Seite“ auswählen.
    5. Block „Beitragsbild“ (1) anklicken und Entferne-Taste drücken.
    6. Block „Trenner“ (2) anklicken und Entferne-Taste drücken.
    7. Template mit dem Button oben rechts speichern.
    8. Menü über das WordPress-Logo oben links > Dashboard verlassen.
    Thread-Starter ewuk

    (@ewuk)

    Besten Dank Bego Mario Garde.

    Problem gelöst.

    Gruß UK

    Thread-Starter ewuk

    (@ewuk)

    Hallo Bego Mario Garde und andere Helfer.

    noch häufen sich die kleinen Probleme – die hoffentlich bald enden – bei meiner Erstellung der Webseite. Daher eine weiteres Problem:

    Irgendetwas blockiert neue Seiten/Elternseiten, die erstellt werden, richtig angezeigt werden, aber in der Elternzeilen-Reihenfolge, die bei jeder aufgerufenen Seite erscheint, nicht im Klappmenu angezeigt werden. Warum nicht?

    Und: Wie kann ein Bildschirmfoto hier im Support hochgeladen werden, um das Problem deutlich zu zeigen?

    Gruß UK

    Du solltest dich (nochmal?) mit den Forenregeln und unseren FAQ beschäftigen.

    In den Forenregeln haben wir geschrieben, dass wir pro Thread nur eine Frage behandeln, weil sich ein Thread nur einmal als „gelöst“ markieren lässt. „Gelöst“ bedeutet vereinfacht gesagt für die Helfer „da brauchst du nicht mehr reinschauen“ – deine Frage wir also nicht mal gelesen. Bitte starte einen neuen Thread.

    In den FAQ findest du auch den Beitrag Wie kann man hier Bilder in einen Forenbeitrag einfügen?

    Thread geschlossen.

Ansicht von 12 Antworten – 1 bis 12 (von insgesamt 12)
  • Das Thema „Identische Fotos auf Seiten – außer Headerafoto – löschen“ ist für neue Antworten geschlossen.