• Gelöst pottersfield

    (@pottersfield)


    Guten Tag,

    ich habe komplett neu wordpress fuer meine website installiert. Schon nach dem ersten Start, wenn ich das vorinstallierte Theme twenty Twenty Three im Editor oeffnen wollte fuer Anpassungen habe ich die Fehlermeldung „Im Editor ist ein unerwarteter Fehler aufgetreten.“ erhalten. Das selbe auch beim Standart Plugin twenty Twenty Two. Das einzige Plugin welches bisher funktioniert, ist twenty Twenty One.

    Der Bericht des Website Zustandes:

    ` wp-core
    
    version: 6.2.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true wp-paths-sizes wordpress_path: /www/htdocs/w01e3ad5/pottersfield.studio
    wordpress_size: 53,19 MB (55776292 bytes)
    uploads_path: /www/htdocs/w01e3ad5/pottersfield.studio/wp-content/uploads
    uploads_size: 0,00 B (0 bytes)
    themes_path: /www/htdocs/w01e3ad5/pottersfield.studio/wp-content/themes
    themes_size: 12,35 MB (12951623 bytes)
    plugins_path: /www/htdocs/w01e3ad5/pottersfield.studio/wp-content/plugins
    plugins_size: 233,31 kB (238908 bytes)
    database_size: 2,26 MB (2374233 bytes)
    total_size: 68,04 MB (71341056 bytes) wp-active-theme name: Twenty Twenty-Three (twentytwentythree)
    version: 1.1
    author: Das WordPress-Team
    author_website: https://de.wordpress.org
    parent_theme: none
    theme_features: core-block-patterns, post-thumbnails, responsive-embeds, editor-styles, html5, automatic-feed-links, block-templates, widgets-block-editor
    theme_path: /www/htdocs/w01e3ad5/pottersfield.studio/wp-content/themes/twentytwentythree
    auto_update: Deaktiviert wp-mu-plugins (1) Health Check Troubleshooting Mode: author: (undefined), version: 1.9.0 wp-plugins-active (2) Health Check & Troubleshooting: version: 1.6.0, author: The WordPress.org community, Automatische Aktualisierungen deaktiviert
    WP Fastest Cache: version: 1.1.8, author: Emre Vona, Automatische Aktualisierungen deaktiviert wp-media image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1691
    imagemagick_version: ImageMagick 6.9.11-60 Q16 x86_64 2021-01-25 https://imagemagick.org
    imagick_version: 3.7.0
    file_uploads: File uploads is turned off
    post_max_size: 200M
    upload_max_filesize: 200M
    max_effective_size: 200 MB
    max_file_uploads: 20
    imagick_limits:
    imagick::RESOURCETYPE_AREA: 31 GB
    imagick::RESOURCETYPE_DISK: 9.22337203685E+18
    imagick::RESOURCETYPE_FILE: 786432
    imagick::RESOURCETYPE_MAP: 31 GB
    imagick::RESOURCETYPE_MEMORY: 16 GB
    imagick::RESOURCETYPE_THREAD: 1
    imagick::RESOURCETYPE_TIME: 9.22337203685E+18
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, AVI, AVIF, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, H, HALD, HDR, HEIC, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: 2.3.0
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.55.0 wp-server server_architecture: Linux 5.15.0-78-generic x86_64
    httpd_software: Apache
    php_version: 8.2.3 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 10000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 200M
    php_post_max_size: 200M
    curl_version: 7.81.0 OpenSSL/3.0.2
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true wp-database extension: mysqli
    server_version: 10.6.12-MariaDB-0ubuntu0.22.04.1-log
    client_version: mysqlnd 8.2.3
    max_allowed_packet: 67108864
    max_connections: 500 wp-constants WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /www/htdocs/w01e3ad5/pottersfield.studio/wp-content
    WP_PLUGIN_DIR: /www/htdocs/w01e3ad5/pottersfield.studio/wp-content/plugins
    WP_MEMORY_LIMIT: 256M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined wp-filesystem wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable

    Und die Fehlermeldung vom Editor:

    getCurrentValue@https://pottersfield.studio/wp-admin/site-editor.php:64:55
    proxyDocumentStyleSheets@https://pottersfield.studio/wp-admin/site-editor.php:72:47
    @https://pottersfield.studio/wp-includes/js/dist/block-editor.min.js:26:224708
    useMemo@https://pottersfield.studio/wp-includes/js/dist/vendor/react-dom.min.js:10:115390
    Fd@https://pottersfield.studio/wp-includes/js/dist/block-editor.min.js:26:224683
    kt@https://pottersfield.studio/wp-includes/js/dist/vendor/react-dom.min.js:10:47634
    js@https://pottersfield.studio/wp-includes/js/dist/vendor/react-dom.min.js:10:120748
    kl@https://pottersfield.studio/wp-includes/js/dist/vendor/react-dom.min.js:10:88656
    yl@https://pottersfield.studio/wp-includes/js/dist/vendor/react-dom.min.js:10:88584
    vl@https://pottersfield.studio/wp-includes/js/dist/vendor/react-dom.min.js:10:88447
    ol@https://pottersfield.studio/wp-includes/js/dist/vendor/react-dom.min.js:10:85271
    cl@https://pottersfield.studio/wp-includes/js/dist/vendor/react-dom.min.js:10:85658
    cl@[native code]
    zn@https://pottersfield.studio/wp-includes/js/dist/vendor/react-dom.min.js:10:32471
    @https://pottersfield.studio/wp-includes/js/dist/vendor/react-dom.min.js:10:83223

    Folgendes hat nicht geholfen:

    • Alle automatisch installierten Plugins deaktivieren
    • Browsercache leeren
    • Einstellungen fuer den Editor (klassisch vs Block) geprueft.
    • Alle Aktualisierungen der Plugins durchgefuehrt
    • WordPress erneut in der aktuellsten Version drueber installieren lassen
    • PHP auf dem server von v8.0 auf v8.2 aktualisiert
    • WP_HOME: & WP_SITEURL: hab ich auch schon versucht zu „hardcoden“ in der config.php Datei, obwohl die korrekten Links in wordpress unter den Einstellungen vergeben sind.

    Egal was ich versuche, ich kriege so gut wie keines der Themes soweit zum Laufen, dass ich es im Template Editor anpassen koennte.

    Ich bin fuer jegliche Hilfe sehr dankbar!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten – 1 bis 10 (von insgesamt 10)
  • Hallo,
    Und Anpassungen an den Templates nimmst du über Design > Website-Editor bei den Templates vor?

    Wenn Du das Theme Twenty Twenty-Three löschst, dann wird ein anderes (Standard-)Theme aktiviert. Was passiert, wenn du anschließend das Theme Twenty Twenty-Three wieder installierst und aktivierst? – Taucht dann der Fehler auch wieder auf?

    Viele Grüße
    Hans-Gerd

    Thread-Starter pottersfield

    (@pottersfield)

    Hallo,

    vielen Dank fuer die Antwort. Ja, ich gehe in der Seitenleiste auf Design > Website-Editor und dann laedt dieser und produziert den Fehler.

    So eben gemacht. twenty-Twenty-Three geloescht, Twenty-twenty-two aktiviert. Kurz getestet, selber Fehler. twenty-twenty-Three wieder installiert und aktiviert und selber Fehler immer noch da.

    Links steht:

    „Design

    Passe das Design deiner Website mit Hilfe des Block-Editors an.

    Templates

    Template-Teile“

    Und in der Mitte ueberlagert ein großer Bereich mit der Fehlermeldung: „Im Editor ist ein unerwarteter Fehler aufgetreten. Fehlermeldung kopieren“

    MfG

    Hallo,
    kannst du davon bitte mal einen Screenshot erstellen? – Wie kann man hier Bilder in einen Forenbeitrag einfügen?.

    Viele Grüße
    Hans-Gerd

    Thread-Starter pottersfield

    (@pottersfield)

    Ansicht mit den Themes

    https://pottersfield.studio/wp-content/uploads/2023/08/SCR-20230806-kjge.png

    Fehlermeldung im Editor

    https://pottersfield.studio/wp-content/uploads/2023/08/SCR-20230806-kjsg.png

    • Diese Antwort wurde geändert vor 11 Monaten, 3 Wochen von pottersfield.

    Hallo,
    wenn du eine Website entwickelst, solltest du Cache-Plugins erst mal nicht aktivieren.
    Deaktiviere doch bitte mal WP Fastest Cache (das hatte ich übersehen).

    Viele Grüße
    Hans-Gerd

    Thread-Starter pottersfield

    (@pottersfield)

    Hi,

    okay, das Plugin hab ich nur installiert, da mir der Websitezustand gesagt hat, dass es keinen Cache finden konnte. Selbst ohne das Plugin (direkt out of the box von der wordpress Installation) als auch jetzt wo das Plugin deaktiviert/deinstalliert ist, bleibt das Verhalten gleich.

    mfG

    Hallo,
    hilfreich könnte auch die Aktivierung des Debug-Modus sein. Damit Fehler ausgelesen werden können, müssen die Fehler in eine Log-Datei auf dem Server geschrieben werden, auf die man dann per FTP (oder auch SSH) zugreifen kann.
    Sichere bitte zunächst die wp-config.php auf deinem lokalen Rechner.
    Gib dann bitte mit einem geeigneten Programmier-Editor (z. B. Notepad++) in der wp-config.php oberhalb von /* That's all, stop editing! Happy blogging. */ folgendes ein:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false);
    define( 'WP_DEBUG_LOG', true );

    Achte darauf, dass du define('WP_DEBUG', false); überschreibst, falls die Zeile bereits in der wp-config.php steht. Wenn versucht wird, diese Konstante ein zweites mal zu definieren, gibt es einen Fehler, der deine Seite lahmlegen würde.
    Mit diesen drei Codezeilen sagen wir WordPress, dass der Debug-Modus aktiviert werden soll. Die Fehlermeldungen sollen aber nicht direkt angezeigt werden, sondern in die Datei /wp-content/debug.log geschrieben werden.
    Wenn der Fehler gefunden wurde bzw. wenn die Fehler nicht mehr in die debug.log geschrieben werden sollen, dann musst du daran denken, die Variable
    define( 'WP_DEBUG_LOG', true );
    wieder auf false zu setzen:
    define( 'WP_DEBUG_LOG', false);

    Evtl. könnte auch ein Blick in die error-log beim Hoster aufschlussreich sein.

    Viele Grüße
    Hans-Gerd

    Wenn du die Fehlermeldung siehst, öffne bitte die Entwickler-Tools deines Browsers (Taste F12), öffne den Tab Netzwek (1) lade die Seite nochmal neu und schau, was für die Datei site-editor.php(2) unter Antwort (3) ausgegeben wird. Vermutlich steht bei (4) eine Fehlermeldung, die Hinweise auf die Ursache gibt.

    Screenshot
    Zum Vergrößern bitte anklicken …

    Ich bezweifele, dass JavaScript-Fehler im PHP-Error-Log protokolliert werden.

    Hast du schon versucht, unter Dashboard > Aktualisierungen WordPress „erneut [zu] aktualisieren“?

    Thread-Starter pottersfield

    (@pottersfield)

    @pixolin @hage ch hatte eig. eine andere Antwort vorbereitet, aber als ich weiter getroubleshootet hab, hab ich den Fehler gefunden. Ich hab zwischenzeitlich sogar bei wordpress selbst ueber deren free tier eine neue website erstellt und die selbe Fehlermeldung auch dort erhalten, weshalb ich ausschließen konnte, dass es an mir/meiner Installation liegt. Welche Konstante bleibt als: macOS und Safari. Somit, kurzerhand Brave Browser installiert und siehe da, es funktioniert 🤯. Ich nutze unter macOS mit Safari einzelne extensions. Also naechster Schritt, alle extensions deaktiviert, siehe da, es funktioniert. nachdem ich dann Schritt fuer Schritt wieder diese aktiviert hab, hab ich die Fehlerquelle gefunden.

    https://apps.apple.com/de/app/nightshift-dark-mode/id1561604170?l=en-GB&mt=12

    Nightshift eine extensions fuer Dark Mode websites scheint sich nicht mit dem Editor zu vertragen, zumindest mit aktuellen Themes….

    Werde das ganze mal dort melden und in der Zwischenzeit nach einer Alternative suchen. ich weiß nicht ob man hier Loesungen markieren kann, oder den Titel anpassen kann, sollte jemand anderes das gleiche Szenario haben, dass man die Loesung schneller findet!

    Vielen Dank fuer die Unterstuetzung!

    Danke für die Rückmeldung. Toll, dass du den Fehler so gut eingrenzen konntest. 👍🏼

    ich weiß nicht ob man hier Loesungen markieren kann

    kannst du, und wir bitten sogar darum, weil wir uns dann schneller um noch nicht beantwortete Fragen kümmern können. Dazu findest du entweder unter dem Eingabeformular für Antworten eine Checkbox oder du verwendest das Pulldown-Menü oben rechts.

    Ich ändere den Status auf „gelöst“. Weiterhin viel Erfolg mit WordPress.

Ansicht von 10 Antworten – 1 bis 10 (von insgesamt 10)
  • Das Thema „Im Editor ist ein unerwarteter Fehler aufgetreten.“ ist für neue Antworten geschlossen.