Support » Allgemeine Fragen » Inhalte aus Datenbank werden nicht angezeigt

  • Ich weiß leider nicht, wie ich den Titel besser formulieren kann, versuche aber hier mein Problem zu schildern:
    Ich habe vor ein paar Wochen einen Reisebericht in Form einer Website erstellt, mehr viel Mühe, mit vielen Seiten, Bildern, Links etc….
    Vor ein paar Tagen kam eine Meldung von meinem Host-1und1), dass meine Dateien angegriffen wurden und meine Seite vorübergehend gesperrt ist. Ich habe eine Liste mit beschädigten Dateien bekommen, die ich löschen und ersetzen muss, dann kann ich wieder die Seite benutzen.
    Diese Liste war ewig lang, aber ich habe mich daran gemacht, alle zu löschen und durch neue WordPress-Files zu ersetzen. Zum Glück waren es alles Konfigurations-und Systemdateien, die man ja ganz einfach mit der neuen WordPress-Version herunterladen kann. Der Upload-Ordner nicht, es befinden sich also alle Bilder, die ich hochgeladen hatte noch an ihrem ursprünglichen Pfad.
    Habe dann die wp-config-Datei wieder angepasst und die SQL-Datenbank, wo ja noch alle Inhalte gespeichert sind, eingetragen, also keine neue angelegt oder so.
    Wenn ich die Datenbank exportiere, sehe ich auch eine riesige Textdatei, in der alles steht, was ich auch so gemacht habe (also die Seiteninhalte usw.), so wie es sein muss.
    Allerdings scheint die Seite nicht auf diese Datenbank „zuzugreifen“. Sie präsentiert sich im admin-Modus wie völlig neu, ohne Inhalt bzw. nur mit der Sample-Seite, dem Sample-Post und so. Als ich nach dem Anpassen der config-Datei die Seite geöffnet habe, ging es los, wie wenn man komplett von vorne anfängt (WordPress installieren, Seitentitel eintragen…). Die Seite ansehen kann man auch nicht, aber das ist erstmal das geringere Problem.
    Wie kann ich dafür sorgen, dass all die Inhalte, die in meiner Datenbank ja 100% da sind, auch wieder auf der Seite sind?
    Muss ich in der config-Datei irgendetwas bei dem Teil „ABSPATH“ eintragen? Aber der Pfad ist eigentlich auch der richtige (ich habe versuchsweise eine Datei in die neue Seite hochgeladen und sie liegt brav genau in dem Upload-Ordner, wo auch alle anderen Bilder von vorher sind – aber warum sehe ich die alle in de Medienübersicht nicht?)

    Ich hoffe, ich konnte mein Problem schildern und wäre sehr dankbar über Mithilfe!
    Ich bin ziemliche Anfängerin, also bitte so einfach wie möglich erklären=) habe mir die Infos, was es mit der Datenbank und den ganzen Files auf sich hat, zusammen gesucht, aber jetzt komm ich nicht weiter.

    Achja, der Link (obwohl man da ja eh nichts sieht): http://www.al-mamlaka.monoculing.com

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Bei gehackten Seiten sollte man tatsächlich nicht lange rumtüfteln und sich mit der Frage quälen, ob man alle Schwachstellen erwischt hat, sondern so wie von dir beschrieben die vorhandenen Dateien mit einem frischen Satz WordPress-Dateien überschreiben.

    Das von dir geschilderte anschließende Verhalten deutet darauf hin, dass WordPress zwar auf eine Datenbank zugreifen, dort aber nicht die bereits vorhandenen Informationen auslesen kann … und folglich vermutet, dass du von vorne beginnen möchtest.

    Bist du sicher, dass du beim Einrichten der wp-config.php das richtige Tabellen-Prefix* angegeben hast? (* das ist die „Vorsilbe“ der Datenbank-Tabellen. WordPress geht zunächst davon aus, dass alle Tabellen mit wp_ beginnen. Es wird aber immer wieder angeraten, diese Vorsilbe zu ändern. Und wenn WordPress nach Tabellen mit wp_ sucht, die aber z.B. abc_ heißen, möchte es gerne von vorne loslegen.)

    Danke!!!Es hat tatsächlich funktioniert!!! Von diesem Präfix habe ich noch nie etwas gehört….. das hätte ich von selbst nie herausbekommen. Vielen vielen Dank!

    🙂 gern geschehen!

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Das Thema „Inhalte aus Datenbank werden nicht angezeigt“ ist für neue Antworten geschlossen.