• Hallo, wir wollen eine Multisite aufbauen und haben gemäß Anleitung folgende Schritte ausgeführt:

    1. in die wp-config. php haben wir Zeile define('WP_ALLOW_MULTISITE', true); eingesetzt.
    2. URL Struktur nach Variante 2 festgelegt
    3. Alle Plugins deaktiviert

    Auf der Seite =>Werkzeuge=>Netzwerkeinrichtung erscheint eine Warnung

    „Warnung: Ein bestehendes WordPress-Netzwerk wurde gefunden.“

    4. in die wp-config.php wie folgt eingefügt:

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'www.internet-profi24.de');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    5. in die .htaccess ersetzt wie folgt:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    Nach der Neuanmeldung bekommen wir den Fehler

    weißer Bildschirm Serverfehler 500

    Was machen wir falsch ?

    • Dieses Thema wurde geändert vor 4 Jahren, 4 Monaten von Bego Mario Garde. Grund: Codeformatierung ergänzt
Ansicht von 4 Antworten – 1 bis 4 (von insgesamt 4)
  • Die Fehlermeldung „500 – Internal Server Error“ beschreibt erst einmal nur, dass ein Fehler aufgetreten ist, aber nicht, was die Ursache ist. Damit soll verhindert werden, dass Angreifer auf mögliche Sicherheitslücken hingewiesen werden. Mehr Informationen erhältst du im Error-Log des Webservers, in dem die Ursachen protokolliert werden. Vielleicht ist an anderer Stelle ein Tippfehler reingerutscht oder der Server unterstützt (noch) kein mod_rewrite – schwer zu sagen.

    Thread-Starter candita132

    (@candita132)

    Hallo im Plesk habe ich folgenden Fehler gefunden:

    Apache Fehler

    [core:alert] /var/www/vhosts/internet-profi24.de/httpdocs/.htaccess: Invalid command ‚\xef\xbb\xbf‘, perhaps misspelled or defined by a module not included in the server configuration, referer: http://www.internet-profi24.de/wp-login.php

    „der der Server unterstützt (noch) kein mod_rewrite – schwer zu sagen.“

    Wo kann ich dazu etwas finden ?

    Danke für Deine Hilfe.

    Du hast vermutlich die .htaccess mit Windows Notepad bearbeitet und in einem falschen Zeichenformat gespeichert. Bitte nutze einen geeigneten Programmiereditor (z.B. Atom Editor, Visual Studio Code oder Notepad++, alle kostenlos erhältlich); die speichern im Zeichenformat UTF-8 ohne BOM. Dann bekommt der Webserver auch keinen Schluckauf.

    Thread-Starter candita132

    (@candita132)

    Danke, das war der entscheidene Ansatz !

Ansicht von 4 Antworten – 1 bis 4 (von insgesamt 4)
  • Das Thema „Installation von Multisite wirft nach Änderung der .htaccess Fehler aus“ ist für neue Antworten geschlossen.