Support » Installation » Installation WP – Es gab einen kritischen Fehler auf deiner Website.

  • Gelöst juergenlachmuth

    (@juergenlachmuth)


    Nach ca. zwanzig WP Installationen hat es mich nun auch erwischt.

    Bei einer localhost Installation von WordPress 5.8.2 bekomme ich die DB Verbindung während der Installation nicht hin – trotz der korrekten Anmeldedaten meldet WordPress anschliessend:

    „Es gab einen kritischen Fehler auf deiner Website.“

    Erstelle ich die wp-config.php manuell mit den korrekten Zugangsdaten erhalte ich

    Diese Seite funktioniert nicht
    localhost kann diese Anfrage momentan nicht verarbeiten.
    HTTP ERROR 500

    Zugriff auf die MariaDB 10.4.21 ist vorhanden – PHP 8.1.1 läuft ebenfalls ohne Probleme.

    Der einzige Unterschied zu den vorherigen Installationen: Apple M1 Prozessor – (das kann aber eigentlich nicht der Grund sein, oder …)

    Vielen Dank für irgendeinen Tip.

    • Dieses Thema wurde geändert vor 8 Monaten, 4 Wochen von juergenlachmuth.
Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • PHP 8.1.1 läuft ebenfalls ohne Probleme.

    Das wird das Problem sein. 🙂
    Viele Themes und Plugins sind noch nicht auf dem Stand der neuesten PHP-Version und einige wenig tun sich auch mit PHP 8.0 noch schwer. Wahrscheinlich verschwinden die Probleme, wenn du auf PHP 7.4 umstellst – und das wird noch 10 Monate mit Sicherheitsupdates versorgt.

    Der einzige Unterschied zu den vorherigen Installationen: Apple M1 Prozessor

    Das ist ja nur für eine lokale Installation interessant, kann dann aber auf deinem eigenen Mac zumindest für Fehlermeldungen sorgen, wenn nicht alle Module für Apple Silicon kompiliert wurden.

    Thread-Starter juergenlachmuth

    (@juergenlachmuth)

    Hallo Bego Mario,

    vielen Dank für den Hinweis auf PHP 7.4. Dies würde allerdings bedeuten, das WordPress noch nicht für PHP 8.1.1 installierbar ist.

    Hier wäre ein Hinweis im Xampp hilfreich – ich habe jetzt drei Stunden verbraten.

    Ich installiere jetzt einmal die 7.4 Xampp Distribution und schaue dann mal weiter…

    Wenn du beim Support eines Webhosters anrufst und eine Frage zu Webanwendungen wie WordPress stellst, wirst du üblicherweise an die Supportforen der Webanwendung verwiesen – der Webhoster stellt dir nur einen funktionierenden Webserver zur Verfügung und was du damit machst, ist dann deine Sache. Genauso wird es sein, wenn du die Apache-Freunde auf WordPress ansprichst. Der Server funktioniert, PHP ist top aktuell … wen kümmert’s das viele Entwickler, die ihre Themes und Plugins kostenlos zur Verfügung stellen, noch nicht so weit sind?

    Abgesehen davon ist allerdings auch XAMPP ein wenig überholt. Wenn du in der Schiene bleiben möchtest, würde ich eher die Pakete von Bitnami empfehlen oder aber zu Local wechseln.

    Thread-Starter juergenlachmuth

    (@juergenlachmuth)

    Hallo Bego Mario,

    in der Tat, die WP Installation ist noch nicht für die PHP 8.1.1 „bereit“…

    Die Installation hat unter 7.4.2 ohne Probleme funktioniert.

    Vielen Dank für deine Hilfe und für die Unterstützung hier im Forum.

    Gelöst…

    Schönes neues Jahr 2022 euch allen
    Jürgen

    Das wünsche ich (wünschen wir hier) dir auch.

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Das Thema „Installation WP – Es gab einen kritischen Fehler auf deiner Website.“ ist für neue Antworten geschlossen.