Support » Themes » Installationsfehler OceanWP Theme

  • fstahlhofen

    (@fstahlhofen)


    Hallo,

    Ich habe heute WordPress schon 2x neu Installiert und bekomme immer noch den selben Fehler. Sobald ich im Theme eine Demoseite auswähle wird es falsch Dargestellt.

    Kann mir Jemand einen Tipp geben woran es liegt?

    MfG Fabian S.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Moderator Bego Mario Garde

    (@pixolin)

    … bekomme immer noch den selben Fehler

    Und der ist?

    Wie soll es aussehen?
    Wie sieht es statt dessen aus?
    Welche Schritte haben dazu geführt?
    Wie können wir das nachvollziehen?
    Was hast du probiert, um das Problem zu lösen?
    Welche Demoseite wählst du aus?
    Hast du benötigte Plugins/Page Builder installiert?

    fstahlhofen

    (@fstahlhofen)

    Und der ist?

    Der Fehler ist ein Darstellungsfehler.

    Wie soll es aussehen?

    Es sollte alles aussehen wie diese Demoseite: https://gym.oceanwp.org oder jedes andere von OceanWP. Alle Demoseiten dieses Themes funktionieren bei mir nicht.

    Wie sieht es statt dessen aus?

    Den Fehler kann man sich auf p.fabian-stahlhofen.de angucken… Ich würde es mal so beschreiben, als wäre nichts an seinem Platz.

    Welche Schritte haben dazu geführt?

    Normale Installation von WordPress (Neuste Version) und dann das OceanWP Theme Aktivieren und einrichten.

    Wie können wir das nachvollziehen?

    …?

    Was hast du probiert, um das Problem zu lösen?

    Die PHP Version geprüft und Es neu Installiert.

    Welche Demoseite wählst du aus?

    Gym (https://gym.oceanwp.org)

    Hast du benötigte Plugins/Page Builder installiert?

    Ja, bis auf Ocean Sticky Header und Ocean Elementor Widgets welche aber nur Addon’s sind.

    Moderator Bego Mario Garde

    (@pixolin)

    Geh bitte mal auf Einstellungen > Allgemein. Dort hast du einmal die URL mit http://und einmal mit https:// eingetragen. Das sollte einheitlich sein, danach klappt’s vermutlich auch mit dem Layout.

    Habe vorher beides auf http:// gehabt und jetzt mal beides auf https:// umgestellt. Hat leider nicht geholfen.

    Moderator Bego Mario Garde

    (@pixolin)

    Naja, jetzt sind ja auch die Mediendateien alle mit „http“ in der URL hochgeladen worden und bei Aufruf der Webseite werden sie nicht geladen, weil es sonst gemischte (und damit unsichere) Inhalte gibt. Du müsstest mit einem Plugin wie Better Search Replace die URL mit http:// mit der URL mit https:// in allen Tabellen ersetzen. Oder die vorhandenen Inhalte komplett löschen und die Demo neu importieren.

    Soll ich mein SSL Zertifikat auf only SSL stellen und dann WordPress nochmal neu installieren?

    Teste doch am besten erst mal den Vorschlag von @pixolin: Mit „Better search and replace“ kannst du das ersetzen, wobei du zunächst einen Testdurchlauf machen kannst.

    fstahlhofen

    (@fstahlhofen)

    Habe jetzt das search and replace Tool durchlaufen lassen. Es hat nichts verändert, bis darauf, dass ich jetzt auch keinen Header mehr habe.

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website und kannst den Bericht über den Button „Bericht in die Zwischenablage kopieren“ und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Du kannst ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung eines Plugins, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise ein Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu auch mal die Informationen in dem Beitrag Health Check durch.

    Elementor hat übrigens auch ein eigenes Menu, um die URL umzustellen.

    Vorab der Bericht:

    
    ### wp-core ###
    
    version: 5.5
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /www/htdocs/w01aa990/p.fabian-stahlhofen.de
    wordpress_size: 45,36 MB (47568641 bytes)
    uploads_path: /www/htdocs/w01aa990/p.fabian-stahlhofen.de/wp-content/uploads
    uploads_size: 3,54 MB (3709432 bytes)
    themes_path: /www/htdocs/w01aa990/p.fabian-stahlhofen.de/wp-content/themes
    themes_size: 16,79 MB (17606736 bytes)
    plugins_path: /www/htdocs/w01aa990/p.fabian-stahlhofen.de/wp-content/plugins
    plugins_size: 50,82 MB (53292986 bytes)
    database_size: 1,56 MB (1637472 bytes)
    total_size: 118,08 MB (123815267 bytes)
    
    ### wp-active-theme ###
    
    name: OceanWP (oceanwp)
    version: 1.8.7
    author: Nick
    author_website: https://oceanwp.org/about-me/
    parent_theme: none
    theme_features: core-block-patterns, menus, post-formats, title-tag, automatic-feed-links, post-thumbnails, custom-header, custom-logo, html5, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, editor-style, customize-selective-refresh-widgets, align-wide, wp-block-styles, responsive-embeds, editor-styles, widgets
    theme_path: /www/htdocs/w01aa990/p.fabian-stahlhofen.de/wp-content/themes/oceanwp
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (3) ###
    
    Twenty Nineteen: version: 1.7, author: the WordPress team,Automatische Aktualisierungen deaktiviert
    Twenty Seventeen: version: 2.4, author: the WordPress team,Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 1.5, author: the WordPress team,Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (9) ###
    
    Antispam Bee: version: 2.9.2, author: pluginkollektiv, Automatische Aktualisierungen deaktiviert
    Better Search Replace: version: 1.3.3, author: Delicious Brains, Automatische Aktualisierungen deaktiviert
    Elementor: version: 3.0.2, author: Elementor.com (latest version: 3.0.3), Automatische Aktualisierungen deaktiviert
    Ocean Extra: version: 1.6.5, author: OceanWP, Automatische Aktualisierungen deaktiviert
    Ocean Social Sharing: version: 1.1.0, author: OceanWP, Automatische Aktualisierungen deaktiviert
    SuitePlugins - Login Widget for Ultimate Member: version: 1.0.9.3, author: SuitePlugins, Automatische Aktualisierungen deaktiviert
    Ultimate Member: version: 2.1.7, author: Ultimate Member, Automatische Aktualisierungen deaktiviert
    WPForms Lite: version: 1.6.2.2, author: WPForms, Automatische Aktualisierungen deaktiviert
    WP Mail SMTP: version: 2.3.1, author: WPForms, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 200M
    upload_max_filesize: 200M
    max_effective_size: 200 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 31 GB
    	imagick::RESOURCETYPE_DISK: 1.84467440737E+19
    	imagick::RESOURCETYPE_FILE: 786432
    	imagick::RESOURCETYPE_MAP: 31 GB
    	imagick::RESOURCETYPE_MEMORY: 16 GB
    	imagick::RESOURCETYPE_THREAD: 4
    gd_version: 2.2.5
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.15.0-112-generic x86_64
    httpd_software: Apache
    php_version: 7.4.5 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 10000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 200M
    php_post_max_size: 200M
    curl_version: 7.58.0 OpenSSL/1.1.1
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.28-nmm1-log
    client_version: mysqlnd 7.4.5
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /www/htdocs/w01aa990/p.fabian-stahlhofen.de/wp-content
    WP_PLUGIN_DIR: /www/htdocs/w01aa990/p.fabian-stahlhofen.de/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### wpforms ###
    
    version: 1.6.2.2
    license: false
    lite: Aug 25, 2020 @ 7:36pm
    total_forms: undefined
    total_entries: undefined
    
    ### wp_mail_smtp ###
    
    version: 2.3.1
    license_key_type: lite
    debug: Keine Debug-Hinweise gefunden.
    db_tables: smkjb_wpmailsmtp_tasks_meta
    
    

    Ich werde das mit dem Plugin gleich einmal testen.

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)