Support » Plugins » Internal Error 500 – Wenn ich ein beliebiges Plugin aktiviere

  • Gelöst joergschoel

    (@joergschoel)


    Hallo zusammen,
    Ich bin relativ neu in WP. Meine Frau möchte sich eine Homepage einrichten für ihre Hebammentätigkeit. Wir haben bei IONOS eine Domain und Webspace erworben. Dann auch gleich den WP Installer benutzt und nach 2 Anläufen ging es auch.
    Die Seite befindet sich jetzt im Aufbau. Bevor wir sie mit Inhalten füllen, wollte ich die Struktur schaffen damit sie auch sicher und rechtskonform ist. Darum habe ich einige Plugins installiert. Dabei tritt nun aber immer wieder ein Fehler auf.

    WP-Version: 5.4.1–de_DE
    Theme: Twenty Seventeen Version: 2.3

    Aktive Plugins:
    Antispam Bee Version 2.9.2 von pluginkollektiv
    Broken Link Checker Version 1.11.13 von WPMU DEV
    Complianz | GDPR/CCPA Cookie Consent Version 4.6.3 von RogierLankhorst
    Contact Form 7 Version 5.1.9 von Takayuki Miyoshi
    Limit Login Attempts Reloaded Version 2.13.0 von WPChef
    Statify Version 1.7.1 von pluginkollektiv
    Yoast SEO Version 14.2 von Team Yoast
    OMGF Version 3.6.2 von Daan van den Bergh
    UpdraftPlus – Backup/Restore Version 1.16.25 von UpdraftPlus.Com

    Alle anderen Themes und Plugins sind gelöscht.

    Fehlerbeschreibung:
    In der oben aufgeführten Pluginkonfiguration erhalte ich beim Erstellen einer neuen Seite oder bei dem Versuch eine Seite zu verändern einen Error 500. Das Front-End funktioniert aber einwandfrei. Nur der Adminbereich streikt.
    Sobald ich ein Plugin deaktiviere läuft wieder alles.
    Zunächst hatte ich „Complianz“, weil das letzte Plugin war das ich aktiviert habe, im Verdacht den Fehler zu verursachen. Ich habe dann versucht Complianz gegen etwas anderes einzutauschen habe dann aber das gleiche Problem.
    Wenn ich die Plugins einzeln aktiviere und deaktiviere funktioniert es immer bis das letzte Plugin auf aktiv geschaltet wird. Es spielt keine Rolle welches Plugin es ist.
    Ich habe auch andere Plugins getestet, der Fehler tritt auch dann auf wenn eine aktive Pluginzahl von 7-8 Plugins überschritten wird.

    Was habe ich schon versucht:
    – .htaccess neu aufgesetzt
    – in der .htaccess
    php_value memory_limit 256M
    php_value upload_max_filesize 64M
    php_value post_max_size 64M
    php_value max_execution_time 300
    php_value max_input_time 1000
    gesetzt. Dies hatte aber in allen Variationen nur einen anders formatierten Error 500 zur Folge
    – alle Plugins gelöscht und neu installiert
    – in den Plugins alle nicht dringenden Funktionen abgeschaltet
    – Verschiedene Plugins zum optimieren ausprobiert
    – die PHP Info nach Schwachstellen durchsucht -> https://hebammemerkel.de/test/
    – in der php.ini memory_limit gesetzt
    – in der wp-config
    define( ‚WP_MEMORY_LIMIT‘, ‚128M‘ );
    define( ‚WP_MAX_MEMORY_LIMIT‘, ‚256M‘);
    eingesetzt. (in verschiedenen Varianten)

    Kann mir jemand helfen?

    • Dieses Thema wurde geändert vor 1 Monat von joergschoel.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • bscu

    (@bscu)

    Mit dem Limit kannst du dir sparen, darin liegt es nicht. Laut phpInfo ist der Wert von memory_limit auf -1 gesetzt, das bedeutet unlimitiert.

    Kommst du an die Log-Files von PHP dran?

    • Diese Antwort wurde geändert vor 1 Monat von bscu.
    • Diese Antwort wurde geändert vor 1 Monat von bscu.
    joergschoel

    (@joergschoel)

    Kommst du an die Log-Files von PHP dran?

    Ich habe per FTP einfach einen Unterordner „Test“ erstellt und darin eine index.php geparkt.

    <?php
    
    // Zeigt alle Informationen (Standardwert ist INFO_ALL)
    phpinfo();
    
    ?>

    Wo liegen die Log Files denn normalerweise?

    • Diese Antwort wurde geändert vor 1 Monat von joergschoel.
    Moderator Bego Mario Garde

    (@pixolin)

    Du könntest in der wp-config.php folgende Zeilen oberhalb von oberhalb von /* That's all, stop editing! Happy blogging. */ eintragen:

    Hilfreich wäre ein Error-Log, den du durch einen Eintrag in der wp-config.php erhältst:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    (Quelle: Debugging in WordPress)

    Die Fehlermeldungen werden dann im Verzeichnis wp-content in eine Datei debug.log geschrieben.

    Bitte verwende für den Eintrag einen geeigneten Code-Editor (z.B. VS Code oder Notepad++, beide kostenlos erhältlich), nicht Windows Notepad oder Textedit auf dem Mac, weil diese Programme im falschen Zeichenformat arbeiten.

    joergschoel

    (@joergschoel)

    Hallo Bego,
    vielen Dank für deine Mühe.
    Ich habe deinen Ansatz ausprobiert.
    Leider erzeugt der „Error 500“ bei mir keinen Eintrag in der debug.log.
    Die Datei wird nichtmal erstellt.
    Ich habe gerade extra an einer anderen Stelle einen Fehler eingebaut um zu testen, ob der Debugmodus arbeitet. — Tut er.
    Aber es tauchen nur Einträge auf die direkt auf den von mir eingebauten Fehler verweisen.
    Noch andere Ideen?

    Moderator Bego Mario Garde

    (@pixolin)

    Kurios. Hast du schon mit dem Support deines Webhosters gesprochen?

    joergschoel

    (@joergschoel)

    Also,
    ich habe den Support kontaktiert, bisher keine Antwort.
    Aber ich habe selber einen Workaround gefunden. Vielleicht hilft es dem ein oder anderen vorrübergehend. Oder jemand kommt dadurch auf die Ursache des Problems.

    Ich habe mir gratis Webspace bei ***.com besorgt. Unglaublich langsam und nervig.
    Wordpress installiert und die Seite kurzum dort nachgebaut. Siehe da – es läuft. Dann habe ich nach Unterschieden gesucht und auch gefunden. Es war auf der ***-Version ein Plugin vorinstalliert.
    Classic WordPress Editor
    Diesen habe ich dann auch mal auf der Orginalseite installiert und aktiviert.
    Jetzt kann ich auch weitere Plugins hinzufügen.

    Offensichtlich kommt eins der Plugins mit dem Blockeditor nicht zurecht. Der Fehler kommt aber erst in der Kombination mit anderen Plugnins zum tragen.

    Leider kommt meine Frau mit dem Blockeditor besser zurecht als mit dem Classik. Aber immerhin kommt der Fehler jetzt nicht mehr.

    In der Hoffnung, dass es noch eine saubere Löung gibt lasse ich den Beitrag noch als Unbeantwortet offen.


    Moderationshinweis: Name des Webhosters gelöscht, weil für die ursprüngliche Frage irrelevant.

    Moderator Bego Mario Garde

    (@pixolin)

    Offensichtlich kommt eins der Plugins mit dem Blockeditor nicht zurecht.

    Dazu würde es schon reichen, wenn der Block-Editor und das Plugin eine Funktion mit gleichem Namen enthalten.

    Du hattest allerdings geschrieben, dass das Problem besteht „Wenn ich ein beliebiges Plugin aktiviere“?

    Für eine „saubere Lösung“ müsstest du weiter versuchen, den Fehler einzukreisen: Welche Plugins lassen sich einzeln installieren? Klappt eine Installation mehrerer dieser Plugins? Lässt sich das Problem auf ein einzelnes Plugin beschränken?

    Es wäre tragisch, wenn wir alle mit dem Block-Editor keine Plugins mehr installieren könnten. Wahrscheinlicher ist, dass es an einer individuellen Serverkonfiguration, einem Theme, einem bestimmten Plugin oder einer fehlerhaften Aktualisierung von WordPress (hey, gleich heute neues Update machen!) liegt.

    joergschoel

    (@joergschoel)

    Du hattest allerdings geschrieben, dass das Problem besteht „Wenn ich ein beliebiges Plugin aktiviere“?

    Ja so ist es auch. Yoast alleine läuft. Auch im Kombination mit allen anderen Plugins. Nur offensichtlich nicht gleichzeitig. Da muss man erstmal drauf kommen.

    Im Yoast Forum wurde heute das gleiche Problem beschrieben.
    Mit meinem Workaround klappt es auch bei dem dort Betroffenen.
    Er hatte kurz zuvor ein Yoast Update eingespielt. Weshalb ich davon ausgehe, dass der Fehler sich dort eingeschilchen hat.

    Er bekommt diesen Fehler im Log angezeigt:
    mmap() failed: [12] Cannot allocate memory

    Ich denke es reicht wenn das Thema im Yoast Forum besprochen wird.
    Danke euch für die Hilfe

    • Diese Antwort wurde geändert vor 4 Wochen von joergschoel.
Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)