Support » Allgemeine Fragen » Internal Server error nach Umzug

  • Gelöst sventasch

    (@sventasch)



    Hallo,

    ich habe die WordPress Seite meines Kumpels zu IONOS umgezogen. Ich bin dabei wiefolgt vorgegangen:

    1. MSQL Dump der Datenbank erzeugt
    2. Datenbank auf den IONOS Server installiert
    3. Dump importiert
    4. WP Ordner vom alten Server abgezogen
    5. Daten auf den IONOS Server geladen
    6. Domain mit den Ordner verknüpft.

    Nun bekomme ich leider folgende Fehlermeldung:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Könnt ihr mir bitte weiterhelfen?

    Vielen Dank
    Sven

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Wenn ich deinen Link anklicke, wo lande ich da? Beim alten oder beim neuen Provider?

    Hallo,
    hast Du denn auch die wp-config.php entsprechend geändert ?

    /**
     * Ersetze datenbankname_hier_einfuegen
     * mit dem Namen der Datenbank, die du verwenden möchtest.
     */
    define('DB_NAME', 'datenbankname_hier_einfuegen');
    
    /**
     * Ersetze benutzername_hier_einfuegen
     * mit deinem MySQL-Datenbank-Benutzernamen.
     */
    define('DB_USER', 'benutzername_hier_einfuegen');
    
    /**
     * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
     */
    define('DB_PASSWORD', 'passwort_hier_einfuegen');
    

    Viele Grüße
    Hans-Gerd

    Ahja, da hatte ich vergessen zu schreiben. Ich habe die WP_Config mit den Datenbankdaten vom neuen Server angepasst. Da die Domain umgezogen ist, denke ich das ich auf dem neuen Server lande. Vielen Dank!

    …denke ich das ich auf dem neuen Server lande

    Ja, du kannst denken, der Server nicht. Wie lange ist es her, dass du die Einträge auf den neuen Server eingetragen hast? Bis das überall greift, kann es durchaus mal bis zu 24 Stunden dauern.

    In solchen Fällen ist es ratsam, die Installation am alten Ort so zu belassen wie sie ist, aber an den Inhalten keine Änderungen mehr vorzunehmen. Das macht man dann nur noch am neuen Ort. So kommt es zu keinem Unterbruch in der Erreichbarkeit.

    ein Ping an deine Domain liefert ein ‚invalid host‘ zurück.

    kannst du mit oneandone.net etwas anfangen? Passt das eher zum Alten oder zum Neuen?

    @sventasch

    kopiere dir mal die .htaccess-Datei auf deinen Rechner und lösche sie anschließend auf dem Server.

    Solltest du dich nun wieder anmelden können, navigiere zu Einstellungen -> Permalinks und speichere neu.

    Falls das immer noch zu einem 500er Error führt, teste, ob die Domain überhaupt erreichbar ist. Dafür die .htaccess w. o. beschrieben entfernen.

    Den nachfolgenden Code kopieren und in einen Texteditor einfügen, das dann als index.html speichern und ins Stammverzeichnis deiner WordPress-Installation (dort wo du auch die .htaccess gefunden hattest) hochladen. Nun die Domain aufrufen.

    <!DOCTYPE html>
    <html>
    <head>
    
    </head>
    <body style="background: black";>
    <h1 style="color: white;">Die Domain ist erreichbar</h1>
    	 
    </body>
    </html>

    Hallo,

    vielen Dank für eure Hilfe! Ich bin in Sachen Umzug absoluter Leihe, deshalb seid bitte gnädig, wenn ich nicht so viel weiß oder verstehe.

    Ich habe die .htaccess mal umbenannt. Nun kommt eine weiße Seite ohne Meldung. Wenn ich die Seite mit WP-Admin aufrufe, kommt der Login und ich kann mich mit den alten Logindaten einloggen. Jedoch sehe ich dort ein sehr übersichtliches WP, was mir aussieht wie eine Neuinstallation. Auch das Theme schein nicht geladen zu sein.

    Solltest du dich nun wieder anmelden können, navigiere zu Einstellungen -> Permalinks und speichere neu.

    Außerdem erscheint im Frontend nun

    Error establishing a database connection

    was bedeutet, dass die eingetragenen Daten (Datenbankdaten) in der wp-config.php nicht korrekt sind.

    Hallo,

    ich habe es jetzt hinbekommen. Woran es genau lag, weiß ich nicht. Habe einfach nochmal alles gelöscht und es Schritt für Schritt neu gemacht. Ein PlugIn (Cockie Note) ging auch nicht. Weiß gar nicht, für was das ist. ich habe ja die Seite neu übernommen. Nun bin ich heilfroh 🙂 Danke für eure Hilfe. Sven

    Cookie Note wird wahrscheinlich einen Hinweis zeigen, dass Cookies verwendet werden. EU-Vorschrift. Eigentlich unsinnig und nur nervig.

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)