Support » Allgemeine Fragen » Jeglicher File Upload funktioniert nicht

  • Gel├Âst noveb

    (@noveb)


    Hallo liebe Leute ­čÖé ,

    TL;DR: File Upload geht nicht, Strato Support sagt es liegt an WordPress, mir gehen die Ideen aus

    ich habe gestern das WordPress Hosting bei Strato bestellt und wollte es heute einrichten. Dazu habe ich ├╝ber mein Strato Kundenportal die Schritte zur WordPress Installation durchgef├╝hrt und auf den ersten Blick hat auch alles funktioniert.
    Leider gibt es ein Problem mit File Uploads, denn WordPress kann keine Dateien auf die Festplatte schreiben.
    Dieser Fehler tritt beispielsweise auf bei:

    • WordPress Update mit der Fehlermeldung:
      „Herunterladen der Aktualisierung von https://downloads.wordpress.org/release/de_DE/wordpress-5.4.zip ÔÇŽ

      Download fehlgeschlagen.: Die Pr├╝fsumme der Datei (d41d8cd98f00b204e9800998ecf8427e) stimmt nicht mit dem erwarteten Pr├╝fsummenwert (1fb4f66c84d2b7b140d6a4dfdb3b179d) ├╝berein.

      Die Installation ging schief“

    • Installation von Daten Importer / allg. Plugins:
      „Installation fehlgeschlagen: Das Paket konnte nicht installiert werden.“
    • Installation von Themes:
      „Installation fehlgeschlagen: Download fehlgeschlagen. Die Pr├╝fsumme der Datei (d41d8cd98f00b204e9800998ecf8427e) stimmt nicht mit dem erwarteten Pr├╝fsummenwert (899ff5247dd1c173463e54a71eb98996) ├╝berein.“
    • Upload von Fotos:
      “ DCIM00123.jpg Konnte die Datei nicht auf die Festplatte kopieren. „

    Von den ~25GB Hostingspace sind ├╝ber 24GB noch frei und ├╝ber SFTP kann ich problemlos Dateien hochladen. Da es eine ganz frische Installation und auch Strato Account ist, sollte ich da nichts verstellt haben, schon gar nicht an der WordPress Konfiguration.

    Ich habe die Installation auch schon mehrfach gel├Âscht und sowohl den „Sicherheits-Modus“ als auch „Felxibilit├Ąts-Modus“ (Strato Ding, so eine Art Autoupdate An/Aus) ausprobiert, das Problem bleibt bestehen. Sogar eine eigene Installation habe ich vorgenommen (WP download bei wordpress.org, Upload in meinen Webspace, etc) leider ohne Erfolg und immer den gleich Fehlern.

    Wenn ich ├╝ber SFTP die Rechte checke (alle „755“), bzw. mit dem rekursiven Dampfhammer nochmals alle auf „755“ nagle, hat das keine Auswirkung auf den Fehler.

    Den Strato Support habe ich jetzt schon dreimal telefonisch kontaktiert und wenig produktive Hilfe bekommen. Am Ende wird darauf verwiesen, dass sie f├╝r WordPress keinen Support haben.
    Daher: Hi, k├Ânnt ihr mir helfen?

    Viele Gr├╝├če
    Jochen

    p.s.: keine plugins installiert, bzw. standards deinstalliert.
    Strato Zugriffslogs haben nur einen Error von heute morgen, keine vom Nachmittag/Abend:

    15.04.2020 11:35:47 neue.seite.wiki [client 178.x.x.x] FastCGI: comm with server "/home/strato/http/fastcgi/rid/xx/xx/xxxxxxxxxx/htdocs/WordPress_SecureMode_01/wp-admin/admin.php" aborted: idle timeout (240 sec)
    15.04.2020 11:35:47 neue.seite.wiki [client 178.x.x.x] AH00524: Handler for fastcgi-script returned invalid result code 1

    Zustandsbericht:

    ### wp-core ###
    
    version: 5.4
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: false
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web522/c0/94/510518894/htdocs/wordpress
    wordpress_size: 41,88 MB (43918664 bytes)
    uploads_path: /mnt/web522/c0/94/510518894/htdocs/wordpress/wp-content/uploads
    uploads_size: 51,79 KB (53038 bytes)
    themes_path: /mnt/web522/c0/94/510518894/htdocs/wordpress/wp-content/themes
    themes_size: 3,79 MB (3975557 bytes)
    plugins_path: /mnt/web522/c0/94/510518894/htdocs/wordpress/wp-content/plugins
    plugins_size: 234,98 KB (240617 bytes)
    database_size: 944,00 KB (966656 bytes)
    total_size: 46,88 MB (49154532 bytes)
    
    ### wp-active-theme ###
    
    name: Twenty Twenty (twentytwenty)
    version: 1.2
    author: WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: automatic-feed-links, custom-background, post-thumbnails, custom-logo, title-tag, html5, align-wide, responsive-embeds, customize-selective-refresh-widgets, editor-color-palette, editor-font-sizes, widgets, menus, editor-style
    theme_path: /mnt/web522/c0/94/510518894/htdocs/wordpress/wp-content/themes/twentytwenty
    
    ### wp-themes-inactive (2) ###
    
    Twenty Nineteen: version: 1.5, author: WordPress-Team
    Twenty Seventeen: version: 2.3, author: WordPress-Team
    
    ### wp-plugins-inactive (2) ###
    
    Akismet Anti-Spam: version: 4.1.4, author: Automattic
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verf├╝gbar
    imagemagick_version: Nicht verf├╝gbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc
    httpd_software: Apache/2.4.41 (Unix)
    php_version: 7.4.4
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 240
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 64M
    php_post_max_size: 76M
    curl_version: 7.54.0 OpenSSL/1.0.2k
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.42-log
    client_version: 5.5.54
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web522/c0/94/510518894/htdocs/wordpress/wp-content
    WP_PLUGIN_DIR: /mnt/web522/c0/94/510518894/htdocs/wordpress/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    • Dieses Thema wurde ge├Ąndert vor 2 Jahre, 2 Monaten von noveb.
Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Poste doch bitte mal den Inhalt deiner wp-config.php.

    (Zugangsdaten zur Datenbank und SALT-Keys bitte entfernen und optimal w├Ąre es, wenn du auch noch den [Code]-Button zum Formatieren verwenden k├Ânntest.)

    Thread-Ersteller noveb

    (@noveb)

    Gerne doch. Das ist die, der manuellen, ebenfalls fehlerhaften Installation. Die Originale der Strato Installationen hab ich nicht mehr, sah aber nach ziemlich den selben Werten aus.

    <?php
    /**
     * Grundeinstellungen f├╝r WordPress
     *
     * Zu diesen Einstellungen geh├Âren:
     *
     * * MySQL-Zugangsdaten,
     * * Tabellenpr├Ąfix,
     * * Sicherheitsschl├╝ssel
     * * und ABSPATH.
     *
     * Mehr Informationen zur wp-config.php gibt es auf der
     * {@link https://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren}
     * Seite im Codex. Die Zugangsdaten f├╝r die MySQL-Datenbank
     * bekommst du von deinem Webhoster.
     *
     * Diese Datei wird zur Erstellung der wp-config.php verwendet.
     * Du musst aber daf├╝r nicht das Installationsskript verwenden.
     * Stattdessen kannst du auch diese Datei als wp-config.php mit
     * deinen Zugangsdaten f├╝r die Datenbank abspeichern.
     *
     * @package WordPress
     */
    
    // ** MySQL-Einstellungen ** //
    /**   Diese Zugangsdaten bekommst du von deinem Webhoster. **/
    
    /**
     * Ersetze datenbankname_hier_einfuegen
     * mit dem Namen der Datenbank, die du verwenden m├Âchtest.
     */
    define( 'DB_NAME', 'db_name' );
    
    /**
     * Ersetze benutzername_hier_einfuegen
     * mit deinem MySQL-Datenbank-Benutzernamen.
     */
    define( 'DB_USER', 'db_user' );
    
    /**
     * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
     */
    define( 'DB_PASSWORD', 'db_password' );
    
    /**
     * Ersetze localhost mit der MySQL-Serveradresse.
     */
    define( 'DB_HOST', 'rdbms.strato.de' );
    
    /**
     * Der Datenbankzeichensatz, der beim Erstellen der
     * Datenbanktabellen verwendet werden soll
     */
    define( 'DB_CHARSET', 'utf8mb4' );
    
    /**
     * Der Collate-Type sollte nicht ge├Ąndert werden.
     */
    define('DB_COLLATE', '');
    
    /**#@+
     * Sicherheitsschl├╝ssel
     *
     * Ändere jeden untenstehenden Platzhaltertext in eine beliebige,
     * m├Âglichst einmalig genutzte Zeichenkette.
     * Auf der Seite {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * kannst du dir alle Schl├╝ssel generieren lassen.
     * Du kannst die Schl├╝ssel jederzeit wieder ├Ąndern, alle angemeldeten
     * Benutzer m├╝ssen sich danach erneut anmelden.
     *
     * @since 2.6.0
     */
    define( 'AUTH_KEY',         'abcd' );
    define( 'SECURE_AUTH_KEY',  'abcd' );
    define( 'LOGGED_IN_KEY',    'abcd' );
    define( 'NONCE_KEY',        'abcd' );
    define( 'AUTH_SALT',        'abcd' );
    define( 'SECURE_AUTH_SALT', 'abcd' );
    define( 'LOGGED_IN_SALT',   'abcd' );
    define( 'NONCE_SALT',       'abcd' );
    
    /**#@-*/
    
    /**
     * WordPress Datenbanktabellen-Pr├Ąfix
     *
     * Wenn du verschiedene Pr├Ąfixe benutzt, kannst du innerhalb einer Datenbank
     * verschiedene WordPress-Installationen betreiben.
     * Bitte verwende nur Zahlen, Buchstaben und Unterstriche!
     */
    $table_prefix = 'wp_';
    
    /**
     * F├╝r Entwickler: Der WordPress-Debug-Modus.
     *
     * Setze den Wert auf ÔÇ×trueÔÇť, um bei der Entwicklung Warnungen und Fehler-Meldungen angezeigt zu bekommen.
     * Plugin- und Theme-Entwicklern wird nachdr├╝cklich empfohlen, WP_DEBUG
     * in ihrer Entwicklungsumgebung zu verwenden.
     *
     * Besuche den Codex, um mehr Informationen ├╝ber andere Konstanten zu finden,
     * die zum Debuggen genutzt werden k├Ânnen.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define( 'WP_DEBUG', false );
    
    /* Das warÔÇÖs, Schluss mit dem Bearbeiten! Viel Spa├č. */
    /* That's all, stop editing! Happy publishing. */
    
    /** Der absolute Pfad zum WordPress-Verzeichnis. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', dirname( __FILE__ ) . '/' );
    }
    
    /** Definiert WordPress-Variablen und f├╝gt Dateien ein.  */
    require_once( ABSPATH . 'wp-settings.php' );
    

    Was mir noch auffiel eben, in der Installation durch Strato lag eine .htaccess Datei mit folgendem Inhalt (diese ist jetzt in der manuellen Installation nicht mehr enthalten):

    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Hm, nein, das ist auch unkritisch. Ich h├Ątte erwartet, dass du mit einer Konstante ├änderungen ausgeschlossen hast ÔÇô┬áfinde ich aber nicht.

    Ist Server Side Security deaktiviert?

    Thread-Ersteller noveb

    (@noveb)

    Das war anfangs aktiviert, habe ich als eine der ersten Ma├čnahmen deaktiviert. Aber hat leider auch nichts ge├Ąndert.

    ├ťbrigens schonmal vielen Dank f├╝r die schnelle Hilfe!!

    Wenn’s denn Hilfe w├Ąre ÔÇŽ┬á

    Ich muss nochmal nachfragen: Mit „WordPress-Hosting“ meinst du nicht ein normales Webhosting, bei dem du selber WordPress installierst, sondern ein Managed Hosting, bei dem Strato Themes und Plugins vorgibt? Dann w├Ąre es kein Fehler sondern gewolltes Verhalten, dass du keine eigenen Plugins hochladen/installieren kannst. Wundert mich aber, dass dem Support von Strato dazu nichts einf├Ąllt.

    Thread-Ersteller noveb

    (@noveb)

    Es ist das „WordPress Hosting Starter“ Paket https://www.strato.de/hosting/wordpress-hosting
    ├ťber das Strato Kundenzenter kann man die Installation vornehmen, gibt die selben Daten wie bei der WordPress Installation in eine Maske von Strato ein, verkn├╝pft die Installation mit einer Domain von Strato und die bauen das mit den entsprechenden Daten. Also bisschen mehr als „hier ist Webspace, jetzt mach was du willst“, viel weniger als z.B. wordpress.com
    Bei Support kam ich am 1st Lvl wohl nicht vorbei und

    W├Ąrend ich das schreibe und aus Verzweiflung einfach noch mal einen Upload probiert habe, funktioniert der pl├Âtzlich! Hat wohl doch noch jemand bei Strato den richtigen Knopf gedr├╝ckt, ich habe nichts ge├Ąndert gerade ­čśÇ

    Ich l├Âsche jetzt meine manuelle Installation noch mal und versuche eine Installation ├╝ber Strato.

    Vielen vielen Dank trotzdem, ist ja deine Freizeit! Ich hoffe, ich muss mich nicht mehr melden ­čśÇ

    • Diese Antwort wurde ge├Ąndert vor 2 Jahre, 2 Monaten von noveb.
    Thread-Ersteller noveb

    (@noveb)

    So, eine schlechte und eine gute Nachricht:
    Mit der Installation ├╝ber Strato war wieder der selbe Mist kaputt.

    Die gute: ich habe wp_debug aktiviert und Notice: fwrite(): write of 1160 bytes failed with errno=49 Disc quota exceeded in /mnt/web522/c0/94/510518894/htdocs/WordPress_01/wp-includes/Requests/Transport/cURL.php on line 481
    erhalten.

    Das widerum l├Ąsst ja auf einen vollen Webspace schlie├čen (wenn ich mich nicht irre) was absolut nicht sein kann, da nur ca 500MB von 25GB genutzt werden (laut Strato Kundenzenter├╝bersicht).

    Sch├Ątze ich nerve morgen den Strato Support noch etwas ^^

    buereau

    (@buereau)

    Hallo zusammen,
    ich habe urpl├Âtzlich das Problem, dass ich keine Bilder mehr in die Mediathek laden kann. Eine Stunde zuvor habe ich noch ein Video, ein Bild und eine Gif hochladen k├Ânnen, dann die Fehlermeldung:

    „Bildname“ konnte nicht hochgeladen werden.
    Konnte die Datei nicht auf die Festplatte kopieren.

    Wie wurde das Problem denn bei dir behoben? (Bin auch bei Strato…)
    Ich habe auch alle Rechte gecheckt etc. aber keine ├änderung…

    Lieben Dank schon mal und viele Gr├╝├če

    • Diese Antwort wurde ge├Ąndert vor 2 Jahre von buereau.
    Moderator Bego Mario Garde

    (@pixolin)

    @buereau Wenn du eine Antwort willst, h├Ąng dich doch bitte nicht an einen Thread mit einem „me too“ an. Oder hast du exakt den selben Hosting-Vertrag, die Dateien auf dem selben Server, die gleichen Plugins und Theme installiert? Wenn nicht, w├Ąre es doch sch├Ân, wenn wir dein Problem gesondert behandeln w├╝rden.

    Thread geschlossen.

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Das Thema ÔÇ×Jeglicher File Upload funktioniert nichtÔÇť ist f├╝r neue Antworten geschlossen.