Support » Allgemeine Fragen » Kann keine internen Links erstellen

  • Hallo zusammen
    Ich bin total neu bei WP. Ich habe es auf meinem Server zu Hause installiert und bin nun daran eine eigene Internetseite aufzubauen.

    Mein Problem im Moment ist, dass ich keine internen Links erstellen kann. Bei der Suchenfunktion wird mir nichts angezeigt.

    Was ich gemacht habe:
    – Vier Seiten erstellt: Seite1, Seite2, Seite3, Seite4. Diese Seiten stehen im Moment auf Entwurf und sind alle unter alle Seiten sichtbar.
    – Auf Seite1 Das Wort „Seite2″markiert und auf das Symbol für Link gedrückt. Es erscheint dann der Kasten um einen Link zu erstellen. Die Seite2 zum Auswählen erscheint aber nicht, resp. Es erscheint gar nichts.

    Ich habe dann versucht die Seiten zu veröffentlichen, ebenfalls ohne Erfolg.
    Hat mir jemand einen Tipp wo mein Denkfehler liegt. In verschiedenen Büchern und Anleitungen finde ich immer nur das beschriebene Vorgehen

    Vielen Dank
    Marcel

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Auf Seite1 Das Wort „Seite2″markiert und auf das Symbol für Link gedrückt. Es erscheint dann der Kasten um einen Link zu erstellen. Die Seite2 zum Auswählen erscheint aber nicht, resp. Es erscheint gar nichts.

    Der Kasten ist ein Eingabefeld, in dem du den Titel der Seite, auf die du verlinken möchtest, eingeben kannst. Du siehst dann eine Auswahl an Seiten, für die der eingegeben Suchbegriff passt und kannst die richtige Seite anklicken. Mit dem abgeknickten Pfeil übernimmst du die Eingabe.

    Wenn die Suche allerdings auch nicht klappt und du selbst beim Veröffentlichen Schwierigkeiten hast, stimmt generell etwas nicht. Das kann z.B. an einer fehlerhaften Installation liegen, wenn nicht alle WordPress-Dateien sauber übertragen wurden (in dem Fall kannst du per FTP auf deinem Webserver die Verzeichnisse wp-admin und wp-includes löschen und anschließend aus einer frisch heruntergeladenen und entpackten WordPress-Datei wieder hochladen), oder wenn eines der Plugins nicht funktioniert, wie gewünscht.

    Zusätzliche Informationen liefern dir die Entwicklertools deines Browsers (Rechtsklick > Element untersuchen, dann im Abschnitt Console nach Fehlermeldungen schauen) und die Aktivierung des Debugging-Modus, in dem du in der wp-config.php die Konstante WP_DEBUG auf true setzt: define( 'WP_DEBUG', true );

    Hat das veröffentlichen denn funktioinert?
    Also siehst du die Seiten auf der Website (außerhalb des Adminbereichs)?

    Thread-Ersteller maalke

    (@maalke)

    Ja das Veröffentlichen geht. Habe eben noch bemerkt, dass auf dem Mac alles geht, nur auf dem ipad gehts nicht.

    Moderator PraetorIM

    (@praetorim)

    Die Seite2 kann auch noch nicht in dem Auswahlkasten erscheinen, da sie noch nicht veröffentlicht ist. Die WordPress-Funktion geht halt davon aus, dass ein Link auf eine (noch) nicht zugängliche Seite keinen Sinn macht. Nachdem Du Seite2 veröffentlicht hast, findest Du sie auch auf Seite1 im Link-Auswahlmenu (ggfs. musst Du Seite1 einmal zwischendurch abspeichern, damit die verfügbaren Seiten für das Link-Auswahlmenü neu geladen werden).

    Wenn Du das so nicht willst, etwa weil alle 4 Seiten zugleich (und mit gegenseitiger Verlinkung) veröffentlicht werden sollen, musst Du entweder die Links nachträglich (nach dem Veröffentlichen) einfügen oder aber Du trägst die entsprechenden URLs per Hand (also ohne das Auswahlmenue) ein. Die hierfür erforderliche URL findest Du auf beim Editieren der jeweiligen Seite unter dem Titel als „Permalink“ angegeben.

    Hast du mal versucht, die Plugins zu deaktivieren um den Fehler einzugrenzen?
    Geben die Entwickler-Werkzeuge des Browsers eine Fehlermeldung aus?

    Thread-Ersteller maalke

    (@maalke)

    Nein deaktiviert habe ich noch nichts. Bin noch etwas frisch dabei, als dass ich schon durchblicken würde. Wie obrn geschrieben gehts am Mac, beim ipad pto nicht. Scheint ein Problem beim Gerät zu sein.

    Neulich in der Autowerkstatt:
    „Mein Wagen macht komische Geräusche im Motor.“
    „Können Sie mal die Motorhaube aufmachen?“
    „Nein, das geht nicht. Ich hab meinen Führerschein noch nicht lang genug, als dass ich schon durchblicken würde.“

    Spaß beiseite … wie sollen wir dir helfen, wenn du alle Ratschläge, um mögliche Fehlerquellen einzugrenzen, ignorierst?

    Thread-Ersteller maalke

    (@maalke)

    Sorry da hast Du mich falsch verstanden. Ich möchte gar nichtd ignorieren. Ich habe nur etwas länger bis ich alles gefunden habe. Heute Morgen un 07.00 habe ich spontan entschieden alles zu installieren und bin nun daran eine Seite zu basteln. Hatte letzthin mal etwas zu schnell und nicht sauber genug nach einer Forumsantwort an der SQL Datenbank gebastelt. Das kam nicht gut. Deshalb bin ich vielleicht übervorsichtig. Tut mir leid. Ich versuche Heute Abend mal Umzusetzen was ich auf die Reihe krieg.

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „Kann keine internen Links erstellen“ ist für neue Antworten geschlossen.