Support » Allgemeine Fragen » Katgeorie-Seiten: „Sorry, no posts found“

  • Gelöst tengri

    (@tengri)


    Hallo,
    ich habe eine Website mit WPML und drei Sprachen (DE, EN, RU).
    Seit kurzem bekomme ich die Kategorie-Seiten (archive pages) aller Kategeorien in EN und RU nicht mehr korrekt angezeigt, Beispiel hier http://eddaschlager.com/en/journalism/articles/
    Im Tab steht „Seite nicht gefunden“, da wo die Posts aufgelistet sein müssten, steht „Sorry, No Posts Found“.
    Aber die Seite selbst wird aufgerufen und sie existiert de facto auch.
    Betrifft wirklich alle Kategorien der jeweiligen Sprache. Bei Schlagwörtern ist alles okay.
    Habe per Yoast SEO das /category/ aus der URL entfernt, aber das ist schon länger her, Fehler ist mir erst kürzlich aufgefallen.
    Ich poste es hier und nicht bei Plugins, weil gestern das Gleiche immer wieder mal auch bei den deutschen Kategorie-Seiten auftrat, nach Cache-Löschen etc. sich die Installation dann aber wieder einkriegte.
    Hat jemand eine Idee, woran das liegen kann?
    Vielen Dank!

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Ich vermute, dass es tatsächlich ein Problem mit WPML ist. Frage doch parallel hierzu auch dort nach (und informiere bitte beide Seiten, wenn eine Lösung gefunden wurde). Wenn du Pech hast, hakt es aber auch bei Yoast. Was passiert, wenn du das Plug-in deaktivierst?

    Sind die neuesten Versionen WordPress/Yoast/WPML, etc. installiert?

    Könnten Caches das Problem verursachen, irgendwelche Cache-Plug-ins, etx.?

    Thread-Ersteller tengri

    (@tengri)

    Hallo,
    noch WP 4.6.1, alles andere auf aktuellem Stand.
    ich vermute auch, dass es irgendwas mit WPML und Yoast zu tun hat.
    Habe beide Plugins abgestellt, einzeln, zusammen, auch alle anderen, Problem besteht dennoch.
    Lediglich die WPML-Umleitung uaf die EN-, bzw. RU-Startseite funktioniert, wenn Yoast abgestellt ist, d.h. es bleibt nicht auf der jeweiligen Kategorie-Seite hängen wie jetzt. Aber die Seiten werden in allen Fällen nicht korrekt abgerufen.
    Ja, habe bereits bei WPML gefragt, noch keine Antwort.
    Falls hier trotzdem noch jemandem was einfällt, wäre ich dankbar.

    Vielleicht solltest du es mal mit WP 4.7 ausprobieren.
    Wenn du zuvor ein komplettes Backup (alle Dateien und Datenbank) anlegst, könntest du den jetzigen Zustand ja notfalls wiederherstellen.

    Was ist mit Caches?
    Hast du auch mal testweise die .htaccess-Datei umbenannt?

    Hier wäre noch ein Tipp:
    https://wpml.org/forums/topic/wpml-setup-stuck-on-setp-2-select-languages-all-of-way-is-not-working/

    Vielleichst findest du noch mehr mögliche Lösungen,
    Ich hatte folgende Suchbegriffe eingegeben und das obige gefunden:

    „Sorry, No Posts Found“ WMPL
    

    Alternative könntest du es auch damit versuchen:

    „Sorry, No Posts Found“ Yoast
    
    Thread-Ersteller tengri

    (@tengri)

    Ehrlich gesagt halte ich es nicht für eine gute Idee, meine Installation, die grad zerschossen ist, jetzt auf 4.7 upzudaten. Ich fürchte, da werden die Probleme nur größer, da auch noch nicht alle meine Plugins nachgezogen haben.
    Ja, hab WP Fastest Cache, an- und ausgeschaltet, ständig am cleanen, bringt keinen Unterschied.
    Nein, vor dem Anfassen von .htaccess hab ich Angst.
    Es hat wohl was mit WPML und dem entfernen von /category/ per Yoast zu tun.
    Aber nach dem Rückgängig-Machen-und-wieder-Einfügen von /category/ machen jetzt meine deutschen Kategorien wieder Mist und werden nicht korrekt ausgegeben.

    Thread-Ersteller tengri

    (@tengri)

    So, habe jetzt also zurückgestellt auf /category/ anzeigen und Yoast komplett abgestellt – jetzt funktionieren alle Kategorie-Links und -Seiten in allen Sprachen. Hm.
    Das ist ja nun auch keine Lösung … aber ich suche mal weiter im WPML-Forum.

    Thread-Ersteller tengri

    (@tengri)

    Offensichtlich gibt es genau für das Problem schon eine Lösung – nämlich dieses Plugin, das genau die Ibkompatibilität von WPML und Yoast in der Hinsicht löst.
    Nach Cache-Leeren konnte ich auch Yoast wieder anknipsen, dann das Plugin installiert, jetzt funktionieren alle Kategorien-Links und -Seiten – ohne /category/.
    Problem gelöst – danke für die moralische Unterstützung.

    Klasse! Danke für die Rückmeldung.

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „Katgeorie-Seiten: „Sorry, no posts found““ ist für neue Antworten geschlossen.