Support » Installation » Kein Email Versand – weder per wp-mail() noch SMTP

  • robertbalke

    (@robertbalke)


    Hallo Zusammen,
    Problem: keine Mails werden verschickt (z.B. Passwort vergessen Email)
    nach mehreren Stunden googeln und testen bin ich mit meinem Latein am Ende 🙁 und hoffe auf eure Hilfe! Danke!
    Ich bin gerade dabei einen Relaunch meiner Website aufzubauen. Dafür habe ich auf meinem Server ein Unterverzeichnis erstellt. Dort habe ich dann eine zweite WordPress Instanz installiert. (auf meinem Host-Europe Server hatte ich noch nie Probleme mit den Mails)
    Fehlerquelle(?): bei der Installation habe ich mich bei meiner Email Adresse vertippt. Sodass ich natürlich keine Emails bekommen kann.
    Lösungsversuch 1: Daraufhin habe ich (anhand von mehreren Anleitungen) die Admin Email-Adresse und User Email-adresse direkt in der Datenbank korrigiert. Dies hat das Problem nicht gelöst – weiterhin keine Emails.
    Plugins für Testmails geben mir keine Fehlermeldungen heraus – Das Senden der Mails sei erfolgreich.
    Lösungsversuch 2: Dann habe ich mit zwei verschiedenen Plugins den Materialversand über SMTP eingerichtet. (Dieser ist auf meiner Live-website auch aktiv und funktioniert tadellos)
    Aber auch über SMTP kein Erfolg. Hier bekomme ich zumindest eine Fehlermeldung. „Email not Send“ Der Port 587 könnte blockiert sein. Dies ist aber definitiv nicht der Fall.
    Lösungsversuch 3: für meinen Newsletter verende ich Sendinblue. In deren Plugin kann man einstellen das der gesamte Materialversand über die läuft. Aber auch das funktioniert nicht. (keine Fehlermeldung – Senden einer Testmail sei erfolgreich aber es kommt nichts an)
    Lösungsversuch 4: Dann habe ich mit Hilfe von WP_ALLOW_REPAIR die Datenbank repariert aber alle Tabellen waren in Ordnung.
    Lösungsversuch 5: Dann habe ich versucht mit aktivem WP_DEBUG erneut versucht Mails zu verschicken aber es ist kein Fehler aufgetreten der eine log File geschrieben hätten.
    Hat jemand eine Idee was ich noch versuchen kann? Ich wäre für jeden Tipp dankbar!
    Viele Grüße Robert

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Moderator Bego Mario Garde

    (@pixolin)

    Kannst du dich im Backend anmelden?
    Dann ruf mal http://art.robertbalke.de/wp-admin/options.php auf und suche im Browser nach dem Feld mit der Beschriftung admin_email. Hier solltest du eine Änderung vornehmen können, ohne diese nochmal bestätigen zu müssen.

    Mit dem Plugin Check E-Mail kannst du die Mail-Funktionalität prüfen.

    Ich habe die Erfahrung gemacht, dass einige E-Mail-Provider bei bisher unbekannten E-Mail-Adressen prüfen, ob diese Adresse überhaupt existiert und anderenfalls die Annahme verweigern, da sie die E-Mail von einem nicht bestehendem E-Mail-Account als Spam ansehen. Das wäre eine weitere mögliche Erklärung, wieso die E-Mails nicht zugestellt werden.

    Thread-Ersteller robertbalke

    (@robertbalke)

    Hi Bego,
    Danke für Deine schnelle Antwort!
    die Änderung über die options.php habe ich schon getestet. Dies hat bei mir nicht funktioniert. Daraufhin habe ich wie oben geschrieben Die Mail Adresse direkt in der Datenbank geändert. Dies hat gut funktioniert. Seitdem habe ich meine richtige Emailadresse im System.

    Das Plugin Check E-Mail habe ich auch installiert. Es versendet angeblich Emails – aber nichts kommt an. Ich habe sowohl verschiedene Email Adressen als Versender und Empfänger versucht.

    Moderator Bego Mario Garde

    (@pixolin)

    Hast du mal den Support deines Webhosters angesprochen?
    Manchmal hängt auch etwas in der Mail-Warteschlange fest …

    Thread-Ersteller robertbalke

    (@robertbalke)

    @bego: Auf Deinen Rat hin habe ich bei Host Europe angerufen und hatte auch einen sehr kompetenten Ansprechpartner. Er hat sich sogar in meiner WordPress Instanz eingeloggt und hat alles gecheckt. Ihm war es aber auch nicht möglich den Fehler zu beheben. 🙁

    Ich werde wohl alles neu aufsetzen.

    Danke für Deine Hilfe!
    Robert

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    auch wenn ich mir kaum vorstellen kann, dass das zum Erfolg führt, hier noch ein Ansatz:
    Du kannst ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung eines Plugins, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise ein Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu auch mal die Informationen in dem Beitrag zu Health Check durch.
    Viele Grüße,
    Hans-Gerd

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Das Thema „Kein Email Versand – weder per wp-mail() noch SMTP“ ist für neue Antworten geschlossen.