Support » Allgemeine Fragen » KEIN Log-in MÖGLICH!!!Help!

  • Hi,

    habe mich von malware getrennt und nun geht gar nichts mehr. Kein WordPress Log-in mehr möglich….folgende Meldung wird angezeigt beim Start der Seite:

    /** * marco-piano functions and definitions. * * @link https://developer.wordpress.org/themes/basics/theme-functions/ * * @package marco-piano */ if ( ! function_exists( ‚marco_piano_setup‘ ) ) : /** * Sets up theme defaults and registers support for various WordPress features. * * Note that this function is hooked into the after_setup_theme hook, which * runs before the init hook. The init hook is too late for some features, such * as indicating support for post thumbnails. */ function marco_piano_setup() { /* * Make theme available for translation. * Translations can be filed in the /languages/ directory. * If you’re building a theme based on marco-piano, use a find and replace * to change ‚marco-piano‘ to the name of your theme in all the template files. */ load_theme_textdomain( ‚marco-piano‘, get_template_directory() . ‚/languages‘ ); // Add default posts and comments RSS feed links to head. add_theme_support( ‚automatic-feed-links‘ ); /* * Let WordPress manage the document title. * By adding theme support, we declare that this theme does not use a * hard-coded

    Ich bin überfragt und bitte um Hilfe:) Wäre echt klasse! Danke sehr

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 30)
  • @bscu,

    Das ist eine andere functions.php!

    Wenn er die functions.php vom theme aus der Updraftsicherung unter dem genannten Pfad nimmt, wäre das ok und das würde ich dann schon testen.

    @hage ich check das mal eben…

    jetzt bekomme ich diesen fehler:

    Fatal error: Uncaught Error: Call to undefined function get_template_directory() in /kunden/368065_76297/marco-piano/wp-config.php:161 Stack trace: #0 /kunden/368065_76297/marco-piano/wp-load.php(37): require_once() #1 /kunden/368065_76297/marco-piano/wp-blog-header.php(13): require_once(‚/kunden/368065_…‘) #2 /kunden/368065_76297/marco-piano/index.php(17): require(‚/kunden/368065_…‘) #3 {main} thrown in /kunden/368065_76297/marco-piano/wp-config.php on line 161

    Hallo,
    Du hast aber die functions.php von der Sicherung in den Ordner des themes kopiert, das Du nutzt, also z. B. in \wp-content\themes\hier_ist_mein_theme ?
    Du hast auch schon mal getestet, den Ordner des themes per FTP umzubenennen – siehe meine Antwort von vor ca. 5 Stunden ?

    Viele Grüße
    Hans-Gerd

    ja, habe ich……🤔🤔🤔

    hmm, das waren zwei Fragen von mir. Bezieht sich die Antwort von Dir auf die erste oder zweite oder beide Fragen ?

    Ja, auf beide Fragen….

    So langsam glaube ich, du solltest ein komplettes Backup einspielen, da scheint noch mehr kaputt zu sein.

    ich denke auch……welche manuelle methode würdest du mir vorschlagen? Das Backup wurde mit Updraft erstellt….

    Da kann ich dir leider nicht weiterhelfen, da ich Updraft nicht kenne.

    kein ding…..trotzdem schon mal danke für deine mühe👍

    Hast Du eine aktuelle Sicherung von Updraft Plus auf Deinem lokalen Rechner ?
    Sicherheitshalber würde ich vorher noch mal alle Dateien vom Server auf Deinen lokalen Rechner kopieren
    Danach alle Dateien aus der Sicherung von Updraft Plus (plugins, themes, uploads, andere) lokal entpacken und per FTP (Binär) hochladen (evtl. erst mal nur themes, dann testen, danach plugins). Die anderen beiden Dateien dürften in dem Zusammenhang nicht so wichtig sein.
    Allerdings könnte es natürlich sein, dass das Problem mit der WP-Installation bei Dir zusammenhängt (z. B. wp-config.php) und das sind Dateien, die in Updraft Plus nicht gesichert werden. Diese Dateien habe ich immer lokal per FTP separat gesichert.
    Hier ein Link zu einer Beschreibung, wie man mit Updraft Plus Sicherungen erstellt und wiederherstellt.
    Möglicherweise wäre es aber auch hilfreich, einen Dienstleister wegen des Problems anzusprechen.
    Gerade habe ich das hier noch gefunden – Wiederherstellung, wenn backend nicht funktioniert:
    https://updraftplus.com/frequently-asked-questions/
    https://updraftplus.com/faqs/i-want-to-restore-but-have-either-cannot-or-have-failed-to-do-so-from-the-wp-admin-console/

    hans, das ist sehr nett von dir….ich werde auf alle fälle berichten👏

    Hi,

    habe mich von malware getrennt

    @sebalanskaski1

    Ich habe den Link zu deiner Website entfernt. Durch ein Backup besteht die nicht geringe Wahrscheinlichkeit, dass du mit dem Backup erneut Malware auf deine Website bringst.

    Ich würde dir raten, WordPress komplett neu aufzusetzen und alle erforderlichen Maßnahmen für deine neue Website zu ergreifen.

    👍👍👍Das mache ich

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 30)
  • Das Thema „KEIN Log-in MÖGLICH!!!Help!“ ist für neue Antworten geschlossen.