Support » Allgemeine Fragen » Kein Login im Backend möglich

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Du kannst versuchen, die Plugins vorübergehend zu deaktivieren, um sie als mögliche Fehlerursache auszuschließen. Dazu benennst du per SFTP das Verzeichnis wp-content/plugins in z.B. wp-content/no.plugins um und versuchst erneut, dich anzumelden. Danach kannst du das Verzeichnis wieder in wp-content/plugins umbenennen und im Backend die Plugins einzeln aktivieren. Gibt es wieder Probleme, weißt du zumindest schon mal, woran es liegt.

    Ein define( 'RELOCATE', true ); macht nur Sinn, wenn du dabei bist, deine Website umzuziehen  – deshalb auch der Name der Konstante.

    Thread-Ersteller easyback

    (@easyback)

    Grüß Dich,

    das hatte ich auch schon versucht 🙁 gerade nochmal, leider auch wieder ohne Erfolg.

    Gleiches Verhalten wie bisher.

    Wäre nett, wenn du vorher beschreibst, was du schon ausprobiert hast.

    Bekommen wir eine URL zur Website?

    Thread-Ersteller easyback

    (@easyback)

    ich hab schon so viel versucht unzählige Male, da hatte ich nicht mehr alles auf dem Schirm. Alles was man üblicherweise findet hab ich schon durch, also neuer Benutzer, Passwort Reset, Cookies, Debugging Modus, Plugins raus. Ich hoffe, ich hab jetzt alles erwischt.

    Seiten URL gerne per PN, da es ein persönliches Familientagebuch ist.

    OK, dann kann ich dir nicht weiterhelfen.

    Kannst du mich nicht anrufen oder mal schnell bei mir einloggen?

    Thread-Ersteller easyback

    (@easyback)

    Ich konnte mich jetzt in die Funktion:
    function wp_validate_auth_cookie() vorarbeiten

    if ( ! hash_equals( $hash, $hmac ) ) {
    			/**
    			 * Fires if a bad authentication cookie hash is encountered.
    			 *
    			 * @since 2.7.0
    			 *
    			 * @param string[] $cookie_elements An array of data for the authentication cookie.
    			 */
    			 
    			echo $hash.'----'.$hmac;
    			echo "<pre>";
    			die(var_dump($cookie_elements));
    			echo "</pre>";
    			do_action( 'auth_cookie_bad_hash', $cookie_elements );
    			return false;
    		}

    die beiden Variablen $hash und $hmac sind nicht gleich und somit flieg ich dann raus. Jetzt ist nur die Frage, warum einer beiden Hash Werte nicht korrekt berechnet wird.

    Alles was man üblicherweise findet hab ich schon durch, also neuer Benutzer, Passwort Reset, Cookies, …

    Hast du das Passwort als MD5-Hashwert eingetragen?

    Thread-Ersteller easyback

    (@easyback)

    Ja, über die phpmyadmin mit MD5 Funktion

    • Diese Antwort wurde geändert vor 9 Monaten, 4 Wochen von easyback.

    Hast du mal einen anderen Browser ausprobiert?

    Thread-Ersteller easyback

    (@easyback)

    Ja, gerade nochmal getestet. Edge, Firefox, Chrome. Ohne Erfolg, der Hash ist weiterhin unterschiedlich.

    Nur um Missverständnisse zu vermeiden: Du trägst das Passwort wie hier im Bild ein?

    Screenshot Einstellungen
    (zum Vergrößern anklicken)

    (also Passwort im Klartext, Funktion MD5 ausgewählt)

    Thread-Ersteller easyback

    (@easyback)

    Exakt so. Bei anderen Instanzen auf dem Server gibts keine Probleme, das tatsächlich nur die eine Installation.

    Thread-Ersteller easyback

    (@easyback)

    Ich hab das Problem gefunden!

    Wahrscheinlich durch Jahrelange Migration der Installation (der Blog ist mittlerweile 13 Jahre alt) ergab sich in der wp-config.php folgende Konstellation, und die wp-settings.php wurde 2 mal inkludiert, und da liegt das Problem. Nach der Anpassung an die wp-config.php einer frischen 5.6er Version klappt alles ohne Probleme.

    /* Das wars schon, ab hier bitte nichts mehr editieren! Viel Spaß beim bloggen. */
    define(‚ABSPATH‘, dirname(__FILE__).’/‘);
    require_once(ABSPATH.’wp-settings.php‘);
    define(‚AUTH_KEY‘, ‚xxx‘);
    define(‚SECURE_AUTH_KEY‘, ‚xxx‘);
    define(‚NONCE_KEY‘, ‚xxx‘);
    define(‚AUTH_SALT‘, ‚xxx‘);
    define(‚SECURE_AUTH_SALT‘, ‚xxx‘);
    define(‚LOGGED_IN_SALT‘, ‚xxx‘);
    define(‚NONCE_SALT‘, ‚xxx‘);

    /** Absolute path to the WordPress directory. */
    if ( !defined(‚ABSPATH‘) )
    define(‚ABSPATH‘, dirname(__FILE__) . ‚/‘);

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‚wp-settings.php‘);

    • Diese Antwort wurde geändert vor 9 Monaten, 4 Wochen von easyback.
    • Diese Antwort wurde geändert vor 9 Monaten, 4 Wochen von easyback.

    Schön, dass du eine Lösung gefunden hast.
    Danke für die Rückmeldung.

    Thread als „gelöst“ markiert.

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Das Thema „Kein Login im Backend möglich“ ist für neue Antworten geschlossen.