Support » Allgemeine Fragen » Kein neuer Benutzer

  • Ich wollte seit einiger Zeit wieder einen neuen Benutzer anlegen.
    Leider ging das nicht, weil offensichtlich der Passwortgenerator nicht funktioniert.
    Der Button „Passwort generieren“ ist rot hinterlegt, ebenso der Button „Anzeigen/Verstecken“ und zeigt keine Reaktion.
    Nach Eingabe aller Felder und Abschicken des Formulars kommt die Fehlermeldung:
    „Fehler: Die Passwörter stimmen nicht überein. Bitte gib in beide Passwortfelder dasselbe Passwort ein.“ Es gibt aber nur 1 Feld?!
    Kann mir jemand bitte helfen?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Vor einiger Zeit hatten wir das Thema hier schon mal im Forum. Schau doch bitte mal in den folgenden Beitrag. Im englischsprachigen Forum habe ich den folgenden Beitrag gefunden, in dem offenbar ein paar Lösungsmöglichkeiten genannt werden.
    Eine Lösungsmöglichkeit:

    Schnelle Lösung, die bei mir funktioniert hat:
    Versuchen Sie, auf „Passwort generieren“ zu klicken, wenn dies nicht möglich ist (Passwort ausblenden wird nicht angezeigt, wenn Sie darauf klicken).
    Aktualisieren Sie die Seite.
    Klicken Sie auf „Passwort generieren“ (dieses Mal sollte es funktionieren) und geben Sie Ihr Passwort in das Feld für das generierte Passwort ein. Füllen Sie alle Felder wie erforderlich aus und speichern Sie.
    Ich hatte das gleiche Problem mit den nicht ausgefüllten Passwortfeldern (es wurde nur 1 Feld angezeigt), aber die obige Lösung hat das Problem behoben, und ich habe soeben problemlos 4 neue Benutzer erstellt.

    Übersetzung mit http://www.DeepL.com/Translator

    Thread-Ersteller herbertla

    (@herbertla)

    Danke für den Hilfeversuch 🙂
    leider hatte ich mit keiner der im Englischen Foren genannten Methoden Erfolg.

    Ich habe mal die Seite untersucht und da bin ich auf folgenden Code gestossen, Datei wp-admin/user_new.php:

    			<input class="hidden" value=" " /><!-- #24364 workaround -->
    			<button type="button" class="button wp-generate-pw hide-if-no-js"><?php _e( 'Generate password' ); ?></button>
    			<div class="wp-pwd">
    				<?php $initial_password = wp_generate_password( 24 ); ?>
    				<span class="password-input-wrapper">
    					<input type="password" name="pass1" id="pass1" class="regular-text" autocomplete="off" data-reveal="1" data-pw="<?php echo esc_attr( $initial_password ); ?>" aria-describedby="pass-strength-result" />
    				</span>
    				<button type="button" class="button wp-hide-pw hide-if-no-js" data-toggle="0" aria-label="<?php esc_attr_e( 'Hide password' ); ?>">
    					<span class="dashicons dashicons-hidden" aria-hidden="true"></span>
    					<span class="text"><?php _e( 'Hide' ); ?></span>
    				</button>
    				<div style="display:none" id="pass-strength-result" aria-live="polite"></div>
    			</div>
    		</td>
    	</tr>
    	<tr class="form-field form-required user-pass2-wrap hide-if-js">
    		<th scope="row"><label for="pass2"><?php _e( 'Repeat Password' ); ?> <span class="description"><?php _e( '(required)' ); ?></span></label></th>
    		<td>
    		<input name="pass2" type="password" id="pass2" autocomplete="off" aria-describedby="pass2-desc" />
    		<p class="description" id="pass2-desc"><?php _e( 'Type the password again.' ); ?></p>
    		</td>
    	</tr>

    Also wenn ich mit meinen bescheidenen PHP-Kenntnisse richtig liege, sind die beiden Buttons bewusst blockiert wenn „Java“ fehlt!
    Kann das mit dem vermaledeiten jQuery zusammen hängen?

    • Diese Antwort wurde geändert vor 11 Monaten, 3 Wochen von Hans-Gerd Gerhards. Grund: Bitte den Code immer als "Code" formatieren
    Thread-Ersteller herbertla

    (@herbertla)

    Version WordPress 5.8, 21.07.2021

    Wenn man sich den Quellcode der Seite ansieht, wenn man einen neuen User anlegen möchte, dann hat das in der Tat was mit Javascript zu tun: Ich habe das gerade mal in Firefox getestet. Wenn ich in Firefox javascript deaktiviere, dann erhalte ich genau die Ansicht, die offensichtlich zu dem Problem führt:
    Ohne Javascript:
    Einstellungen.
    Mit Javascript:
    Einstellungen.
    Entweder du prüfst in deinem Browser, ob Javascript aktiviert ist oder du nutzt mal testweise einen anderen Browser, um zu sehen, ob es da funktioniert.

    Thread-Ersteller herbertla

    (@herbertla)

    Hallo Hans-Gerd,
    das genau war die Lösung! Vielen Dank für die Unterstützung, ganz grosses „Like“!

    Ist für mich zwar etwas verwunderlich , dass ein Workaround eingerichtet wird, aber dar Fehler zu dem das führt nicht abgefangen wird.

    Du kannst den Call schliessen!

    Hallo,
    freut mich, dass es klappt und danke für die Info. Das Problem hatten wir ja hier schon ein paar Mal und können damit evtl. auf diese Lösung verweisen.
    Übrigens: Du brauchst nur dieses Thema oben als gelöst markieren. Das habe ich jetzt schon gemacht. 😉
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller herbertla

    (@herbertla)

    Nachtrag!

    Ich hatte den User jetzt unter EDGE angelegt, weil ich das nie benutze und unter Chrome positiv getestet

    Unter Firefox funktioniert das immer noch nicht, auch wenn javascript.enabled=true gesetzt?

    • Diese Antwort wurde geändert vor 11 Monaten, 3 Wochen von herbertla.

    Dann vielleicht einfach noch mal den Browsercache in Firefox löschen oder alternativ Firefox im privaten Fenster öffnen.
    Ich habe den Status erst mal wieder auf „nicht gelöst“ gesetzt.

    • Diese Antwort wurde geändert vor 11 Monaten, 2 Wochen von Hans-Gerd Gerhards. Grund: Status auf nicht gelöst
Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „Kein neuer Benutzer“ ist für neue Antworten geschlossen.