Support » Installation » Kein Zugang mehr zum Admin nach Update

  • Gelöst daniela2020

    (@daniela2020)


    Hi,

    ich habe gestern ein Update von meinem Theme gemacht, und komme nun nicht mehr in den Adminbereich.
    Folgende Fehlermeldung erhalte ich:
    Parse error: syntax error, unexpected ‚[‚ in /home/www/meine website/wp-content/themes/acmephoto/acmethemes/admin-notice/class-admin-notice-handler.php on line 75

    nun war ich im ftp bei dieser line und da steht das: $body_args = [

    aber ich habe dort ja nichts gemacht, ich hab lediglich „update“ im wp-admin bereich geklickt.

    Ich hoffe jemand kann mir da nun helfen,
    Lieben Dank,
    Daniela

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Leider fehlen da Informationen zu deiner Website. Du hättest zumindest eine URL zu deiner Website angeben können.

    Ich kann deshalb nur die Vermutung anstellen, dass du eine veraltete PHP-Version verwendest. Das kannst du entweder im Kundenmenü deines Webhosters prüfen (und am besten gleich eine aktuellere PHP-Version aktivieren!) oder du erstellst mit einem geeigneten Programmiereditor (z.B. Atom Editor, Visual Studio Code oder Notepad++, alle kostenlos erhältlich) eine Datei phpinfo.php mit folgendem Inhalt:
    <?php phpinfo();

    Die Datei lädst du dann per FTP in dein WordPress-Verzeichnis hoch und rufst im Browser https://example.com/phpinfo.php auf. Du kannst dann ablesen, welche PHP-Version aktuell verwendet wird. Alles unter PHP 7.2 solltest du nicht mehr verwenden.

    Wenn du Schwierigkeiten bei der Umstellung der PHP-Version hast, sprich mal den Support deines Webhosters an. Sollte das Problem weiterhin bestehen, obwohl du eine aktuelle PHP-Version verwendest, melde dich bitte nochmal.

    Hallo,
    du findest evtl. eine Option unter Werkzeuge > Websitezustand > Info einen Bericht zur Website und kannst den Bericht über den Button „Bericht in die Zwischenablage kopieren“ und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte.
    Viele Grüße
    Hans-Gerd

    @hage das dürfte schwierig werden, wenn Daniela nicht mehr in den Admin-Bereich kommt. 😉

    hallo,

    @bego mario garde, ich konnte bei hoststar auf php7.1 ändern, das tat ich auch aber es geht trotzdem nicht.
    hab dort mal hingeschrieben,… bin ziemlich ratlos..

    wenn du noch tipps hast bin ich echt dankbar!
    lieben dank,
    daniela

    @pixolin – oh je, hätte ich besser lesen sollen und nicht zwischendurch mal antworten.
    @daniela2020:
    Versuche zunächst das theme neu runterzuladen, zu entpacken und per FTP (Einstellung Binär) in den entsprechenden Ordner hochladen.
    Wenn das nicht klappt, dann deaktiviere zunächst das theme, indem du per FTP den Namen des theme – Ordners änderst, der das Problem verursacht: z. B. \wp-content\themes\theme_ordner in \wp-content\themes\_theme_ordner – ich habe hier vor dem Namen des Ordners einen Unterstrich gesetzt.
    In dem Fall wird dann ein Standard-Theme, z. B. twenty seventeen oder twenty nineteen aktiviert – Voraussetzung ist allerdings, dass ein entsprechendes Standardtheme noch existiert.
    Hier noch ein Link zu der Vorgehensweise
    Viele Grüße
    Hans-Gerd

    @hage Lustig, das hatte ich auch erst geschrieben und nach langem Tippen ist mir aufgefallen, dass sie von $body_args = [ schreibt und da hab ich mir gedacht, dass das ja eine neue* Schreibweise von $body_args = array()`. Ich vermute deshalb eher, dass es an der PHP-Version liegt.

    (* neu ist relativ. Die Schreibweise ist ab PHP 5.4 erlaubt.)

    @pixolin: stimmt natürlich. Aber ich war jetzt davon ausgegangen, dass die PHP-Version umgestellt ist. Insofern wäre natürlich dein Vorschlag am Anfang hilfreich, wenn @daniela2020 dieses kleine script phpinfo.php erstellt, damit man dann Klarheit hat 😉
    Und verkehrt ist es sicher nicht, erst mal zu sehen, was passiert, wenn ein Standardtheme aktiviert ist.

    Hallo,

    ich hatte selbst die neueste Php Version geändert -ohne Erfolg. Hab dann auch meinen Hoster geschrieben, die haben es dann dort gemacht – und nun…. Tadaaa alles geht wieder!

    Danke euch allen fürs Helfen und Kopfzerbrechen!!
    Lieben Gruß
    Daniela

    freut mich 🙂

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)