Support » Installation » Kein Zugriff auf Dashboard

  • Hallo zusammen,

    ich habe mir vor ein paar Tagen das Plugin „All in One Security & Firewall“ installiert, da kürzlich meine Webseite offensichtlich gehackt wurde.

    Nun aber habe ich die Sicherheitsstandards so hoch gesetzt, dass ich leider keinen Zugriff mehr auf mein Dashboard bekomme. Ich erhalte folgende Fehlermeldung:

    „Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /mnt/web307/b1/05/530705/htdocs/institut/wp-content/plugins/js_composer/include/classes/core/class-vc-mapper.php on line 111 Notice: Constant WP_TEMP_DIR already defined in /mnt/web307/b1/05/530705/htdocs/institut/wp-config.php on line 120
    Du bist leider nicht berechtigt, auf diese Seite zuzugreifen.“

    Was muss ich denn nun wie ändern, um wieder auf das Dashboard zu gelangen?

    Auf meine Datenbank kann ich wieder zugreifen und auch die Adminrechte sind vorhanden.

    Vielen Dank schon einmal im Voraus für die Hilfe.

    Viele Grüße

    Ingo Wupperfeld

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten - 16 bis 25 (von insgesamt 25)
  • Ich hatte ja vorhin den Benutzer gelöscht und nochmals neu angelegt und wenn ich demnach alles richtig gemacht. Dennoch aber funktioniert es immer noch nicht. Irgendwo muss es noch eine Einstellung geben, die mir den Zugang blockiert. Aber wo?

    Wie wäre es denn damit, wenn ich WordPress komplett neu installiere, aber dann auf die bisherige Datenbank zugreife. Dies müsste doch gehen. Allerdings muss ich dann wissen, aus welchen Dateien ich welche Informationen sammeln muss, um dies durchzuführen.

    Irgendwo muss es noch eine Einstellung geben, die mir den Zugang blockiert. Aber wo?

    Keine Ahnung, was du da machst.
    Meine Empfehlung: Einfach mal eine Nacht drüber schlafen und dann morgen mit neuer Energie alles noch mal durchgehen, was wir dir hier schon geschrieben haben und die Anleitungen und Beschreibungen noch mal in aller Ruhe durchlesen.
    Ich habe die Erfahrung gemacht, dass dann manche Dinge ganz schnell erledigt sind.
    Wilder Aktionismus ist da keine gute Idee.

    Mittlerweile habe ich per FTP-Programm WordPress gelöscht und noch einmal komplett installiert, habe aber die alte Datenbank behalten und bei der Neuinstallation die entsprechenden Datenbank-Daten eingegeben.
    Es erscheint wieder die Meldung „Du bist leider nicht berechtigt, auf diese Seite zuzugreifen.“
    Somit muss die Zugangssperre irgendwo in der Datenbank verankert sein. Wo könnte dies sein?

    Diese Fehlerbeschreibung ist zu vage, um eine konkrete Empfehlung zu geben.
    Schau dir mal diesen Beitrag an: https://kinsta.com/de/wissensdatenbank/sorry-you-are-not-allowed-to-access-this-page-fehler-in-wordpress/

    In dem Beitrag werden ganz unterschiedliche Gründe genannt, wieso diese Fehlermeldung auftauchen kann. Geh die Liste mal schrittweise durch.

    Durch deine eigenen, wenig dokumentierten Versuche wird die Sache nicht übersichtlicher. Was sind z.B. „entsprechende Datenbank-Daten“? Ist damit auch das Tabellen-Präfix mit gemeint?

    Nach meiner Erfahrung braucht die Lösung eines Problems erheblich länger, wenn du voreilig Annahmen triffst wie z.B. „Somit muss die Zugangssperre irgendwo in der Datenbank verankert sein.“ – mit dieser Aussage würdest du z.B. die fehlerhafte Eingabe von Datenbank-Zugangsdaten (einschließlich Tabellen-Präfix) von vornherein ausschließen.

    Hallo,

    vielen Dank für Deine Antwort.
    Den Tabellenpräfix habe ich schon manuell geändert, aber das ist nicht der Fehler.
    Ich habe heute noch ein Forum eröffnet zum Plugin „All in One Security & Firewall“, damit dies ggf. auch von Experten gefunden wird, die sich mit diesem Plugin auskennen.

    Ich habe heute WordPress noch einmal installiert, dann aber auf die alte Datenbank zugegriffen und konnte mich nicht anmelden. Beim Aufruf der wp-admin-Seite konnte ich keine Anmeldung durchführen und bekam lediglich die Meldung: „Du bist leider nicht berechtigt, auf diese Seite zuzugreifen.“

    Die Zugriffsverweigerung muss irgendwo in der Datenbank verankert sein. Ich weiß aber nicht, wo dies sein soll.

    Ich habe auch schon alle Tabellen gelöscht, die zum „All in One Security & Firewall“-Plugin gehören (beginnen mit „aiowp“), aber dennoch wird der Zugriff blockiert.

    Ich habe auch in der Tabelle „options“ gesehen, dass das „All in One Security & Firewall“-Plugin immer noch als aktiv verankert ist. Ich weiß aber nicht, wie ich das in der Datenbank löschen muss (ohne Schaden anzurichten) und wo ggf. noch weitere Komonenten durch dieses Plugin versteckt sind, die mir den Zugriff verweigern.

    Für mich ist diese Datenbank auch Neuland. Deswegen meine Anfrage.

    Viele Grüße

    Ingo Wupperfeld

    Ich habe heute noch ein Forum eröffnet zum Plugin „All in One Security & Firewall“, damit dies ggf. auch von Experten gefunden wird, die sich mit diesem Plugin auskennen.

    Hab ich gesehen … und gleich wieder geschlossen. Lass den Quatsch bitte – es reicht, wenn du die Frage hier einmal stellst. Oder du wendest dich an den Plugin-Entwickler. Das Support-Forum des Plugins findest du hier:
    https://wordpress.org/support/plugin/all-in-one-wp-security-and-firewall/

    Es bringt auch wenig, wenn du einfach nur wiederholst, was du bereits geschrieben hast und Antworten dabei völlig ignorierst.

    Ich habe auch in der Tabelle „options“ gesehen, dass das „All in One Security & Firewall“-Plugin immer noch als aktiv verankert ist.

    Wenn du vorher das Plugin-Verzeichnis gelöscht hast und dann immer noch einen Datenbankeintrag siehst, der das Plugin als aktiv anzeigt, arbeitest du vielleicht in der falschen Datenbank.

    Inzwischen habe ich den Eindruck, dass du in irgendeiner Datenbank Änderungen vornimmst, wie es dir gerade einfällt, ohne auf die Antworten hier einzugehen. In dem Fall spare ich mir weitere Anregungen, drücke dir aber ganz fest die Daumen.

    Zunächst einmal danke für die Antwort. Ich werde keine zweite Anfrage mehr öffnen. Habe halt gedacht, dass darüber die Plugin-Spezialisten darauf aufmerksam würden.

    Ich habe das Plugin in meinem FTP-Programm manuell gelöscht, also den entsprechenden Unterordner im Ordner „plugins“. In der Datenbank befinden sich aber dennoch scheinbar Reste des Plugins. Ich habe auch nicht an „irgendeiner“ Datenbank Änderungen vorgenommen, sondern es war schon die Datenbank, die zu meiner Homepage gehört. Und ich habe festgestellt, dass diese restlichen Eintragungen bzw. Tabellen noch vorhanden waren, <u>nachdem</u> ich das Plugin gelöscht hatte.

    Außerdem ignoriere ich die anderen Beiträge nicht, sondern ich habe sie schon befolgt, haben aber nicht zum Erfolg geführt.

    Um das Problem weiter einzukreisen, habe ich heute WordPress neu installiert, kann mich aber dennoch nicht anmelden. Somit wird es wohl an einem Datenbankeintrag liegen und stelle sicherlich dann auch die berechtigte Frage, wo ein solcher Eintrag denn sein könnte.

    Ich werde aber gerne den Tipp aufnehmen und einmal die Entwickler des Plugins anschreiben. Muss das auf Englisch geschrieben sein oder geht das auch auf Deutsch?

    Du solltest die Anfrage an die Plugin-Entwickler schon auf Englisch stellen. Wenn du dich da nicht so fit fühlst, kannst du auch die automatisierte Übersetzung von https://deepl.com/translate nutzen – die reicht für eine Anfrage bestimmt aus. Hilfreich wäre, wenn du die bisherigen Schritte kurz und prägnant auflistest – das spart Rückfragen.

    Was du versucht hast oder nicht können wir nur deinen Antworten entnehmen. Wenn ich dir empfehle, eine Liste mit 11 Punkten abzuarbeiten und du dich nach 12 Minuten bereits mit einer ausführlichen Antwort zu anderen Dingen meldest, ist das zumindest eine … interessante Reaktion.

    Die Schritte, die ich unternommen hätte, um so ein Problem zu lösen wären Plugin-Verzeichnis umbenennen, .htaccess umbenennen, Cache (Browser und Server/Plugin) zu leeren, neuen Admin anlegen. Es überrascht mich sehr, dass du damit keinen Erfolg hattest, aber vermutlich fehlt irgendeine Information.

    Vielen Dank für die wertvolen Informationen. Ich werde mich mal an den Entwickler des Plugins wenden.

    Ich hatte bereits vorgestern versucht, die hier genannten Lösungen (Browser-Cache löschen, neuen Benutzer anlegen etc.) umzusetzen, aber sie brachten keinen Erfolg. Deshalb konnte ich gestern auch schon nach 12 Minuten antworten. Aber nichts für ungut.

    Das Problem scheint an irgendeiner Einstellung in der Datenbank zu liegen und das Plugin scheint auch noch aktiv zu sein. Ich muss das mit dem Entwickler klären.

Ansicht von 10 Antworten - 16 bis 25 (von insgesamt 25)