Support » Allgemeine Fragen » Keine Anmeldung mehr möglich

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Mit welchem Editor hast du die WordPress-Konfigurationsdatei wp-config.php gespeichert? Stimmt die Datei-Kodierung? Hast du geprüft, ob vor dem Tag <?php Zeichen oder Leerschritte eingefügt sind?

    Du kannst auch gerne die wp-config.php hier teilen, solltest dann aber die Zugangsdaten zur Datenbank unkenntlich machen und den Abschnitt der Sicherheitsschlüssel entfernen.

    Thread-Ersteller 10mine07

    (@10mine07)

    Hallo,

    Der Editor ist TextEdit:

    Das ist meine derzeitige wp-config.php:

    <?php
    /**
     * In dieser Datei werden die Grundeinstellungen für WordPress vorgenommen.
     *
     * Zu diesen Einstellungen gehören: MySQL-Zugangsdaten, Tabellenpräfix,
     * Secret-Keys, Sprache und ABSPATH. Mehr Informationen zur wp-config.php gibt es
     * auf der {@link http://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren}
     * Seite im Codex. Die Informationen für die MySQL-Datenbank bekommst du von deinem Webhoster.
     *
     * Diese Datei wird von der wp-config.php-Erzeugungsroutine verwendet. Sie wird ausgeführt,
     * wenn noch keine wp-config.php (aber eine wp-config-sample.php) vorhanden ist,
     * und die Installationsroutine (/wp-admin/install.php) aufgerufen wird.
     * Man kann aber auch direkt in dieser Datei alle Eingaben vornehmen und sie von
     * wp-config-sample.php in wp-config.php umbenennen und die Installation starten.
     *
     * @package WordPress
     */
    
    /**  MySQL Einstellungen - diese Angaben bekommst du von deinem Webhoster. */
    /**  Ersetze database_name_here mit dem Namen der Datenbank, die du verwenden möchtest. */
    define('DB_NAME', 'PASSWORT');
    
    /** Ersetze username_here mit deinem MySQL-Datenbank-Benutzernamen */
    define('DB_USER', 'PASSWORT');
    
    /** Ersetze password_here mit deinem MySQL-Passwort */
    define('DB_PASSWORD', 'PASSWORT');
    
    /** Ersetze localhost mit der MySQL-Serveradresse */
    define('DB_HOST', 'rdbms.strato.de');
    
    /** Der Datenbankzeichensatz der beim Erstellen der Datenbanktabellen verwendet werden soll */
    define('DB_CHARSET', 'utf8');
    
    /** Der collate type sollte nicht geändert werden */
    define('DB_COLLATE', '');
    
    <strong>
    Bereich Sicherheitsschlüssel (habe ich raus genommen)
    </strong>
    
    /**
     * WordPress Datenbanktabellen-Präfix
     *
     *  Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
     *  verschiedene WordPress-Installationen betreiben. Nur Zahlen, Buchstaben und Unterstriche bitte!
     */
    $table_prefix  = 'wp_';
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    OK, das sieht so weit gut aus. Ein weitere Grund für die Fehlermeldung könnte sein, dass die Datei mit der falschen Kodierung hochgeladen wurde. Installier doch mal den kostenlosen Atom-Editor, speichere die Datei damit ab und lad sie wieder auf den Webserver hoch. Klappt es dann?

    Thread-Ersteller 10mine07

    (@10mine07)

    Ich habe es versucht, aber leider hilft es nichts.

    OK … Hast du mal versucht, den Plugin-Ordner vorübergehend umzubenennen, um Plugins als mögliche Fehlerquelle auszuschließen?

    Thread-Ersteller 10mine07

    (@10mine07)

    Ich habe sogar den Plugin-Ordner komplett gelöscht, aber die Meldung tritt weiterhin auf und ich komme demnach weiterhin nicht rein.

    Da du alle Tipps von Bego, auch im oben zitierten Thread, offenbar befolgt hast, hab ich schon mal in Erwägung gezogen, dass du, wie schon vor einem Jahr mal, gehackt worden sein könntest, aber eine erste Überprüfung mit Online-Tools (sucuri, virustotal) hat keine Hinweise darauf ergeben.

    Moderator PraetorIM

    (@praetorim)

    Hallo 10mine07,

    der Fehler liegt meist, wie Bego ja schon geschrieben hat, an einem Fehler beim Abspeichern der wp-config.php (oder in selteneren Fällen auch der functions.php).

    Bitte kontrolliere noch einmal, ob die Datei als ANSI-Datei oder als UTF-8 (mit oder ohne BOM?) gespeichert ist.

    Moderator PraetorIM

    (@praetorim)

    Noch ein Nachtrag: Wenn ich Deine Login-Seite aufrufe, wird zumindest ein Cookie gesetzt, nämlich vom „qTranslate“-Plugin. Im Supportforum für dieses Plugin wird Dein Problem entsprechend beschrieben, so dass es auch hieran liegen könnte: https://wordpress.org/support/topic/repost-cannot-login-to-admin-pages-due-to-prepath-language-set-by-qtranslate-x?replies=36

    Thread-Ersteller 10mine07

    (@10mine07)

    Hallo.

    Entschuldigung für den späten Nachtrag. Ich konnte mich erst jetzt mit dem Problem intensiv beschäftigen. Ich habe es gelöst, indem ich WordPress gelöscht habe und wieder heruntergeladen habe etc..

    Anders war es leider nicht möglich. Danke für die Hilfe.

    LG

    Jasmin

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Das Thema „Keine Anmeldung mehr möglich“ ist für neue Antworten geschlossen.