Support » Allgemeine Fragen » Keine Anzeige von Beitragsbilder in Gutenberg Böcken

  • Hallo,
    ich habe nach unterschiedlichen Testläufen festgestellt das ich im Gutenberg Editor ein grundsätzliches Problem mit dem Anzeigen von Beitragsbildern habe. Immer wenn ich einen Block nutze, der Daten der Beiträge in irgendeiner Form anzeigen soll, wird alles bis auf Bilder ordnungsgemäß angezeigt.
    Ich dachte erst das es an der Verschachtelung von Blöcken liegt, das ist aber auch nicht der Fall. Was kann das Anzeigen der Bilder verhindern?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Deine Frage ist bisher schlecht nachvollziehbar.

    Zunächst einmal zu den Fachbegriffen: Mit Beitragsbildern (englisch: Featured Images) werden Bilder bezeichnet, die stellvertretend für den Beitrag stehen sollen. Du kennst das vielleicht aus Nachrichten-Portalen wie Spiegel-Online, bei denen neben jedem Aufmacher auch ein Bild steht, das den Inhalt des Beitrags visuell darstellen soll, aber nicht zwingend im Beitrag selber vorkommt.

    Ob und wie Beitragsbilder vom Theme verwendet werden, hängt von den Layout-Entscheidungen des Theme-Entwicklers einerseits und häufig von den Theme-Einstellungen durch den Anwender andererseits ab. Alle Beitragsbilder haben aber gemein, dass sie nicht in Blöcken des Block-Editors vorkommen, weil sie nicht Inhalt des Beitrags sind. (Was dich nicht davon abhält, das gleiche Bild auch nochmal im Inhalt zu verwenden – nur ist es dann kein „Beitragsbild“ mehr.)

    Bilder in Beiträgen (die keine „Featured Images“ sind, keine Beitragsbilder in der WordPress-Terminologie) sollten immern angezeigt werden, wenn der Beitrag in vollem Umfang dargestellt wird. Viele Themes bieten aber die Möglichkeit, auf Beitrags-Übersichtsseiten (Startseite, Archiv-Seiten nach Monat/Autor/Katgeorie) nur gekürzte Aufmacher des Beitrags zu zeigen, die bei WordPress „(Text-)Auszug“ oder auf Englisch Excerpt heißen und einen kompakten Überblick ermöglichen sollen.

    Excerpts werden vereinfacht ausgegeben. Das heißt: keine HTML-Tags, keine Leerzeilen und – ganz wichtig! – keine Bilder. Sollten also auf einer Übersichtsseite keine in den Beiträgen verwendeten Bilder ausgegeben werden, werden wahrscheinlich nur Auszüge der Beiträge angezeigt. Enthält die Übersichtsseite auch keine Beitragsbilder, wurden

    • beim Erstellen des Beitrags keine Beitragsbilder hinzugefügt (rechte Spalte > Tab Dokument > Beitragsbild)
    • bei den Theme-Einstellungen festgelegt, dass keine Beitragsbilder ausgegeben werden sollen
    • vom Theme-Entwickler entschieden, dass Beitragsbilder überbewertet sind.

    Das Block-Widget „Neueste Beiträge“ im Block-Editor soll übrigens nur eine Liste der neuesten Beiträge ausgeben, zeigt aber grundsätzlich keine Beitragsbilder an, egal ob sie gesetzt wurden oder nicht. Hier ist es auch egal, ob die die Beitragsinhalte gekürzt (Excerpt) oder vollständig ausgibst.

    Ich hoffe, das bringt ein wenig Klarheit in die Sache. Ansonsten musst du nochmal etwas konkreter und für Außenstehende nachvollziehbarer beschreiben, wo der Schuh drückt.

    Hast du rechts unten im Beitrag ein Beitragsbild eingestellt?

    PS: @pixolin war viel ausführlicher und schneller 😉

    • Diese Antwort wurde geändert vor 8 Monaten, 1 Woche von jostu55.

    Erst einmal danke in die Einführung der WP -Terminologie. Ich hoffe jetzt mein Problem besser beschreiben zu können.
    Das Problem bezieht sich nicht auf die „Featured Images“, sondern auf Bilder in Beiträgen.
    Die in Beiträgen eingebauten Bilder werden dort immer richtig angezeigt!
    Wenn ich nur irgendeinen Gutenberg Block nutze der einen oder mehrere Beiträge als Aufmacher Anzeigen soll, dann werden immer alle Daten, wie Titel, Autor, Erstellungsdatum usw. richtig dargestellt. Nur Bilder aus diesen Beiträgen werden nicht angezeigt.
    Mit einem Slider der nicht Gutenberg basierend ist, habe ich Problemlos mehrere Beiträge im Wechsel, mit jeweils einem Bild aus dem Beitrag anzeigen können. Mein Ziel ist aber gerade alles weitestgehend auf Gutenberg umzustellen.
    Wie man auf der Homepage meiner Seite sieht, sind dort 5 Aufmacher eingebaut, die aber nur den in der Blockkonfiguration einsetzbaren Bild-Platzhalter Anzeigen. Dieser sollte eigentlich nur angezeigt werden, wenn kein Bild im Beitrag vorhanden ist. Die Beiträger haben aber in diesem Fall eigene Bilder.
    Da das Problem unabhängig von der Art des Blocks und Hersteller auftritt, scheint es etwas zentrales zu sein, das die Anzeige der Beitragsbilder verhindert.
    Ich habe alle Blöcke folgender Hersteller ausprobiert, die Beiträge in irgendeiner Form Anzeigen sollen:
    • KIOKEN Blocks
    • Advanced Gutenberg
    • Ultimate Add-Ons für Gutenberg

    Du verwendest das Plugin „Options for Twenty seventeen“ und „Advanced Gutenberg“!!
    Auf der Startseite verwendest du den Block Advanced Gutenberg Recent Posts.
    Das Advanced Gutenber Plugin kann die Featured Images darstellen, wenn die Option rechts beim Tab Block eingeschaltet ist. Siehe hier bei ca 0:51! Da muß aber ein Beitragsbild aufgewählt sein, wie oben geschrieben. Beim Twenty-Seventeen werden in diesem Fall auch die Beitragsbilder im Beitrag angezeigt, bei dir ist da nichts. Ggf auch aus dem ober erstgenannten Plugin, wenn da eine Option wie z.B. „Beitragsbilder nicht anzeigen“ aktiv geschalten ist. Ich habe kurz in das Options for Twenty Seventeen hineingeschaut, aber mit ist das nichts in die Augen gesprungen. Was nicht heißt, das es das nicht doch gibt! Also Beide Plugins noch einmal genau durchforsten und Beschreibungen/Settings und Videos studieren.
    Wie gesagt, laut Video soll das klappen 😉

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Das Thema „Keine Anzeige von Beitragsbilder in Gutenberg Böcken“ ist für neue Antworten geschlossen.