Support » Themes » Keine Bilder/Formatierung etc. auf Seiten

  • Hallo liebe Communitiy,

    ich habe das Problem, dass auf keine meiner Seiten mehr Bilder angezeigt werden.
    Auch wenn ich eine neue Seite erstelle und Bilder aus der Mediathek neu einfüge, werden diese nicht angezeigt. Auch Formatierungen wie Spalten oder Trennstriche werden nicht angezeigt. Im Editor selbst sieht alles wie gewünscht aus. Aber schon in der Vorschau sind dann alle Bilder und Formatierungen weg, sodass nur der blanke Fließtext direkt aneinandergereiht angezeigt wird.

    Das Problem tritt nur auf Seiten auf, nicht auf Beiträgen.

    Hat jemand eine Idee?

    LG

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Moderator Bego Mario Garde

    (@pixolin)

    In unserem angehefteten Beitrag

    Bevor du ein neues Thema (Thread) erstellst

    haben wir beschrieben, welche Informationen wir benötigen, um dir bei einem Problem zu helfen. Dazu gehört der Website-Bericht, der uns mit wichtigen Eckdaten zu deiner Website versorgt. Du kannst den Website-Bericht ganz bequem per Button kopieren und hier in einer Antwort einfügen. Du findest den Button unter Werkzeuge → Website-Zustand im Tab „Bericht“. Warte bitte mit dem Klick auf den Button, bis die Zustandsanzeige abgeschlossen ist.

    Thread-Ersteller woandershin

    (@woandershin)

    Hallo,

    vielen Dank für die Rückmeldung, leider bin ich heute erst dazu gekommen. Hier der Bericht:

    
    ### wp-core ###
    
    version: 5.8.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 3
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/web28385685/html
    wordpress_size: 46,58 MB (48845548 bytes)
    uploads_path: /var/www/web28385685/html/wp-content/uploads
    uploads_size: 1,36 GB (1456324047 bytes)
    themes_path: /var/www/web28385685/html/wp-content/themes
    themes_size: 8,48 MB (8890804 bytes)
    plugins_path: /var/www/web28385685/html/wp-content/plugins
    plugins_size: 23,54 MB (24686570 bytes)
    database_size: 2,73 MB (2860556 bytes)
    total_size: 1,44 GB (1541607525 bytes)
    
    ### wp-active-theme ###
    
    name: twentyseventeen-child (twentyseventeen-child)
    version: 1.0
    author: Chrissi
    author_website: http://www.woandershin.org
    parent_theme: Twenty Seventeen (twentyseventeen)
    theme_features: core-block-patterns, post-thumbnails, widgets-block-editor, automatic-feed-links, title-tag, custom-line-height, menus, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, editor-styles, wp-block-styles, responsive-embeds, starter-content, custom-header, widgets
    theme_path: /var/www/web28385685/html/wp-content/themes/twentyseventeen-child
    auto_update: Deaktiviert
    
    ### wp-parent-theme ###
    
    name: Twenty Seventeen (twentyseventeen)
    version: 2.6 (latest version: 2.8)
    author: WordPress-Team
    author_website: https://de.wordpress.org/
    theme_path: /var/www/web28385685/html/wp-content/themes/twentyseventeen
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (3) ###
    
    Twenty Nineteen: version: 2.0, author: WordPress-Team (latest version: 2.1), Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 1.7, author: WordPress-Team (latest version: 1.8), Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.2, author: WordPress-Team (latest version: 1.4), Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (5) ###
    
    Add From Server: version: 3.4.5, author: Dion Hulse, Automatische Aktualisierungen deaktiviert
    Akismet Anti-Spam: version: 4.1.10, author: Automattic (latest version: 4.2.1), Automatische Aktualisierungen deaktiviert
    Auto Excerpt everywhere: version: 1.5, author: Serena Villa, Automatische Aktualisierungen deaktiviert
    SimpLy Gallery Block & Lightbox: version: 2.1.7, author: GalleryCreator (latest version: 2.3.1), Automatische Aktualisierungen deaktiviert
    WordPress Importer: version: 0.7, author: wordpressdotorg, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (2) ###
    
    Kadence Blocks – Gutenberg Blocks for Page Builder Features: version: 2.0.12, author: Kadence WP (latest version: 2.1.15), Automatische Aktualisierungen deaktiviert
    NextGEN Gallery: version: 3.12, author: Imagely (latest version: 3.17), Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1673
    imagemagick_version: ImageMagick 6.8.9-9 Q16 x86_64 2019-12-29 http://www.imagemagick.org
    imagick_version: 3.4.3
    file_uploads: File uploads is turned off
    post_max_size: 8M
    upload_max_filesize: 4M
    max_effective_size: 4 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 96 GB
    	imagick::RESOURCETYPE_DISK: -1
    	imagick::RESOURCETYPE_FILE: 6144
    	imagick::RESOURCETYPE_MAP: 96 GB
    	imagick::RESOURCETYPE_MEMORY: 48 GB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, AAI, AI, ART, ARW, AVI, AVS, BGR, BGRA, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DCM, DCR, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FITS, FRACTAL, FTS, G3, GIF, GIF87, GRADIENT, GRAY, GROUP4, GV, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, ICB, ICO, ICON, INFO, INLINE, IPL, ISOBRL, JBG, JBIG, JNG, JNX, JPEG, JPG, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAP, MASK, MAT, MATTE, MEF, MIFF, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, XPM
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.15.18-13-pve x86_64
    httpd_software: Apache
    php_version: 7.1.33 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 4M
    php_post_max_size: 8M
    curl_version: 7.38.0 OpenSSL/1.0.1t
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.25
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/web28385685/html/wp-content
    WP_PLUGIN_DIR: /var/www/web28385685/html/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Hallo,

    ich habe das Problem, dass auf keine meiner Seiten mehr Bilder angezeigt werden.

    Auf der Hauptseite wird auf jeden Fall beim Aufruf ein Bild gezeigt. Hast du mal den Browsercache gelöscht bzw. die Seite z. B. im Inkognitomodus (Chrome) aufgerufen?
    Zum Bericht:

    • Akismet Anti-Spam würde ich aus Datenschutzgründen nicht einsetzen, besser ist da Antispam Bee
    • Die PHP-Version von dir (7.1.x) entspricht nicht dem aktuellen Stand. Hier würde ich auf PHP 7.4 beim Hoster umstellen
    • Die Einstellung WP_DEBUG_DISPLAY: true ist nicht günstig, weil damit Fehler auf der produktiven Seite ausgegeben werden. Dazu musst du die wp-config.php ändern. Dazu solltest du einen geeigneten Programmier-Editor (z. B. Notepad++) verwenden. Vorher bitte die Datei z. B. auf deinem lokalen Rechner sichern.

    Die Größe deiner WordPress-Instanz ist mit 1,44 GB relativ üppig. Evtl. gibt es auch ein Problem mit nicht ausreichendem Webspace bei deinem Hoster.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller woandershin

    (@woandershin)

    Hallo Hans-Gerd,

    vielen Dank für die Rückmeldung. Ich werde deine Anmerkungen jetzt Stück für Stück umsetzen. Zur Größe der WordPress-Instanz. Ich nehme an, dass meine Fotos den Großteil des Speicher belegen? Ich habe den Blog schon eine Weile und anfangs viel zu Große Bilddateien in die Mediathek geladen. Erst später fing ich an die Fotos fürs Web zu optimieren. Gibt es ein Plugin, mit dem ich die alten Fotos automatisch komprimieren kann? Mein Hoster ist Alphahosting und mein Tarif gibt 75 GB SSD Webspace an. Das sollte vorerst genügen.

    Viele Grüße
    Christopher

    Hallo,

    Gibt es ein Plugin, mit dem ich die alten Fotos automatisch komprimieren kann?

    Das ist an sich eine neue Frage. Bitte lies doch noch mal in unserer FAQ: Eine Frage = ein Thema (II, 1a).
    In dem folgenden (englischsprachigen) Beitrag findest du einige Vorschläge für Plugins. Hier noch ein Beitrag in deutsch.
    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Nochmal zurück zur ursprünglichen Frage, wieso keine Bilder angezeigt werden: Du verwendest das Plugin Auto Excerpt everywhere. Excerpts – oder Textauszüge, wie wir sie auf Deutsch nennen – sollen das sein, was in der Presse als „Aufmacher“ bezeichnet wird: ein kurzer Anriss des Themas mit einem Link zum eigentlichen Beitrag. Um möglichst viele Themen auf einer Übersichtsseite „aufmachen“ zu können, werden Textauszüge möglichst kompakt dargestellt, also immer ohne Formatierung und vor allem ohne Bilder.

    Schau doch mal, welche Einstellungen du mit dem Plugin vorgenommen hast. Eventuell ist es auch sinnvoll, das Plugin ganz zu Deaktivieren.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)