• Gelöst Andreas

    (@andreas2021)


    Guten Abend,

    um Bilder zur Mediathek hinzuzufügen, klicke ich in einer Galerie auf das „+“ und kann nun wählen zwischen „Mediathek öffnen“ und „Hochladen“. Im ersten Fall kan ich dann wählen: „Dateien hochladen“ oder erst auf „Galerie bearbeiten“ und dann auf „Zur Galerie hinzufügen“. In beiden Fällen kommt bei mir dann immer folgende Fehlermeldung „Der Server kann das Bild nicht verarbeiten. Dies kann vorkommen, wenn der Server beschäftigt ist oder nicht genug Ressourcen hat, um die Aufgabe abzuschließen. Es könnte helfen, ein kleineres Bild hochzuladen. Die maximale Größe sollte 2560 Pixel nicht überschreiten.“

    Das „Hochladen“ von Bilddateien in eine Galerie funktioniert problemlos.

    Dieses Problem habe ich erst seit heute, vorher funktionierte alles problemlos.

    Der Website-Zustand hat 4 kleine Probleme, die aber schon länger bestehen und nie Probleme machten:

    • Inaktive Plugins sollten entfernt werden
    • Du solltest einen persistenten Objekt-Cache verwenden Leistung
    • Es sind nicht alle empfohlenen Sicherheits-Header installiert
    • Seiten-Cache wurde nicht erkannt, aber die Antwortzeit des Servers ist OK Leistung

    Hat irgendjemand eine Idee, woran es liegen könnte? Die Größe der Dateien ist wie immer.

Ansicht von 12 Antworten – 1 bis 12 (von insgesamt 12)
  • Neue Version ist raus. Mal sehen, welchen Bug ich jetzt eingebaut habe. 😉

    @hupe13
    Kann es sein, dass deine Antworten fälschlicherweise hier gelandet sind? – Ich sehe den Zusammenhang zwischen dem gemeldeten Problem und deiner Antwort nicht. 😉

    @andreas2021
    das Problem („nicht genug Ressourcen“) könnte mit einem zu geringen Wert für memory_limit zusammenhängen. Möglicherweise kannst du mehr Arbeitsspeicher zuweisen (hängt vom Vertrag und Hoster ab, evtl. mal beim Support des Hosters nachfragen):
    Trag doch bitte mal mit einem geeigneten Code-Editor (z.B. VS Code oder Notepad++) in der wp-config.php oberhalb von /* That's all, stop editing! Happy blogging. */ folgende Zeile ein:
    define( 'WP_MEMORY_LIMIT', '512M' );

    Wenn du dann noch die URL oben einträgst, dann kann das für eine Analyse auch hilfreich sein.

    Hilfreich für eine Analyse wäre der Website-Bericht:
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Hier ein Screenshot dazu (bei Klick auf das Bild, wird das Bild vergrößert):
    Website-Bericht

    Und mit z. B. STRG V in die Antwort bei diesem Thema einfügen.

    Viele Grüße
    Hans-Gerd

    Kann es sein, dass deine Antworten fälschlicherweise hier gelandet sind? – Ich sehe den Zusammenhang zwischen dem gemeldeten Problem und deiner Antwort nicht.

    Nein, alles richtig. @andreas2021 verwendet Extensions for Leaflet Map und das ist in diesem Fall das schuldige Plugin. Ich habe beim Fixen des Bugs genau dieselbe Fehlermeldung erhalten.

    Dabei habe ich auch gelernt, dass es bei Multisites eine Einstellung gibt, die die Größe der Bilder beim Hochladen beschränkt: Auf der Seite https://www.deine-domain.tld/wp-admin/network/settings.php gibt es eine Einstellung „Maximale Dateigröße eines Uploads“, die war bei mir zu klein. Die könnte bei ähnlichen Fragen auch eine Rolle spielen.

    Thread-Starter Andreas

    (@andreas2021)

    Guten Morgen, nun funktioniert wieder alles. Ich habe das „Extensions for Leaflet Map“ -Plugin aktualisiert – jetzt passt es. Der Zusammenhang ist noch nicht so recht klar. Hauptsache, es passt wieder.

    Vielen Dank!!!

    • Diese Antwort wurde geändert vor 3 Monaten, 2 Wochen von Andreas.
    • Diese Antwort wurde geändert vor 3 Monaten, 2 Wochen von Andreas.

    Der Zusammenhang ist noch nicht so recht klar.

    Aber mir. Das Plugin hat eine Art Dateimanager und der hat beim Upload einen Bug gehabt.

    Hallo @hupe13
    ok, danke für die Rückmeldung.
    Schön, dass das Problem gelöst ist. 😊

    Viele Grüße
    Hans-Gerd

    … hängt vom Vertrag und Hoster ab …

    Dazu ein paar einfache Gedanken am frühen Morgen:

    Arbeitsspeicher beim Webhoster hochsetzen

    🤓

    Das hat nichts mit dem Arbeitsspeicher und wp-config.php zu tun. Ich habe mal die Quellen durchsucht (ack), da finde ich fileupload_maxk und das nur nur im Zusammenhang mit get_site_option und die Standardeinstellung ist 1500. Bei der Suche im Netz findet man interessante Ergebnisse dazu. Aber das wird zu spezifisch hier.

    Thread-Starter Andreas

    (@andreas2021)

    Am Webspeicher lag es bei mir definitiv nicht. Zum einen ging es auf den einen Weg, zum anderen sind über 50GB von 75GB frei !

    Du meinst diese Einstellung?

    Screenshot

    Das betrifft aber wirklich nur Multisites und davon war in der ursprünglichen Frage keine Rede.

    Bei einfachen WordPress-Installationen (einfach im Sinne von „keine Multisite) spielt zum einen die vom Server vorgegebene Upload-Größe eine Rolle, die mit dem Wert upload_max_filesize in der php.ini festgelegt wird. Häufig wird aber übersehen, dass die Dateigröße (z.B. bei stark komprimierten jpeg-Bildern) nachranging ist, weil die Grafikbibliothek das hochgeladene Bild zur Skalierung bitweise einliest. Hier spielen die tatsächlichen Abmessungen des Bildes einerseits (deshalb der Hinweis auf die Bildgröße) und der zur Verfügung gestellte Arbeitsspeicher andererseits eine Rolle. Und auf Letzteres hatte Hans-Gerd hingewiesen.

    Dass da ein verwendetes Plugin einen Bug hat, der den Upload verhindert, ist dann nochmal ein ganz anderes Thema.

    Ja. Ich bin darüber beim Bug finden gestolpert und dachte, diese Einstellung ist auch für andere von Interesse, wenn der Upload in die Mediathek nicht funktioniert.

Ansicht von 12 Antworten – 1 bis 12 (von insgesamt 12)