Support » Allgemeine Fragen » Keine direkte Aktualisierung von Übersetzungen

  • Hallo, seit ich 4.9-DE habe, fehlt im Aktualisierungspanel die Möglichkeit, Übersetzungen zu aktualisieren. Diese werden im Zähler angezeigt, nichts passiert.

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Moderator Bego Mario Garde

    (@pixolin)

    Gib uns doch bitte erst einmal ein paar weitere Informationen zu deiner Website. Nur mit dem Hinweis „nichts passiert“ können wir wenig anfangen. Was meinst du mit „Diese werden im Zähler angezeigt“?

    Du könntest bei deiner Website auch erst einmal einen „Gesundheits-Check“ durchführen. Dazu hat das Support-Team ein eigenes Plugin entwickelt:
    https://de.wordpress.org/plugins/health-check/ Praktischerweise erhältst du mit dem Plugin auch viele Informationen über deine Website, die bei der Fehlerbehebung nützlich sein könnten.

    Alles klar:
    – WordPress-Header-Bereich sagt aktuell 1 Aktualisierung (der Mouse-Over sagt Übersetzung-Aktualisierungen)
    – wenn man in den Bereich der Aktualisierungen klickt hat man die Bereiche „WordPress“ / „PlugIns“ / „Themen“ und dort wo die Übersetzungen wären ist nichts; dieser Punkt ist einfach nicht vorhanden
    – CachePlugIn: WP-Rocket (bezahlt)
    – Theme: Flatsome (bezahlt)
    – Konsole zeigt keinen Fehler an
    – Server: Apache/2.4.10 (Debian)
    – PHP: 5.6.30-0+deb8u1
    – WordPress: 4.9.1
    – WooCommerce: 3.2.5

    Ich hab nach der Aktualisierung auf WP 4.9 keine neuen PlugIn installiert; auch das deaktivieren von PlugIns hat den Fehler nicht beseitigt.
    Diesen Health Check habe ich noch nicht gemacht.

    Ich bin nicht ganz alleine damit …
    http://forum.wpde.org/installation/178585-keine-direkte-aktualisierung-von-uebersetzungen.html

    Moderator Bego Mario Garde

    (@pixolin)

    Das kann ich nicht nachvollziehen. Stelle ich in Einstellungen > Allgemein die Übersetzung von Deutsch auf die formelle Variante Deutsch (Sie) um, werden mir sofort Aktualisierungen für die Übersetzung angezeigt, die ich mit einem Button „Übersetzung aktualisieren“ abrufen kann.

    Diesen Health Check habe ich noch nicht gemacht.

    Aha. Warum nicht?

    Ich bin nicht ganz alleine damit …
    Schön, dass dieses Problem jetzt dort weiterdiskutiert wird.

    Hallo,
    Ich habe das versucht, fand aber nur Deutsch/English zur Auswahl.

    Kann man die Übersetzungen durch dir „Hintertür“ erzwingen?

    Ich habe versucht, WP im Aktualisirungs-Dialog neu zu installieren, bekam dann einen Fehler „500“.

    Moderator Torsten Landsiedel

    (@zodiac1978)

    @mojoclub Prüfe mal die Verbindung zu wordpress.org von deinem Server.

    Z.B. hiermit: http://dd32.id.au/uploads/2013/10/https-debugger.zip

    @lsbk Sofern du nicht zum mojoclub gehörst, öffne bitte einen eigenen Thread für dein Problem. Danke!

    Gruß, Torsten

    Vielleicht kann uns jetzt noch jemand helfen …
    ich habe jetzt herausgefunden, dass es an der Berechtigung „update_languages“ liegt, dass die Aktualisierung der Übersetzungen nicht mehr angezeigt wird. Eigentlich existiert diese in der DB gar nicht. Auf meinem lokalen Rechner, der genau den gleich Stand hat, gibt es diese Berechtigung auch nicht. Der Button zur Aktualisierung wird aber trotzdem angezeigt. Also eine neue Berechtigung anlegt und der Administrator-Rolle zugewiesen. Das hat aber überhaupt nichts gebracht.

    Dirty Fix jetzt:
    Kurzerhand die Prüfung auf diese Berechtigung auskommentiert. Der Update-Button für die Übersetzungen wird jetzt wieder angezeigt. Beim nächsten WordPress-Update wird er aber vermutlich wieder herausfliegen…

    Moderator Bego Mario Garde

    (@pixolin)

    @mojoclub
    Vielleicht kann uns jetzt noch jemand helfen …

    Was soll das? Wir haben dich mehrfach um Informationen zu deiner Website gebeten und nur einen Bruchteil der Informationen erhalten. Dem Vorschlag, die Verbindung zu WordPress.org zu prüfen, bist du auch nicht gefolgt. Statt dessen fabulierst du irgendwas von Berechtigungen in der Datenbank und scheinst nicht nachvollziehbare Änderungen im Core vorzunehmen. Erwartest du ernsthaft, dass dir da noch jemand hilft?

    Bitte nutze das Plugin Health Check und teile hier die Informationen zu deiner Website (Reiter Debugging-Informationen).

    Wir haben inzwischen herausgefunden, dass das Problem mit fehlenden oder falschen Berechtigungen zu tun. Diese Info wollte ich hier im Forum weitergeben. Mehr nicht.
    Es tut mir Leid, dass ich Deinen Anforderungen nicht zufriedenstellend nachgekommen bin. Ich werde dies sofort nachholen. Ich bin dankbar, dass Du hilfst. Easy, ok?

    Health-Check Information:

    
    ### WordPress ###
    
    Version: 4.9.1
    Language: de_DE
    Permalink structure: /magazin/%postname%/
    Is this site using HTTPS?: Ja
    Can anyone register on this site?: Yes
    Default comment status: open
    Is this a multisite?: No
    User Count: 7
    Communication with WordPress.org: WordPress.org is reachable
    Create loopback requests: The loopback request to your site completed successfully.
    
    ### Drop-ins ###
    
    advanced-cache.php: Erweitertes Caching-Plugin.
    
    ### Active theme ###
    
    Name: Flatsome
    Version: 3.4.2
    Author: UX-Themes
    Author website: http://www.uxthemes.com/
    Parent theme: Not a child theme
    Supported theme features: post-thumbnails, woocommerce, title-tag, automatic-feed-links, customize-selective-refresh-widgets, html5, menus, post-formats, wc-product-gallery-lightbox, widgets
    
    ### Other themes (1) ###
    
    Twenty Fifteen (twentyfifteen): version 1.9 by dem WordPress-Team
    
    ### Active Plugins (26) ###
    
    Contact Form 7: version 4.9.2 by Takayuki Miyoshi
    Easy WP SMTP: version 1.3.1 by wpecommerce
    EWWW Image Optimizer: version 4.0.4 by Shane Bishop
    Health Check: version 0.7.0 by The WordPress.org community
    HTTPS Debugger: version 1.1 by the WordPress team
    jQuery Colorbox: version 4.6.2 by Arne Franken
    Regenerate Thumbnails: version 3.0.0 by Alex Mills (Viper007Bond)
    Tawk.to Live Chat: version 0.3.4 by Tawkto
    UpdraftPlus - Backup/Restore: version 1.13.16 by UpdraftPlus.Com, DavidAnderson
    Use Google Libraries: version 1.6.2.3 by Jason Penney
    WooCommerce: version 3.2.6 by Automattic
    WooCommerce Dynamic Pricing: version 3.1.3 by Lucas Stark
    WooCommerce Force Sells: version 1.1.13 by WooCommerce
    WooCommerce Google Product Feed: version 7.4.1 by Ademti Software Ltd.
    WooCommerce Min/Max Quantities: version 2.3.18 by WooCommerce
    WooCommerce Schreib Customization: version 0.1 by Schreib GmbH
    WooCommerce Schreib Dynamic Pricing: version 1.0.0 by Schreib GmbH
    WooCommerce Schreib Force Sells: version 1.0.0 by Schreib GmbH
    WooCommerce web2print WEBGL: version 0.1 by Schreib GmbH
    WooSidebars: version 1.4.3 by WooThemes
    WooSwatches - Woocommerce Color or Image Variation Swatches: version 2.3.6 by parbat chaudhari
    WP Instagram Widget: version 2.0.0 by Scott Evans
    WP Rocket: version 2.11.2 by WP Media
    YITH WooCommerce Ajax Search: version 1.5.4 by YITHEMES
    YITH WooCommerce Wishlist: version 2.1.2 by YITHEMES
    Yoast SEO: version 5.9.3 by Team Yoast
    
    ### Inactive Plugins (12) ###
    
    EU Cookie Law: version 2.11 by Alex Moss, Marco Milesi, Peadig, Shane Jones
    Nextend Facebook Connect: version 2.0.2 by Nextendweb
    Nextend Google Connect: version 1.6.1 by Roland Soos, Jamie Bainbridge
    Query Monitor: version 2.17.0 by John Blackbourn
    SendCloud | Smart Shipping Service: version 1.0.14 by SendCloud B.V.
    shipcloud for WooCommerce: version 1.6.2 by Awesome UG
    Taxonomy Metadata: version 0.5 by mitcho (Michael Yoshitaka Erlewine), sirzooro
    Tidio Chat: version 3.2.0 by Tidio Ltd.
    WooCommerce Billomat: version 1.0 by Billomat
    WooCommerce Helper: version 1.7.2 by WooCommerce
    WooRechnung: version 1.1.0 by ZWEISCHNEIDER GmbH & Co. KG
    WordPress Importer: version 0.6.3 by wordpressdotorg
    
    ### Server ###
    
    Server architecture: Linux 3.16.0-4-amd64 x86_64
    PHP Version: 5.6.30-0+deb8u1 (Supports 64bit values)
    PHP SAPI: fpm-fcgi
    PHP max input variables: 1000
    PHP time limit: 6000
    PHP memory limit: 6144M
    Upload max filesize: 50M
    PHP post max size: 20M
    cURL Version: 7.38.0 OpenSSL/1.0.1t
    SUHOSIN installed: No
    Is the Imagick library available: Yes
    
    ### Database ###
    
    Extension: mysqli
    Server version: 5.5.57-0+deb8u1
    Client version: 5.5.53
    Database prefix: wp_
    
    ### WordPress constants ###
    
    ABSPATH: /var/www/memento-trauerkarten.de/
    WP_HOME: Undefined
    WP_SITEURL: Undefined
    WP_DEBUG: Disabled
    WP_MAX_MEMORY_LIMIT: 6144M
    WP_DEBUG_DISPLAY: Enabled
    WP_DEBUG_LOG: Disabled
    SCRIPT_DEBUG: Disabled
    WP_CACHE: Enabled
    CONCATENATE_SCRIPTS: Undefined
    COMPRESS_SCRIPTS: Undefined
    COMPRESS_CSS: Undefined
    WP_LOCAL_DEV: Undefined
    
    ### Filesystem permissions ###
    
    The main WordPress directory: Writable
    The wp-content directory: Writable
    The uploads directory: Writable
    The plugins directory: Writable
    The themes directory: Writable
    The Must Use Plugins directory: Writable
    
    

    HTTPS-Tester:
    [1]-[7] PASS
    [8] [Streams]: WARNING
    [9] [Streams with a POST body]: WARNING
    [10] [cURL]: WARNING
    [11] [INFO]

    8-11 Communication with WordPress.org suceeded after 1.382 seconds, but an unexpected response was received: Dann kommt eine <!DOCTYPE html> … Datei.

    Moderator Bego Mario Garde

    (@pixolin)

    Vielen Dank für die Informationen.

    Du hast reichlich Plugins installiert, bei der Serverkonfiguration sollte das aber kein Problem darstellen. Hast du im Health Check mal den Fehlerdiagnose-Modus aktiviert? Damit werden die aktivierten Plugins nur für dich vorübergehend deaktiviert. Wird dann immer noch eine Aktualisierung für Übersetzungen angezeigt?

    Zu deinem gekauften Theme kann ich nichts sagen, weil ich keinen Zugriff darauf habe. Hast du mal geprüft, ob hier ggf. Updates vorliegen?

    Wegen der Warnings des HTTPS-Tester würde ich prüfen (lassen), welche OpenSSL-Version installiert ist.

    Du kannst auch mal versuchen, die Dateien aus dem Verzeichnis wp-content/languages zu verschieben (das Verzeichnis selbst sollte bestehen bleiben). Danach müsstest du in Dashboard > Aktualisierungen eigentlich neue Übersetzungen angezeigt bekommen.

    Es besteht auch die Möglichkeit, dass ein Transient (interner Cache) für die Updates nicht sauber gelöscht wurde. Verwendest du WP-CLI? Dann könntest du mit wp transient delete --all die Transients löschen.

    Moderator Torsten Landsiedel

    (@zodiac1978)

    but an unexpected response was received: Dann kommt eine <!DOCTYPE html> … Datei

    Dann kommt wohl Grütze zurück. Konkret: Eine HTML-Datei. Wahrscheinlich eine Fehlermeldungsseite. Kannst du den Inhalt posten?

    Wegen der Warnings des HTTPS-Tester würde ich prüfen (lassen), welche OpenSSL-Version installiert ist.

    Ist in den Debug-Infos: cURL Version: 7.38.0 OpenSSL/1.0.1t

    Auf jeden Fall veraltet, aber warum nur Übersetzungen davon betroffen sein sollten …

    ich habe jetzt herausgefunden, dass es an der Berechtigung „update_languages“ liegt

    Hier gibt es eine Sektion „Installing and updating language files“ mit merh Infos zu dieser Capability, die dir vielleicht weiterhilft:

    https://make.wordpress.org/core/2017/10/15/improvements-for-roles-and-capabilities-in-4-9/

    Gruß, Torsten

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Das Thema „Keine direkte Aktualisierung von Übersetzungen“ ist für neue Antworten geschlossen.