Support » Allgemeine Fragen » Keine Formatierung mehr

  • Nachdem ich auf die aktuellste WordPressversion upgegradet habe und der Aufforderung von WordPress, die Datenbank zu aktualisieren per Mausklick auf den entsprechenden Button nachgekommen bin und die Aktualisierung als erfolgreich abgeschlossen gemeldet worden ist, sind sämtliche Formatierungen der Webseite weg. Es ist völlig egal, mit welchem Browser ich auch arbeite, die Webseite funktioniert nicht mehr ordnungsgemäß. Alles wird einfach nur wie Fließtext angezeigt.
    Auch ein Rollback auf 5.9 brachte kein Ergebnis mehr.
    Ich habe jetzt wieder auf die aktuellste Version gewechselt.
    Merkwürdigerweise wird die Seite jedoch im Backend richtig angezeigt, so wie sie eigentlich auch außerhalb des Logins zu sehen sein sollte.

    Ich brauche da dringend Hilfe. Gern beantworte ich auch alle Fragen, so weit ich dazu in der Lage bin.
    Vielen Dank für die geschätzte Hilfe.
    Gruß
    Robert

    • Dieses Thema wurde geändert vor 1 Jahr, 8 Monaten von WordPressuser1962. Grund: Ergänzungsinfo

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Hallo,
    das Problem wird vermutlich mit dem Plugin Autoptimize zusammenhängen. Deaktiviere bitte das Plugin zunächst mal. In der developer console (Aufruf mit F12 in Chrome) sieht man auch entsprechende Fehler. Das könnte auch mit einer falschen Konfiguration des Plugins zusammenhängen.

    Wenn du die Website wie folgt aufrufst https://www.kin***w.de/?ao_noptimize=1 (natürlich mit deiner richtigen URL, die ich hier gekürzt habe), dann wird die Website auch korrekt angezeigt. Das macht deutlich, dass es mit dem Plugin Autoptimize zusammenhängt. Evtl. reicht auch schon, wenn du oben in der Zeile unter Autoptimize die Option zum Löschen des Caches wählst.

    Leider hast du den Bericht nicht gesendet, mit dessen Hilfe eine weitergehende Analyse möglich gewesen wäre. Du findest unter Werkzeuge > Websitezustand > Info den Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Lies bitte auch noch mal: Bevor du ein neues Thema (Thread) erstellst.

    Ich brauche da dringend Hilfe.

    Wenn du dringend Hilfe brauchst, wende dich bitte an einen Dienstleister. Hier im Forum bieten wir Hilfe in unserer Freizeit an.

    Viele Grüße
    Hans-Gerd

    • Diese Antwort wurde geändert vor 1 Jahr, 8 Monaten von Hans-Gerd Gerhards. Grund: Ergänzung
    • Diese Antwort wurde geändert vor 1 Jahr, 8 Monaten von Hans-Gerd Gerhards. Grund: Korrektur Erläuterung
    Thread-Starter WordPressuser1962

    (@wordpressuser1962)

    Lieber Hans Gerd,
    vielen Dank für Deine Hilfe. Ich bitte zunächst um Entschuldigung für meine unbeabsichtigte Provokation mit der Bitte um „schnelle Hilfe“.
    Ich habe natürlich meinen Dienstleister des Themes, welches ich nutze, bereits kontaktiert. Da jedoch dort über das Wochenende und den Feiertag niemand da ist und der E-Mailsupport bis zu 72 Stunden dauern kann, meine Webseite jedoch laufen soll und muss, äußerte ich diese Bitte. Dies einfach nur zum Verständnis.

    Ich habe dieses Plugin gar nicht aktiviert, so wie ich die meisten mal heruntergeladenen Plugins deaktiviert habe. Von daher war ich davon ausgegangen, dass sie auch keine Probleme mehr machen können, zumal die vorherige WordPressversion ja noch problemlos funktionierte. Um Deinen Vorschlag, die Option zum Löschen des Caches dennoch zu probieren, habe ich das Plugin mal aktiviert und die Option ausgelöst. Geändert hat es nichts. Deshalb habe ich es dann wieder deaktiviert.

    Hier mal der Bericht, den ich kopieren sollte. Leider verstehe ich nicht, was Du mit Aktenzeichen meinst, weshalb der Bericht jetzt erst einmal einfach eingefügt wurde.

    Ich bedanke mich schon mal vorab für alle Mühen, die hier für mein Problem auf sich genommen werde und entschuldige mich nochmals für den unangemessenen Druck.

    Herzliche Grüße
    Robert

    
    ### wp-core ###
    
    version: 6.0.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /kunden/155572_57439/webseiten/kinderverkehrsbuehne
    wordpress_size: 284,41 MB (298230584 bytes)
    uploads_path: /kunden/155572_57439/webseiten/kinderverkehrsbuehne/wp-content/uploads
    uploads_size: 2,56 MB (2689018 bytes)
    themes_path: /kunden/155572_57439/webseiten/kinderverkehrsbuehne/wp-content/themes
    themes_size: 47,60 MB (49907786 bytes)
    plugins_path: /kunden/155572_57439/webseiten/kinderverkehrsbuehne/wp-content/plugins
    plugins_size: 68,09 MB (71397839 bytes)
    database_size: 12,12 MB (12709585 bytes)
    total_size: 414,79 MB (434934812 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: DI OneBusiness (di-onebusiness)
    version: 1.4
    author: Designers Inn
    author_website: (undefined)
    parent_theme: DI Basis – based on Divi 4.7.6.1 (di-basis)
    theme_features: core-block-patterns, widgets-block-editor, custom-background, automatic-feed-links, post-thumbnails, menus, title-tag, post-formats, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, editor-style, widgets
    theme_path: /kunden/155572_57439/webseiten/kinderverkehrsbuehne/wp-content/themes/di-onebusiness
    auto_update: Deaktiviert
    
    ### wp-parent-theme ###
    
    name: DI Basis – based on Divi 4.7.6.1 (di-basis)
    version: 4.7.6.1
    author: Childthemes by Designers Inn, Basistheme based in Divi by Elegantthemes
    author_website: (undefined)
    theme_path: /kunden/155572_57439/webseiten/kinderverkehrsbuehne/wp-content/themes/di-basis
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (3) ###
    
    Twenty Twenty: version: 2.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.6, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.2, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (3) ###
    
    Borlabs Cookie - Cookie Opt-in: version: 2.2.56, author: Borlabs GmbH, Automatische Aktualisierungen aktiviert
    Coming Soon Page, Maintenance Mode, Landing Pages & WordPress Website Builder by SeedProd: version: 6.15.4, author: SeedProd, Automatische Aktualisierungen aktiviert
    WP Downgrade | Specific Core Version: version: 1.2.5, author: Reisetiger, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (19) ###
    
    Autoclear Autoptimize Cache: version: 2.1.1, author: Theme Surgeons, Automatische Aktualisierungen aktiviert
    Autoptimize: version: 3.1.2, author: Frank Goossens (futtta), Automatische Aktualisierungen aktiviert
    Autoptimize CriticalCSS.com Power-Up: version: 1.19.0, author: Deny Dias & Optimizing Matters, Automatische Aktualisierungen deaktiviert
    Better Search Replace: version: 1.4.1, author: Delicious Brains, Automatische Aktualisierungen aktiviert
    Comet Cache: version: 170220, author: WP Sharks, Automatische Aktualisierungen aktiviert
    Disable Attachment Pages: version: 1.1, author: PALASTHOTEL by Kim-Christian Meyer, Automatische Aktualisierungen aktiviert
    Enable Gzip Compression: version: 1.0.3, author: Moki-Moki Ios, Automatische Aktualisierungen aktiviert
    JQuery Expanding Box: version: 2, author: Hit Reach, Automatische Aktualisierungen deaktiviert
    Page Builder by SiteOrigin: version: 2.17.0, author: SiteOrigin, Automatische Aktualisierungen aktiviert
    Pro WP Limit Login Attempts: version: 2.3.3, author: Arshid, Automatische Aktualisierungen deaktiviert
    Redirection: version: 5.3.4, author: John Godley, Automatische Aktualisierungen aktiviert
    SiteOrigin Widgets Bundle: version: 1.42.1, author: SiteOrigin, Automatische Aktualisierungen aktiviert
    Spacer: version: 3.0.5, author: Justin Saad, Automatische Aktualisierungen aktiviert
    Text Toggle: version: 1.1, author: Terry O'Brien (HoosierDragon), Automatische Aktualisierungen aktiviert
    Title Remover: version: 1.2.1, author: WPGurus, Automatische Aktualisierungen aktiviert
    Under Construction: version: 3.93, author: WebFactory Ltd, Automatische Aktualisierungen deaktiviert
    WP-Optimize - Clean, Compress, Cache: version: 3.2.7, author: David Anderson, Ruhani Rabin, Team Updraft, Automatische Aktualisierungen deaktiviert
    Yoast Duplicate Post: version: 4.5, author: Enrico Battocchi & Team Yoast, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 19.7.1, author: Team Yoast, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1692
    imagemagick_version: ImageMagick 6.9.12-63 Q16 x86_64 17457 https://legacy.imagemagick.org
    imagick_version: 3.7.0
    file_uploads: File uploads is turned off
    post_max_size: 75M
    upload_max_filesize: 50M
    max_effective_size: 50 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 59 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 786432
    	imagick::RESOURCETYPE_MAP: 59 GB
    	imagick::RESOURCETYPE_MEMORY: 29 GB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, AVI, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: 2.3.3
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-1160.62.1.el7.x86_64 x86_64
    httpd_software: Apache
    php_version: 8.0.23 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1500
    time_limit: 240
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 50M
    php_post_max_size: 75M
    curl_version: 7.61.1 OpenSSL/1.1.1k
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.4.26-MariaDB
    client_version: mysqlnd 8.0.23
    max_allowed_packet: 64000000
    max_connections: 400
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /kunden/155572_57439/webseiten/kinderverkehrsbuehne/wp-content
    WP_PLUGIN_DIR: /kunden/155572_57439/webseiten/kinderverkehrsbuehne/wp-content/plugins
    WP_MEMORY_LIMIT: 512M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    • Diese Antwort wurde geändert vor 1 Jahr, 8 Monaten von WordPressuser1962. Grund: Ergänzung

    Hallo,

    Ich bedanke mich schon mal vorab für alle Mühen, die hier für mein Problem auf sich genommen werde und entschuldige mich nochmals für den unangemessenen Druck.

    alles gut – kein Problem 😊

    Dann teste mal bitte folgende Option: Aktiviere das Plugin Autoptimize und lösche den Cache.

    Hier ein Screenshot dazu (bei Klick auf das Bild, wird das Bild vergrößert):

    Screenshot Einstellungen.

    Sollte das nicht funktionieren, dann kannst du testweise das Plugin Autoclear Autoptimize Cache installieren.

    Mehr Infos dazu findest du z. B. hier.

    Außerdem ist es sinnvoll, über den Kundenaccount des Hosters PHP auf 7.4.x umzustellen. Manche Plugins und Themes funktionieren (noch) nicht unter PHP 8.x

    Viele Grüße
    Hans-Gerd

    Thread-Starter WordPressuser1962

    (@wordpressuser1962)

    Hallo Gerd,
    danke für den weiteren Support. Hat alles nichts gebracht. Weder die Umstellung auf PHP 7.4, noch das Plugin Autoclear Autoptimze Cache. Ebenfalls auch nicht das manuelle löschen des Cache über den Button in Autoptimze. Leider kann ich den Pluginordner nicht einfach umbenennen, da ich das Borlaps Cookie Plugin aus rechtlichen Gründen aktiviert lassen muss.
    Ich werde jetzt erst einmal dies Plugin komplett deinstallieren, dann müsste die Website ja erst einmal laufen, bis eine Lösung gefunden wurde.

    Ich habe jetzt gerade den Pluginanbieter in Belgien kontaktiert. Der hatte mir gerade geschrieben und mich gefragt, ob die Seite mit dem Zusatz „?nopagecache=123xyz“ funktioniert. Tat sie aber auch nicht. Mal sehen, was er noch so vorschlägt. Ich halte Euch auf dem Laufenden, was der Support schreibt. Das könnte dann sicherlich auch für andere nützlich sein, die mit dem Problem konfrontiert sind.

    Bin natürlich für weitere Hilfe dankbar, denn es ist ja auch nicht garantiert, dass der Support des Anbieters erfolgreich sein wird.

    Thread-Starter WordPressuser1962

    (@wordpressuser1962)

    Gerade eine weitere Mail vom Support.

    „I just tested with „/?Qsdf=sqdf“ (die komplette URL habe ich mal weggelassen, weil ich nicht weiß, ob das erwünscht ist und DU sie ja auch in der ersten Antwort gekürzt hattest) and that does seem to work though, which in fact indicates a problem with the page cache. Can you make sure all page cache(s) you or your host might have get cleared?“

    Ich habe das dann auch mit dem Zusatz probiert und damit funktioniert die Seite.

    Wenn ich das richtig verstanden habe, scheinen sich die Seitencaches nicht zu leeren. Aber wie soll das vonstatten gehen? Ich kann ja nur im Browser die Seite neu laden. Dann müsste doch der Cache im Browser geleert werden. Das nützt aber nichts. Und selbst wenn. Auf anderen Brwosern, die ich ja „frisch“ gestartet habe, wird die Website ja auch falsch angezeigt.

    Im Übrigen habe ich ja noch eine weitere Website, wo das Plugin installiert ist und dort läuft alles einwandfrei, nachdem ich gerade eben dort (mit ängstlichen Risiko) das WordPress auf den neuesten Stand brachte und die Seite einwandfrei läuft.

    Hallo,
    ich habe die Website gerade mal in einem anderen Browser geöffnet. Das sieht aber jetzt ok aus.
    Hast du dann auch mal den Browsercache geleert und/oder einen anderen Browser zum Testen genutzt und/oder die Website im Inkognito-Modus z. B. von Chrome getestet? (bei Chrome oben die drei senkrechten Punkte und dann „Neues Inkognito-Fenster“) und auch mal die Cookies löschen.

    Viele Grüße
    Hans-Gerd

    Thread-Starter WordPressuser1962

    (@wordpressuser1962)

    Der Support hatte sich gemeldet und gefragt, ob ich cometcache am Laufen hätte. Das hatte ich tatsächlich deaktiviert, weil ich dachte, dass beides, also cometcache und Autoptimize sich ggf. „beißen“ würde.
    Nachdem ich cometcache aktivert habe und damit den cache leerte, funktioniert die Seite auch.
    Aber wenn ich zusätzlich Autoptimize einschalte, wird die Webseite wieder falsch dargestellt. Ich lasse nun Autoptimize einfach weg. Da die Seite ja nicht her umfangreich ist, dürfte es auch nicht wirklich große Probleme mit der Geschwindigkeit geben, denke ich.

    Merkwürdigerweise ist auf meiner anderen Website, die ich am Laufen habe und die ich erst vorhin (mit Angst im Bauch 🙂 ) auf das neue WordPress aktualisiert habe, alles ok, trotz Autoptimize und den gleichen Einstellungen darin.
    Vielleicht liegt es j auch am Theme selbst. Deren Support habe ich ja auch kontaktiert. Aber da warte ich noch auf eine Antwort.

    Hallo,

    Da die Seite ja nicht her umfangreich ist, dürfte es auch nicht wirklich große Probleme mit der Geschwindigkeit geben, denke ich.

    Vermutlich ist Autoptimize dann bezogen auf diese WordPress-Instanz nicht korrekt eingestellt. Aber ich denke auch, dass das bezogen auf die Performance keine sehr große Rolle spielt.

    Viele Grüße
    Hans-Gerd

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „Keine Formatierung mehr“ ist für neue Antworten geschlossen.