Support » Allgemeine Fragen » Keine Installation von Themes oder Plugins

  • Hallo,

    ich habe ein Problem mit einer Seite die ich gerade einrichte. Die Seite wird bei 1&1 gehostet. Ich habe bereits mit dem Support telefoniert und auch per E-Mail via Screenshots mein Problem geschildert. Ich wurde allerdings darauf verwiesen mich hier an das Forum zu wenden.

    Das Problem ist wie folgt: Die Seite ist bereits mit der aktuellen Version von WordPress ausgestattet und funktioniert soweit erstmal. Ich nutze PHP 7.3 und technisch gesehen ist laut 1&1 auch soweit alles in Ordnung (Webspace Speicher etc.)

    Allerdings kann ich keine Plugins oder Themes installieren. Weder über das WordPress Backend noch direkt via FTP. Dies gilt jedoch komischerweise nicht für alle Plugins. Ich habe beispielsweise Plugins wie „Crazy Lazy“, „Autoptimize“ oder Really Simple SSL problemlos installieren können (Direkt via WordPress). Wenn ich jedoch Plugins wie „Yoast SEO“, „W3 Total Cache“ sowie auch Themes installieren will, dann bekomme ich stets eine Fehlermeldung.

    Im Fall von Yoast SEO ist das zum Beispiel:

    Installation fehlgeschlagen: Die Datei konnte nicht kopiert werden. wordpress-seo/images/support-team.svg

    Selbiges bei dem Versuch ein Theme zu installieren. Das Theme „GeneratePress“ konnte ich problemlos installieren. Möchte ein Theme wie zum Beispiel „Pixova Lite“ installieren, erhalte ich die Fehlermeldung:

    Installation fehlgeschlagen: Die Datei konnte nicht kopiert werden. pixova-lite/layout/css/animate.min.css

    Hat jemand eine Idee woran das liegen könnte und was ich dagegen unternehmen kann?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)
  • Moderator Bego Mario Garde

    (@pixolin)

    Im Gegesatz zu den bezahlten MitarbeiterInnen des Webhosters erhältst du hier von Freiwilligen Hilfe zur Selbsthilfe. Grundsätzlich ist richtig, dass Webhoster dir nur die Leistung eines richtig konfigurierten Webservers schulden, aber mit Webanwendungen nichts zu tun haben. Dass du hierhin „verwiesen“ wurdest, überrascht mich ein wenig, aber sicher war das eher eine Empfehlung. 😉

    Wie auch immer … 

    Geh doch bitte mal auf Werkzeuge > Webzustand.
    Werden dort Fehler angezeigt? Welche?

    Geh bitte anschließend in den Tab Bericht und klick dort auf den Button „Bericht in die Zwischenablage kopieren“. Füge den Bericht anschließend unverändert (mit den Apostroph-Zeichen) in eine Antwort hier ein. Wir bekommen so mehr Informationen über deine Website, die vielleicht weiterhelfen.

    
    ### wp-core ###
    
    version: 5.2.4
    site_language: de_DE
    user_language: de_DE
    permalink: /%postname%/
    https_status: false
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/41/d802449982/htdocs
    wordpress_size: 52,57 MB (55127636 bytes)
    uploads_path: /homepages/41/d802449982/htdocs/wp-content/uploads
    uploads_size: 0,00 B (0 bytes)
    themes_path: /homepages/41/d802449982/htdocs/wp-content/themes
    themes_size: 3,03 MB (3172611 bytes)
    plugins_path: /homepages/41/d802449982/htdocs/wp-content/plugins
    plugins_size: 28,00 B (28 bytes)
    database_size: 816,00 KB (835584 bytes)
    total_size: 56,40 MB (59135859 bytes)
    
    ### wp-active-theme ###
    
    name: GeneratePress
    version: 2.3.2
    author: Tom Usborne
    author_website: https://tomusborne.com
    parent_theme: none
    theme_features: automatic-feed-links, post-thumbnails, post-formats, woocommerce, title-tag, html5, customize-selective-refresh-widgets, align-wide, editor-color-palette, responsive-embeds, custom-logo, menus, editor-style, widgets
    theme_path: /homepages/41/d802449982/htdocs/wp-content/themes/generatepress
    
    ### wp-themes (1) ###
    
    Twenty Nineteen: version: 1.4, author: Das WordPress-Team
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.0-ui19238.028-uiabi1-infong-amd64 x86_64
    httpd_software: Apache
    php_version: 7.3.11 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50000
    memory_limit: -1
    max_input_time: -1
    upload_max_size: 64M
    php_post_max_size: 64M
    curl_version: 7.38.0 OpenSSL/1.0.1t
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.27-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/41/d802449982/htdocs/wp-content
    WP_PLUGIN_DIR: /homepages/41/d802449982/htdocs/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: -1
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    Moderator Bego Mario Garde

    (@pixolin)

    Bei deiner Website sind die Konstanten

    WP_CONTENT_DIR
    WP_PLUGIN_DIR
    WP_MAX_MEMORY_LIMIT

    scheinbar vordefiniert. Gibt es insbesondere für die Angabe des Verzeichnispfads für Plugins einen Grund? Ansonsten kommentiere doch bitte die drei Zeilen in der wp-config.php aus, mit denen diese Vorgaben gemacht werden. Klappt es dann? Was zeigt das Menü Werkzeuge > Website-Zustand > Bericht > Server dann für ein PHP memory_limit an?

    Du kannst auch mal in der wp-config.php das Debugging mit define( 'WP_DEBUG', true ); einschalten – werden dann bei der Installation von Plugins Fehler angezeigt?

    Also ich habe keine manuellen Änderungen an der wp-config.php vorgenommen.

    Die Konstanten

    WP_CONTENT_DIR
    WP_PLUGIN_DIR
    WP_MAX_MEMORY_LIMIT

    sind in der wp-config.php – wenn ich diese via ftp über Filezilla aufrufe, nicht vorhanden.

    Das Debugging mit define( ‚WP_DEBUG‘, true ); habe ich eingeschaltet. der fehler existiert aber nach wie vor.

    Meine wp-config.php sieht wie folgt aus. Die datenbank Angaben habe ich durch „XXXXXX“ ersetzt.

    <?php
    /**
     * Grundeinstellungen für WordPress
     *
     * Zu diesen Einstellungen gehören:
     *
     * * MySQL-Zugangsdaten,
     * * Tabellenpräfix,
     * * Sicherheitsschlüssel
     * * und ABSPATH.
     *
     * Mehr Informationen zur wp-config.php gibt es auf der
     * {@link https://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren}
     * Seite im Codex. Die Zugangsdaten für die MySQL-Datenbank
     * bekommst du von deinem Webhoster.
     *
     * Diese Datei wird zur Erstellung der wp-config.php verwendet.
     * Du musst aber dafür nicht das Installationsskript verwenden.
     * Stattdessen kannst du auch diese Datei als wp-config.php mit
     * deinen Zugangsdaten für die Datenbank abspeichern.
     *
     * @package WordPress
     */
    
    // ** MySQL-Einstellungen ** //
    /**   Diese Zugangsdaten bekommst du von deinem Webhoster. **/
    
    /**
     * Ersetze datenbankname_hier_einfuegen
     * mit dem Namen der Datenbank, die du verwenden möchtest.
     */
    define( 'DB_NAME', 'xxxxx' );
    
    /**
     * Ersetze benutzername_hier_einfuegen
     * mit deinem MySQL-Datenbank-Benutzernamen.
     */
    define( 'DB_USER', 'xxxxxx' );
    
    /**
     * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
     */
    define( 'DB_PASSWORD', 'xxxxxxxx' );
    
    /**
     * Ersetze localhost mit der MySQL-Serveradresse.
     */
    define( 'DB_HOST', 'xxxxxxxxx' );
    
    /**
     * Der Datenbankzeichensatz, der beim Erstellen der
     * Datenbanktabellen verwendet werden soll
     */
    define( 'DB_CHARSET', 'utf8mb4' );
    
    /**
     * Der Collate-Type sollte nicht geändert werden.
     */
    define('DB_COLLATE', '');
    
    /**#@+
     * Sicherheitsschlüssel
     *
     * Ändere jeden untenstehenden Platzhaltertext in eine beliebige,
     * möglichst einmalig genutzte Zeichenkette.
     * Auf der Seite {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * kannst du dir alle Schlüssel generieren lassen.
     * Du kannst die Schlüssel jederzeit wieder ändern, alle angemeldeten
     * Benutzer müssen sich danach erneut anmelden.
     *
     * @since 2.6.0
     */
    [Keys gelöscht]
    /**#@-*/
    
    /**
     * WordPress Datenbanktabellen-Präfix
     *
     * Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
     * verschiedene WordPress-Installationen betreiben.
     * Bitte verwende nur Zahlen, Buchstaben und Unterstriche!
     */
    $table_prefix = 'wp_';
    
    /**
     * Für Entwickler: Der WordPress-Debug-Modus.
     *
     * Setze den Wert auf „true“, um bei der Entwicklung Warnungen und Fehler-Meldungen angezeigt zu bekommen.
     * Plugin- und Theme-Entwicklern wird nachdrücklich empfohlen, WP_DEBUG
     * in ihrer Entwicklungsumgebung zu verwenden.
     *
     * Besuche den Codex, um mehr Informationen über andere Konstanten zu finden,
     * die zum Debuggen genutzt werden können.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define( 'WP_DEBUG', true );
    
    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß. */
    /* That's all, stop editing! Happy publishing. */
    
    /** Der absolute Pfad zum WordPress-Verzeichnis. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', dirname( __FILE__ ) . '/' );
    }
    
    /** Definiert WordPress-Variablen und fügt Dateien ein.  */
    require_once( ABSPATH . 'wp-settings.php' );

    Moderationshinweis: Codeformatierung korrigiert – bitte künftig [code]-Button im Beitragseditor des Forums verwenden.

    Moderator Bego Mario Garde

    (@pixolin)

    Debugging bedeutet Fehlersuche, nicht Fehlerbehebung.
    Due Konstante define( 'WP_DEBUG', true ); sorgt nur dafür, dass zusätzliche Informationen ausgegeben werden.

    Bitte schau doch mal im Kundenmenü deines Webhosters, welche PHP-Einstellungen dort gemacht wurden. Hast du ggf. eine eigene php.ini angelegt?

    Du verwendest kein „Managed WordPress-Hosting“, oder?

    Bitte schau doch mal im Kundenmenü deines Webhosters, welche PHP-Einstellungen dort gemacht wurden. Hast du ggf. eine eigene php.ini angelegt?

    Nein, ich habe wie bereits gesagt nicht eigenständig angelegt. Ich habe bereits über 100 Seiten mit WordPress erstellt und dieses Problem noch nie gehabt, weshalb ich auch ratlos bin woran es liegen kann.

    Du verwendest kein „Managed WordPress-Hosting“, oder?

    Nein.

    Moderator Bego Mario Garde

    (@pixolin)

    Bitte schau doch mal im Kundenmenü deines Webhosters, welche PHP-Einstellungen dort gemacht wurden.

    … kann so schwer nicht sein? 🙂

    Wonach genau muss ich suchen/schauen? Ich bin mit PHP Einstellungen nicht vertraut

    Moderator Bego Mario Garde

    (@pixolin)

    Ich hab jetzt mal in ein Kundenaccount geschaut … das ist bei Ionos wirklich nicht hübsch gemacht. Was steht denn in deiner .htaccess?

    Ggf. könntest du über dem von WordPress erzeugten Block mal folgendes eintragen:

    <IfModule mod_php7.c>
    
    ##
    ## adjust memory limit
    php_value memory_limit 256M
    
    ## adjust maximum time in seconds a script is allowed to run
    php_value max_execution_time 600
    
    ## enable error messages
    php_flag display_errors on
    
    </IfModule> 

    (Quelle: Ionos Hilfe)

    Danach wieder testen.

    Die .htaccess datei muss stets manuell angelegt werden. das habe ich auch getan. der Inhalt ist folgender:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    <ifModule mod_gzip.c>
    mod_gzip_on Yes
    mod_gzip_dechunk Yes
    mod_gzip_item_include file .(html?|txt|css|js|php|pl)$
    mod_gzip_item_include handler ^cgi-script$
    mod_gzip_item_include mime ^text/.*
    mod_gzip_item_include mime ^application/x-javascript.*
    mod_gzip_item_exclude mime ^image/.*
    mod_gzip_item_exclude rspheader ^Content-Encoding:.*gzip.*
    </ifModule>
    
    <IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/xml
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/x-javascript
    </IfModule>
    
    # END WordPress
    
    ## EXPIRES CACHING ##
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType image/jpg "access 1 year"
    ExpiresByType image/jpeg "access 1 year"
    ExpiresByType image/gif "access 1 year"
    ExpiresByType image/png "access 1 year"
    ExpiresByType text/css "access 1 month"
    ExpiresByType application/pdf "access 1 month"
    ExpiresByType text/x-javascript "access 1 month"
    ExpiresByType application/x-shockwave-flash "access 1 month"
    ExpiresByType image/x-icon "access 1 year"
    ExpiresDefault "access 2 days"
    </IfModule>
    ## EXPIRES CACHING ##
    
    <filesMatch "\\.(js|js.gz)$">
    Header set Cache-Control "max-age=604800, private"
    </filesMatch>

    Ich habe den Code:

    <IfModule mod_php7.c>
    
    ##
    ## adjust memory limit
    php_value memory_limit 256M
    
    ## adjust maximum time in seconds a script is allowed to run
    php_value max_execution_time 600
    
    ## enable error messages
    php_flag display_errors on
    
    </IfModule> 

    jetzt in die .htaccess eingefügt. Hat auch nichts bewirkt. Fehlermeldung kommt weiterhin.

    Moderator Bego Mario Garde

    (@pixolin)

    Der WordPress-Block

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    sollte immer am Ende stehen.

    Abgesehen davon … probier das mal mit dem zusätzlichen Code-Schnipsel aus.

    Da einige Plugins installiert wurden und andere nicht, nehme ich an, dass das vom Webhost zur Verfügung gestellte Memory-Limit nicht ausreicht oder die Skriptlaufzeit zu kurz eingestellt wurde. Was anderes fällt mir ehrlich gesagt im Moment nicht ein.

    OK, ich habe die .htaccess jetzt wie folgt geändert:

    <IfModule mod_php7.c>
    
    ##
    ## adjust memory limit
    php_value memory_limit 256M
    
    ## adjust maximum time in seconds a script is allowed to run
    php_value max_execution_time 600
    
    ## enable error messages
    php_flag display_errors on
    
    </IfModule> 
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Es funktioniert dennoch nicht.Ich habe es jetzt mal bei dem Plugin „CMP – Coming soon …“ getestet und es kommt folgender fehler:

    Installation fehlgeschlagen: Die Datei konnte nicht kopiert werden. cmp-coming-soon-maintenance/img/thumbnails/ares_thumbnail.jpg

    Der Fehler scheint bei 1&1 zu liegen. ich habe soeben eine E-Mail erhalten:

    Sehr geehrter Herr XXXX,

    vielen Dank für die Mitteilung zur Fehlermeldung bei der Installation von Plugins und Themes im WordPress.

    Nach Rücksprache mit unserem Backoffice ist aufgefallen, dass es bei der Bestellung zu einem Fehler im Webspace kam.
    Der Webspace ist intern nur auf 50 MB, statt auf 50 GB hinterlegt.
    Daher ist eine Installation nicht möglich, da das System keinen Speicherplatz erkennt.

    Die entsprechende Fachabteilung kümmert sich um diesen Fehler. Sie werden per E-Mail über die Bearbeitung informiert.

    Bitte haben Sie etwas Geduld.

    Vielen Dank für Ihr Verständnis.

    • Diese Antwort wurde geändert vor 1 week, 5 days von Aventador77.
Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)