Support » Themes » Keine Option für die „automatische Aktualisierung“ trotz WordPress 5.7.2

  • Gelöst Maximiliane

    (@diegoldmine)


    Hallo liebes Forum,

    mit meiner ersten Website habe ich mich über die letzten Wochen in WordPress eingearbeitet, bin also noch sehr neu und unerfahren in dem Feld.

    Nur zufällig habe ich gelesen, dass WordPress seit dem Update auf 5.5. eine Option der „automatischen Aktualisierung“ von Themes und Plugins anbietet. Diese Option scheint es bei mir nicht zu geben. Mittlerweile bin ich, nach regelmäßigem selbständigem Aktualisieren, bei Version 5.7.2.

    Die Website wird über Strato gehostet und erst im Nachhinein habe ich entdeckt, dass Strato ebenfalls eine Option des automatischen Updates anbietet. Den sogenannten „Sicherheits-Modus“. Meine Website habe ich allerdings im „Flexibilitäts-Modus“ erstellt. Ich traue mich nicht zu wechseln, da ich befürchte, dass dann alles Arbeit verschwunden ist.

    Weiß jemand Rat?

    Liebe Grüße
    Mine

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Moderator Bego Mario Garde

    (@pixolin)

    Wenn du bei Strato WordPress über das Kundenmenü installierst, deaktiviert Strato die automatische Aktualisierung und verweist auf die Möglichkeit, Updates über das Kundenmenü durchzuführen. Angeblich soll das eigene Audit-Team die Installation vorab prüfen, aber ich nehme eher an, dass man so die Ressourcen der eigenen Server schonen möchte.

    Ich bin mir nicht ganz sicher, ob hier eine Änderung der Konfigurationsdatei wp-config.php ausreicht, um die automatischen Aktualisierungen zu aktivieren. Wenn du per FTP-Programm (z.B. FileZilla) auf die Dateien zugreifen kannst, lad doch mal die wp-config.php herunter und füge sie hier als Antwort ein (bitte vor dem Absenden die Zeilen mit den Zugangsdaten zur Datenbank und den SALT-Keys löschen – wir wollen deine Zugangsdaten nicht veröffentlichen).

    Ein Bericht zu deiner Website wäre ebenfalls hilfreich: Geh bitte auf Werkzeuge > Website-Zustand > Bericht, klick auf den Button und füge den Bericht mit Strg-V unverändert in deine Antwort ein.

    Thread-Ersteller Maximiliane

    (@diegoldmine)

    Danke für deine Antwort. 🙂

    Hier erstmal die wp-config.php – ich hoffe ich habe nicht zu viel gelöscht um die Zugangsdaten zu entfernen:

    <?php
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://wordpress.org/support/article/editing-wp-config-php/
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define( 'DB_NAME', 'DB4395268' );
    
    /** MySQL hostname */
    define( 'DB_HOST', 'rdbms.strato.de' );
    
    /** Database Charset to use in creating database tables. */
    define( 'DB_CHARSET', 'utf8' );
    
    /** The Database Collate type. Don't change this if in doubt. */
    define( 'DB_COLLATE', '' );
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    
    /**
     * Other customizations.
     */
    define('FS_METHOD','direct');
    define('FS_CHMOD_DIR',0755);
    define('FS_CHMOD_FILE',0644);
    define('WP_TEMP_DIR',dirname(__FILE__).'/wp-content/uploads');
    
    /**
     * Turn off automatic updates since these are managed externally by Installatron.
     * If you remove this define() to re-enable WordPress's automatic background updating
     * then it's advised to disable auto-updating in Installatron.
     */
    define('AUTOMATIC_UPDATER_DISABLED', true);
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix = 'iyzl_';
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the documentation.
     *
     * @link https://wordpress.org/support/article/debugging-in-wordpress/
     */
    define( 'WP_DEBUG', false );
    
    /* That's all, stop editing! Happy publishing. */
    
    /** Absolute path to the WordPress directory. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', __DIR__ . '/' );
    }
    
    /** Sets up WordPress vars and included files. */
    require_once ABSPATH . 'wp-settings.php';
    
    define( 'WP_AUTO_UPDATE_CORE', true );
    ?>
    Thread-Ersteller Maximiliane

    (@diegoldmine)

    Und hier der Bericht aus WordPress:

    
    ### wp-core ###
    
    version: 5.7.2
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web507/b1/11/510807611/htdocs/STRATO-apps/wordpress_01/app
    wordpress_size: 53,16 MB (55739454 bytes)
    uploads_path: /mnt/web507/b1/11/510807611/htdocs/STRATO-apps/wordpress_01/app/wp-content/uploads
    uploads_size: 8,26 MB (8656607 bytes)
    themes_path: /mnt/web507/b1/11/510807611/htdocs/STRATO-apps/wordpress_01/app/wp-content/themes
    themes_size: 16,85 MB (17671752 bytes)
    plugins_path: /mnt/web507/b1/11/510807611/htdocs/STRATO-apps/wordpress_01/app/wp-content/plugins
    plugins_size: 91,75 MB (96207384 bytes)
    database_size: 30,97 MB (32473088 bytes)
    total_size: 200,99 MB (210748285 bytes)
    
    ### wp-active-theme ###
    
    name: OceanWP (oceanwp)
    version: 2.0.8
    author: Nick
    author_website: https://oceanwp.org/about-me/
    parent_theme: none
    theme_features: core-block-patterns, align-wide, wp-block-styles, responsive-embeds, editor-styles, editor-style, menus, post-formats, title-tag, automatic-feed-links, post-thumbnails, custom-header, custom-logo, html5, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, widgets
    theme_path: /mnt/web507/b1/11/510807611/htdocs/STRATO-apps/wordpress_01/app/wp-content/themes/oceanwp
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-One: version: 1.3, author: WordPress-Team
    
    ### wp-mu-plugins (1) ###
    
    installatron_hide_status_test.php: author: (undefined), version: (undefined)
    
    ### wp-plugins-active (9) ###
    
    Better Search Replace: version: 1.3.4, author: Delicious Brains
    Elementor: version: 3.2.3, author: Elementor.com
    Envato Elements: version: 2.0.8, author: Envato
    Limit Login Attempts Reloaded: version: 2.22.0, author: Limit Login Attempts Reloaded
    Ocean Extra: version: 1.7.5, author: OceanWP
    Strato Assistant: version: 5.7.0, author: Strato
    UpdraftPlus - Backup/Restore: version: 1.16.56, author: UpdraftPlus.Com, DavidAnderson
    Wordfence Security: version: 7.5.3, author: Wordfence
    Yoast SEO: version: 16.2, author: Team Yoast
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1692
    imagemagick_version: ImageMagick 6.9.12-10 Q16 x86_64 2021-04-29 https://imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 76M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 4 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 192
    	imagick::RESOURCETYPE_MAP: 4 GB
    	imagick::RESOURCETYPE_MEMORY: 2 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Linux localhost 3.10.0-1127.10.1.el7.x86_64 #1 SMP Linux localhost 3.10.0-1127.10.1.el7.x86_64 #1 SMP Linux localhost 3.10.0-1127.10.1.el7.x86_64 #1 SMP
    httpd_software: Apache/2.4.46 (Unix)
    php_version: 7.4.19 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 240
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 64M
    php_post_max_size: 76M
    curl_version: 7.76.1 OpenSSL/1.1.1k
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.42-log
    client_version: 5.6.45
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web507/b1/11/510807611/htdocs/STRATO-apps/wordpress_01/app/wp-content
    WP_PLUGIN_DIR: /mnt/web507/b1/11/510807611/htdocs/STRATO-apps/wordpress_01/app/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    
    Moderator Bego Mario Garde

    (@pixolin)

    Wie bereits vermutet ist in der wp-config.php eingetragen, dass automatische Updates nicht durchgeführt werden sollen:

    /**
     * Turn off automatic updates since these are managed externally by Installatron.
     * If you remove this define() to re-enable WordPress's automatic background updating
     * then it's advised to disable auto-updating in Installatron.
     */
    define('AUTOMATIC_UPDATER_DISABLED', true);
    

    Du kannst die Zeile mit zwei vorangestellten Schrägstrichen deaktivieren:

    define('AUTOMATIC_UPDATER_DISABLED', true);

    Danach sollten auch die Updates wieder laufen.

    Die Zeile define( 'WP_AUTO_UPDATE_CORE', true ); und das schließende Tag ?> am Ende der Zeile solltest du beide löschen.

    Thread-Ersteller Maximiliane

    (@diegoldmine)

    Es hat funktioniert!!! Vielen, vielen Dank! 🙂

    Moderator Bego Mario Garde

    (@pixolin)

    Freut mich! Danke für deine Rückmeldung.

    Moderator Angelika Reisiger

    (@la-geek)

    Hallo zusammen,
    auch wenn das Problem gelöst ist: Wie kommt der Eintrag in die wp-config.php? So etwas wird i. d. R. nur manuell hinzugefügt. Oder liefert Strato die 1-Klick-Installationen damit aus? (Würde mich wirklich mal interessieren) 🙂

    Moderator Bego Mario Garde

    (@pixolin)

    Oder liefert Strato die 1-Klick-Installationen damit aus?

    Das.

    Ich vermute, dass man den Traffic damit reduzieren will (ggf. gibt es eine gecachte Version im Installatron).

    Ich hatte irgendwann jemand von Strato angesprochen und bekam die Auskunft, man wolle sich lieber auf das eigene Audit verlassen, als auf eine OpenSource-Community. Ich möchte das nicht weiter kommentieren.

    Moderator Angelika Reisiger

    (@la-geek)

    Oh je 🙈

    Danke für die Info!

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)