Support » Allgemeine Fragen » Keine Vimeo Video Darstellung möglich

  • Gelöst s.wini

    (@swini-1)


    Hallo ihr Lieben,
    Ich kämpfe seit einem Monat mit einem seltsamen Problem und benötige dringend eure Hilfe.
    Auf meiner Seite war am 7.1. 23 die WP Mediathek der Vimeo Filme (extern bei Vimeo im plus account gehostet) komplett leer.
    Ich habs zuerst durch den google index festgestellt, daß meine 50 Videos laut console nicht mehr gefunden wurden.

    Vom Theme (uncode) Ersteller hab ich keine Antwort bekommen – was nicht schlimm war, da ich durch Tests festgestellt habe, daß es
    durchweg alle Themes betrifft (inkl. wp standard). Da ich viele Website Kunden auf unterschiedlichen Host Umgebungen habe, war der nächste Versuch,
    die Videos auf anderen Servern in den identischen Themes einzubetten.
    (Mit einbetten meine ich das Einfügen der Vimeo Url in ein Videomodul.)
    Meine Videos sind alle öffentlich, das kann nicht das Problem sein.

    Das ergab, auf Ionos, Hostpress, etc funktioniert alles ohne Probleme, nur bei Strato funktioniert Vimeo nicht mehr.
    Youtube geht ohne Probleme.

    Das seltsam, am 10.1.24 lief alles wieder ganz normal, alle Videos vorhanden, die Mediathek voll.
    Bis gestern – da hat das Spektakel wieder begonnen.
    Mail von der search console indexing issue – ein Blich auf die Seite alle Videos weg >> Mediathek leer.

    Anbei ein Link zum Screencast was passiert:

    Video Upload Standard theme
    https://vimeo.com/911492048/f97b7794d7

    Video upload uncode theme
    https://vimeo.com/911396012/e67a2fccb2

    Strato meint es wäre ein WordPress Problem – aber wieso funktioniert dann alles bei ionos bspw. wie gehabt.
    Plugins, WP aktuell, php 8.1

    Mein Video auf einem ionos Server
    https://www.anaka.de/video/

    Dasselbe Video auf meiner Strato Seite
    https://www.sabinewittmann.de/work/haribo-freizeitspass-2/

    Ich bin echt mit meinem Latein am Ende und für jeden Tipp dankbar.

    Viele Grüße
    Sabine

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 24)
  • Moderator Michi91

    (@michi91)

    Könntest du bei Strato eine zusätzliche WordPress Installation aufsetzen? Und schauen ob es dort auch auftritt?

    Was für Plugins verwendest du?


    Spontan gibts für mich folgende Möglichkeiten:
    – Konflikte mit einem Plugin
    – Bugs in einem Plugin
    – Netzwerkprobleme zwischen Strato und Vimeo. Eventuell blockt Vimeo auch die Strato-IP’s wegen Spamverdacht?

    Thread-Starter s.wini

    (@swini-1)

    Hallo Michi, danke für Deine Antwort.
    Ich hab es auf meinen beiden Domains getestet
    http://www.sabinewittmann.de
    http://www.deinvoodoo.de/video1

    und zusätzlich auf 5 Kundendomains, die auch auf Strato Servern liegen.
    Ebenso ohne Plugins und mit WP Standardtheme getestet.

    Die error logfiles sehen je nach theme immer ähnlich aus:

    error_uncode theme
    /wp-content/themes/uncode/core/inc/admin.php on line 923
    /wp-content/themes/uncode/core/inc/admin.php on line 1020

    923
    $vimeo = unserialize(wp_remote_fopen(„http://vimeo.com/api/v2/video/“.basename(strtok($urlEnterd, ‚?‘)).“.php“));
    $code = ‚‚;

    1020
    //For logged in users
    add_action(‚wp_ajax_get_oembed‘,’uncode_admin_get_oembed‘);

    ……………………….
    error_Divi theme

    Deprecated: preg_match_all(): Passing null to parameter #2 ($subject) of type string is deprecated in /mnt/web016/b3/09/5530109/htdocs/deinvoodoo/wp-content/themes/Divi/includes/builder/feature/dynamic-assets/dynamic-assets.php on line 467

    467
    $pattern = ‚~https?://(?:www.)?(?:youtube.com/watch\?v=|youtu.be/|vimeo.com/)([^\s]+)~i‘;
    preg_match_all( $pattern, $content, $matches );

    …………………

    Youtube funktioniert seltsamerweise wunderbar.
    Ich tippe auf eine Neukonfigiration der Strato Server oder einen Fehler in meiner .htaccess, wobei ich in diesem Zeitraum nichts geändert habe, und es dann ja auch auf den Kundenseiten gehen müsste.

    Der Strato Support hat mich abgewimmelt – da es ein WP Problem ist, und sie da keinen Support bieten.

    ……………..
    Und wie gesagt, ich hab die Seiten testweise auf ionos und Hostpress kopiert, da funktioniert alles problemlos – wie bei mir zuvor auch.
    ……………..
    Den Vimeo support hab ich zuallererst angeschrieben – die konnten kein Problem feststellen.

    • Diese Antwort wurde geändert vor 4 Monaten von s.wini.
    Thread-Starter s.wini

    (@swini-1)

    Ich wollte einen kurzen Zwischenbericht geben: Die Zugriffe von Strato auf die Vimeo api werden ab einer gewissen Anzahl blockiert. Der Vimeo Server gibt dann den Parameter Null aus, was im errorlog erstmal auf eine theme admin php error schliessen lässt. siehe hier: Hi again swini! It seems this error is caused by Vimeo directly, probably because you exceeded the API request limit. There is no way to fix this except to wait a few hours to see if it fixes itself. This problem causes a PHP warning. Da meine Seiten auf einem Strato shared Server liegen, ist es auch egal, daß ich einen plus account bei Vimeo mit 125 api Zugriffen habe. Ich geb Bescheid, sobald ich mehr weiß. Und deswegen betrifft das Problem auch nicht ionos oder hostpress, aber auch alle meine Kundenseiten, die auf Strato liegen, egal welches theme und welche plugins!
    btw iframe embedding funktioniert, da es nicht auf die Vimeo Api zugreift.

    Danke für die ausführliche Rückmeldung, die sicher speziell für User interessant ist, die bei Strato ihre Websites hosten (müssen oder wollen). 🤷‍♂️

    Thread-Starter s.wini

    (@swini-1)

    Ja, und ich bin ein Täter erster Stunde – seit 2001, da ein Bekannter den Laden damals mitgegründet hat. Frag nicht, wie oft ich schon wechseln wollte, oder wie oft ich das migrate Säckchen schon gepackt hatte. Man muß halt wie ein Trüffelschweinchen selbst alles testen und versuchen. Wenn ich Dir den emailverkehr seit 7.1.24 wegen dieser Sache zeigen würde, hättest Du Spaß für die nächsten Wochen. 🙂

    Thread-Starter s.wini

    (@swini-1)

    Ich freu mich schon, wenn ich alle Module getauscht hab in Textmodule, daß sie mir dann erzählen, es ginge doch alles….

    Moderator Michi91

    (@michi91)

    Das Problem kannst du natürlich auch bei anderen Hostern bekommen. Vimeo blockiert ja die IP und nicht speziell den Provider. Wenn du bei ionos mit anderen die auch die Vimeo api ansprechen landest, blüht das gleiche Problem.

    Ich denke hier wäre der Theme Entwickler gefragt. Ich vermute ganz stark, dass der Code nicht gerade optimiert ist, möglichst wenige Anfragen zu senden.

    Thread-Starter s.wini

    (@swini-1)

    Hi Michi, ohne die Theme Entwickler wäre ich gar nicht soweit gekommen, das Problem zu eroieren. Du hast natürlich Recht, daß das bei shared hosting immer passieren kann. Aber die Ignoranz bei der Fehlersuche ist schon unglaublich. Du kannst Dir nicht vorstellen, wie viele Emails ich seitb Dezember geschrieben habe, die alle mit völlig haltlosen Antworten zurück kamen. Ich bin froh, daß mein Blutdruck momentan wieder auf einem relativ normalen Level ist. Von Vimeo bin ich bei einem Bezahl Account auch sehr enttäuscht. Sie könnten ja zumindest eine Fehlermeldung schicken, die man weiter untersuchen kann – und nicht ein null…..

    Thread-Starter s.wini

    (@swini-1)

    Das Problem kannst du natürlich auch bei anderen Hostern bekommen. Vimeo blockiert ja die IP und nicht speziell den Provider

    Ich hab da nochmal nachgesehen, und NS Lookup gibt meine website IP
    folgendermaßen aus sabinewittmann.de./81.169.145.XX
    Und seltsamerweise teile ich mir da mit 3 meiner Kunden schon mal die IP inkl. der ausgex-ten Ziffern. wenn also diese ip geblockt wird, ist klar warum nichts mehr geht. Komplett unterschiedliche Pakete – zu ganz unterschiedlichen Zeiten bestellt….

    Thread-Starter s.wini

    (@swini-1)

    Ich will hier auch kein host bashing betreiben, sondern vielleicht anderen Verzweifelten die Lösung erleichtern

    Anonymous User 20597857

    (@anonymized-20597857)

    Bekanntlich mische ich mich hier immer wieder ungefragt in Themen ein, manchmal sogar mit hilfreichen Ideen.

    Aber diesmal ist mir mal eins wichtig: Dein Blutdruck, @swini-1 !
    Bitte pass auf dich auf, nichts ist es wert, die Gesundheit zu strapazieren, sage ich als Hypertonie 3+ Betroffener. Schon gar nicht die allseits bekannten Problemhoster.

    Apropos Videohosting:
    Da ein Bekannter auch eine Weile eine YT Alternative sucht(e), kam er auch schnell auf Vimeo (ok, ich (als ehem. Filmschaffender) habe den, an sich professionellen Anbieter empfohlen). Doch recht begeistert war er davon nicht und so suchte er aktuell wieder.

    Und: Wir haben ein paar interessante Alternativen gefunden, welche immerhin einen Test wert sind und waren. Einer davon ganz besonders.
    (Nein, es sind keine Portale mit Social Media Effekt, sondern reine Hoster.)

    PS: auch ich will keinen Anbieter, egal welche Branche „bashen“, denn jeder hat so seine speziellen Vorzüge, aber ich zeige gerne Alternativen auf.

    Die Frage (an die Mods) ist nur:
    Darf ich Alternativen nennen? (Nein, ich bin bei keinem beteiligt, nicht mal Reseller, Affiliate oder so)

    Und seltsamerweise teile ich mir da mit 3 meiner Kunden schon mal die IP inkl. der ausgex-ten Ziffern.

    Das ist nicht seltsam, sondern durchaus üblich, wenn die Domains auf dem gleichen Server liegen. Der Webserver trennt dann anhand des Domainnamens und weiß dann, was er ausliefern soll.

    Thread-Starter s.wini

    (@swini-1)

    Danke, gut zu wissen.

    Moderator Michi91

    (@michi91)

    Und die IP die du per Lookup auf die Domain machst, muss nicht zwangsläufig die selbe IP sein, die auch als ausgehende IP von einem Webserver verwendet wird.
    Bei uns im RZ z.B. haben wir hunderte „eingehende“ IP’s, aber ausgehend nur ein paar wenige.

    @kurapika – nur zu kannst du gerne machen. Nur Eigenwerbung (was reflinks etc mit beinhaltet) ist nicht erlaubt 🙂 Wie schon geschrieben, sehe ich den Verursacher auch eher bei Vimeo, als bei Strato 😀

    Ich als Webentwickler würde vermutlich am ehesten versuchen das Theme zu optimieren, sodass es möglichst keine weiteren Anfragen verschickt und alle Ergebnisse zwischenspeichert.

    Ich als Webseitenbetreiber würde mir überlegen, ob ich die Videos nicht einfach selber hoste, statt auf einem Portal. (Aber das hängt sicherlich von mehreren Faktoren ab und ist von mir sehr pauschal gedacht)

    • Diese Antwort wurde geändert vor 4 Monaten von Michi91.

    Ich hatte mal ein ähnliches Problem mit Plugins, die sich Informationen von Github holen. Dort musste ich irgendwie dem Plugin einen Key zur Authentifizierung gegenüber Github mitgeben. Ansonsten wurde meine Anfrage genauso abgewiesen. Und nicht jedes Plugin, was ich getestet habe, konnte das.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 24)