Support » Allgemeine Fragen » keinen Zugriff auf das Dashboard

  • Gelöst iteservices

    (@iteservices)


    Hallo,

    ich habe bei einem Webhoster meine WP mit Shop etc. gehostet. Leider bekomme ich bei einer Anmeldung am Backend die Meldung „Du bist leider nicht berechtigt, auf diese Seite zuzugreifen.“. Die Seite funktioniert soweit noch. Aber ist nicht mehr administrierbar.

    Ich habe nun schon folgendes probiert:

    – Cache und Cookies gelöscht
    – anderen Browser verwendet.
    – Plugins deaktiviert per FTP (Ordner umbenannt)
    – neuen User angelegt mit der Option (a:1:{s:13:“administrator“;b:1;}) und (a:1:{s:13:“administrator“;s:1;})
    – .htaccess Fiels umbenannt.
    – DB geprüft, scheint laut WP alles IO
    – db_version geprüft ist die 53496

    Ich vermute das eine config Datei nicht passt oder eben die Rollen in der DB nicht mehr passen. Allerdings kenne ich die WP Installation da zu wenig.

    Ich benötige bitte Hilfe von den Profis.

    Gruß
    André

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)
  • Auch hier fehlt wieder der Website-Bericht und wir können nur raten … 

    Ist das ein Managed WordPress-Hosting bei ionos?
    Was sagt der Support dort?

    Thread-Starter iteservices

    (@iteservices)

    Hi, da ich keinen Zugriff mehr auf den Adminbereich habe wird das schwer. Gibt es eventuell einen anderen Weg?

    Es war eine managed Seite bei IONOS ja. Sie sollte umgestellt werden, da ging etwas schief und dann wurde die Seite manuell umgestellt…

    Eine Vermutung wäre das es an den Config Files liegt aber ich bin mir da leider nicht sicher.

    Der Support wollte versuchen seit 5 Tagen und heute habe ich auf ein Backup gedrängt, da kam raus das es nur noch gestern möglich gewesen wäre….

    Raten soll hier keiner das habe ich schon genug 😉

    Gruß
    André

    • Diese Antwort wurde geändert vor 2 Monaten, 2 Wochen von iteservices.
    • Diese Antwort wurde geändert vor 2 Monaten, 2 Wochen von iteservices.

    Hi, da ich keinen Zugriff mehr auf den Adminbereich habe wird das schwer.

    Ups, stimmt. Da wir so häufig wenig bis gar keine Informationen zur Website bekommen, entwickelt sich bei mir inzwischen ein gewisser Beißreflex – sorry.

    Es war eine managed Seite bei IONOS ja. Sie sollte umgestellt werden, da ging etwas schief und dann wurde die Seite manuell umgestellt…

    Abgesehen davon, dass du immer eigene Backups machen solltest, klingt das nach einem Fehler bei ionos. Vielleicht kann @krafit hier weiterhelfen? (Du wolltest ja „Hilfe von den Profis“ 😉 )

    Ich hätte jetzt eine Reihe von Maßnahmen vorgeschlagen, die du aber nach eigener Aussage alle schon durch hast. Wir können gerne einen Blick in die wp-config.php werfen (Zugangsdaten zur Datenbank und SALT-Keys bitte löschen).

    Thread-Starter iteservices

    (@iteservices)

    Hi,

    Ups, stimmt. Da wir so häufig wenig bis gar keine Informationen zur Website bekommen, entwickelt sich bei mir inzwischen ein gewisser Beißreflex – sorry.

    Alles gut geht mir auch manchmal so.

    Backups habe ich ja, die wurden mit Jet-Pack gemacht. Nur wollte ich erstmal warten bis IONOS aufgegeben hat, da das natürlich nur alles Backups sind, wo die Website noch managed ist. Ich weis nicht was das bei IONOS auslöst wenn ich denen nun ein Backup eindrücke…..

    Die wp-config.php habe ich schon durch die sample ersetzt aber da war nichts auffälliges drin.

    define('FS_METHOD', 'direct');
    define('DISALLOW_FILE_EDIT', true);
    define('WP_HOME', 'https://www.leinhos-online.de/');
    define('WP_SITEURL', 'https://www.leinhos-online.de/');
    define('FORCE_SSL_ADMIN', true);

    Dies habe ich nur hinzugefügt.

    Es muss ja entweder was mit der Adminrollen zutun haben oder eventuell mit den .htaccess dateien.

    Nur weis ich leider nicht ob ich die einfach neu generieren kann.

    Weitere Info:
    Das ist der www_capabilities Eintrag in der DB, der ist allerdings auch bei der Managed variante genauso.

    'a:17:{s:13:\"administrator\";b:1;s:34:\"wpml_manage_translation_management\";b:1;s:21:\"wpml_manage_languages\";b:1;s:41:\"wpml_manage_theme_and_plugin_localization\";b:1;s:19:\"wpml_manage_support\";b:1;s:36:\"wpml_manage_woocommerce_multilingual\";b:1;s:37:\"wpml_operate_woocommerce_multilingual\";b:1;s:29:\"wpml_manage_media_translation\";b:1;s:22:\"wpml_manage_navigation\";b:1;s:24:\"wpml_manage_sticky_links\";b:1;s:30:\"wpml_manage_string_translation\";b:1;s:33:\"wpml_manage_translation_analytics\";b:1;s:25:\"wpml_manage_wp_menus_sync\";b:1;s:32:\"wpml_manage_taxonomy_translation\";b:1;s:27:\"wpml_manage_troubleshooting\";b:1;s:31:\"wpml_manage_translation_options\";b:1;s:9:\"translate\";b:1;}');

    • Diese Antwort wurde geändert vor 2 Monaten, 2 Wochen von iteservices.
    define('WP_HOME', '…');
    define('WP_SITEURL', '…');

    sollten eigentlich nur eingetragen werden, wenn du laufend zwischen Staging und Produktions-Umgebung wechselst, weil damit der Datenbankeintrag überschrieben wird. Sind Website- und WordPress-URL in Einstellungen > Allgemein richtig gesetzt, ist der Eintrag überflüssig.
    Die anderen Konstanten sind korrekt gesetzt und sollten nichts mit dem Problem zu tun haben.

    Es muss ja entweder was mit der Adminrollen zutun haben oder eventuell mit den .htaccess dateien.

    Ich hatte das so verstanden, dass du schon versucht hast, per Datenbankeintrag einen neuen Admin anzulegen? Das sollte eigentlich reichen.

    Zum Debuggen kannst du die .htaccess ruhig in sowas wie no.htaccess umbenennen. WordPress erstellt beim erneuten Festlegen der Permalinks eine neue .htaccess.

    Zu WPML kann ich dir nichts sagen, weil es mir für kostenlosen Support nicht zur Verfügung steht. Vielleicht magst du diesen Beitrag nochmal durchgehen: https://kinsta.com/de/blog/ausgesperrt-aus-wordpress-admin/

    Thread-Starter iteservices

    (@iteservices)

    Das habe ich jetzt nochmal gemacht. Zumindest den Teil mit dem User anlegen.
    Gibt es denn keine Logdatei die irgendwo generiert wird?

    Das habe ich mal in die wp-config.php hinzugefügt aber ich habe bestimmt nicht die Berechtigung die Datei im Verzeichnis zu sehen.

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );

    Leider steht nicht drin wenn ich versuche die wp-admin aufzurufen.

    Ich habe leider keine Idee mehr.

    Gruß
    André

    • Diese Antwort wurde geändert vor 2 Monaten, 2 Wochen von iteservices.
    • Diese Antwort wurde geändert vor 2 Monaten, 2 Wochen von iteservices.
    • Diese Antwort wurde geändert vor 2 Monaten, 2 Wochen von iteservices.

    Hey @iteservices,

    Ich kann hier nur sehr eingeschränkt supporten, aber ich habe gesehen, dass du dazu eine neue Support-Anfrage bei IONOS gestartet hast.

    Die ist an der richtigen Stelle gelandet und der geschätzte Kollege wirft einen Blick auf das Problem. Ich würde dir in der Zwischenzeit empfehlen erstmal keine weiteren eigenen Rettungsversuche zu starten, nicht das sich da etwas in die Quere kommt 🙂

    Beste Grüße,
    Simon

    Thread-Starter iteservices

    (@iteservices)

    Also erstmal ein riesiges DANKE!!!

    Ich möchte gar nicht wissen woher Ihr wisst wie mein Ticketstatus bei IONOS ist 🙂
    Aber ich wusste nicht mal das es da eins gibt….
    Egal ich komme wieder drauf! Würde zwar gerne wissen wo das Problem lag aber das werde ich bestimmt nie erfahren 🙁

    Es waren einige Plugins defekt, die ich aber dank @pixolin und einem seiner Beiträge beheben konnte. Einfach Ordner aus Plugins löschen und neu installieren 🙂 )

    Das einzige was noch nicht funktioniert ist der Zugriff auf meine WPML Sachen :-(. Da hat leider Ordnerlöschen nicht funktioniert. Die Daten sind alle da (ich weis zwar nicht wo, in der Datenbank, finde keine Tabelle mit WPML im Namen)

    Da werde ich bei den WPML Kollegen wohl einen Call öffnen müssen.

    Bekomme da bei Stringübersetzung auch angezeigt das ich nicht berechtigt bin.

    Gruß
    André

    Ich möchte gar nicht wissen woher Ihr wisst wie mein Ticketstatus bei IONOS ist …

    Das Support-Team hat keinen Einblick in die Support-Tätigkeiten der Webhoster, aber wir freuen uns über einen „losen Kontakt“ zu den Webhostern.

    Es waren einige Plugins defekt, die ich aber dank @pixolin und einem seiner Beiträge beheben konnte. Einfach Ordner aus Plugins löschen und neu installieren 🙂 )

    In dem Fall würde ich auch nochmal ein neues WordPress-Core-Update anstoßen, aber wie gesagt erst, wenn der Support des Webhosters seine Bemühungen abgeschlossen hat.

    Da werde ich bei den WPML Kollegen wohl einen Call öffnen müssen.

    Gute Idee, zumal wir bei gekauften Plugins kaum weiterhelfen können.

    Thread-Starter iteservices

    (@iteservices)

    In dem Fall würde ich auch nochmal ein neues WordPress-Core-Update anstoßen, aber wie gesagt erst, wenn der Support des Webhosters seine Bemühungen abgeschlossen hat.

    Also später nochmal Word-press 6.0.1 erneut über Aktualisierung installieren?

    Der Support von WPML schaut gerade schon. 😉

    Ja, genau, den WordPress-Core nochmal installieren – wenn bei den Plugins einige Dateien gefehlt haben, kann das auch beim Core so sein.

    @iteservices sagen wir es so: ab und zu schaut auch mal ein IONOS mitarbeiter hier vorbei 😉

    Thread-Starter iteservices

    (@iteservices)

    Ah ich glaube zu verstehen 😉

    Könnte mir dieser eventuell sagen ob ich die Installation des Core auf 6.0.1 noch mal durchführen kann?

    Danke auf jedenfall noch einmal.

    Ich bin zwar kein Mitarbeiter von IONOS, aber du kannst selber prüfen, ob du die Installation erneut durchführen kannst, in dem du unter Dashboard > Aktualisierungen auf den Button erneut aktualisieren klickst.

    Wie weit der Kundensupport des Webhosters vorher noch Änderungen vornehmen möchte, können wir hier nicht beurteilen. Das solltest du bitte mit dem Support abstimmen.

    Es wäre nett, wenn du den Thread hier noch als „gelöst“ markierst, wenn das Thema für dich erledigt ist.

    Thread-Starter iteservices

    (@iteservices)

    Nun ist „nur“ noch das WPML Problem zu lösen aber da muss ich bestimmt neu installieren.
    Danke für die Unterstützung.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)