Support » Allgemeine Fragen » Komme mit Staging-Site nicht auf Dashboard

  • Gelöst freilich

    (@freilich)


    Hallo

    WP Staging installiert, Meldung erhalten, dass Installation ok.

    Versuch Seite zu laden:

    Zuerst Dashboard der Echtseite, dann WP Staging, dann Actions und öffnen.

    Es öffnet das Frontend der Echtseite ohne farbigen Balken und auch kein Dashboard.

    Wie kann ich das Dashboard bei Staging erreichen?

    Ich bin für jede Hilfe dankbar.

    Gruß

    freilich

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Eigentlich sollten wir solche Thread direkt schließen, weil die Frage ohne hellseherische Fähigkeiten überhaupt nicht zu beantworten ist.

    Um welche Website handelt es sich?

    Was ist mit „Staging“ gemeint? Was mit „Actions“? Beides Begriffe kommen im WordPress-Core nicht vor. Verwendest du dafür ein Plugin? Welches? Oder handelt es sich um eine Variante deines Webhosters? Wer ist das?

    Bitte lies dir den angehefteten Beitrag Bevor du ein neues Thema (Thread) erstellst durch. Ohne die dort genannten Informationen können wir nicht helfen und können den Thread dann nur schließen.

    Hallo @freilich,

    eventuell hilft dir diese Anleitung weiter, nach deiner Schilderung ist es das richtige Plugin 😉

    So wie du den Vorgang schilderst ist die Staging-Seite wohl nicht richtig erstellt bzw. du rufst diese fehlerhaft auf.

    Bei der Erstellung vergibst du ja einen Ordnernamen, wenn alles erstellt ist melde dich aus dem Original-Backend ab! Und rufe danach die neue URL auf. Diese besteht aus deiner Domain plus dem vergebenen Ordnernamen. Viel Erfolg.

    Mit freundlichen Grüßen

    Thread-Starter freilich

    (@freilich)

    Hallo wpapm,

    vielen Dank. Ich habe die Staging-Seite. gelöscht und nach Anleitung nochmals erstellt. Neue URL https://adventgemeinde-calw.de/wp-test. So habe ich die Seite dann auch aufgerufen, aber nur wieder das produktive Backend ohne orange Balken erhalten. Wie könnte ich hier noch zu Werke gehen?

    Mit freundlichen Grüßen, freilich

    Hallo @freilich,

    sieht doch gut aus, Login der Staging-Seite ist vorhanden. Und nach dem Anmelden kommst du wieder auf deine Original-Seite? Das wäre dann nicht normal! Irgendwelche Umleitungen in deiner .htaccess? Schau die mal genauer an.

    Mit freundlichen Grüßen

    Thread-Starter freilich

    (@freilich)

    Hallo @wpapm,

    Irgendwelche Umleitungen in deiner .htaccess? Das überfordert mich leider schon. Unten die .htaccess, könntest du mal da draufschauen?

    Vielen Dank und freundliche Grüße, freilich

    
    
    BEGIN All In One WP Security
    
    AIOWPS_BLOCK_WP_FILE_ACCESS_START
    
    Require all denied Order deny,allow Deny from all
    Require all denied Order deny,allow Deny from all
    Require all denied Order deny,allow Deny from all
    
    AIOWPS_BLOCK_WP_FILE_ACCESS_END
    
    AIOWPS_BASIC_HTACCESS_RULES_START
    
    Require all denied Order deny,allow Deny from all
    ServerSignature Off
    LimitRequestBody 10485760
    Require all denied Order deny,allow Deny from all
    
    AIOWPS_BASIC_HTACCESS_RULES_END
    
    AIOWPS_PINGBACK_HTACCESS_RULES_START
    
    Require all denied Order deny,allow Deny from all
    
    AIOWPS_PINGBACK_HTACCESS_RULES_END
    
    AIOWPS_DEBUG_LOG_BLOCK_HTACCESS_RULES_START
    
    Require all denied Order deny,allow Deny from all
    
    AIOWPS_DEBUG_LOG_BLOCK_HTACCESS_RULES_END
    
    AIOWPS_DISABLE_INDEX_VIEWS_START
    
    Options -Indexes
    
    AIOWPS_DISABLE_INDEX_VIEWS_END
    
    AIOWPS_DISABLE_TRACE_TRACK_START
    
    RewriteEngine On RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK) RewriteRule .* - [F]
    
    AIOWPS_DISABLE_TRACE_TRACK_END
    
    AIOWPS_FORBID_PROXY_COMMENTS_START
    
    RewriteEngine On RewriteCond %{REQUEST_METHOD} ^POST RewriteCond %{HTTP:VIA} !^$ [OR] RewriteCond %{HTTP:FORWARDED} !^$ [OR] RewriteCond %{HTTP:USERAGENT_VIA} !^$ [OR] RewriteCond %{HTTP:X_FORWARDED_FOR} !^$ [OR] RewriteCond %{HTTP:X_FORWARDED_HOST} !^$ [OR] RewriteCond %{HTTP:PROXY_CONNECTION} !^$ [OR] RewriteCond %{HTTP:XPROXY_CONNECTION} !^$ [OR] RewriteCond %{HTTP:HTTP_PC_REMOTE_ADDR} !^$ [OR] RewriteCond %{HTTP:HTTP_CLIENT_IP} !^$ RewriteRule wp-comments-post.php - [F]
    
    AIOWPS_FORBID_PROXY_COMMENTS_END
    
    AIOWPS_DENY_BAD_QUERY_STRINGS_START
    
    RewriteEngine On RewriteCond %{QUERY_STRING} ftp: [NC,OR] RewriteCond %{QUERY_STRING} http: [NC,OR] RewriteCond %{QUERY_STRING} https: [NC,OR] RewriteCond %{QUERY_STRING} mosConfig [NC,OR] RewriteCond %{QUERY_STRING} ^.(globals|encode|loopback). [NC,OR] RewriteCond %{QUERY_STRING} (\;|'|\"|%22).(request|insert|union|declare|drop) [NC] RewriteRule ^(.)$ - [F,L]
    
    AIOWPS_DENY_BAD_QUERY_STRINGS_END
    
    AIOWPS_ADVANCED_CHAR_STRING_FILTER_START
    
    
    RedirectMatch 403 \,
    RedirectMatch 403 \:
    RedirectMatch 403 \;
    RedirectMatch 403 =
    RedirectMatch 403 [
    RedirectMatch 403 ]
    RedirectMatch 403 \^
    RedirectMatch 403 `
    RedirectMatch 403 {
    RedirectMatch 403 }
    RedirectMatch 403 ~
    RedirectMatch 403 \"
    RedirectMatch 403 \$
    RedirectMatch 403 \<
    RedirectMatch 403 >
    RedirectMatch 403 |
    RedirectMatch 403 ..
    RedirectMatch 403 \%0
    RedirectMatch 403 \%A
    RedirectMatch 403 \%B
    RedirectMatch 403 \%C
    RedirectMatch 403 \%D
    RedirectMatch 403 \%E
    RedirectMatch 403 \%F
    RedirectMatch 403 \%22
    RedirectMatch 403 \%27
    RedirectMatch 403 \%28
    RedirectMatch 403 \%29
    RedirectMatch 403 \%3C
    RedirectMatch 403 \%3E
    RedirectMatch 403 \%3F
    RedirectMatch 403 \%5B
    RedirectMatch 403 \%5C
    RedirectMatch 403 \%5D
    RedirectMatch 403 \%7B
    RedirectMatch 403 \%7C
    RedirectMatch 403 \%7D
    
    COMMON PATTERNS
    
    Redirectmatch 403 _vpi
    RedirectMatch 403 .inc
    Redirectmatch 403 xAou6
    Redirectmatch 403 db_name
    Redirectmatch 403 select(
    Redirectmatch 403 convert(
    Redirectmatch 403 \/query\/
    RedirectMatch 403 ImpEvData
    Redirectmatch 403 .XMLHTTP
    Redirectmatch 403 proxydeny
    RedirectMatch 403 function.
    Redirectmatch 403 remoteFile
    Redirectmatch 403 servername
    Redirectmatch 403 \&rptmode=
    Redirectmatch 403 sys_cpanel
    RedirectMatch 403 db_connect
    RedirectMatch 403 doeditconfig
    RedirectMatch 403 check_proxy
    Redirectmatch 403 system_user
    Redirectmatch 403 \/(null)\/
    Redirectmatch 403 clientrequest
    Redirectmatch 403 option_value
    RedirectMatch 403 ref.outcontrol
    
    SPECIFIC EXPLOITS
    
    RedirectMatch 403 errors.
    RedirectMatch 403 config.
    RedirectMatch 403 include.
    RedirectMatch 403 display.
    RedirectMatch 403 register.
    Redirectmatch 403 password.
    RedirectMatch 403 maincore.
    RedirectMatch 403 authorize.
    Redirectmatch 403 macromates.
    RedirectMatch 403 head_auth.
    RedirectMatch 403 submit_links.
    RedirectMatch 403 change_action.
    Redirectmatch 403 com_facileforms\/
    RedirectMatch 403 admin_db_utilities.
    RedirectMatch 403 admin.webring.docs.
    Redirectmatch 403 Table\/Latest\/index.
    
    
    AIOWPS_ADVANCED_CHAR_STRING_FILTER_END
    
    AIOWPS_BLOCK_SPAMBOTS_START
    
    RewriteEngine On RewriteCond %{REQUEST_METHOD} POST RewriteCond %{REQUEST_URI} ^(.)?wp-comments-post.php(.)$ RewriteCond %{HTTP_REFERER} !^http(s)?://adventgemeinde-calw.de [NC,OR] RewriteCond %{HTTP_USER_AGENT} ^$ RewriteRule .* http://127.0.0.1 [L]
    
    AIOWPS_BLOCK_SPAMBOTS_END
    
    AIOWPS_PREVENT_IMAGE_HOTLINKS_START
    
    RewriteEngine On RewriteCond %{HTTP_REFERER} !^$ RewriteCond %{REQUEST_FILENAME} -f RewriteCond %{REQUEST_FILENAME} .(gif|jpe?g?|png)$ [NC] RewriteCond %{HTTP_REFERER} !^http(s)?://adventgemeinde-calw.de [NC] RewriteRule .(gif|jpe?g?|png)$ - [F,NC,L]
    
    AIOWPS_PREVENT_IMAGE_HOTLINKS_END
    
    END All In One WP Security
    
    Options -MultiViews
    Options +FollowSymLinks
    
    ServerSignature Off
    
    Options All -Indexes
    
    RewriteEngine On
    
    match any URL with www and rewrite it to https without the www
    
    RewriteCond %{HTTP_HOST} ^(www.)(.) [NC] RewriteRule (.) https://%2%{REQUEST_URI} [L,R=301]
    
    match urls that are non https (without the www)
    
    RewriteCond %{HTTPS} off
    RewriteCond %{HTTP_HOST} !^(www.)(.) [NC] RewriteRule (.) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    
    BEGIN WordPress
    
    Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    
    dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    
    Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    
    RewriteEngine On RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}] RewriteBase / RewriteRule ^index.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L]
    
    END WordPress
    
    Order Allow,Deny Deny from all
    Thread-Starter freilich

    (@freilich)

    Hallo,

    ich melde mich nochmals, weil ich meinen Fehler gefunden habe. Nachdem ich das Plugin WP-Staging installiert hatte, war das Verzeichnis wie ich es nannte „wp-test“ auch da. Mir wurde die Staging Anmeldemaske gezeigt, wenn ich mich aber anmeldete bekam ich immer die Echtseite. Beim Fehlersuchen war mir dann die Seite eine große Hilfe. https://wp-staging.com/docs/can-not-login-to-staging-website/

    Mein Fehler war, dass ich eingegeben habe: https.//adventgemeinde-calw.de/wp-test/ richtig ist aber: https://adventgemeinde-calw.de/wp-test/wp-admin/ Damit komme ich in das Dashboard meiner Testumgebung mit dem orange Balken.

    Das Forum war mir dieses Mal leider keine Hilfe, trotzdem Danke bis zum Nächstenmal. Den Thread habe ich auf gelöst gesetzt.

    Mit freundlichen Grüßen

    Das Forum war mir dieses Mal leider keine Hilfe.

    Warum das so ist, habe ich geschrieben.
    Darauf gar nicht erst einzugehen, dann aber nochmal zu betonen, das Forum wäre keine Hilfe gewesen, ist schon etwas merkwürdig.

    Wie auch immer … es läuft ja jetzt. Viel Erfolg.

    Thread geschlossen.

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Das Thema „Komme mit Staging-Site nicht auf Dashboard“ ist für neue Antworten geschlossen.