Support » Installation » Komme nach Anmeldung nicht aufs Backend

  • Gelöst sina2008

    (@sina2008)


    WordPress Version: 6.1.1.
    Woocommerce Shop
    PHP 8.0

    Folgendes Problem:

    Ich habe als Testumgebung für die Umstellung auf PHP 8.0 eine WP-Installation innerhalb von STRATO von einer Domain auf eine andere Domain kopiert. In der Datenbank habe ich die Urls in den Tabellen wp_options und wp_user angepasst.

    Die Seiten werden im Frontend angezeigt.
    Anmeldeformular funktioniert auch. (wp-login.php)

    Nach dem Anmelden erscheint auf der Website im Frontend oben die wpadminbar, ich kann aber nicht ins Backend wechseln. (Das funktioniert normalerweise ja über den Link mit dem Seitennamen ganz oben links. Auch rechts oben der Username ist grau, ich kann ihn nicht anklicken.)

    Folgendes habe ich getestet:

    1. Plugin-Verzeichnis umbenannt, so dass nun kein Plugin geladen wird.
    2. .htacces im Installationsverzeichnis umbenannt, so dass sie nicht erkannt wird.
    => keine Veränderung. Es bleiben die Webseiten abrufbar, oben bleibt die wpadminbar und ich kann nicht ins Backend wechseln.

    3. Eingabe https://sabine-rupp.de/paracord/wp-admin
    => Du bist leider nicht berechtigt, auf diese Seite zuzugreifen.

    Bei allen Aufrufen habe ich zuvor den Cache im Browser (Firefox) geleert.

    Hier die wp-config.php (ohne empfindliche Daten ;-)):

    <?php
    /**
     * Grundeinstellungen für WordPress
     *
     * Zu diesen Einstellungen gehören:
     *
     * * MySQL-Zugangsdaten,
     * * Tabellenpräfix,
     * * Sicherheitsschlüssel
     * * und ABSPATH.
     *
     * Mehr Informationen zur wp-config.php gibt es auf der
     * {@link https://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren}
     * Seite im Codex. Die Zugangsdaten für die MySQL-Datenbank
     * bekommst du von deinem Webhoster.
     *
     * Diese Datei wird zur Erstellung der wp-config.php verwendet.
     * Du musst aber dafür nicht das Installationsskript verwenden.
     * Stattdessen kannst du auch diese Datei als wp-config.php mit
     * deinen Zugangsdaten für die Datenbank abspeichern.
     *
     * @package WordPress
     */
    
    // ** MySQL-Einstellungen ** //
    /**   Diese Zugangsdaten bekommst du von deinem Webhoster. **/
    
    /**
     * Ersetze datenbankname_hier_einfuegen
     * mit dem Namen der Datenbank, die du verwenden möchtest.
     */
    /**...*/
     * Für Entwickler: Der WordPress-Debug-Modus.
     *
     * Setze den Wert auf „true“, um bei der Entwicklung Warnungen und Fehler-Meldungen angezeigt zu bekommen.
     * Plugin- und Theme-Entwicklern wird nachdrücklich empfohlen, WP_DEBUG
     * in ihrer Entwicklungsumgebung zu verwenden.
     *
     * Besuche den Codex, um mehr Informationen über andere Konstanten zu finden,
     * die zum Debuggen genutzt werden können.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    
    define('WP_DEBUG', false); //Debug einschalten, ein = true, aus = false; normalerweise ausschalten
    define('WP_DEBUG_DISPLAY', false); //true = Warnmeldungen in Datei debug.log schreiben
    define('WP_DEBUG_LOG', false); //true = Warnmeldungen nicht im Browser anzeigen
    
    /** automatisches Update abschalten - https://codex.wordpress.org/de:Automatische_Hintergrund_Updates_einstellen **/
    define( 'AUTOMATIC_UPDATER_DISABLED', true );
    
    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß. */
    /* That's all, stop editing! Happy publishing. */
    
    /** Der absolute Pfad zum WordPress-Verzeichnis. */
    define('UPLOADS', 'wp-content/uploads'); 
    define('WP_PLUGIN_DIR', __DIR__ . "/wp-content/plugins"); 
    define('WP_PLUGIN_URL', 'https://sabine-rupp.de/paracord/wp-content/plugins'); 
    define('WP_LANG_DIR', __DIR__ . "/wp-content/languages"); 
    define('WP_HOME', 'https://sabine-rupp.de/paracord'); 
    define('WP_SITEURL', 'https://sabine-rupp.de/paracord'); 
    define('WP_CACHE', false); 
    define('WP_ENVIRONMENT_TYPE', 'staging'); 
    if ( ! defined( 'ABSPATH' ) ) {
    	define('ABSPATH', dirname( __FILE__ ) . '/');
    }
    /** Germanized Verschlüsselungs-Konstante - Meldung im Dashboard */
    /** ... */
    
    define('RELOCATE', true);
    
    /** Definiert WordPress-Variablen und fügt Dateien ein.  */
    require_once(ABSPATH . 'wp-settings.php');
    

    Und hier die .htaccess im Installationsverzeichnis:

    # BEGIN WordPress
    # Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /paracord/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /paracord/index.php [L]
    </IfModule>
    
    # END WordPress

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Warum hast du diese Zeilen eingetragen?

    define('UPLOADS', 'wp-content/uploads'); 
    define('WP_PLUGIN_DIR', __DIR__ . "/wp-content/plugins"); 
    define('WP_PLUGIN_URL', 'https://sab***upp.de/paracord/wp-content/plugins'); 
    define('WP_LANG_DIR', __DIR__ . "/wp-content/languages"); 
    define('WP_HOME', 'https://sab***upp.de/paracord'); 
    define('WP_SITEURL', 'https://sab***upp.de/paracord'); 

    Hast du an der Datenbank sonstige Änderungen vorgenommen, z.B. am Tabellen-Präfix?

    Thread-Starter sina2008

    (@sina2008)

    Ich glaube, diese Zeilen in der wp-config.php stammen vom Plugin WP Staging. Dieses hatte ich ursprünglich verwendet, aber die aktuelle Installation habe ich dann manuell gemacht, weil WP Staging keine separate Datenbank verwendet.

    Ja, ich hatte an der Datenbank der Testumgebung Änderungen gemacht, auch die Präfix geändert.
    => Diese Änderungen haben den Fehler verursacht!

    Lösung:
    – geänderte DB in der Testumgebung gelöscht
    – DB aus der Live-Installation manuell exportiert und in die Testumgebung manuell importiert
    – In DB Testumgebung nur in Tabelle wp_options die url geändert.

    Die Präfix in der DB Testumgebung ist jetzt dieselbe, wie die der DB Liveinstallation.
    => Sollte ich das ändern (z. B. mit Plugin Better Search & Replace)?
    Wenn ja, worauf muss ich achten?


    Vielen Dank für Deine Unterstützung, Bego!

    Wenn du das Tabellen-Präfix änderst, musst du in der Datenbank-Tabelle ??_usermeta (mit ??_ als unbekanntem Präfix deiner Datenbank-Tabellen) die Felder

    wp_capabilities ,
    wp_user_level,
    wp_user-settings und
    wp_user-settings-time

    so ändern, dass die mit dem Datenbank-Tabellenpräfix übereinstimmen. Bei einem Tabellen-Präfix xyz_ wird aus wp_capabilities dann xyz_capabilities usw.

    Eine wenig dokumentierte Besonderheit, an der ich gestern mindestens eine Stunde gesessen habe. 😀

    Thread-Starter sina2008

    (@sina2008)

    Das ist ein wertvoller Hinweis für die Zukunft – Danke!

    (Ich hatte die Tabelle wp_usermeta auch gefunden und diese Felder entsprechend angepasst – leider ohne Erfolg. Wahrscheinlich war alles schon vermurkst oder/und ich hatte Fehler gemacht.)

    Danke nochmals für Deine Mühe. Die war sicher nicht vergebens, denn wahrscheinlich haben auch andere User dasselbe Problem.

    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von sina2008.
    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von sina2008.
Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Das Thema „Komme nach Anmeldung nicht aufs Backend“ ist für neue Antworten geschlossen.