Support » Allgemeine Fragen » Komme nicht mehr auf die Seite oder in den Adminbereich

  • Gelöst starblade74

    (@starblade74)


    Hallo,

    meine Domain ist bei all-inkl.com gehostet und ich habe eben das ssl aktiviert. lief auch alles ohne probleme. seite und adminbereich waren ereichbar.

    Anschließend noch in WordPress selber vorher die WordPress-Adresse (URL) und Wbseite-Adresse in https://www.bored-zombie.de geändert

    danach habe ich ein plugin installiert um die htaccess von wordpress aus zu bearbeiten und folgende zeile eingetragen ( laut empfehlung )

    Umleitung aller URLs mittels 301-Redirect auf HTTPS

    In diesem Schritt wird sichergestellt, … bla bla bla

    Dieser wird in der Regel auf Apache-Servern mittels einer 301-Weiterleitung in der htaccess-Datei realisiert.

    Die htaccess-Datei wird dabei beispielsweise wie folgt angepasst:
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

    direkt nach dem speichern kam eine fehlermeldung, ich solle alles rückgängig machen, was aber nicht mehr ging, da der adminbereich und die seite nicht mehr zu erreichen sind

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at webmaster@bored-zombie.de to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Das Plugin habe ich inzwischen via Ftp gelöscht
    Das SSL ist bei meinem Hoster wieder deaktiviert

    Ich weiß gerade echt nicht was ich noch machen kann :/ Hilfäää

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    mir ist nicht klar, warum Du SSL wieder deaktivert hast. Wahrscheinlich hast Du „lediglich“ ein Problem mit Deiner .htaccess gehabt. Daher würde ich das SSL – Zertifikat erst mal wieder aktivieren.
    Hilfreich könnte auch eine neue .htaccess sein:

    • verbinde Dich mit Deinem Server über FTP
    • suche die .htaccess-Datei in Deinem Stammordner
    • lade eine Kopie der Datei per FTP auf Deinen Computer (es ist immer eine gute Idee, für alle Fälle ein Backup zu haben)
    • lösche die .htaccess-Datei von Deinem Server, nachdem Du eine Sicherungskopie auf Deinem lokalen Computer hast.

    Um WordPress zu zwingen, eine neue, saubere .htaccess-Datei zu erzeugen:

    • gehe zu den Einstellungen > Permalinks in Deinen WordPress Dashboard
    • unten auf der Seite klicken: auf Änderungen speichern (Du musst keine Änderungen vornehmen – klicke einfach auf die Schaltfläche)

    Weitere Anpassungen in der .htaccess können dann vorgenommen werden, wenn die Seite wieder läuft.

    Hier noch ein paar hilfreiche Infos: Auf der folgenden Seite findest Du eine Anleitung, wie Du Deine Webseite korrekt umstellst. Die folgende Anleitung ist ebenfalls hilfreich.
    Wenn Du nicht mehr auf das Dashboard zugreifen kannst, dann könntest Du auch die korrekte URL in der Datenbank (Tabelle wp_options) und dort unter siteurl und home prüfen und ggfs. ändern.
    Außerdem solltest Du prüfen, ob tatsächlich das SSL – Zertifikat beim Hoster (Kundenmenü) angelegt worden ist.

    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Ich würde zunächst einmal vermuten, dass der Internal Server Error mit dem Eintrag in der .htaccess zusammenhängt und würde deshalb …

    1. SSL wieder aktivieren
    2. Per Kundenmenü deines Webhosters > Datenbankverwaltung (phpMyAdmin) prüfen, was in der Tabelle wp_options als siteurl und home eingetragen ist und ggf. die Einträge auf https://… ändern.
    3. Die .htaccess in no.htaccess umbenennen. (Ein Backup ist vorab besser als eine komplette Löschung.)
    4. Versuchen, mich im Backend anzumelden und dort unter Einstellungen > Permalinks die gewünschte Link-Struktur speichern. Dabei solltest du darauf achten, ob du einen Hinweis bekommst, dass die .htaccess manuell angelegt werden muss. Falls nicht, sollte eine neue .htaccess mit einem WordPress-Block vorhanden sein.
    5. Falls das soweit alles klappt, selber eine Regel oberhalb des WordPress-Blocks einfügen:
      RewriteCond %{HTTPS} off
      RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

      Achte darauf, dass du mit solchen Weiterleitungsregeln keine Endlosschleifen einbaust, die von URL mit www auf URL ohne www auf URL mit www usw. weiterleiten.

    Nachtrag: Im Wesentlichen zweimal die gleiche Antwort, nur war Hans-Gerd wiedermal schneller als ich. 🙂

    starblade74

    (@starblade74)

    Hallo,

    die .htaccess ist auf jeden Fall Schuld. Ich hatte diese jetzt umbenannt in .htaccessBAK

    und konnte mich dann auch wieder in den Adminbereich einloggen

    SSL ist wieder aktiviert und die WordPress-Adresse und Webseite-Adresse wieder in https://www.bored-zombie.de geändert

    Den Permalink musste ich auch neu setzen, da die Beiträge sonst nicht gefunden worden sind.

    Das Plugin lasse ich dann mal weg und lösche es auch direkt aus meinem Gedächnis. Die Anleitung werde ich mir gleich mit einem warmen Kakao durchlesen.

    Wp Fastest Cache musste ich auch neu speicher, weil da auch einiges in der htaccess drin stand. Hoffe das es damit jetzt getan ist

    Vielen Lieben Dank für Eure tolle und schnelle Hilfe 🙂

    Moderator Bego Mario Garde

    (@pixolin)

    Schön, dass du selber eine Lösung gefunden hast.
    So ein heißer Kakao ist ja bei der Jahreszeit auch was feines.

    Ich markiere den Thread dann mal als „gelöst“, bevor der hier zum Zombie wird …

    starblade74

    (@starblade74)

    Die Lösung habe ich nur durch Euch gefunden 😉

    Noch eine Frage …. verstehe ich das richtig

    Nun installierst du das Plugin Better Search Replace. Nach Aktivierung des Plugins findest du das Menü in Werkzeuge. Nun ersetzt du in allen Tabellen (alle auswählen!) http://example mit https://example

    also

    http://www.bored-zombie.de mit https://www.bored-zombie.de ?

    • Diese Antwort wurde geändert vor 1 Woche von starblade74.
    Moderator Bego Mario Garde

    (@pixolin)

    Richtig. Vorsichtshalber auf Tippfehler prüfen und dann noch das Häkchen bei „Testlauf“ rausnehmen. Ein Backup der Datenbank vor der Änderung kann nicht schaden. Aber ansonsten kein großes Ding.

    Eigentlich reicht sogar, wenn du http://bored mit https://bored ersetzt. Es geht ja nur um die Ersetzung des Übertragungs-Schemas (https) für deine URL.

    starblade74

    (@starblade74)

    ok, dann noch einmal herzlichen dank für die tolle hilfe 🙂

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)