Support » Allgemeine Fragen » Kommentare fehlen

  • Gelöst ethem4414

    (@ethem4414)


    Hallo zusammen,

    ich habe bereits im FAQ und die Suchfunktion genutzt. Im FAQ steht dazu gar nichts und die Suchfunktion spuckt einiges aus, aber das alles mir bei meinem individuellen Problem nicht weitergeholfen. Der Link ist http://www.factsforfuture.net/rednecks.

    In meinem Post (hab bisher nur den einen) kann man keine Kommentare hinterlassen. Der Artikel ist zu Ende und man ist direkt am Footer.
    Ja, unter „edit“ -> rechts runtergescrollt unter „discussion“ ist „allow comments“ aktiviert.
    Ja, im Dashboard ist unter „settings“ die Funktion „Allow people to submit comments on new posts “ aktiviert.
    Ja, unter „posts“ -> der Artikel „quick edit“ ist „allow comments“ aktiviert.
    Ja, ich habe WordPress auf 5.5., also die aktuellste Version, aktualisiert.
    Ja, meine Plugins (Elementor, MonsterInsights, Yoast SEO, Updraft, Really Simple SSL, Starter Templates, WPForms Lite und Elementor – Header, Footer & Blocks) sind auf dem neusten Stand.

    Meine WordPress- und Webdesign-Kenntnisse sind sehr limitiert. Meine Vermutung ist, dass es mit meinem Theme „Astra“ zusammenhängen könnte. Das ist aber nicht mehr als geraten, ich weiß es nicht.

    Könnt ihr mir da weiterhelfen? Wieso kann man keine Kommentare hinterlassen?
    Vielen Dank und Grüße

    Ethem

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Hallo,
    teste das doch mal mit einem Standard-Theme wie twenty twenty. Gibt es da das gleiche Problem?
    Du kannst alternativ ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme auch bei twenty twenty auftauchen.
    Viele Grüße,
    Hans-Gerd

    ethem4414

    (@ethem4414)

    Vielen Dank Hans-Gerd für die schnelle Antwort.

    Was passiert, wenn ich das Theme ändere und es dann wieder rückgängig mache? Hat das irgendwelche Konsequenzen? Ich will nicht, dass sich dadurch irgendwas verschiebt.

    Grüße

    Ethem

    Hallo,
    normalerweise kann nichts passieren, aber eine Gewähr kann ich natürlich dafür nicht bieten. Am besten machst du vorher eine Sicherung.
    Viele Grüße,
    Hans-Gerd

    ethem4414

    (@ethem4414)

    Hallo,
    also ich hab ein Backup gemacht und Twenty Twenty aktiviert. Sieht bescheiden aus und das Problem ist leider nicht behoben. Die Kommentare sind überall aktiviert (rechts bei edit, unter settings und im quick edit). Ich sehe jetzt unter dem Artikel eine Suchfunktion, die ich nicht eingefügt habe und folgende Punkte:

    Recent Posts
    Von Rednecks und Gastarbeitern
    Recent Comments
    Archives
    January 2019
    Categories
    Rassismus
    Meta
    Site Admin
    Log out
    Entries feed
    Comments feed
    WordPress.org

    Also immer noch keine Kommentare.

    Grüße

    Ethem

    Hallo,
    es ging ja nur erstmal darum, zu sehen, ob das Problem möglicherweise durch das Theme verursacht wird.
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website und kannst den Bericht über den Button „Bericht in die Zwischenablage kopieren“ und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße,
    Hans-Gerd

    ethem4414

    (@ethem4414)

    Hallo,

    das wäre dann folgender Bericht:

    
    ### wp-core ###
    
    version: 5.5
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home4/ethem/public_html
    wordpress_size: 91,94 MB (96404255 bytes)
    uploads_path: /home4/ethem/public_html/wp-content/uploads
    uploads_size: 21,09 MB (22111265 bytes)
    themes_path: /home4/ethem/public_html/wp-content/themes
    themes_size: 9,38 MB (9831427 bytes)
    plugins_path: /home4/ethem/public_html/wp-content/plugins
    plugins_size: 71,87 MB (75362359 bytes)
    database_size: 6,62 MB (6936759 bytes)
    total_size: 200,89 MB (210646065 bytes)
    
    ### wp-active-theme ###
    
    name: Astra (astra)
    version: 2.5.4
    author: Brainstorm Force
    author_website: https://wpastra.com/about/
    parent_theme: none
    theme_features: core-block-patterns, astra_hooks, align-wide, automatic-feed-links, title-tag, post-thumbnails, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, woocommerce, amp, widgets, menus
    theme_path: /home4/ethem/public_html/wp-content/themes/astra
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (4) ###
    
    Twenty Nineteen: version: 1.7, author: the WordPress team,Automatische Aktualisierungen deaktiviert
    Twenty Seventeen: version: 2.4, author: the WordPress team,Automatische Aktualisierungen deaktiviert
    Twenty Sixteen: version: 2.2, author: the WordPress team,Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 1.5, author: the WordPress team,Automatische Aktualisierungen deaktiviert
    
    ### wp-mu-plugins (1) ###
    
    Endurance Page Cache: version: 2.0.2, author: Mike Hansen
    
    ### wp-plugins-active (8) ###
    
    Elementor: version: 2.9.14, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    Elementor - Header, Footer & Blocks: version: 1.5.3, author: Brainstorm Force, Nikhil Chavan, Automatische Aktualisierungen deaktiviert
    Google Analytics for WordPress by MonsterInsights: version: 7.12.2, author: MonsterInsights, Automatische Aktualisierungen deaktiviert
    Really Simple SSL: version: 3.3.4, author: Really Simple Plugins, Automatische Aktualisierungen deaktiviert
    Starter Templates: version: 2.3.4, author: Brainstorm Force, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.16.26, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    WPForms Lite: version: 1.6.2.2, author: WPForms, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 14.8, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1654
    imagemagick_version: ImageMagick 6.7.6-8 2016-07-19 Q16 http://www.imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 260M
    upload_max_filesize: 256M
    max_effective_size: 256 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 126 GB
    	imagick::RESOURCETYPE_DISK: -1
    	imagick::RESOURCETYPE_FILE: 12288
    	imagick::RESOURCETYPE_MAP: 48 MB
    	imagick::RESOURCETYPE_MEMORY: 48 MB
    	imagick::RESOURCETYPE_THREAD: not available
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 8.71
    
    ### wp-server ###
    
    server_architecture: Linux 4.14.135-214.ELK.el6.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.4.9 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 256M
    php_post_max_size: 260M
    curl_version: 7.71.1 OpenSSL/1.1.1g
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.41-84.1
    client_version: mysqlnd 7.4.9
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home4/ethem/public_html/wp-content
    WP_PLUGIN_DIR: /home4/ethem/public_html/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    ### wpforms ###
    
    version: 1.6.2.2
    license: false
    lite: Jan 29, 2019 @ 6:42pm
    total_forms: 1
    total_entries: 1
    
    

    Viele Grüße

    Ethem

    Hallo,
    ich sehe in dem Bericht keine Dinge, die das genannte Problem verursachen könnten, auch wenn das eine oder andere Plugin m. E. überflüssig ist und die timezone auf Berlin gestellt werden sollte.
    Die Hinweise zu WordPress 5.5 hast du schon gelesen?
    Es könnte evtl. auch sein, dass das Problem durch einen Konflikt zwischen Plugins verursacht wird.
    Ich hatte das schon geschrieben, aber ich bin mir nicht sicher, ob du das schon getestet hat: Du kannst ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung eines Plugins, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise ein Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu auch mal die Informationen in dem Beitrag Health Check durch.
    Viele Grüße,
    Hans-Gerd

    ethem4414

    (@ethem4414)

    Hallo,

    habe die Hinweise zu WordPress 5.5 jetzt nachgelesen, danke für den Link.
    Stimmt, das hattest du geschrieben, aber ich habe es übersehen. Leider ist ausgerechnet gestern mein WLAN ausgestiegen und ich muss mir fürs Schreiben dieser Zeilen mit meinem Smartphone einen Hotspot einrichten. Sobald mein WLAN am Mo oder Di hoffentlich wieder geht, probiere ich das mit dem Plugin Health Check & Troubleshooting.
    Welche Plugins erachtest du bei mir als überflüssig? Ich dachte eigentlich, ich hätte eher zu wenige. Als ich versucht habe, mein Problem auf YouTube zu lösen, habe ich bei den Videos gesehen, dass so Mancher bis zu 20 Plugins hat…

    Grüße

    Ethem

    Moderator Angelika Reisiger

    (@la-geek)

    Hallo @ethem4414

    du kannst im Theme Astra über den Customizer, also Klickweg =

    Design -> Customizer -> Blog -> Blog/Arhive
    sowie
    Design -> Customizer -> Blog -> Einzelner Beitrag

    die „Comments“ ausblenden (deaktiviertes Augen-Icon)

    Vielleicht hast du das gemacht?

    ethem4414

    (@ethem4414)

    Hallo @la-geek,

    vielen Dank für den Ratschlag, der vor allem den genauen Klickweg beschreibt.

    Ich bin den Klickweg gegangen und bei beiden (Blog/Archive und Einzelner Beitrag) zeigt sich Folgendes:

    Beitragsstruktur

    aktiviert Beitragsbild
    aktiviert Titel & Blog Meta

    Meta

    aktiviert Kommentare
    aktiviert Kategorie
    aktiviert Autor
    deaktiviert Veröffentlichungsdatum
    deaktiviert Schlagwort

    Also das ist es leider nicht. Hätte mich auch gewundert, denn ich bin diesen Klickweg noch nie gegangen und habe dank dir was Neues gelernt, vielen Dank 🙂

    Grüße

    Ethem

    ethem4414

    (@ethem4414)

    Hallo @hage,

    ich habe jetzt das Plugin Health Check & Troubleshooting installiert, aktiviert und die Problembehandlung gestartet. Das Plugin hat wie versprochen alle anderen Plugins deaktiviert und das Standard-Thema twenty twenty aktiviert.
    Leider kann ich danach über „Website besuchen“ nicht mehr auf meine Website zugreifen, um zu sehen, ob das Problem (der fehlenden Kommentare) behoben wurde. Ich klicke auf „Website besuchen“ und ich sehe nur noch weiß/ocker/beige. Da lädt nichts, man kann nichts klicken, das ganze Fenster ist in dieser Farbe.
    Ich habe mir den von dir empfohlenen Artikel auf Health Check Informationen durchgelesen und war auch auf Plugin Health Check. Dort steht unter Hilfe, was man bei meinem Problem (dass man nicht mehr auf seine Website zugreifen kann) alle Cookies löschen muss („I am unable to access my site after enabling troubleshooting
    If you should find your self stuck in Troubleshooting Mode for any reason, you can easily disable it by clearing your cookies.

    Are you unfamiliar with how to clear your cookies? No worries, you may also close all your browser windows, or perform a computer restart and it will clear this specific cookie automatically.)

    Auch das hab ich gemacht, aber das Problem ist nicht behoben. Solange das Health Check Troubleshooting-Plugin aktiv ist, kann ich nicht auf meine Website zugreifen und schauen, ob es an einem Plugin liegt.

    Grüße

    Ethem

    Hallo,

    Da lädt nichts, man kann nichts klicken, das ganze Fenster ist in dieser Farbe.

    das ist logisch, weil ja twenty twenty im Problembehandlungsmodus installiert ist.
    Oben in der Leiste findest du die Option „Problembehandlungsmodus“. Hier kannst du andere Themes auswählen. Über „Aktive Plugins verwalten“ kannst du einzelne oder mehrere Plugins im Problembehandlungsmodus aktivieren.
    Alternativ kannst du folgendermaßen auch folgendermaßen vorgehen (ohne den Problembehandlungsmodus nach einer Sicherung):

    1. Lade den Ordner plugins per FTP auf deinen lokalen Rechner.
    2. Benenne auf dem Server per FTP den Ordner plugins um in plugins.old.
    3. Dann legst du einen Ordner plugins wieder neu an.
    4. Jetzt testest du mal, ob du dich wieder anmelden kannst und auf das dashboard zugreifen kannst.
    5. Dann kopierst du aus dem Ordner plugins.old auf dem lokalen Rechner einzeln die jeweiligen Ordner wieder in den Ordner plugins auf dem Server.
    6. Nachdem du jeweils einen Ordner kopierst hast, testest du, ob Kommentare funktionieren.
    7. Sollte es funktionieren, kopierst du den nächsten Ordner. Sollte es nicht funktionieren, löschst du den gerade kopierten Ordner wieder. Das ist dann das plugin, das Probleme macht.
    8. Danach setzt du den Vorgang (Schritt 5. – 7.) solange fort, bis du alle Ordner kopiert hast.

    Nachteil bei dieser Methode ist allerdings, dass die Besucher deine Webseite in dem jeweiligen Zustand sehen.
    Viele Grüße,
    Hans-Gerd

    ethem4414

    (@ethem4414)

    Hallo,

    das Problem ist (teilweise) gelöst. Die Möglichkeit, Kommentare war die ganze Zeit vorhanden, nur eben oben beim Titel. Gehe auf http://www.factsforfuture.net/rednecks und oben unter dem Titel steht direkt „Kommentar verfassen“. Das habe ich vom Inkognito-Modus aus gemacht und jetzt ist unten die Kommentar-Funktion ganz normal vorhanden. Komisch..

    Könntest du mir noch sagen, welches Plugin deiner Meinung nach überflüssig ist? Meine Seite kommt mir irgendwie langsam vor. Ich weiß nicht, ob das anderen auch so geht. Meine Bilder sind alle auf jpeg, damit sie nicht zu viel Platz wegnehmen.

    Alle Guides, die ich mir zu Plugins anschaue, haben weitaus mehr als ich. Kann es wirklich sein, dass ich zu viele habe? Die haben schließlich alle ihre Daseinsberechtigung. DAchte ich zumindest 😉

    Grüße

    Ethem

    Hallo,
    freut mich, dass das Problem gelöst ist – ich markiere das Thema dann als gelöst.
    Bitte immer ein neues Thema beginnen, siehe FAQ (Eine Frage = Ein Thread (Thema))
    Nur so viel: Die Werte für die Seite sind in der Tat nicht berauschend, siehe hier.
    Viele Grüße,
    Hans-Gerd

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)