Support » Allgemeine Fragen » Konnte die Datei nicht auf die Festplatte kopieren.

  • Moin,
    ich weiß, dass dieses Thema hier schon mehrfach angesprochen wurde, ich konnte es jedoch mit den vorgeschlagenen Lösungen nicht lösen.
    Beim Bild-Upload erhalte ich plötzlich (d.h. vor einigen Stunden ging es noch) den Fehler: „Konnte die Datei nicht auf die Festplatte kopieren.“

    Der Strato-Service sagt dazu, nachdem ich sie auf den temporären Bilderordner angesprochen habe und dass sie diesen löschen sollen, dass ich den Pfad unter „Einstellungen“ > „Medien“ ändern soll, da der vorher absolut angegeben sei. (Auf den temporären Ordner sind sie gar nicht erst eingegangen.)
    Das stimmt aber nicht, hier steht (Punkte kommen von mir) /mnt/…/…/../…./htdocs/STRATO-apps/wordpress_02/app/wp-content/uploads drin – es ist egal, was ich hier ändere, der Fehler besteht weiter. Auch wenn ich den kompletten Pfad darunter angebe, Fehler bleibt.

    Memory Limit habe ich in der wp_config ergänzt: define( ‚WP_MEMORY_LIMIT‘, ‚512M‘ ); – keine Änderung. Ansonsten steht hier noch define(‚WP_TEMP_DIR‘,dirname(__FILE__).’/wp-content/uploads‘); – was ja korrekt sein sollte.

    Komisch ist, dass vor dieser Fehlermeldung diese ausgegeben wurde:
    „Die Verarbeitung des Bildes ist fehlgeschlagen. Der Server ist möglicherweise ausgelastet oder hat nicht genügend Ressourcen zur Verfügung. Eventuell hilft es, wenn du ein kleineres Bild hochlädst. Die vorgeschlagene Maximalgröße ist 2500 Pixel.“
    Bei diesem Problem wird das Bild allerdings dennoch hochgeladen, aber erst beim wiederholten Laden/Öffnen angezeigt. Damit hätte ich noch leben können, danach ging aber nichts mehr und es kam dann der hier genannte Fehler.

    Server Side Security – Gästebuch-Einstellung war schon immer deaktiviert.
    Wenn ich htaccess mal umbenenne, geht die ganze Site nicht mehr.
    Wenn ich über health check mal alles deaktiviere, Standard-Theme aktiviere, ist der Fehler weiterhin da.
    Wenn ich mal ein kleines Bild hochladen möchte, geht das auch nicht.

    Ich hab jetzt keine Idee mehr, wer kann helfen? Bitte bitte.

    Achso, Site ist im Bearbeitungsmodus, kann man so nix „offiziell“ sehen, Debug-Modus ist an – ich seh allerdings nix, also es steht nirgends was. Müsste doch was ganz am Anfang sein, wenn ich irgendeine Seite aufmache, oder?

    WP 5.6
    Gesamtgröße der Installation 1,21 GB
    Aktiver Editor
    WP_Image_Editor_Imagick
    ImageMagick-Versionsnummer
    1691
    ImageMagick-Versions-Zeichenfolge
    ImageMagick 6.9.11-39 Q16 x86_64 2020-12-01 https://imagemagick.org
    Imagick-Resource-Limits
    area: 4 GB
    disk: 9.2233720368548E+18
    file: 192
    map: 4 GB
    memory: 2 GB
    thread: 64
    GD-Version
    bundled (2.1.0 compatible)
    Ghostscript-Version
    Nicht verfügbar

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 42)
  • Hallo,
    es scheint sich wohl anzudeuten, dass das Problem mit dem Hoster (Strato) zusammenhängt. Insofern würde ich empfehlen, Kontakt mit dem Hoster aufzunehmen und möglichst auf diesen Thread (Verlinkung) zu verweisen.
    Ich sehe leider keine Möglichkeit, wie wir euch in diesem Fall helfen können.
    Viele Grüße
    Hans-Gerd

    @multiformes WordPress ist zu komplex, um „alles“ wissen zu können und wir helfen nach bestem Wissen, können aber (auch weil uns oft entscheidende Detailinformationen fehlen) unmöglich jedes Problem lösen. Mir passiert es aber auch, dass ich Dinge übersehe oder (mit Erinnerung an ähnliche Probleme, die andere Teilnehmende berichtet haben) viel zu kompliziert denke, auch wenn eine Lösung eigentlich ganz einfach ist.

    Ich würde es mir selber leichter machen, unter jeden dritten Beitrag „keine Ahnung“ zu schreiben, nur hilft das niemand bei der Lösung des Problems (und wen interessiert, wovon ich Ahnung habe oder auch nicht?). Da wir aber viele LeserInnen und einige mehr oder weniger aktiven Teilnehmende haben, ist es gut möglich, dass jemand anders spontan zur Lösung beitragen kann.

    Du hast deine Frage vor zwei Tagen gestellt, wir haben einige typische Probleme ausschließen können – manchmal hilft auch ein bisschen Geduld. Aber die von Hans-Gerd vorgeschlagene Rückfrage beim Support von Strato ist sicherlich der naheliegende nächste Schritt.

    Thread-Ersteller multiformes

    (@multiformes)

    Moin,

    alles gut – ich weiß das ja sehr zu schätzen, dass es das hier und euch gibt. Strato war ja meine 1. Anlaufstelle, ich befürchte aber, dass da nicht so viel zurückkommt bzw. der ursprüngliche Lösungsvorschlag war m.E. Quatsch. Ich werde warten, was da als nächstes kommt. Nur warte ich darauf seit Tagen. Das ist schon sehr frustrierend.

    Übrigens habe ich jetzt alles mal auf eine andere URL (im gleichen Hosting-Paket) gepackt und da geht es jetzt (vorerst) ohne Probleme. Es war eine 1:1 Kopie, keine anderen Einstellungen. Mal doof gefragt, kann es am Umlaut in meiner URL liegen? Wie ist das bei den anderen beiden? @matznklaus @armend91

    Guten Morgen @multiformes,

    am Umlaut deiner URL dürfte es nicht liegen. Ich habe keine Umlaute in meiner URL. Ich habe die Befürchtung, dass es ein Virus sein könnte, hoffe aber dass es nicht so ist.

    Ich habe zum Test eine komplett neue WordPress-Installation aufgesetzt und dann diese mit der Datenbank der alten Installation verbunden und die URL auf den Ordner der neuen Installation umgeleitet, nachdem ich dort alles so aufgesetzt habe wie auf der Original-Seite. Das führte dazu, dass es für einige Tage funktionierte, jedoch war das scheinbar nur eine temporäre Lösung, denn der „Fehler“ ist wieder da.

    Ich warte ebenfalls auf eine Rückmeldung vom Strato-Support.

    Hallo Zusammen,
    ich habe seit ca. 1 Woche ebenfalls dieses Problem (vor und nach WP 5.6) – habe 2 unterschiedliche WordPress-Seiten (mit unterschiedlichen Themes) in einem strato-Paket am laufen – bei beiden Seiten habe ich dieses Upload-Problem. Ich betreue noch 3 weitere strato-Pakete – in diesen läuft alles einwandfrei – wenn ich testhalber in einem der weiteren Pakete die selbe WP-Installation mit dem selben Theme und gleichen Plugins wie in dem fehlerhaften installiere, funktioniert alles perfekt.

    Also denke ich das es an der strato-Konfiguration des Pakets liegt – habe ebenfalls an strato geschrieben – mal sehen was da kommt …

    @multiformes
    Bei meinen betroffenen Domains sind keine Umlaute enthalten.

    Ich habe es auch gestern Abend mit einer frischen WordPress Installation inkl. neuer DB versucht. Auch dort habe ich den Fehler erhalten. Ich werde den Strato-Support nochmals kontaktieren und sobald ich etwas hilfreiches weiß, teile ich es hier.

    Ich bin auch bei Strato und habe das gleich Problem seit 4-5 Tagen.

    Erst war beim Medien-Uplaod der Fehler „Die Verarbeitung des Bildes ist fehlgeschlagen. Der Server ist möglicherweise ausgelastet oder hat nicht genügend Ressourcen zur Verfügung. Eventuell hilft es, wenn du ein kleineres Bild hochlädst. Die vorgeschlagene Maximalgröße ist 2500 Pixel.“
    Aktuell ist es der Fehler „Konnte die Datei nicht auf die Festplatte kopieren.“

    Habe mit dem Strato-Support gesprochen. Die haben aktuell laut Aussage des Mitarbeiters vermehrt Upload-Probleme bei WordPress. Er hat mich zu einem Sammelticket hinzugefügt, was innerhalb von 24 Stunden (also bis morgen) gefixt sein sollte.
    Wenn das nicht der Fall ist, werde ich einen Wechseln des Hosting-Anbieters ernsthaft überlegen.

    Hier die strato-Antwort:

    Dies liegt daran, dass mit der 1-Click Installation der absolute Pfad in den Einstellungen hinterlegt wird.

    Diesen findet man in WP unter „Einstellungen“ -> „Medien“ oder in der Datenbank unter „options“ -> „upload_path“.

    Bitte ändern Sie dies in https://hallostrato-welt.de/wp-content/uploads/
    Sie können die Datenbank vom Kundenlogin aus wie folgt öffnen und die Einstellung in der Datenbank unter „options“ -> „upload_path“ durchführen.

    https://www.strato.de/faq/hosting/hosting-wie-kann-ich-ueber-phpmyadmin-auf-die-datenbank-zugreifen/

    Hierzu noch weitere Anleitungen aus dem Netz die ich alternativ gerne zur Verfügung stelle. Bitte beachten Sie, dass wir für diese Anleitungen keine Verantwortung übernehmen:

    https://aufschnur.de/wordpress-uploads-verzeichnis-festlegen/
    https://rahmanzeb.com/change-upload-file-path-wordpress-mysql/

    Im Anschluss steht Ihnen der Bildupload erneut zur Verfügung.

    ——

    Wenn ich das in https://meinedomain.de/wp-content/uploads ändere sind alle Vorschaubilder weg und auf der Startseite die Bilder ebenfalls. In WP steht dann als Bild-URL z.B. https://meinedomain.de/https://meinedomain.de/wp-content/uploads/bild.jpg

    Wenn ich in wp-content/uploads ändere sind zwar alle Bilder da, der Fehler aber ebenso.

    Ich habe wieder ein paar Zeilen an strato zurückgeschrieben – ich werde berichten …

    Hallo,
    danke für die Info. Einen Kommentar zu dieser Antwort von Strato erspare ich mir an dieser Stelle besser 😉
    Viele Grüße
    Hans-Gerd

    Hallo zusammen.

    Ich habe hier das gleiche Problem mit Strato.

    Auch ich bekam die gleichen Standardempfehlungen vom Strato-Service.
    Diese scheinen „hoch kompetent“. Seit wann hat eine URL etwas im „upload_path“ zu suchen.
    Dafür wäre doch eher der Parameter „upload_url_path“ zu verwenden.
    Außerdem ist es doch wohl so, dass die Einstellung durch WordPress dann richtig ist, wenn man in seiner Medienverwaltung die Uploads, die man bisher gemacht hat, ordentlich sehen kann. Das ist bei mir – und ich denke auch bei den meisten hier – der Fall.

    Ein sehr interessanter Zustand ist mir aber noch aufgefallen: (Und jetzt nicht lachen!)

    Vormittags funktioniert bei mir das Upload und das Ersetzen von Dateien! Nachmittags nicht mehr.
    Bitte jetzt nicht alle am Vormittag hoch laden. Dann funktioniert nämlich dieser „Patch“ nicht mehr für mich.

    Hoffen wir mal, dass sich irgendwann mal jemand dem Problem annimmt, der etwas davon versteht. Wenn nicht, werden wohl die Kunden über kurz oder lang mit den Füßen entscheiden. Denn der Zustand ist eigentlich nicht tragbar. Es ist ja nicht so, dass Strato sonst mit seinem WordPress-Hosting brillieren kann. Da muss man nur mal die Ladezeiten mit anderen Hostern vergleichen, die auch nicht teurer sind.

    Also bitte Strato: Nehmt endlich eure Kunden mit WordPress-Installationen ernst. Und behandelt sie mit euren Serviceempfehlungen, wie

    „…
    Diesen findet man in WP unter „Einstellungen“ -> „Medien“ oder in der Datenbank unter „options“ -> „upload_path“.
    
    Bitte ändern Sie dies in https://hallostrato-welt.de/wp-content/uploads/
    Sie können die Datenbank vom Kundenlogin aus wie folgt öffnen und die Einstellung in der Datenbank unter „options“ -> „upload_path“ durchführen.
    …“

    nicht wie kleine Kinder!

    Danke.


    Moderationshinweis: Schuldzuweisung helfen uns nicht weiter und polemische Äußerungen über die Kompetenz der Webhoster sind hier unerwünscht.
    Aufgrund der Rückmeldungen gehe ich davon aus, dass den meisten Support-MitarbeiterInnen bei Strato die geschilderten Probleme bekannt sind und dasss sie sich zusammen mit den Netzwerkadministratoren um eine Lösung bemühen.
    Wir bekommen hier im Supportforum öfters die Bitte vorgetragen, komplexe Sachverhalte möglichst verständlich („für Fünfjährige“) zu formulieren. Ich würde die Serviceempfehlung eher als einen Versuch sehen, auch technisch weniger versierten Kunden (ob du dazu gehörst, kann ein Support-Mitarbeiter nicht einschätzen) eine mögliche Lösung zu erklären.

    • Diese Antwort wurde geändert vor 1 Jahr, 6 Monaten von Bego Mario Garde. Grund: Moderationshinweis: bitte kein Webhoster-Bashing
    Thread-Ersteller multiformes

    (@multiformes)

    Moin,
    ich hab nun den Vorschlag von Strato bekommen, dass sich die Technikabteilung das mal in meinem Hostingpaket genauer ansieht.
    Hat das schon jemand bei sich freigegeben? Dann könnte man die Erkenntnisse daraus einmal mit weitergeben.

    Die oben gepostete Antwort von strato kam nach der Freigabe um mein Paket zu „untersuchen“ …

    Thread-Ersteller multiformes

    (@multiformes)

    @madmotion oh echt? Das hatte ich „pauschal“ als erste Antwort erhalten – hmm, ok dann lass ich die mal gucken und drücke uns die Daumen, dass dann mehr dabei rauskommt

    @multiformes
    @madmotion
    @matweiss
    @originalo
    @matznklaus
    @armend91

    hattet ihr WordPress selbst installiert (also Download von WordPress.org usw.) oder hattet ihr die 1-Klick-Installation genutzt, die Strato anbietet?

    Bei der Website eines Kunden, die auf Strato gehostet ist und selbst installiert wurde, treten diese Probleme nicht auf.

    @la-geek Ich habe WordPress auf dem Webspace selbst installiert. Auch ich habe die „upload_path“-Lösung von Strato vorgeschlagen bekommen.

    Interessant ist hierbei auch, dass alle drei WordPress Installationen, die auf dem Webspace installiert sind, diesen Fehler aufwiesen. Aktuell scheint es zu funktionieren. Jedoch weiß ich nicht wie lange das so bleibt. Ich melde mich auf jeden Fall wieder, sobald es irgendwas neues gibt.

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 42)
  • Das Thema „Konnte die Datei nicht auf die Festplatte kopieren.“ ist für neue Antworten geschlossen.