Support » Allgemeine Fragen » Kritischer Fehler

  • Gelöst rayil28

    (@rayil28)


    Hallo, im Error-Login File erhalten ich zwei folgende Fehler:

    [Mon Mar 08 16:14:57 2021] [php7:error] [pid 15366] [client 88.68.221.0]
    [host http://www.MEINE DOMAIN.de] PHP Fatal error: Allowed memory size of 268435456
    bytes exhausted (tried to allocate 20480 bytes) in /is/htdocs/
    wp13596653_MNV12UUV1L/www/MEINE DOMAIN/wp-includes/meta.php on line 1078

    [Mon Mar 08 16:14:57 2021] [php7:error] [pid 15366] [client 88.68.221.0]
    [host http://www.MEINE DOMAIN.de] PHP Fatal error: Allowed memory size of 268435456
    bytes exhausted (tried to allocate 32768 bytes) in /is/htdocs/wp13596653_MNV12UUV1L/
    www/MEINE DOMAIN/wp-content/plugins/wpforms-lite/vendor/woocommerce/
    action-scheduler/classes/abstracts/ActionScheduler_Lock.php on line 1`

    Auf Facebook wurde mir gesagt, dass es ein „Memory Size Exhausted“ Fehler ist. Beim Hoster ist 256M eingestellt. Im Anschluss habe ich in der wp-config Datei über
    "/* That's all, stop editing! Happy publishing. */"
    folgenden Code eingefügt:

    define('WP_MEMORY_LIMIT', '256M'); 
    define('WP_MAX_MEMORY_LIMIT', '256M');

    Der Fehler ist nicht verschwunden. Was kann ich tun?

    • Dieses Thema wurde geändert vor 1 Jahr, 8 Monaten von rayil28.
    • Dieses Thema wurde geändert vor 1 Jahr, 8 Monaten von Hans-Gerd Gerhards. Grund: Formatierung als Code
Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Hallo,
    du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße
    Hans-Gerd

    Thread-Starter rayil28

    (@rayil28)

    Das oben genannte Problem habe ich gelöst, indem ich auf 320M umgestellt habe. Allerdings bin ich mit der Lösung nicht zufrieden. Es gibt wohl PlugIns, die viel Speicher verbrauchen. Gibt es ein Plugin, um die Speicherfressenden Plugins zu identifizieren?

    Außerdem ist ein neuer Fehler aufgetreten im Error-Log-File:

    [Mon Mar 08 15:51:35 2021] [ssl:warn] [pid 26253] [client [host AH01909:
    MEINE-DOMAIN.de:443:0 server certificate does NOT include an ID which
    matches the server name

    Wie kann ich das Problem lösen?

    Hier der gewünschte Bericht zum Website-Zustand:
    _______________________________________________________

    
    ### wp-core ###
    
    version: 5.6.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: undefined
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /is/htdocs/wp13596653_MNV12UUV1L/www/MeineDomain
    wordpress_size: 54,04 MB (56660339 bytes)
    uploads_path: /is/htdocs/wp13596653_MNV12UUV1L/www/MeineDomain/wp-content/uploads
    uploads_size: 1,50 MB (1572538 bytes)
    themes_path: /is/htdocs/wp13596653_MNV12UUV1L/www/MeineDomain/wp-content/themes
    themes_size: 13,38 MB (14027514 bytes)
    plugins_path: /is/htdocs/wp13596653_MNV12UUV1L/www/MeineDomain/wp-content/plugins
    plugins_size: 92,55 MB (97046849 bytes)
    database_size: 112,33 MB (117786520 bytes)
    total_size: 273,79 MB (287093760 bytes)
    
    ### wp-dropins (1) ###
    
    db.php: true
    
    ### wp-active-theme ###
    
    name: OceanWP (oceanwp)
    version: 2.0.3
    author: Nick
    author_website: https://oceanwp.org/about-me/
    parent_theme: none
    theme_features: core-block-patterns, align-wide, wp-block-styles, responsive-embeds, editor-styles, editor-style, menus, post-formats, title-tag, automatic-feed-links, post-thumbnails, custom-header, custom-logo, html5, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, widgets
    theme_path: /is/htdocs/wp13596653_MNV12UUV1L/www/MeineDomain/wp-content/themes/oceanwp
    auto_update: Deaktiviert
    
    ### wp-plugins-active (14) ###
    
    BBQ Firewall: version: 20210211, author: Jeff Starr, Automatische Aktualisierungen deaktiviert
    
    Borlabs Cookie - Cookie Opt-in: version: 2.2.22, author: Benjamin A. Bornschein, Borlabs, Automatische Aktualisierungen deaktiviert
    
    Elementor: version: 3.1.3, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    
    Elementor - Header, Footer & Blocks: version: 1.5.6, author: Brainstorm Force, Nikhil Chavan, Automatische Aktualisierungen deaktiviert
    
    Limit Login Attempts Reloaded: version: 2.20.3, author: Limit Login Attempts Reloaded, Automatische Aktualisierungen deaktiviert
    
    Query Monitor: version: 3.6.7, author: John Blackbourn, Automatische Aktualisierungen deaktiviert
    
    Styler for WPForms: version: 2.0.2, author: Sushil Kumar, Automatische Aktualisierungen deaktiviert
    
    UpdraftPlus - Backup/Restore: version: 1.16.47, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    
    Wordfence Login Security: version: 1.0.6, author: Wordfence, Automatische Aktualisierungen deaktiviert
    
    WPForms Lite: version: 1.6.5, author: WPForms, Automatische Aktualisierungen deaktiviert
    
    WP Mail SMTP: version: 2.6.0, author: WPForms, Automatische Aktualisierungen deaktiviert
    
    WPS Hide Login: version: 1.8.5, author: WPServeur, NicolasKulka, wpformation, Automatische Aktualisierungen deaktiviert
    
    Yoast Duplicate Post: version: 4.1.1, author: Enrico Battocchi & Team Yoast, Automatische Aktualisierungen deaktiviert
    
    Yoast SEO: version: 15.9.1, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 32M
    upload_max_filesize: 32M
    max_effective_size: 32 MB
    max_file_uploads: 50
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.14.132-xenu-he x86_64
    httpd_software: Apache
    php_version: 7.4.14-he.0 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 320M
    max_input_time: 60
    upload_max_filesize: 32M
    php_post_max_size: 32M
    curl_version: 7.64.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.32-35-log
    client_version: mysqlnd 7.4.14-he.0
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /is/htdocs/wp13596653_MNV12UUV1L/www/MeineDomain/wp-content
    WP_PLUGIN_DIR: /is/htdocs/wp13596653_MNV12UUV1L/www/MeineDomain/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 320M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    ### wpforms ###
    
    version: 1.6.5
    lite: Jan 4, 2021 @ 12:28am
    upload_dir: Writable
    db_tables: wp_wpforms_tasks_meta
    total_forms: 1
    total_submissions: 22
    
    ### wp_mail_smtp ###
    
    version: 2.6.0
    license_key_type: lite
    debug: Keine Debug-Hinweise gefunden.
    db_tables: wp_wpmailsmtp_tasks_meta
    lite_install_date: Jan 4, 2021 @ 2:40pm
    
    • Diese Antwort wurde geändert vor 1 Jahr, 8 Monaten von rayil28.
    • Diese Antwort wurde geändert vor 1 Jahr, 8 Monaten von Hans-Gerd Gerhards. Grund: Bitte den Code immer als "Code" formatieren

    server certificate does NOT include an ID which matches the server name

    Das ist ein Server-Problem und hat nichts mit WordPress zu tun. Da solltest du deinen Hoster und/oder google fragen.

    Klick mich

    Hallo,
    da scheint es wohl ein Problem mit dem SSL-Zertifikat zu geben.
    Auf der folgenden Seite kannst du das prüfen.
    Deine Frage bezüglich der „speicherfressenden“ Plugins: Du hast einige Plugins installiert, die irgendwas mit Sicherheit zu tun haben: BBQ Firewall, Wordfence, Limit Login Attempts Reloaded und WPS Hide Login. Die Frage ist, ob dies nicht ein Grund für das Problem ist und ob es überhaupt sinnvoll ist, ähnliche Plugins zu aktivieren. Bezogen auf Wordfence sehe ich das kritisch. Evtl. schaust du mal in die folgende Facebook-Gruppe.
    Gute Erfahrungen habe ich mit NinjaFirewall gemacht.
    Viele Grüße
    Hans-Gerd

    Thread-Starter rayil28

    (@rayil28)

    Vielen Dank für die Hilfe!

    Was das SSL Zertifikat angeht erscheint auf der Seite von ssllabs.com folgender Fehler:
    „Server sent fatal alert: handshake_failure“ für Safari und IE 11 / Win Phone 8.1 R.
    Hast du eine Idee, was ich da tun kann?

    Plugins:
    Wie kann ich herausfinden wie viel Speicher die jeweiligen Plugins fressen?

    Hast du eine Idee, was ich da tun kann?

    Du must deinen Hoster kontaktieren, das ist immer noch ein Serverproblem.

    Das oben genannte Problem habe ich gelöst, indem ich auf 320M umgestellt habe.

    Der Webhoster weist dir nur wenig Arbeitsspeicher zu, damit sich möglichst viele Anwender:innen den gleichen Server teilen können? Haha, dann ändern wir doch einfach die wp-config.php und dann soll er doch mal sehen, wie er … – nein, das geht natürlich nicht. Du kannst WordPress anweisen, nicht mehr als einen in der wp-config.php angegeben Wert zu überschreiten (etwa wenn du selber noch andere Webanwendungen parallel laufen lassen möchtest) aber du kannst nicht die Servereinstellungen überschreiben und damit dem Webhoster ein Schnippchen schlagen.

    Das Plugin Query Monitor zeigt, dir, wieviel Arbeitsspeicher durch WordPress-Core, Theme und Plugins verwendet wird, wobei du dann den Wert nicht (nur) im Backend ablesen solltest.

    Dass hat alles nichts mit dem geschilderten Problem mit dem SSL-Zertifikat zu tun, bezieht sich aber auf die Fehlermeldung, dass der zugewiesene Arbeitsspeicher nicht ausreicht.

    Was das SSL Zertifikat angeht erscheint auf der Seite von ssllabs.com folgender Fehler:
    „Server sent fatal alert: handshake_failure“ für Safari und IE 11 / Win Phone 8.1 R.
    Hast du eine Idee, was ich da tun kann?

    Gar nichts. Diese Webbrowser (Safari < 9) sind einfach zu alt und unterstützen nicht die aktuellen Protokolle. Wer mit diesen noch im Internet unterwegs ist, hat ein Problem.

    Entscheidend ist die Gesamtbewertung.

    Mit einer URL (gerne auch mit einem Dienst wie bitly.com gekürzt) hätten wir uns das sogar anschauen können. ¯\_(ツ)_/¯

    Thread-Starter rayil28

    (@rayil28)

    @pixolin ich habe nicht ganz verstanden was du meinst mit:

    „Der Webhoster weist dir nur wenig Arbeitsspeicher zu, damit sich möglichst viele Anwender:innen den gleichen Server teilen können? Haha, dann ändern wir doch einfach die wp-config.php und dann soll er doch mal sehen, wie er … – nein, das geht natürlich nicht. Du kannst WordPress anweisen, nicht mehr als einen in der wp-config.php angegeben Wert zu überschreiten (etwa wenn du selber noch andere Webanwendungen parallel laufen lassen möchtest) aber du kannst nicht die Servereinstellungen überschreiben und damit dem Webhoster ein Schnippchen schlagen.“

    Ich glaube wir haben uns missverstanden. Ich habe lediglich ein Code in die wp-config.php Datei hinzugefügt.

    define('WP_MEMORY_LIMIT', '320M'); 
    define('WP_MAX_MEMORY_LIMIT', '320M');

    Das Problem auf meinem Backend hat sich dadurch gelöst. Wenn ich richtig verstanden habe, dann „hintergehe“ ich die Einstellungen des Hosters damit? Was kann schlimmstenfalls passieren? Welche Alternative habe ich noch, außer die Plugins zu ändern und den Speicher zu reduzieren?

    Wenn ich Query Monitor installiere kann ich sehen, welche Plugins wie viel Speicher verbrauchen. Ok. Wo und wie sollte ich das es noch überprüfen außer im Backend?

    • Diese Antwort wurde geändert vor 1 Jahr, 8 Monaten von rayil28.
    • Diese Antwort wurde geändert vor 1 Jahr, 8 Monaten von rayil28.
    • Diese Antwort wurde geändert vor 1 Jahr, 8 Monaten von rayil28.
    • Diese Antwort wurde geändert vor 1 Jahr, 8 Monaten von rayil28.
    Thread-Starter rayil28

    (@rayil28)

    @hupe13

    Danke. Den SSL Fehler für Safari 6,7,8 und IE 11 / Win Phone 8.1 kann ich dann getrost ignorieren? Habe ich irgendwelche Nachteile, wenn ich das so lasse?

    • Diese Antwort wurde geändert vor 1 Jahr, 8 Monaten von rayil28.

    Nein, nur Vorteile. Welche Note vergibt denn ssllabs?

    Client und Server wollen über eine verschlüsselte Verbindung kommuninizieren. Beim Aushandeln dieser gibt es bestimmte Verschlüsselungsverfahren. Bei manchen werden Schwachstellen gefunden, dann sollten diese nicht mehr verwendet werden.

    Das kann man mit einer „Geheimsprache“ der Eltern gegenüber den Kindern vergleichen. Am Anfang kann diese z.B. englisch sein, aber irgendwann lernen die Kinder englisch und können das dann „entschlüsseln“. Dann müssen sich die Eltern was neues ausdenken.

    Der Vergleich hinkt vielleicht, aber so ähnlich läuft das ab.

    Thread-Starter rayil28

    (@rayil28)

    @hupe13 Grade A

    Vielen Dank für deine Hilfe. Das Problem mit dem SSL ist dann gelöst.

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Das Thema „Kritischer Fehler“ ist für neue Antworten geschlossen.