Support » Allgemeine Fragen » kritischer fehler

  • kann mir jemand sagen was das ist?

    Ein Fehler vom Typ E_ERROR wurde in der Zeile 232 der Datei /home/uwenocaz/www/supendy.com/wp-content/plugins/woocommerce/includes/class-wc-post-types.php verursacht. Fehlermeldung: Uncaught ValueError: Missing format specifier at end of string in /home/uwenocaz/www/supendy.com/wp-content/plugins/woocommerce/includes/class-wc-post-types.php:232 Stack trace: #0 /home/uwenocaz/www/supendy.com/wp-content/plugins/woocommerce/includes/class-wc-post-types.php(232): sprintf('Alle %', 'Compatible Mode...') #1 /home/uwenocaz/www/supendy.com/wp-includes/class-wp-hook.php(307): WC_Post_Types::register_taxonomies('') #2 /home/uwenocaz/www/supendy.com/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters(NULL, Array) #3 /home/uwenocaz/www/supendy.com/wp-includes/plugin.php(476): WP_Hook->do_action(Array) #4 /home/uwenocaz/www/supendy.com/wp-settings.php(598): do_action('init') #5 /home/uwenocaz/www/supendy.com/wp-config.php(116): require_once('/home/uwenocaz/...') #6 /home/uwenocaz/www/supendy.com/wp-load.php(50): require_once('/home/uwenocaz/...') #7 /home/uwenocaz/www/supendy.com/wp-blog-header.php(13): require_once('/home/uwenocaz/...') #8 /home/uwenocaz/www/supendy.com/index.php(17): require('/home/uwenocaz/...') #9 {main} thrown

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Moderator Bego Mario Garde

    (@pixolin)

    Bekommen wir auch noch den Website-Bericht? 🙂

    Geh bitte auf Werkzeuge > Website-Zustand > Bericht, klick auf den Button und füge den Bericht mit Strg-V unverändert in deine Antwort ein.

    kann mir jemand sagen was das ist?

    Ja, ein Fehler. Viel mehr kann man mit den Information auch nicht sagen.

    Bevor du ein neues Thema/Thread erstellst

    Thread-Ersteller mettlercommerce

    (@mettlercommerce)

    @pixolin vielen dank für deine Nachricht hier der Bericht.

    
    ### wp-core ###
    
    version: 6.0
    site_language: de_CH
    user_language: de_CH
    timezone: Europe/Zurich
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: -1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/uwenocaz/www/supendy.com
    wordpress_size: 78.23 MB (82026240 bytes)
    uploads_path: /home/uwenocaz/www/supendy.com/wp-content/uploads
    uploads_size: 2.94 MB (3087434 bytes)
    themes_path: /home/uwenocaz/www/supendy.com/wp-content/themes
    themes_size: 84.11 MB (88197681 bytes)
    plugins_path: /home/uwenocaz/www/supendy.com/wp-content/plugins
    plugins_size: 205.51 MB (215489746 bytes)
    database_size: 37.11 MB (38912000 bytes)
    total_size: 407.90 MB (427713101 bytes)
    
    ### wp-active-theme ###
    
    name: OceanWP (oceanwp)
    version: 3.3.3
    author: OceanWP
    author_website: https://oceanwp.org/about-oceanwp/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, align-wide, wp-block-styles, responsive-embeds, editor-styles, editor-style, menus, post-formats, title-tag, automatic-feed-links, post-thumbnails, custom-header, custom-logo, html5, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, widgets
    theme_path: /home/uwenocaz/www/supendy.com/wp-content/themes/oceanwp
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (14) ###
    
    Byvex WooCommerce Starter: version: 1.0.15, author: Byvex Team, Automatische Aktualisierungen deaktiviert
    Customizr: version: 4.4.20, author: nikeo, Automatische Aktualisierungen deaktiviert
    Diet Shop: version: 1.1.9, author: aThemeArt, Automatische Aktualisierungen deaktiviert
    Fastest Shop: version: 1.1.5, author: aThemeArt, Automatische Aktualisierungen deaktiviert
    Grocery Shop: version: 2.0.1, author: aThemeArt, Automatische Aktualisierungen deaktiviert
    Grocery Store: version: 1.1.7, author: aThemeArt, Automatische Aktualisierungen deaktiviert
    Jot Shop: version: 1.0.8, author: ThemeHunk, Automatische Aktualisierungen deaktiviert
    Shoper: version: 1.3.5, author: aThemeArt, Automatische Aktualisierungen deaktiviert
    shopstore: version: 4.3.4, author: aThemeArt, Automatische Aktualisierungen deaktiviert
    Startup Shop: version: 1.1.1, author: aThemeArt, Automatische Aktualisierungen deaktiviert
    Twenty Nineteen: version: 2.3, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 2.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.6, author: the WordPress team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.2, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (22) ###
    
    Breadcrumb NavXT: version: 7.0.2, author: John Havlik, Automatische Aktualisierungen aktiviert
    Chaty: version: 2.9.2, author: Premio, Automatische Aktualisierungen aktiviert
    Classic Widgets: version: 0.3, author: WordPress Contributors, Automatische Aktualisierungen aktiviert
    Contact Form 7: version: 5.6, author: Takayuki Miyoshi, Automatische Aktualisierungen aktiviert
    Dropship Me: version: 1.0.3.16, author: Vitaly Kukin, Automatische Aktualisierungen aktiviert
    Elementor: version: 3.6.6, author: Elementor.com, Automatische Aktualisierungen aktiviert
    Facebook for WooCommerce: version: 2.6.16, author: Facebook, Automatische Aktualisierungen aktiviert
    Facebook for WordPress: version: 3.0.6, author: Facebook, Automatische Aktualisierungen aktiviert
    Jetpack: version: 11.0, author: Automattic, Automatische Aktualisierungen aktiviert
    MailPoet 3 (New): version: 3.90.1, author: MailPoet, Automatische Aktualisierungen aktiviert
    MailPoet 3 Premium (New): version: 3.90.1, author: MailPoet, Automatische Aktualisierungen aktiviert
    Ocean Extra: version: 2.0.2, author: OceanWP, Automatische Aktualisierungen aktiviert
    Site Kit by Google: version: 1.75.0, author: Google, Automatische Aktualisierungen aktiviert
    Snapchat Pixel for WooCommerce: version: 1.0.0, author: Snapchat, Automatische Aktualisierungen aktiviert
    WooCommerce: version: 6.6.0, author: Automattic, Automatische Aktualisierungen aktiviert
    WooCommerce Blocks: version: 7.8.3, author: Automattic, Automatische Aktualisierungen aktiviert
    WooCommerce Payments: version: 4.3.0, author: Automattic, Automatische Aktualisierungen aktiviert
    WooCommerce PayPal Payments: version: 1.8.1, author: WooCommerce, Automatische Aktualisierungen aktiviert
    WooCommerce Shipping & Tax: version: 1.26.0, author: WooCommerce, Automatische Aktualisierungen aktiviert
    WooCommerce Stripe Gateway: version: 6.4.1, author: WooCommerce, Automatische Aktualisierungen aktiviert
    Yakkyofy: version: 1.0.7, author: Yakkyofy, Automatische Aktualisierungen aktiviert
    Yoast SEO: version: 19.1, author: Team Yoast, Automatische Aktualisierungen aktiviert
    
    ### wp-plugins-inactive (2) ###
    
    Aliexpress Dropship for Woocommerce (Lite version): version: 2.2.1, author: MA-Group, Automatische Aktualisierungen aktiviert
    WooCommerce wallee: version: 1.7.14, author: wallee AG, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1692
    imagemagick_version: ImageMagick 6.9.12-34 Q16 amd64 2021-12-22 https://imagemagick.org
    imagick_version: 3.5.1
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 384 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 1536
    	imagick::RESOURCETYPE_MAP: 384 GB
    	imagick::RESOURCETYPE_MEMORY: 192 GB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, AVI, AVIF, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, H, HALD, HDR, HEIC, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMF, WMV, WMZ, WPG, X3F, XBM, XC, XCF, XPM, XPS, XV, YCbCr, YCbCrA, YUV
    gd_version: 2.3.1
    gd_formats: GIF, JPEG, PNG, WebP, BMP
    ghostscript_version: 9.52
    
    ### wp-server ###
    
    server_architecture: FreeBSD 12.3-RELEASE-p1 amd64
    httpd_software: Apache
    php_version: 7.4.30 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.83.1 OpenSSL/1.1.1o
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.35-MariaDB-log
    client_version: mysqlnd 7.4.30
    max_allowed_packet: 16777216
    max_connections: 400
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/uwenocaz/www/supendy.com/wp-content
    WP_PLUGIN_DIR: /home/uwenocaz/www/supendy.com/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### jetpack ###
    
    site_id: 198678585
    ssl_cert: No
    time_diff: undefined
    version_option: 11.0:1655745641
    old_version: 11.0:1655745641
    public: Public
    master_user: #1 mettlercommerce
    current_user: #1 mettlercommerce
    tokens_set: Blog User
    blog_token: 7XgfHNtPgNCyZB$Ba9bZ5cKUw(e8HREv
    user_token: QI)gqEzz5bE6tNh(g!5P%Vf&MJx2i%MF
    version: 11.0
    jp_plugin_dir: /home/uwenocaz/www/supendy.com/wp-content/plugins/jetpack/
    plan: free
    protect_header: {"trusted_header":"REMOTE_ADDR","segments":1,"reverse":false}
    full_sync: {"started":"Tue, 12 Oct 2021 21:02:13 +0000","finished":"Tue, 12 Oct 2021 21:02:17 +0000","progress":{"options":{"finished":true},"functions":{"finished":true},"constants":{"finished":true},"users":{"total":"1","sent":1,"finished":true,"last_sent":"1"},"network_options":{"finished":true}},"config":{"options":true,"functions":true,"constants":true,"users":[1],"network_options":true}}
    sync_size: undefined
    sync_lag: 0 seconds
    full_sync_size: undefined
    full_sync_lag: 0 seconds
    idc_urls: {"home":"https:\/\/supendy.com","siteurl":"https:\/\/supendy.com","WP_HOME":"","WP_SITEURL":""}
    idc_error_option: false
    idc_optin: true
    cxn_tests: {"9":{"name":"test__wpcom_connection_test","label":false,"short_description":"Supendy is not connected.: 200","long_description":"<p>A healthy connection ensures Jetpack essential services are provided to your WordPress site, such as Stats and Site Security.<\/p><p><span class=\"dashicons fail\"><span class=\"screen-reader-text\">Error<\/span><\/span> Supendy is not connected.: 200<\/p><p><strong>We recommend reconnecting Jetpack.<\/strong><\/p>","severity":"critical","action":"https:\/\/supendy.com\/wp-admin\/admin.php?page=jetpack#\/reconnect","action_label":"Reconnect Jetpack now","show_in_site_health":true,"pass":false,"group":["default"],"type":"direct"}}
    
    ### google-site-kit ###
    
    version: 1.75.0
    php_version: 7.4.30
    wp_version: 6.0
    reference_url: https://supendy.com
    amp_mode: no
    site_status: connected-site
    user_status: authenticated
    verification_status: verified-file
    connected_user_count: 1
    active_modules: site-verification, search-console, adsense, analytics, analytics-4, pagespeed-insights
    required_scopes: 
    	openid: ✅
    	https://www.googleapis.com/auth/userinfo.profile: ✅
    	https://www.googleapis.com/auth/userinfo.email: ✅
    	https://www.googleapis.com/auth/siteverification: ✅
    	https://www.googleapis.com/auth/webmasters: ✅
    	https://www.googleapis.com/auth/adsense.readonly: ✅
    	https://www.googleapis.com/auth/analytics.readonly: ✅
    capabilities: 
    	googlesitekit_authenticate: ✅
    	googlesitekit_setup: ✅
    	googlesitekit_view_posts_insights: ✅
    	googlesitekit_view_dashboard: ✅
    	googlesitekit_view_module_details: ✅
    	googlesitekit_manage_options: ✅
    	googlesitekit_view_splash: ✅
    	googlesitekit_view_authenticated_dashboard: ✅
    enabled_features: 
    	adsenseSetupV2: ⭕
    	dashboardSharing: ⭕
    	ideaHubModule: ⭕
    	swgModule: ⭕
    	userInput: ⭕
    	unifiedDashboard: ✅
    	zeroDataStates: ✅
    search_console_property: https://supendy.com/
    adsense_account_id: none
    adsense_client_id: none
    adsense_account_status: none
    adsense_site_status: none
    adsense_use_snippet: yes
    adsense_web_stories_adunit_id: none
    analytics_account_id: 2106•••••
    analytics_property_id: UA-2106•••••••
    analytics_profile_id: 2535•••••
    analytics_use_snippet: yes
    analytics_4_property_id: 2904588••
    analytics_4_web_data_stream_id: 3007••••••
    analytics_4_measurement_id: G-6N••••••••
    analytics_4_use_snippet: yes
    
    
    Moderator Bego Mario Garde

    (@pixolin)

    Bis auf eine etwas umfangreiche Sammlung an Plugins ist da nichts auffälliges. Jetpack solltest du nicht verwenden, weil es in einigen Modulen nicht unseren Datenschutzvorgaben entspricht und Google Analaytics ist aus dem gleichen Grund wohl auch nicht unkritisch, aber das hat nichts mit der Fehlermeldung zu tun.

    Ich würde zunächst versuchen, die Plugins alle vorübergehend zu deaktivieren. Das geht sehr bequem mit dem Plugin Health Check, dass dir dafür einen Problembehandlungsmodus zur Verfügung stellt. Dann die Plugins einzeln aktivieren (bei den WooCommerce-Plugins zuerst WooCommerce selber, dann die AddOns) und jeweils prüfen, ob es wieder Fehlermeldungen gibt. Ziel ist, im Ausschlußverfahren den Übeltäter die Ursache ausfindig zu machen.

    Bis auf eine etwas umfangreiche Sammlung an Plugins ist da nichts auffälliges.

    Bei den Themes würde ich auch mal aufräumen 😉

    Moderator Bego Mario Garde

    (@pixolin)

    Ja schon, aber für den Fehler auch erst mal unerheblich.

    @mettlercommerce hast du selber Übersetzungen vorgenommen?

    Seit wann besteht das Problem? Betrifft es nur bestimmte Seiten, wenn ja welche? Oder funktioniert die komplette Webseite nicht mehr?

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)