Support » Allgemeine Fragen » Kritischer Fehler, aber kein Admin-Mail

  • Gelöst kurapika

    (@kurapika)


    jetzt habe ich auch erstmals die Meldung „Es gab einen kritischen Fehler … Mail an Admin …
    Passierte seltsamerweise im Backend und im Frontend; lässt sich aber nicht reproduzieren, also es kommt jetzt nichts mehr, egal was man alles anklickt. Daher weiß ich auch nicht mehr, bei welcher Aktion es auftrat.

    Nur leider: Da kommt kein Mail an (Mail-Versand-Empfang usw. ist ok) und weder ich noch Hoster finden irgendwo einen Logeintrag, nichts eben.

    Die Frage ist nun: Wo kann man noch suchen, um solche Meldungen zu prüfen?

    Ich weiß, warum WP im Fehlerfall keine Infos an Besucher rausposaunt, aber seinem Admin gegenüber darf das System schon ein bisschen mitteilsamer sein.

    Es betrifft übrigens eine dzt. noch nicht öffentliche Website.

    
    ### wp-core ###
    
    version: 6.1.1
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: false
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /www/htdocs/w01205e4
    wordpress_size: 428,30 MB (449108883 bytes)
    uploads_path: /www/htdocs/w01205e4/wp-content/uploads
    uploads_size: 801,13 MB (840047206 bytes)
    themes_path: /www/htdocs/w01205e4/wp-content/themes
    themes_size: 7,18 MB (7532759 bytes)
    plugins_path: /www/htdocs/w01205e4/wp-content/plugins
    plugins_size: 76,09 MB (79784432 bytes)
    database_size: 7,08 MB (7423984 bytes)
    total_size: 1,29 GB (1383897264 bytes)
    
    ### wp-active-theme ###
    
    name: MH Magazine Child Theme (mh-magazine-c)
    version: 1.0.0
    author: MH Themes
    author_website: https://www.mhthemes.com/
    parent_theme: MH Magazine (mh-magazine)
    theme_features: core-block-patterns, widgets-block-editor, title-tag, automatic-feed-links, html5, post-thumbnails, post-formats, custom-background, custom-header, custom-logo, customize-selective-refresh-widgets, menus, widgets
    theme_path: /www/htdocs/w01205e4/wp-content/themes/mh-magazine-c
    auto_update: Deaktiviert
    
    ### wp-parent-theme ###
    
    name: MH Magazine (mh-magazine)
    version: 3.9.5
    author: MH Themes
    author_website: https://mhthemes.com/
    theme_path: /www/htdocs/w01205e4/wp-content/themes/mh-magazine
    auto_update: Deaktiviert
    
    ### wp-plugins-active (5) ###
    
    BackWPup: version: 4.0.0, author: Inpsyde GmbH, Automatische Aktualisierungen deaktiviert
    Complianz | GDPR/CCPA Cookie Consent: version: 6.3.5, author: Really Simple Plugins, Automatische Aktualisierungen deaktiviert
    Disable & Remove Google Fonts: version: 1.4.7, author: Fonts Plugin (latest version: 1.5.0), Automatische Aktualisierungen deaktiviert
    Disable Gutenberg: version: 2.8.1, author: Jeff Starr, Automatische Aktualisierungen deaktiviert
    FooGallery: version: 2.2.26, author: FooPlugins, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: FooGallery_Thumb_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    imagick_version: 3.4.4
    file_uploads: File uploads is turned off
    post_max_size: 200M
    upload_max_filesize: 200M
    max_effective_size: 200 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.15.0-196-generic x86_64
    httpd_software: Apache
    php_version: 7.4.30 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 3000
    time_limit: 30
    memory_limit: 64M
    admin_memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 200M
    php_post_max_size: 200M
    curl_version: 7.58.0 OpenSSL/1.1.1
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.37-nmm1-log
    client_version: mysqlnd 7.4.30
    max_allowed_packet: 67108864
    max_connections: 500
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /www/htdocs/w01205e4/wp-content
    WP_PLUGIN_DIR: /www/htdocs/w01205e4/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: true
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • memory_limit: 64M

    Das ist sehr knapp und könnte eine Ursache sein.

    Dann wäre es hilfreich, wenn du den Debug-Modus aktivierst.
    Dazu änderst du mit einem geeigneten Programmier-Editor (nicht Windows Notepad) in der wp-config.php die Zeile
    define( 'WP_DEBUG', false );
    in
    define( 'WP_DEBUG', true );
    Werden nun Fehlermeldungen ausgegeben?

    Thread-Starter kurapika

    (@kurapika)

    Danke, ja ich tippe auch auf diese mageren 64 MB! (was nun bewiesen sein dürfte)

    Den Debug Modus hatte ich aktiviert, dann wieder auf false. (daher stehts so im Bericht)

    Nun war eine Weile Ruhe, ein Medienverwaltungsplugin installiert, aktiviert: ZACK! Wieder Error.
    Gleich wieder WP_DEBUG‘, true und siehe da:
    PHP Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 8192 bytes) in /www/htdocs/w01205e4/wp-admin/includes/ajax-actions.php on line 1050

    Somit wird der Hoster gebeten, dass zu erhöhen. Vllt. auf wenigstens 128, denke das müsste reichen? Kommt halt drauf an, was man noch alles dazu bastelt, was das halt an RAM braucht.

    Interessant:
    Man hat ja im Bericht manchmal (nicht bei jeder Site) 2 verschiedene Wert bez. Memory Limit:

    PHP-Speicher-Limit (memory_limit) 128M
    PHP-Speicher-Limit (nur für Administrator-Ansichten) 256M

    (das ist aus einer anderen Site)
    Wenn nun auch im Admin so ein Fehler zuschlägt, heißt das, dass auch die 256 zu wenig sein könnten?

    Thread-Starter kurapika

    (@kurapika)

    Habe es nun mal auf 256 gesetzt, die Sache scheint nun behoben. Viel mehr ginge bei der Site vllt. eh nicht, ist nur Shared. Sollte aber reichen.

    Markiere mal als gelöst, wenns wieder abschmiert, komme ich wieder vorbei

    Danke für die Rückmeldung und “Gelöst”-Markieren. 👍

    Thread-Starter kurapika

    (@kurapika)

    Jetzt muss ich doch noch was nachfragen:

    Ich dachte, das folgende in der wp-config

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false);

    würde
    – Debugging aktivieren
    – Fehler nur in die debug.log schreiben
    – aber keine auf der Site anzeigen

    Aber nein, es wurden weitere Fehler entdeckt und jedem gezeigt;
    eigentlich Kleinigkeiten (Undefined index: …) aber ich will das bis zur Behebung nicht auf der Site sehen, sondern nur im Log.

    Wie macht man das richtig?

    Thread-Starter kurapika

    (@kurapika)

    Passt schon, ich hatte es verkehrt drin!
    Also WP_DEBUG_DISPLAY stand an 2.ter Stelle und nicht wie oben angegeben.
    Und die Fehler Index-, bzw. Variablenfehler sind auch behoben, alles paletti.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)