Support » Allgemeine Fragen » Kritischer Fehler, keine E-Mail für weitere Anweisungen

  • Gelöst eugps

    (@eugps)


    Hallo,

    ich habe das Problem, dass ich seit einigen Wochen bei WordPress keine Änderungen mehr an meiner Webseite vornehmen kann.

    – wenn ich eine vorhandene Seite in den Papierkorb verschieben will, kommt jedesmal „Warning: Undefined array key „funnel_id““
    – wenn ich auf eine Seite klicke, um sie mit Elementor zu bearbeiten, kommt meistens „Fatal error: Out of memory (allocated 701497344) (tried to allocate 172032 bytes)“
    – wenn ich es doch einmal schaffe, Änderungen vorzunehmen, erscheint „Internal server error“, sobald ich auf „Speichern“ klicke.

    Bei der zweiten Fehlermeldung steht auch: „Es gab einen kritischen Fehler auf deiner Website. Bitte überprüfe den Posteingang deiner Website-Administrator-E-Mail-Adresse für weitere Anweisungen.“ Ich bin der Admin der Webseite und habe keine E-Mail erhalten, auch nicht im Spam-Ordner.

    Ich bin ein absoluter WordPress-(und Technik-)Laie und weiß überhaupt nicht, was das alles zu bedeuten hat und wie ich nun den Fehler beheben kann.
    Es wäre toll, wenn mir jemand weiterhelfen könnte.

    Vielen Dank im Voraus!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das scheinen unterschiedliche Probleme zu sein.

    Am einfachsten ist die Frage zu beantworten, was „Fatal error: Out of memory (allocated 701497344) (tried to allocate 172032 bytes)“ bedeutet: deine Website möchte mehr Arbeitsspeicher belegen, als vom Webhoster zur Verfügung gestellt wird. Abhilfe: entweder beim Webhoster mehr Arbeitsspeicher beauftragen (kostet ein paar Euro zusätzlich im Monat) oder auf das eine oder andere Plugin verzichten. Vermutlich sind dann auch die „500 – internal server error“-Meldungen erledigt.

    Bei „Warning: Undefined array key „funnel_id““ handelt es sich (wie die Meldung schon sagt) um einen Warnhinweis, dass (vermutlich) ein Plugin in einem assoziativen Array einen Index verwenden möchte, der nicht existiert. Radikal-Lösung ist, das Plugin zu löschen. Eine eher kosmetischen Übergangslösung ist, die Warnhinweise zu unterdrücken, indem du in der Konfigurationsdatei wp-config.php oberhalb von /* That's all, stop editing! Happy blogging. */ folgendes einträgst:

    define( 'WP_DEBUG', false );
    @ini_set( 'display_errors', 0 );

    allocated 701497344

    Das sind rund 670MB, das ist schon viel. Wenn man sich die Seite ansieht, kommt man nicht auf die Idee, dass soviel Speicher verbraucht wird.

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Thread-Ersteller eugps

    (@eugps)

    Vielen Dank @pixolin @bscu !

    Ich werde erst das ausprobieren, was @pixolin vorgeschlagen hat und werde berichten, ob das Problem behoben wurde. Wenn nicht, werde ich den Website-Bericht hier posten.

    Thread-Ersteller eugps

    (@eugps)

    Hallo zusammen,

    ich habe in der Zwischenzeit beim Webhoster den Speicher höher gestellt und einige Plugins gelöscht. Das Problem besteht leider weiterhin; „out of memory“ und „internal server error“.

    Ich kopiere hier mal den Website-Bericht rein, wie von @bscu vorgeschlagen:

    ### wp-core ###
    
    version: 6.0
    site_language: de_DE
    user_language: de_DE
    timezone: +01:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: -1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/1/d905477984/htdocs/unternehmer-gps
    wordpress_size: 53,23 MB (55816602 bytes)
    uploads_path: /homepages/1/d905477984/htdocs/unternehmer-gps/wp-content/uploads
    uploads_size: 96,33 MB (101005919 bytes)
    themes_path: /homepages/1/d905477984/htdocs/unternehmer-gps/wp-content/themes
    themes_size: 42,92 MB (45000074 bytes)
    plugins_path: /homepages/1/d905477984/htdocs/unternehmer-gps/wp-content/plugins
    plugins_size: 83,22 MB (87261922 bytes)
    database_size: 424,13 MB (444727296 bytes)
    total_size: 699,82 MB (733811813 bytes)
    
    ### wp-active-theme ###
    
    name: Neve (neve)
    version: 3.2.5
    author: ThemeIsle
    author_website: https://themeisle.com
    parent_theme: none
    theme_features: core-block-patterns, hfg_support, widgets-block-editor, title-tag, post-thumbnails, automatic-feed-links, custom-logo, html5, customize-selective-refresh-widgets, custom-background, align-wide, editor-color-palette, fl-theme-builder-headers, fl-theme-builder-footers, fl-theme-builder-parts, header-footer-elementor, lifterlms-sidebars, lifterlms, service_worker, starter-content, menus, widgets
    theme_path: /homepages/1/d905477984/htdocs/unternehmer-gps/wp-content/themes/neve
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (8) ###
    
    Astra: version: 3.8.2, author: Brainstorm Force, Automatische Aktualisierungen deaktiviert
    Fastest: version: 2.1.9.3, author: designgrande, Automatische Aktualisierungen deaktiviert
    Hello Elementor: version: 2.5.0, author: Elementor Team, Automatische Aktualisierungen deaktiviert
    Intentionally Blank: version: 3.0.3, author: Nilo Velez, Automatische Aktualisierungen deaktiviert
    Twenty Nineteen: version: 2.3, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 2.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.6, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.2, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (12) ###
    
    BackWPup: version: 3.10.0, author: Inpsyde GmbH, Automatische Aktualisierungen deaktiviert
    Cookiebot | GDPR/CCPA Compliant Cookie Consent and Control: version: 4.1.0, author: Cybot A/S, Automatische Aktualisierungen aktiviert
    Crowdsignal Polls & Ratings: version: 3.0.7, author: Automattic, Inc., Automatische Aktualisierungen aktiviert
    Duplicate Page: version: 4.4.8, author: mndpsingh287, Automatische Aktualisierungen aktiviert
    easyrechtssicher Main zur EU-DSGVO: version: 1.0.19, author: Cornel Dolff / easyrechtssicher, Automatische Aktualisierungen aktiviert
    Elementor: version: 3.6.6, author: Elementor.com, Automatische Aktualisierungen aktiviert
    Elementor Pro: version: 3.7.2, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    FunnelCockpit: version: 1.3.5, author: FunnelCockpit, Automatische Aktualisierungen deaktiviert
    Head, Footer and Post Injections: version: 3.2.5, author: Stefano Lissa, Automatische Aktualisierungen aktiviert
    Optimus: version: 1.6.2, author: KeyCDN, Automatische Aktualisierungen aktiviert
    Rank Math SEO: version: 1.0.91, author: Rank Math, Automatische Aktualisierungen aktiviert
    WP Fastest Cache: version: 1.0.2, author: Emre Vona, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.302-icpu-083 x86_64
    httpd_software: Apache
    php_version: 8.0.19 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50000
    memory_limit: -1
    max_input_time: -1
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.38-log
    client_version: mysqlnd 8.0.19
    max_allowed_packet: 67108864
    max_connections: 3000
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/1/d905477984/htdocs/unternehmer-gps/wp-content
    WP_PLUGIN_DIR: /homepages/1/d905477984/htdocs/unternehmer-gps/wp-content/plugins
    WP_MEMORY_LIMIT: 256M
    WP_MAX_MEMORY_LIMIT: -1
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### neve ###
    
    api: Ja
    child: Nein
    customizer_css: Nein
    

    Ich hoffe sehr, dass mir hier jemand weiterhelfen kann.

    Ich hätte in diesem Zusammenhang noch eine Frage:
    Kürzlich habe ich Elementor Pro zusätzlich zu Elementor gekauft.
    Ich hadere damit, Elementor zu löschen, da ich Angst habe, dass dadurch meine Website nicht mehr funktioniert, da diese mit Elementor erstellt wurde.
    Kann ich Elementor ohne Bedenken löschen?

    memory_limit: -1

    Damit sollte es eigentlich keine Begrenzung geben.

    php_version: 8.0.19 64bit

    Wenn du die Möglichkeit hast, auf PHP 7.4.x umzustellen, solltest du das mal versuchen. Einige Plugins kommen mit PHP 8.x noch nicht zurecht und machen Probleme.

    Thread-Ersteller eugps

    (@eugps)

    Vielen Dank für die Antwort, @bscu.

    Ich habe die Umstellung auf PHP 7.4 vorgenommen, jedoch leider keine Veränderung 🙁

    Thread-Ersteller eugps

    (@eugps)

    Das Problem scheint nun behoben zu sein.
    Ich habe Elementor Pro deaktiviert und schwupps…konnte ich wieder Änderungen speichern.

    Das hatte ich vorher nicht probiert, da ich die Pro-Version eigentlich benötige.

    Vielen Dank für eure Hilfe!

    Hallo,
    dann solltest du dich an den Support von Elementor wenden, wenn du nicht auf Elementor Pro verzichten möchtest.
    Hier können wir dir wohl nicht mehr weiterhelfen.
    Kannst du das Thema dann bitte als gelöst markieren, wenn das Problem damit für dich behoben ist:
    Gelöst
    Die Option findest du rechts in der Sidebar. Danke.

    Viele Grüße
    Hans-Gerd

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)