Support » Allgemeine Fragen » Kritischer Fehler – Login in das Backend nicht möglich

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Hallo,
    laut der Info auf dieser Seite ist das Zertifikat abgelaufen und muss neu verlängert werden. Das ist aber eine Sache, die Du mit dem Hoster abklären musst.
    An sich sollte es möglich sein, das Zertifikat über den Kundenbereich des Hosters zu verlängern.

    Viele Grüße
    Hans-Gerd

    Moderator Michi91

    (@michi91)

    wp-config debug aktiviert

    aktiviere dazu mal debug Display, dann muss eigentlich was kommen…

    Ausserdem schau mal nach dem einloggen ins Protokoll. Zu dem Zeitpunkt muss sich ein Error Eintrag finden

    Thread-Starter Patric

    (@patric70)

    hallo,

    das SSL-Zertifikat habe ich jetzt erneuert – das war auch mein erster Gedanke, das es evtl. daran liegt – ich konnte gestern kein neues erstellen, da ich das ja normal über das SSL-Plugin erstelle, an das ich aber derzeit nicht rankomme – ich habe aber vorhin eine andere Möglichkeit gefunden und konnte nun ein neues erstellen.

    Leider kommt aber immer noch die Fehlermeldung, wenn ich mich in den Admin-Bereich einloggen will – zumindest kann ich jetzt aber ausschließen, das es an dem abgleaufenen SSL-Zertifikat liegt.

    ich habe jetzt nochmal den debug-Modus in der wp-config aktiviert, und zwar wie folgt :

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', true );
    define( 'WP_DEBUG_LOG', true );

    das hatte ich zwar schon gestern probiert, evtl. habe ich es aber nicht lange genug laufen lassen – ich lass das jetzt einfach mal ein Tag lang drin, evtl. wird mir ja doch was angezeigt bzw. erstellt sich eine log-datei.

    Ich schaue jetzt nochmal, ob im Error-Log vom Provider etwas protokolliert wird, wenn ich mich einlogge – hierfür habe ich mir meine IP und Uhrzeit notiert.

    Das Problem ist halt, das ich derezit keine Hinweise habe, woran das liegen kann, da ich eben keine konkrete Fehlermeldung erhalte.

    Kann mir jemand sagen, in welcher Datei ich die email-Adresse für die Fehlermeldung finde, die ja angeblich verschickt wird, ich aber nicht erhalten habe ? Evtl. fehlt irgendwo diesbzgl. ein Eintrag oder Aktivierung, das wäre sicherlich hilfreich, wenn ich die Fehlermeldung so doch noch erhalten würde.

    Danke & Gruß

    • Diese Antwort wurde geändert vor 5 Monaten, 3 Wochen von Patric.

    Kann mir jemand sagen, in welcher Datei ich die email-Adresse für die Fehlermeldung finde

    Die steht nicht in einer Datei, sondern in der Datenbank. Zu finden ist das in der Tabelle <prefix>_options in der Spalte option_name und dem Wert admin_email

    Thread-Starter Patric

    (@patric70)

    hallo nochmal,

    @bscu – ja, eigentlich logisch, habe den Eintrag gefunden 🙂

    ich habe jetzt nochmal alles, der übersichtshalber, kurz zusammengefaßt :

    • kein Login / Zugang ins Backend / Adminbereich seit dem 01.01.24 möglich (wp-admin)
    • Fehlermeldung erscheint offenbar erst seit 01.01.24 (kurz, nachdem das SSL-Zertifikat abgelaufen ist)
    • SSL Zertifikat am 02.01.24 erneuert – Fehlermeldung erscheint weiterhin
    • keine Neuregistrierung für User möglich (es erscheint dabei „Ungültige Anmeldedaten“)
    • Login im Front-End funktioiniert für bereits registrierte User
    • WP email-Versand funktioniert und emails kommen bei mir an (z.B. von plugin updates etc.)
    • trotz aktiviertem debug keine Fehlermeldung im Front-End, bei kritischer Fehleranzeige oder im debug-log (Ausnahme vom plugin WP-Statistik)
    • es wird keine email, wie angezeigt, für weitere Anweisung an die Admin-email versendet
    • WP Admin-email ist korrekt hinterlegt und aktiv (in Datenbank geprüft, Zeile admin_email)
    • alle plugins und Themes deaktiviert + standard htacess ohne SSL-Einträge etc. getestet – Fehlermeldung erscheint trotzdem
    • Front-End funktioniert einwandfrei, inkl. aller plugins, Darstellungen, Chat etc.

    Auszug aus debug-log (seit gestern aktiviert) :

    [03-Jan-2024 04:27:00 UTC] WP Statistics Error: The address 103.152.84.1 is not in the database.
    [03-Jan-2024 04:27:03 UTC] WP Statistics Error: The address 103.152.84.1 is not in the database.
    [03-Jan-2024 04:28:06 UTC] WP Statistics Error: The address 103.152.84.1 is not in the database.
    [03-Jan-2024 04:28:25 UTC] WP Statistics Error: The address 103.152.84.1 is not in the database.
    [03-Jan-2024 04:28:25 UTC] WP Statistics Error: The address 103.152.84.1 is not in the database.
    [03-Jan-2024 06:40:30 UTC] WP Statistics Error: The address 103.151.119.18 is not in the database.
    [03-Jan-2024 06:40:30 UTC] WP Statistics Error: The address 103.151.119.18 is not in the database.
    [03-Jan-2024 06:40:33 UTC] WP Statistics Error: The address 103.151.119.18 is not in the database.
    [03-Jan-2024 08:11:44 UTC] WP Statistics Error: The address 103.170.25.255 is not in the database.
    [03-Jan-2024 09:00:20 UTC] WP Statistics Error: The address 103.152.84.1 is not in the database.
    [03-Jan-2024 09:01:07 UTC] WP Statistics Error: The address 103.152.84.1 is not in the database.
    [03-Jan-2024 09:01:58 UTC] WP Statistics Error: The address 103.152.84.1 is not in the database.
    [03-Jan-2024 09:02:12 UTC] WP Statistics Error: The address 103.152.84.1 is not in the database.
    [03-Jan-2024 09:02:43 UTC] WP Statistics Error: The address 103.152.84.1 is not in the database.
    [03-Jan-2024 09:03:00 UTC] WP Statistics Error: The address 103.152.84.1 is not in the database.
    [03-Jan-2024 09:03:10 UTC] WP Statistics Error: The address 103.152.84.1 is not in the database.
    [03-Jan-2024 10:25:32 UTC] WP Statistics Error: The address 2001:df7:480:4157:ed34:dd8b:456d:4193 is not in the database.
    [03-Jan-2024 10:46:11 UTC] WP Statistics Error: The address 103.187.243.139 is not in the database.
    [03-Jan-2024 10:46:11 UTC] WP Statistics Error: The address 103.187.243.139 is not in the database.
    [03-Jan-2024 10:46:21 UTC] WP Statistics Error: The address 103.187.243.139 is not in the database.
    [03-Jan-2024 10:46:24 UTC] WP Statistics Error: The address 103.187.243.139 is not in the database.
    [03-Jan-2024 10:49:01 UTC] WP Statistics Error: The address 103.187.243.139 is not in the database.
    [03-Jan-2024 14:04:07 UTC] WP Statistics Error: The address 190.106.228.43 is not in the database.

    aus meiner Sicht nicht hilfreich – das hat nur was mit dem installierten WP-Statisik-Plugin zu tun.

    In der wp-config habe ich noch einen Eintrag entdeckt, von dem ich nicht weiss, wofür er gut ist und bei meinen Tests auch noch nicht entfernt habe.

    Der Eintrag stammt von dem plugin „Really Simple SSL“, welches das SSL auf meiner Seite managed.

    Den Eintrag hat das plugin automatisch in die wp-config eingefügt, steht ganz oben und lautet :

    //Begin Really Simple SSL session cookie settings
    @ini_set('session.cookie_httponly', true);
    @ini_set('session.cookie_secure', true);
    @ini_set('session.use_only_cookies', true);
    //END Really Simple SSL

    bedeuten die Einträge, das von dem plugin irgendwelche cookies mit cache-Dateien etc. angelegt wurden ? kann man diese evtl. mal löschen bzw. leeren ?

    Irgendwas sagt mir, das das Login-Problem bzw. Weiterleitung in den Adminbereich etwas mit dem SSL / plugin zu tun haben könnte…der Fehler tratt ja erst in Verbindung mit dem abgelaufenen SSL-Zertifkats auf.

    Oder hat jemand sonst noch eine Idee, was den Zugang / Weiterleitung in den Admin-Bereich verhindert könnte ?

    Danke & Grüße

    Was die drei Einträge bedeuten, kannst du hier nachlesen: https://www.php.net/manual/de/session.security.ini.php
    Ich würde diese Einträge mit // am Anfang der Zeile erst mal auskommentieren und dann sehen, was passiert. Solange das SSL-Zertifikat nicht richtig auf dem Server installiert ist, wirst du das Problem kaum lösen können. Also wie @hage schon geschrieben hat:

    Das ist aber eine Sache, die Du mit dem Hoster abklären musst.

    Thread-Starter Patric

    (@patric70)

    das mit den SSL-Einträgen in der wp-config werde ich noch probieren, danke.

    bzgl. Zertifikat : wie erkennt man den bitte, ob ein Zertifikat richtig oder falsch auf dem Server installiert ist ?

    Ich habe mir das Zertifikat über den Browser anzeigen lassen, das ist aus meiner Sicht, alles ok.

    Ich erstelle mir schon seit Jahren die Zertifikate mit Lets Encrypt, das habe ich bestimmt schon 20x so gemacht, hat immer problemlos funktioniert. Ich nutze die Domain seit ca. 18 Jahren bei dem gleichen Provider (Host Europe), da kann man das Zertifikat einfach hochladen, hat bis dato immer geklappt.

    Gruß

    Hallo,
    in meiner Antwort hatte ich dazu einen Link gepostet.

    Aktuell scheint das Zertifikat aber jetzt ok zu sein.

    Viele Grüße
    Hans-Gerd

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)