Support » Allgemeine Fragen » Kritischer Fehler mit Theme OceanWP

  • Gelöst oasisnamibia

    (@oasisnamibia)


    Hallo zusammen,
    ich nutze für meine 3 Websiten das Theme OceanWP – und alle 3 sind nach und nach mit dem kritischen Fehler ausgefallen. Leider kann ich daraus nicht lesen, was genau der Fehler ist. Vielleicht könnt ihr mir weiterhelfen?
    Hoffnungsvolle Grüße
    Tine

    *************
    WordPress-Version 5.9.3
    Aktives Theme: OceanWP (Version 3.2.1)
    Aktuelles Plugin: (Version )
    PHP-Version 7.2.34

    Fehler-Details
    ==============
    Ein Fehler vom Typ E_PARSE wurde in der Zeile 349 der Datei
    /home/pl22697/websites/tago-mago.de/wp-content/themes/oceanwp/inc/template-helpers.php
    verursacht. Fehlermeldung: syntax error, unexpected ‚)‘

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Hallo,
    stelle doch mal bitte im Kundenbereich beim Hoster auf PHP 7.4.x um. Vielleicht ist das Problem dann schon behoben.

    Wenn du dich noch im Dashboard anmelden kannst: Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Viele Grüße
    Hans-Gerd

    Thread-Ersteller oasisnamibia

    (@oasisnamibia)

    Hallo Hans-Gerd,

    vielen Dank für deine schnelle Antwort!
    Für die anderen beiden Websiten konnte ich den Fehler mit dem PHP-Upgrade beheben. Auf Tago-Mago komme ich jetzt nicht mehr drauf, er meldet mir aber auch keinen Fehler mehr sondern sagt „503 Service Unavailable“
    Auf das Backend habe ich über WP jetzt keinen Zugriff mehr…

    Viele Grüße
    Christine

    Hallo,
    hilfreich könnte auch eine neue .htaccess sein:

    • verbinde dich mit deinem Server über FTP
    • suche die .htaccess-Datei in deinem Stammordner
    • lade eine Kopie der Datei auf deinen Computer (als Sicherung)
    • lösche die .htaccess-Datei von deinem Server, nachdem du eine Sicherungskopie auf deinem lokalen Computer hast.

    Um WordPress zu zwingen, eine neue, saubere .htaccess-Datei zu erzeugen:

    • gehe zu den Einstellungen > Permalinks in deinem WordPress Dashboard
    • unten auf der Seite klicken: auf Änderungen speichern (du musst keine Änderungen vornehmen – klicke einfach auf die Schaltfläche).

    Der Error 500 kann leider sehr viele Ursachen haben. In dem folgenden Beitrag findest du einige Lösungsansätze.

    Viele Grüße
    Hans-Gerd

    Die HTTP Error-Codes „500 – Internal Server Error“ und „503 – Service Unavailable“ unterscheiden sich darin, dass beim 500 der Server aufgrund einer Fehlkonfiguration nicht antworten kann, während beim Fehler 503 der Server zwar die Anfrage bearbeitet, aber nicht die Website ausliefern kann. Bei Strato wird der 503 z.B. durch den „Gästebuch-Spamfilter“ ausgelöst, der mit den Redirects von WordPress nicht zurecht kommt.

    Interessant wären die Fehlermeldungen im Error-Log des Webservers, die beschreiben, woran sich der Webserver verschluckt.

    Hallo @oasisnamibia
    die Website scheint wieder korrekt zu funktionieren. Es wäre schön, wenn du kurz beschreibst, wie du das Problem beheben konntest.
    @pixolin: ich hatte eben einen Error 500 – daher der Hinweis

    Kannst du das Thema dann bitte als gelöst markieren, wenn das Problem damit für dich behoben ist:
    Gelöst
    Die Option findest du rechts in der Sidebar. Danke.

    Viele Grüße
    Hans-Gerd

    Thread-Ersteller oasisnamibia

    (@oasisnamibia)

    Vielen Dank für die tolle Hilfe!
    Ich habe die Plugins alle deaktiviert und Stück für Stück wieder aktiviert. Ich denke, es lag daran. Jetzt sollte wieder alles laufen.
    Viele Grüße
    Christine

    Hallo,
    super – freut mich. Danke für die Rückmeldung und “Gelöst”-Markieren.
    vielleicht kannst du uns noch verraten, welches Plugin Probleme verursacht hat.

    Viele Grüße
    Hans-Gerd

    Thread-Ersteller oasisnamibia

    (@oasisnamibia)

    Hallo,
    leider kann ich nicht genau sagen, welches Plugin es verursacht hat. Wahrscheinlich eins von denen, die ich ohnehin nicht wirklich nutze 😀

    Viele Grüße
    Christine

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)