Support » Allgemeine Fragen » Kunden Zugang zur Website gewähren trotz Maintenance Mode

  • Gelöst wildner2010

    (@wildner2010)


    Hallo,

    kann mir jemand einen praktikablen Workflow nennen, wie man Kunden den aktuellen Stand der zu erstellenden Website zeigen kann, obwohl sich die Website selber noch im Maintenance Mode befindet.

    Ich habe es mit eigens angelegten Benutzern versucht aber die können sich trotz entsprechender Einstellungen im „Coming Soon“ Plugin nicht ins Backend einloggen, um sich die Website anzeigen zu lassen.

    Vielleicht gibt es ja auch eine viel praktischere Lösung für dieses Anliegen.

    Ich denke, dass es grundsätzlich ja üblich ist, dass man Personen (Kunde/Texter/Fotograf/etc.) eine Website die sich gerade im Aufbau befindet (vorab) zeigen möchten.

    Aus diversen Gründen muss die Website aber derzeit noch über den Maintenance Mode blockiert werden.

    Ich würde mich sehr über den ein oder anderen Tipp freuen!

    Beste Grüße
    Wildner

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Hallo,
    ich verwende zu diesem Zweck gerne das Plugin Simple Maintenance. Wenn du das Plugin installiert und aktiviert hast, können sich die Benutzer im Dashboard anmelden und sich dann über „Zur Website“ die Website ansehen.

    Hier ein Screenshot dazu (bei Klick auf das Bild, wird das Bild vergrößert):

    Website

    Viele Grüße
    Hans-Gerd

    Das Plugin Maintenance
    bietet ebenfalls ein Login-Formular auf der Hinweisseite (zunächst nur als Schloss-Icon, siehe Screenshot), dass die Website zur Zeit im Wartungsmodus ist. Dann noch einen User (Abonnent) anlegen und schon kann sich der/die Kunde/Kundin die Website nach Anmeldung ansehen.

    Screenshot Einstellungen
    (zum Vergrößern anklicken)

    Thread-Starter wildner2010

    (@wildner2010)

    Hallo @hage und @pixolin!

    Ich danke euch vielmals für eure Infos und Empfehlungen!

    Beste Grüße
    Wildner

    Hallo,
    danke für die Rückmeldung und „Gelöst“-Markieren.
    Schön für Mitleser wäre noch, wenn du kurz beschreibst, wie du das jetzt gelöst hast.

    Viele Grüße
    Hans-Gerd

    Thread-Starter wildner2010

    (@wildner2010)

    Hallo Hans-Gerd,

    gerne.

    Nach euren Empfehlungen war das Plugin „Maintenance“ für mich die ideale Lösung.

    @pixolin
    Allerdings werden bei mir sowohl das Logo und Hintergrundbild nicht angezeigt.
    Und das obwohl ich beides bei den Einstellungen entsprechend hochgeladen habe.

    Hättet du hier evtl. noch einen Tipp für mich?

    Beste Grüße
    Wildner

    Hallo,
    danke für die Rückmeldung.
    Hast du das denn auch unter Design hochgeladen und dann entsprechend mit Klick auf „Save Changes“ gespeichert?
    Viele Grüße
    Hans-Gerd

    Thread-Starter wildner2010

    (@wildner2010)

    Hallo,

    ja, alles gespeichert.

    Ich habe gerade noch einen Hinweis von dem Plugin-Support erhalten aber auch das war letztlich nicht der Grund.

    Alexandru Tapuleasa wrote:
    
    <blockquote>Hi,
    
    It looks like you have a lazyload script enabled but it's not working for some reason. The logo seems to be correctly set to https://wippenbeck-holzbau.de/wp-content/uploads/2022/07/Wippenbeck-Holzbau-Logo.png but you should try disabling the lazyload and see if that fixes it.

    Viele Grüße
    Wildner

    Thread-Starter wildner2010

    (@wildner2010)

    Hallo nochmals.

    Stopp! Nachdem ich den Website-Cache geleert habe, funktioniert es durch das Deaktivieren des Vorausladens der Bilder!

    Jetzt frage ich mich nur noch, wie ich die Overlay-Ebene, die das Weiß abdunkelt, wegbekomme.

    Viele Grüße
    Wildner

    Hallo,
    falls du noch ein Cache-Plugin akviviert haben solltest, wäre es auf jeden Fall wichtig, wenn du dieses Plugin deaktivierst.
    Vielleicht ist das ein Problem mit dem Cache des Browsers. Hast du dann auch mal den Browsercache geleert und/oder einen anderen Browser zum Testen genutzt und/oder das im Inkognito-Modus z. B. von Chrome getestet? (bei Chrome oben die drei senkrechten Punkte und dann „Neues Inkognito-Fenster“) und auch mal die Cookies löschen.

    Viele Grüße
    Hans-Gerd

    Hallo,
    du hast wohl offensichtlich immer noch Autoptimize aktiviert. Das Plugin solltest du wie jedes Cache-Plugin während der Entwicklung auf jeden Fall zumindest deaktivieren.

    Viele Grüße
    Hans-Gerd

    Thread-Starter wildner2010

    (@wildner2010)

    Servus Hans-Gerd,

    exakt, ich habe es oben schon geschrieben.
    Daran lag es.

    Beste Grüße
    Wildner

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)