Support » Installation » langsames und hakeliges Scrollen nach Updateproblemen

  • Gelöst WoKal

    (@wokal)


    Hi!

    Gestern wollte ich wie jeden Monat Theme (OceanWP plus Elementor Pro) und Plugins aktualisieren. Aber diesmal ist das Updaten der Plugins fehlgeschlagen, was zur Folge hatte, dass die Website nicht mehr erreichbar war und WordPress die Meldung anzeigte: „Fatal Error: Uncaught Error … Es gab einen kritischen Fehler auf deiner Website. Bitte überprüfe den Posteingang deiner Website-Administrator-E-Mail-Adresse für weitere Anweisungen.“. Am Ende dieses Posts habe ich die vollständige Meldung eingefügt.

    Ich konnte mich dann auch nicht mehr in das WordPress-Backend einloggen.

    Dann habe ich die Plugins per FTP/Filezilla deaktiviert, damit ich wieder ins Backend reinkomme.
    Danach habe ich die Website mit dem letzten Backup (das ich vor dem Update-Vorgang gemacht habe) über das Plugin „updraftplus“ zurückgeholt. Danach war die Website wieder erreichbar.
    Dann habe ich einen erneuten Versuch gestartet, das Theme und die Plugins upzudaten – und diesmal war das Updaten erfolgreich!

    So weit, ist es gut.

    Jetzt habe ich folgendes Problem:
    Nach diesem ganzen Hickhack hat sich das Scrollverhalten der Website verändert. Und zwar ist das Scrollen per Mausrad jetzt auffällig langsam, hakelig und ruppig geworden. Je weiter runter man scrollt, umso hakeliger. Nach oben scrollen erscheint noch langsamer und ruppiger. Einfach mal auf der o.g. Seite ausprobieren.
    Vor dem misslungenen Updating war das Scrollen schön flüssig und schnell.

    Der Elementor-Support hat mir zu dem Sachverhalt geantwortet, dass der Fehler vom Plugin „Premium addons for Elementor“ käme, weil das kein von Elementor erstelltes Plugin sei und dieses Probleme mit WordPress verursachen würde. Elementor könne jedenfalls nicht helfen und hat empfohlen sich an WordPress zu wenden, was ich hiermit tue. Ausserdem sollte ich das Plugin deaktivieren und schauen, ob es dann funktiert. War aber keine Besserung erkennbar.

    Hoffentlich kann mir jemand helfen oder Tipps geben, weil das ein deutlich wahrnehmbarer Performanceverlust ist.

    Vielen Dank für Eure Hilfe.
    Ciao
    Wolfgang

    Fehlermeldung WordPress (die dort auch erwähnte Email habe ich übrigens nicht erhalten):

    Fatal error: Uncaught Error: Class 'WPML_Elementor_Module_With_Items' not found in /kunden/578992_93055/webseiten/keralock.de/wp-content/plugins/premium-addons-for-elementor/includes/compatibility/widgets/carousel.php:21 Stack trace: #0 /kunden/578992_93055/webseiten/keralock.de/wp-content/plugins/premium-addons-for-elementor/includes/compatibility/premium-addons-wpml.php(74): include_once() #1 /kunden/578992_93055/webseiten/keralock.de/wp-content/plugins/premium-addons-for-elementor/includes/compatibility/premium-addons-wpml.php(37): PremiumAddons\Includes\Compatibility\Premium_Addons_Wpml->includes() #2 /kunden/578992_93055/webseiten/keralock.de/wp-content/plugins/premium-addons-for-elementor/includes/compatibility/premium-addons-wpml.php(632): PremiumAddons\Includes\Compatibility\Premium_Addons_Wpml->__construct() #3 /kunden/578992_93055/webseiten/keralock.de/wp-content/plugins/premium-addons-for-elementor/includes/class-pa-core.php(200): PremiumAddons\Includes\Compatibility\Premium_Addons_Wpml::get_instance() #4 /kund in /kunden/578992_93055/webseiten/keralock.de/wp-content/plugins/premium-addons-for-elementor/includes/compatibility/widgets/carousel.php on line 21
    Es gab einen kritischen Fehler auf deiner Website. Bitte überprüfe den Posteingang deiner Website-Administrator-E-Mail-Adresse für weitere Anweisungen.
    Erfahre mehr über die Problembehandlung in WordPress.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Hallo,
    das ist schwierig für uns, weil wir dir bei gekauften Plugins (hier: Elementor Pro) so gut wie gar nicht helfen können, weil sie uns nicht zur Verfügung stehen. Wir müssten sonst bei jeder Frage erst einmal das Plugin kaufen, uns dort einarbeiten und dann kostenlos den Support anbieten, für den du beim Kauf eigentlich bezahlt hast. Lies bitte auch mal in der FAQ (B 5.) zu diesem Thema.
    Ich setze Elementor nicht ein, sondern arbeite ausschließlich mit dem Block-Editor (Gutenberg).
    Bezogen auf das Plugin Premium addons for Elementor könntest du dich auch direkt an den Support wenden, weil da sicher Erfahrungswerte vorliegen.
    Es könnte evtl. auch sein, dass das Problem durch einen Konflikt zwischen Plugins verursacht wird.
    Du kannst ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty oder Twenty Twenty-One aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung eines Plugins, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise ein Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass Besucher deine Webseite mit allen Infos und plugins sehen, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu bitte auch mal die Informationen in dem Beitrag zu Health Check durch.
    Außerdem findest du unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller WoKal

    (@wokal)

    Hi,
    Danke für die Rückmeldung.

    Habe jetzt mal auch beim Ersteller des Premium addons for Elementor angefragt.

    Irgendwie werde ich den Verdacht nicht los, dass es auch an WPML liegen könnte, weil beim ersten Versuch die Plugins zu aktualisieren (welcher dann misslungenen ist) – es waren glaube ich 14 Plugins, die es abzuarbeiten galt – die Aktualisierungsseite genau bei den letzten 4 WPML-Plugins Updates eingefroren ist. Werde dort mal nachfragen, ob die Ideen haben.

    Unten mein Website-Bericht.

    Danke für die Mühe, ich weiß das sehr zu schätzen.
    Viele Grüße
    Wolfgang

    
    ### wp-core ###
    
    version: 5.8.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /kunden/578992_93055/webseiten/keralock.de
    wordpress_size: 275,98 MB (289390468 bytes)
    uploads_path: /kunden/578992_93055/webseiten/keralock.de/wp-content/uploads
    uploads_size: 31,55 MB (33083380 bytes)
    themes_path: /kunden/578992_93055/webseiten/keralock.de/wp-content/themes
    themes_size: 18,89 MB (19811327 bytes)
    plugins_path: /kunden/578992_93055/webseiten/keralock.de/wp-content/plugins
    plugins_size: 202,45 MB (212282347 bytes)
    database_size: 82,59 MB (86599600 bytes)
    total_size: 611,46 MB (641167122 bytes)
    
    ### wp-active-theme ###
    
    name: OceanWP Child (oceanwp-child-theme-master)
    version: 1.0
    author: Nick
    author_website: https://oceanwp.org/
    parent_theme: OceanWP (oceanwp)
    theme_features: core-block-patterns, widgets-block-editor, align-wide, wp-block-styles, responsive-embeds, editor-styles, editor-style, menus, post-formats, title-tag, automatic-feed-links, post-thumbnails, custom-header, custom-logo, html5, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, widgets
    theme_path: /kunden/578992_93055/webseiten/keralock.de/wp-content/themes/oceanwp-child-theme-master
    auto_update: Deaktiviert
    
    ### wp-parent-theme ###
    
    name: OceanWP (oceanwp)
    version: 3.0.7
    author: Nick
    author_website: https://oceanwp.org/about-me/
    theme_path: /kunden/578992_93055/webseiten/keralock.de/wp-content/themes/oceanwp
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-One: version: 1.4, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (19) ###
    
    All in One SEO: version: 4.1.4.4, author: All in One SEO Team, Automatische Aktualisierungen deaktiviert
    All In One WP Security: version: 4.4.9, author: Tips and Tricks HQ, Peter Petreski, Ruhul, Ivy, Automatische Aktualisierungen deaktiviert
    Complianz | GDPR/CCPA Cookie Consent: version: 5.4.0, author: Really Simple Plugins, Automatische Aktualisierungen deaktiviert
    Elementor: version: 3.4.4, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    Elementor Pro: version: 3.4.1, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    ElementsKit Lite: version: 2.3.7, author: Wpmet, Automatische Aktualisierungen deaktiviert
    Insert Headers and Footers: version: 1.6.0, author: WPBeginner, Automatische Aktualisierungen deaktiviert
    Limit Login Attempts Reloaded: version: 2.23.2, author: Limit Login Attempts Reloaded, Automatische Aktualisierungen deaktiviert
    Livemesh Addons for Elementor: version: 6.14, author: Livemesh, Automatische Aktualisierungen deaktiviert
    Ocean Extra: version: 1.8.1, author: OceanWP, Automatische Aktualisierungen deaktiviert
    Premium Addons for Elementor: version: 4.5.6, author: Leap13, Automatische Aktualisierungen deaktiviert
    Toolset Types: version: 3.4.14, author: OnTheGoSystems, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.16.61, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    WP Mail SMTP: version: 3.1.0, author: WPForms, Automatische Aktualisierungen deaktiviert
    WPML Media: version: 2.6.5, author: OnTheGoSystems, Automatische Aktualisierungen deaktiviert
    WPML Multilingual CMS: version: 4.4.12, author: OnTheGoSystems, Automatische Aktualisierungen deaktiviert
    WPML Sticky Links: version: 1.5.4, author: OnTheGoSystems, Automatische Aktualisierungen deaktiviert
    WPML String Translation: version: 3.1.10, author: OnTheGoSystems, Automatische Aktualisierungen deaktiviert
    WPML Translation Management: version: 2.10.8, author: OnTheGoSystems, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (2) ###
    
    CMP - Coming Soon & Maintenance Plugin: version: 4.0.16, author: NiteoThemes, Automatische Aktualisierungen deaktiviert
    Ocean Social Sharing: version: 2.0.0, author: OceanWP, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 8M
    upload_max_filesize: 8M
    max_effective_size: 8 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 3.18.114-pvops-xen-x64 x86_64
    httpd_software: Apache
    php_version: 7.3.10
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 300
    memory_limit: 256M
    max_input_time: -1
    upload_max_filesize: 8M
    php_post_max_size: 8M
    curl_version: 7.55.1 OpenSSL/1.0.2l
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.19-67.0-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /kunden/578992_93055/webseiten/keralock.de/wp-content
    WP_PLUGIN_DIR: /kunden/578992_93055/webseiten/keralock.de/wp-content/plugins
    WP_MEMORY_LIMIT: 256M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### aioseo (1) ###
    
    noindexed: Suchseite
    
    ### wp_mail_smtp ###
    
    version: 3.1.0
    license_key_type: lite
    debug: Keine Debug-Hinweise gefunden.
    db_tables: wp_Fer7_8yK_wpmailsmtp_tasks_meta, wp_Fer7_8yK_wpmailsmtp_debug_events
    lite_install_date: Jun 2, 2021 @ 2:39pm
    
    
    Moderator Bego Mario Garde

    (@pixolin)

    Irgendwie werde ich den Verdacht nicht los, dass es auch an WPML liegen könnte

    Das lässt sich doch ganz einfach eingrenzen:
    Plugin deativieren und prüfen, ob das Problem weiterhin besteht.

    Ich kann aktuell im Browser kein „hakeliges Scrollen“ reproduzieren, empfinde aber die Animationseffekte als anstrengend für den Betrachter.

    Thread-Ersteller WoKal

    (@wokal)

    der Support vom Premium addons for Elementor sagt …
    „I have checked your page and I can see the issue, but I’m not sure what can cause such a thing.“. Er empfiehlt ebenfalls die Themes und Plugins zu deaktivieren und sukzessive zuzuschalten.

    Moderator Hans-Gerd Gerhards

    (@hage)

    dann wäre es schön, wenn du hier bei Gelegenheit mitteilst, ob das Problem gefunden wurde.
    Ich konnte zumindest nachvollziehen, dass das Scrollen mit dem Mausrad teilweise enorm langsam verlief.

    Thread-Ersteller WoKal

    (@wokal)

    WPML hat jetzt auch geantwortet und kann keinen Fehler bei WPML feststellen und dass im Log ersichtlich sei, dass der Fehler eindeutig vom Premium addon for Elementor-Plugin käme, welches eine eigene für WPML erstellte Code Klasse für die Kompatibilität nicht laden bzw. finden konnte.
    Der Support sagt weiter, dass möglicherweise beim damaligen Update WPML temporär deaktiviert wurde und das besagte Plugin den Fehler dadurch ausgegeben hat, weil somit die Klasse nicht gefunden wurde. Er erwähnte auch, das Plugin wäre zuletzt sogar von WPML mit Version 4.4.7 getestet und für die Nutzung mit WPML zertifiziert worden. WPML hat klar gesagt, dass der Fehler in deren Code ausgelöst wird.

    Ich habe den Ball jetzt nochmal an die Autoren des Premium addons-Plugins zurück gespielt.

    Was mich irritiert, dass das auffällige Scrollverhalten bestehen bleibt, auch wenn das besagte Plugin deaktiviert ist.

    Daher werde ich im nächsten Schritt mal alle vorhandenen Plugins deaktivieren und einzeln zuschalten um zu sehen, ob es vllt doch an einem anderen Plugin liegt. Und wenns daran nicht liegt, dann bleibt ja nur noch das Theme, der Pagebuilder und/oder WP

    Ich halte auf dem Laufenden …

    Thread-Ersteller WoKal

    (@wokal)

    der Vollständigkeit halber um das Thema abzuschließen.

    Aufgrund der Rückmeldungen von euch, dem Support des „verdächtigen“ Plugins „Premium addons for Elementor“ und WPML habe ich jetzt alle Plugins deaktiviert, außer ein Plugin vom verwendeten Theme OceanWP, Elementor und Elementor Pro. Ergebnis, keine Änderung, gleiches Scroll-Problem.

    Das war für mich Indiz, dass die Plugins doch nicht Verursacher der „Störung“ sind, sondern doch das Theme, Elementor oder WordPress. Vor diesem Hintergrund habe ich nochmal den Elementor-Support ins Boot geholt, welcher relativ ratlos war.
    Parallel dazu hatte ich nach dem oben erwähnten Backup (mit updraftPlus) sicherheitshalber nochmal die Permalinks gespeichert und den Cache gelöscht. Allerdings blieb das Phänomen weiter bestehen.

    By the way. Interessanterweise war mir aufgefallen, dass dieses ruckelnde, stockende, verzögernde Scrollverhalten nur auf der Homepage auftrat, nicht aber auf den Unterseiten. Dort funktionierte das Scrollen komischerweise einwandfrei.
    Ein weiteres Phänomen: Wenn man etwas wartete und das Mausrad nicht bewegte, ging das Scrollen auf der Startseite plötzlich einwandfrei, aber wenn man dann mit dem Mausrad schnell nach unten und oben scrollte, wurde das Scrollen wieder langsam und zäh. Wartete man dann wieder etwas, war das Scrollverhalten wieder in Ordnung.

    Lange Rede, kurzer Sinn. Heute morgen wollte ich dann, als weiterer verzweifelter Versuch, noch die CSS-Files regenerieren (ein Tool unter Elementor), mir vorher aber nochmal das Scrollverhalten ansehen.
    Und was soll ich sagen, auf einmal ging das Scrollen wieder einwandfrei. Ich habe keine Idee, warum das jetzt auf einmal funktioniert und woran es hing. Vielleicht hat Elementor irgendwas gemacht, was sie mir nicht mitgeteilt haben, weil an Wunderheilung glaube ich nicht … aber ist egal, Hauptsache, es funktioniert wieder.

    Euch vielen Dank für eure Mühe.

    Ciao
    Wolfgang

    Moderator Bego Mario Garde

    (@pixolin)

    Danke für deine Rückmeldung.

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)