Support » Allgemeine Fragen » Layout 'zerschossen'. Wieder mal!

  • Gelöst Britta Bauer

    (@britta-bauer)


    Hallo zusammen,

    manchmal ist WordPress echt zum Auswachsen: Ich komme seit Ostersamstag heute wieder auf meine Seite und sehe, dass das gesamte Layout ‚zerschossen‘ ist.
    Schriften stimmen plötzlich nicht mehr, Menü ist nicht mehr da, Circle Icons fehlen. Ich habe keine Plugins neu installiert, es gab keine weiteren Aktualisierungen, die ich hätte durchführen sollen – und trotzdem, nichts ist so, wie es vor ein paar Tagen noch ausgesehen hat.
    http://www.bodyandsoap-studio.com

    Habt Ihr eine Idee, wie ich vorgehen kann, ohne auf eine Sicherungskopie zurückgreifen zu müssen? Es nervt, weil das in abgewandelter Form ziemlich häufig passiert. Irgendwas ist immer. Und ich bin noch nicht WordPress fit genug, um immer gleich zu wissen, was jetzt wieder falsch gelaufen ist. Ich hab ja nicht mal an der Seite gearbeitet.

    Wie schützt Ihr denn Eure Seite vor was auch immer da passiert und worauf man offensichtlich so wenig Einfluss hat …

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Moderator Torsten Landsiedel

    (@zodiac1978)

    Hast du mal versucht alle Plugins zu deaktivieren?

    Gruß, Torsten

    Hallo Torsten,

    ja, das habe ich zuerst gemacht.

    Hat bitte jemand noch eine Idee?
    Ich verstehe das Problem einfach nicht und daher weiß ich auch nicht, wo ich ansetzen kann.
    Ganz vielen Dank.

    Anhand deiner Fehlerbeschreibung und einem Blick in die Developer Tools des Browsers kann ich zunächst nicht sagen, woran es liegt. Da hilft eigentlich nur, den Fehler so weit wie möglich einzugrenzen: Backup machen, danach alle Plugins deaktivieren, Standardtheme Twenty Twelve aktivieren, .htaccess vorübergehend umbenennen und die Permalinks auf „Einfach“ stellen. Danach dann ein Plugin zur Prüfung auf Malware installieren und ausführen.

    Hat der Test nichts ergeben und ist die Darstellung dann immer noch so chaotisch, musst du die WordPress-Dateien mit Ausnahme des Verzeichnisses wp-content löschen und aus einem frisch heruntergeladenen Dateipaket neu hochladen. Außerdem könntest du im Kundenmenü deines Webhoster prüfen, welche PHP-Version aktuell verwendet wird. Dazu lädst du eine Datei phpinfo.de mit folgendem Inhalt hoch:

    <?php phpinfo();

    Diese Datei rufst du im Browser auf und suchst dort dann nach „PHP Version“ – alles unter 5.6 ist unzureichend.

    Sieht die Website mit Twenty Twelve nicht schön, aber brauchbar aus, kannst du zuerst das Theme reaktivieren und dann nach und nach die Plugins. Auch die Permalinks sollten dann wieder umgestellt werden.

    Hallo Bego,

    vielen Dank! Na dann werd‘ ich mich da mal durchackern …

    Wäre es denn auch sinnvoll, auf die jetzige Version ein Plugin zur Prüfung von Malware zu installieren um zu sehen, ob es anschlägt, und wenn das negativ ist, direkt WP löschen und neu installieren?

    Ich habe ja auch eine Backup-Datei vom 4.3. über WPBackitup, jedoch die Lite Version, aber da kriege ich den manuellen Restore über MySQl nicht hin.
    Wenn alles nichts hilft, könnte ich die Vollversion kaufen und den Restore von Backitup über das Programm laufen lassen …

    Kurze Rückmeldung:
    Ich habe SiteOrigin, den Entwicklern von ‚Vantage‘ Theme, einen temporären Admin-Zugang gewährt, denn sie konnten sich den Fehler nicht erklären.

    Jetzt ist die Site wieder ok, sie sagen, das Theme war defekt und sie haben es neu aufgesetzt. Also konnte ich WP behalten und der Fehler lag beim Theme. wurde getauscht.

    Danke Euch!
    Britta

    Das sind dann doch mal gute Nachrichten.

    Ich würde ggf. noch die Zugangsdaten ändern – nicht, dass ich Bedenken beim Support von SiteOrigin habe. Es wäre einfach eine sinnvolle Sicherheitsmaßnahme.

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Das Thema „Layout 'zerschossen'. Wieder mal!“ ist für neue Antworten geschlossen.