Support » Allgemeine Fragen » Link zu Anhangseite klappt nur manchmal

  • Gelöst claireskreationen

    (@claireskreationen)


    Hallo!

    Bedauerlicherweise bin ich ein blutiger Anfanger und arbeite hier mit learning by doing. Ich bin Künstlerin und habe eine Seite für meine Bilder, die ich in Galerie gepostet habe. Sie sind mit einem Link zu Anhangseite zu vergrößern und kommentieren. Bis gestern hat das auch wunderbar geklappt. Jetzt lassen sich nur manche vergrößeren und bei den meisten erscheint: Diese Seite scheint nicht zu existieren.

    Ich habe gestern versucht die Kommentare auf der Seite vorne sichtbar zu machen. Es ist nicht gelungen, und ich weiß nicht, ob ich damit möglicherweise diesen Fehler ausgelöst habe.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • WordPress „vergisst“ durch die Installation oder Aktualisierung eines Plugins gelegentlich die eingestellten Permalinks. Das könnte eine Ursache für das beschriebene Problem sein. Um die Permalinks neu einzulesen, ruf bitte mal das Menü Einstellungen > Permalinks auf. Du brauchst hier nichts weiter zu machen, der Aufruf des Menüs reicht bereits. Lassen sich die Anhangseiten dann öffnen?

    Thread-Ersteller claireskreationen

    (@claireskreationen)

    Leider hat das nicht funktioniert.
    Trotzdem vielen Dank für den Tipp!
    WP hat es auch nicht bei jedem Bild „vergessen“. Manche Links funktionieren noch.
    Und auch wenn ich neue Bilder einstelle klappt es nicht!

    Schade. Naja, wäre auch zu einfach gewesen. Damit wir ein bisschen mehr über deine Website erfahren, geh bitte auf Werkzeuge > Website-Zustand > Bericht und warte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist. Klick dann auf den Button „Bericht in die Zwischenablage kopieren“. Den Bericht kannst du anschließend hier in einer neuen Antwort mit Strg-V (Mac: Cmd-V) unverändert einfügen.

    Thread-Ersteller claireskreationen

    (@claireskreationen)

    
    ### wp-core ###
    
    version: 5.7
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/web71/htdocs
    wordpress_size: 46,83 MB (49106218 bytes)
    uploads_path: /var/www/web71/htdocs/wp-content/uploads
    uploads_size: 1,93 GB (2070106760 bytes)
    themes_path: /var/www/web71/htdocs/wp-content/themes
    themes_size: 29,59 MB (31029257 bytes)
    plugins_path: /var/www/web71/htdocs/wp-content/plugins
    plugins_size: 38,53 MB (40397501 bytes)
    database_size: 21,80 MB (22855680 bytes)
    total_size: 2,06 GB (2213495416 bytes)
    
    ### wp-active-theme ###
    
    name: Astra (astra)
    version: 3.2.0
    author: Brainstorm Force
    author_website: https://wpastra.com/about/
    parent_theme: none
    theme_features: core-block-patterns, astra_hooks, align-wide, automatic-feed-links, title-tag, post-thumbnails, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, woocommerce, amp, widgets, menus
    theme_path: /var/www/web71/htdocs/wp-content/themes/astra
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (5) ###
    
    Transportex: version: 1.8.3, author: Themeansar, Automatische Aktualisierungen deaktiviert
    Twenty Nineteen: version: 2.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Seventeen: version: 2.6, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 1.7, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.2, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-mu-plugins (1) ###
    
    InfiniteWP - Client Loader: author: Revmakx, version: (undefined)
    
    ### wp-plugins-active (6) ###
    
    Advanced Editor Tools (previously TinyMCE Advanced): version: 5.6.0, author: Automattic, Automatische Aktualisierungen deaktiviert
    Elementor: version: 3.1.4, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    Elementor - Header, Footer & Blocks: version: 1.5.8, author: Brainstorm Force, Nikhil Chavan, Automatische Aktualisierungen aktiviert
    Head, Footer and Post Injections: version: 3.2.2, author: Stefano Lissa, Automatische Aktualisierungen aktiviert
    InfiniteWP - Client: version: 1.9.4.9, author: Revmakx, Automatische Aktualisierungen deaktiviert
    WP Statistics: version: 13.0.8, author: VeronaLabs, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-23 Q16 x86_64 20190101 https://imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 122 MB
    	imagick::RESOURCETYPE_DISK: 1073741824
    	imagick::RESOURCETYPE_FILE: 6144
    	imagick::RESOURCETYPE_MAP: 512 MB
    	imagick::RESOURCETYPE_MEMORY: 256 MB
    	imagick::RESOURCETYPE_THREAD: 8
    gd_version: 2.2.5
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.19.0-12-amd64 x86_64
    httpd_software: Apache
    php_version: 7.4.16 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 500
    memory_limit: 256M
    max_input_time: 500
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 7.64.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.27-MariaDB-0+deb10u1
    client_version: mysqlnd 7.4.16
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/web71/htdocs/wp-content
    WP_PLUGIN_DIR: /var/www/web71/htdocs/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Tut mir leid, da muss ich passen – im Website-Bericht steht auch nichts Auffälliges, was das Problem erklären würde.

    Du kannst mal ausprobieren, was sich ändert wenn du alle Plugins vorübergehend deaktivierst, um sie als Fehlerquelle auszuschließen. Aber mehr fällt mir dazu im Moment auch nicht ein.

    Noch ein Hinweis: unter „Heute neu!“ hast du direkt die Orginial-Bilder verlinkt, nicht die Anhangseiten. Vielleicht meinst du das mit „Jetzt lassen sich nur manche vergrößern“?

    Thread-Ersteller claireskreationen

    (@claireskreationen)

    Nein, das meine ich nicht. Ich habe das nur auf der HEUTE NEU Seite so. Überall sonst sind die Anhangseiten verlinkt.

    Und wenn ich die Plugins deaktiviere passiert sonst nichts?
    Plugins deaktiviert und wieder aktiviert. Nichts passiert!

    Ich würde ja auch alles neu machen, wenn es ginge, geht aber offenbar auch nicht.
    Und nun????

    Plugins deaktiviert und wieder aktiviert. Nichts passiert!

    Nein, du musst schon testen, ob sich nach dem Deaktivieren der Plugins etwas ändert. Das Ziel ist herauszufinden, ob das Problem von einem Plugin verursacht wird.

    Thread-Ersteller claireskreationen

    (@claireskreationen)

    Lieber Mario!

    Herzlichen Dank für deine Tipps. Es hat jetzt tatsächlich funktioniert. Es ist der Elementor gewesen. Ich bin so glücklich, dass meine Bilder jetzt wieder sichtbar sind!
    Was passiert jetzt, wenn ich ihn ganz lösche?

    Elementor ist ein Page-Builder, der zur Gestaltung der Webseiten eingesetzt wird. Deaktivierst du das Plugin dauerhaft, ändert sich (wenn du das Plugin vorher eingesetzt hast) vermutlich die Darstellung deiner Website.

    Ich benutze Elementor selber nicht, könnte mir aber vorstellen dass am Ende eine Plugin-Einstellung für die fehlenden Anhang-Seiten zuständig ist. Vielleicht fragst du mal in der Facebook-Gruppe Elementor Deutsch nach, ob die dir einen Tipp geben können?

    Thread-Ersteller claireskreationen

    (@claireskreationen)

    Bis jetzt hat sich nichts verändert. Funktioniert also immer noch.
    DANKE, DANKE, DANKE!
    Ob ich ihn verwendet habe oder nicht? Ehrlich, ich weiß es nicht. Wie gesagt learning by doing.

    Und nun kommen gleich noch ein paar Fragen.
    Neues Thema?

    Neues Thema = neuer Thread 😉

    Moderator Bego Mario Garde

    (@pixolin)

    Bitte demnächst auch dran denken, gelöste Probleme als „gelöst“ zu markieren. Dann brauchen die Helfenden hier nicht alle nachschauen und den kompletten Inhalt lesen, um zu erfahren dass sie hier gar nicht mehr helfen brauchen.

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)