• Gelöst nils

    (@nils0)


    Hallo,

    ich bin neu in der WordPress Gemeinschaft und wühle mich grad mit Hilfe von Büchern und Internet durch die Grundlagen. Wir bauen derzeit einen kleine Blog auf (Theme pro blogg) und haben in der rechten Sidebar eine Übersicht über die verfügabren Katagorien. Leider funktioniert der Link daraus nicht. Es erscheint beim Klicken auf eine Kategire stets eine Seite mit dieser Fehlermeldung:
    Parse error: syntax error, unexpected ‚while‘ (T_WHILE) in /www/htdocs/w01726c1/unser-spieleabend.de/wp-content/themes/pro-blogg/archive.php on line 16

    Woran kann das liegen? eigentlich sollte doch hier dann eine Liste der entsprechenden Blogeinträge erscheinen.

    Hier der Link zu unserer Seite, an der wir derzeit testen:

    Ich danke euch für eure Hilfe!

    • Dieses Thema wurde geändert vor 6 Jahren, 11 Monaten von nils.
Ansicht von 5 Antworten – 1 bis 5 (von insgesamt 5)
  • Ich habe das Theme mal rasch installiert und kann den Fehler nicht nachvollziehen. Habt ihr am Theme (speziell am Template archive.php) Änderungen vorgenommen?

    Thread-Starter nils

    (@nils0)

    Ich habe da nur eine Englische Phrase übersetzt. Mehr nicht. Mag sein, dass mir dabei ein Fehler unterlaufen ist. Kann ich die ursprüngliche Datei wiederherstellen?

    Ansonsten habe ich nur Plugins installiert.

    Wechsel mal auf ein Standard-Theme („Twenty …“) und entferne das Theme pro-blogg. Danach installierst du das Theme erneut und aktivierst es. Die Einstellungen sollten dabei erhalten bleiben. (Zur Sicherheit kannst du vorher ein Backup machen.)

    Thread-Starter nils

    (@nils0)

    So, ich habe jetzt mal die ursprüngliche archive.php wiederhergestellt und es funktioniert wieder.
    Mal schauen, ob jetzt irgendein anderer Fehler auftritt.

    Danke für die Hilfe!

    Viel Erfolg.

Ansicht von 5 Antworten – 1 bis 5 (von insgesamt 5)
  • Das Thema „Link zu Kategorien funktioniert nicht“ ist für neue Antworten geschlossen.