Support » Installation » Login auf Multisite funktioniert nicht

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Poste bitte mal den Inhalt der wp-config.php. Vor dem Absenden bitte aus der Antwort die Zeilen mit den Datenbank-Zugangsdaten und SALT-Keys löschen.

    Thread-Starter Flare

    (@alphaventum)

    Das ist der Inhalt der wp-config.php der Multisite.

    <?php
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://wordpress.org/support/article/editing-wp-config-php/
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define( 'DB_NAME', '— GELÖSCHT —' );
    
    /** MySQL database username */
    define( 'DB_USER', '— GELÖSCHT —' );
    
    /** MySQL database password */
    define( 'DB_PASSWORD', ' — GELÖSCHT — );
    
    /** MySQL hostname */
    define( 'DB_HOST', '— GELÖSCHT —' );
    
    /** Database Charset to use in creating database tables. */
    define( 'DB_CHARSET', 'utf8' );
    
    /** The Database Collate type. Don't change this if in doubt. */
    define( 'DB_COLLATE', '' );
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         '— GELÖSCHT —');
    define('SECURE_AUTH_KEY',  '— GELÖSCHT —');
    define('LOGGED_IN_KEY',    '— GELÖSCHT —');
    define('NONCE_KEY',        '— GELÖSCHT —');
    define('AUTH_SALT',        '— GELÖSCHT —');
    define('SECURE_AUTH_SALT', '— GELÖSCHT —');
    define('LOGGED_IN_SALT',   '— GELÖSCHT —');
    define('NONCE_SALT',       '— GELÖSCHT —');
    
    /**
     * Other customizations.
     */
    define('FS_METHOD','direct');
    define('FS_CHMOD_DIR',0755);
    define('FS_CHMOD_FILE',0644);
    define('WP_TEMP_DIR',dirname(__FILE__).'/wp-content/uploads');
    
    /**
     * Turn off automatic updates since these are managed externally by Installatron.
     * If you remove this define() to re-enable WordPress's automatic background updating
     * then it's advised to disable auto-updating in Installatron.
     */
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix = 'rk1i_';
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the documentation.
     *
     * @link https://wordpress.org/support/article/debugging-in-wordpress/
     */
    define( 'WP_DEBUG', false );
    
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    define( 'DOMAIN_CURRENT_SITE', ' — GELÖSCHT —  ‚ );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    
    /* That's all, stop editing! Happy publishing. */
    
    /** Absolute path to the WordPress directory. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', __DIR__ . '/' );
    }
    
    /* Multisite */
    define( 'WP_ALLOW_MULTISITE', true );
    
    /** Sets up WordPress vars and included files. */
    require_once ABSPATH . 'wp-settings.php';
    
    define( 'WP_AUTO_UPDATE_CORE', true );
    ?>

    Die Zeilen

    define('FS_METHOD','direct');
    define('FS_CHMOD_DIR',0755);
    define('FS_CHMOD_FILE',0644);
    define('WP_TEMP_DIR',dirname(__FILE__).'/wp-content/uploads');
    

    deuten darauf hin, dass du wahrscheinlich ein Problem mit den Dateirechten auf deinem Webserver hast. Das solltest du nochmal mit dem Support des Webhosters besprechen.

    Die Zeile

    /* Multisite */
    define( 'WP_ALLOW_MULTISITE', true );

    ist unter /* That's all, stop editing! Happy publishing. */

    gerutscht. Verschieb das bitte mal unter die Zeile

    define( 'WP_DEBUG', false );

     – reine Kosmetik, aber es sieht sauberer aus.

    Unterhalb des Blocks define( 'MULTISITE', true ); füg bitte mal folgenden Code ein:

    define('ADMIN_COOKIE_PATH', '/');
    define('COOKIE_DOMAIN', '');
    define('COOKIEPATH', '');
    define('SITECOOKIEPATH', '');

    Funktioniert es dann mit der Anmeldung in allen Blogs?

    Thread-Starter Flare

    (@alphaventum)

    Super, vielen Dank!
    Login hat geklappt!!

    Schön. Freut mich.
    Danke fürs „gelöst“ markieren.

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)