Support » Installation » Login Fehler nach „Umzug“ von Localhost zu Strato

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Mit welchem Programm hast du denn die wp-config.php bearbeitet?
    Wie bist du ansonsten beim Umzug vorgegangen? Die WordPress-Installation muss ja auch auf die neue Domain umgestellt werden.

    Thread-Starter federmichel

    (@federmichel)

    Die wp-config habe ich mit Notepad++ auf UTF-8 ohne BOM codiert. Der Umzug gestaltete etwas schwieriger. Ich habe verschieden Methoden getestet. Ich habe nachher per FileZille die WordPress Installation einfach rüber gezogen, habe die MySQL Datenbank exportiert und bei Strato importiert. Habe die Datenbank dann noch angepasst indem ich die Einträge mit Localhost auf die neue Domain umgeschrieben habe. Stand jetzt ist halt, dass die Startseite funktioniert, die Links aber noch nicht, da ich die htaccess geleert habe. /wp-login lässt sich aufrufen mit dem Anmeldefenster jedoch halt dieser Fehlermeldung.

    Die wp-config habe ich mit Notepad++ auf UTF-8 ohne BOM codiert.
    Das ist schon mal prima.

    Ich habe nachher per FileZille die WordPress Installation einfach rüber gezogen, habe die MySQL Datenbank exportiert und bei Strato importiert.
    Kann man so machen. Vielleicht nicht der einfachste Weg, aber OK.

    Habe die Datenbank dann noch angepasst indem ich die Einträge mit Localhost auf die neue Domain umgeschrieben habe.
    Wo hast du die Änderung vorgenommen? Nur in der Tabelle wp_options?

    WordPress speichert die URL auch als serialisierten Daten ab. Wenn du dann einfach eine Ersetzung vornimmst, stimmt die Länge der Datenfelder nicht mehr.

    Besser ist es, wenn du die URL mit Better Search Replace ersetzt.

    Stand jetzt ist halt, dass die Startseite funktioniert, die Links aber noch nicht, da ich die htaccess geleert habe.
    Einstellungen > Permalinks, speichern erstellt eine neue .htaccess

    /wp-login lässt sich aufrufen mit dem Anmeldefenster jedoch halt dieser Fehlermeldung.
    Schau mal, ob da vielleicht ein Tippfehler reingerutscht ist, z.B. typographische Anführungszeichen statt Hochkommas. Du kannst auch ausprobieren, die Plugins zu deaktivieren, um sie als Fehlerquelle auszuschließen. (Verzeichnis wp-content/plugins in wp-content/no.plugins umbenennen.

    Thread-Starter federmichel

    (@federmichel)

    Better Search Replace muss aber auf der WP Installation bei Strato eingesetzt werden, richtig? Da komme ich ja blöderweise nicht rein, weshalb ich die htacces auch nicht „neu befüllen“ kann.

    Deaktivierung von Plugins und auch Themes macht leider keinen Unterschied.

    Typografische Fehler kann ich auch keine finden.

    Bin echt ratlos im Moment. :/

    Poste doch mal den Inhalt der wp-config.php. Bitte verwende dabei den [code]-Button in der Formatierungszeile, um deinen Code zu formatieren. Die Zugangsdaten musst du natürlich unkenntlich machen.

    Aktiviere auch in der wp-config.php bitte den Debug-Modus:

    
    define( 'WP_DEBUG', true );
    

    Gibt es dann zusätzliche Fehlermeldungen?

    Thread-Starter federmichel

    (@federmichel)

    Inhalt der wp-config:

    <?php
    /**
     * Grundeinstellungen für WordPress
     *
     * Zu diesen Einstellungen gehören:
     *
     * * MySQL-Zugangsdaten,
     * * Tabellenpräfix,
     * * Sicherheitsschlüssel
     * * und ABSPATH.
     *
     * Mehr Informationen zur wp-config.php gibt es auf der
     * {@link https://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren}
     * Seite im Codex. Die Zugangsdaten für die MySQL-Datenbank
     * bekommst du von deinem Webhoster.
     *
     * Diese Datei wird zur Erstellung der wp-config.php verwendet.
     * Du musst aber dafür nicht das Installationsskript verwenden.
     * Stattdessen kannst du auch diese Datei als wp-config.php mit
     * deinen Zugangsdaten für die Datenbank abspeichern.
     *
     * @package WordPress
     */
    
    // ** MySQL-Einstellungen ** //
    /**   Diese Zugangsdaten bekommst du von deinem Webhoster. **/
    
    /**
     * Ersetze datenbankname_hier_einfuegen
     * mit dem Namen der Datenbank, die du verwenden möchtest.
     */
    define('DB_NAME', 'Name');
    
    /**
     * Ersetze benutzername_hier_einfuegen
     * mit deinem MySQL-Datenbank-Benutzernamen.
     */
    define('DB_USER', 'User');
    
    /**
     * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
     */
    define('DB_PASSWORD', 'Pass');
    
    /**
     * Ersetze localhost mit der MySQL-Serveradresse.
     */
    define('DB_HOST', 'Host');
    
    /**
     * Der Datenbankzeichensatz, der beim Erstellen der
     * Datenbanktabellen verwendet werden soll
     */
    define('DB_CHARSET', 'utf8mb4');
    
    /**
     * Der Collate-Type sollte nicht geändert werden.
     */
    define('DB_COLLATE', '');
    
    /**#@+
     * Sicherheitsschlüssel
     *
     * Ändere jeden untenstehenden Platzhaltertext in eine beliebige,
     * möglichst einmalig genutzte Zeichenkette.
     * Auf der Seite {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * kannst du dir alle Schlüssel generieren lassen.
     * Du kannst die Schlüssel jederzeit wieder ändern, alle angemeldeten
     * Benutzer müssen sich danach erneut anmelden.
     *
     * @since 2.6.0
     */
    … [gelöscht]
    
    /**#@-*/
    
    /**
     * WordPress Datenbanktabellen-Präfix
     *
     * Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
     * verschiedene WordPress-Installationen betreiben.
     * Bitte verwende nur Zahlen, Buchstaben und Unterstriche!
     */
    $table_prefix  = 'wp_';
    
    /**
     * Für Entwickler: Der WordPress-Debug-Modus.
     *
     * Setze den Wert auf „true“, um bei der Entwicklung Warnungen und Fehler-Meldungen angezeigt zu bekommen.
     * Plugin- und Theme-Entwicklern wird nachdrücklich empfohlen, WP_DEBUG
     * in ihrer Entwicklungsumgebung zu verwenden.
     *
     * Besuche den Codex, um mehr Informationen über andere Konstanten zu finden,
     * die zum Debuggen genutzt werden können.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define('WP_DEBUG', true);
    
    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß beim Bloggen. */
    /* That's all, stop editing! Happy blogging. */
    
    /** Der absolute Pfad zum WordPress-Verzeichnis. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Definiert WordPress-Variablen und fügt Dateien ein.  */
    require_once(ABSPATH . 'wp-settings.php');

    Das kommt im Debug Mode (war allerdings beim letzten mal wo ich geschaut habe weniger)

    Warning: fopen(F:/Xampp/htdocs/wp-content/plugins/mobile-menu/mobmenu.php): failed to open stream: No such file or directory in /mnt/web208/c2/24/59122424/htdocs/wp-includes/functions.php on line 4834 Warning: fread() expects parameter 1 to be resource, boolean given in /mnt/web208/c2/24/59122424/htdocs/wp-includes/functions.php on line 4837 Warning: fclose() expects parameter 1 to be resource, boolean given in /mnt/web208/c2/24/59122424/htdocs/wp-includes/functions.php on line 4840  Warning: Cannot modify header information - headers already sent by (output started at /mnt/web208/c2/24/59122424/htdocs/wp-login.php:1) in /mnt/web208/c2/24/59122424/htdocs/wp-login.php on line 421 Warning: Cannot modify header information - headers already sent by (output started at /mnt/web208/c2/24/59122424/htdocs/wp-login.php:1) in /mnt/web208/c2/24/59122424/htdocs/wp-login.php on line 434

    • Diese Antwort wurde geändert vor 4 Jahre, 6 Monaten von federmichel.
    • Diese Antwort wurde geändert vor 4 Jahre, 6 Monaten von federmichel.
    • Diese Antwort wurde geändert vor 4 Jahre, 6 Monaten von Bego Mario Garde. Grund: Code-Formatierung korrigiert
    Thread-Starter federmichel

    (@federmichel)

    Sorry, irgendwie klappt die Formatierung des Beitrags nicht…

    Thread-Starter federmichel

    (@federmichel)

    Keine Idee mehr?

    Better Search Replace muss aber auf der WP Installation bei Strato eingesetzt werden, richtig?

    Alternativ dieses Tool einsetzen:
    https://interconnectit.com/products/search-and-replace-for-wordpress-databases/

    Gruß, Torsten

    Die wp-config.php sieht soweit OK aus. Auf meine Frage, wie und wo die Ersetzung der URL vorgenommen wurde, habe ich leider keine Antwort bekommen (nicht antworten, aber nach neuen Ideen fragen 🙄). Ich würde den Umzug nochmal neu angehen, vielleicht auch einfach mit dem Plugin Duplicator.

    Thread-Starter federmichel

    (@federmichel)

    Danke für die Hilfe.
    Ich habe es jetzt anders, ohne WordPress gelöst.

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Das Thema „Login Fehler nach „Umzug“ von Localhost zu Strato“ ist für neue Antworten geschlossen.