Support » Allgemeine Fragen » Login funktioniert nicht mehr nach SSL Umstellung

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Moderator Bego Mario Garde

    (@pixolin)

    Hallo @filmfreek und willkommen im Forum,

    wie bist du denn bei der Umstellung vorgegangen?
    Hast du Änderungen an der Konfigurationsdatei wp-config.php vorgenommen?
    Mit welchem Editor?

    Alle Hilfestellungen haben bis dato nichts gebracht.
    Wirklich „alle“? Oder die, die du ausprobiert hast? Und welche waren das?
    Ich bin so schlecht im Raten …

    Filmfreek

    (@filmfreek)

    Hi, ich habe das SSL Zertifikat bei Strato aktiviert und das war’s. Also in dem Zusammenhang keine Änderungen an der WP-config.php vorgenommen. Sollte ich?

    Ich habe dann im Laufe der Fehlerursachenforschung immer mal wieder die WP-config auch angefasst, aber nichts hatte geholfen.
    Was ich alles getestet habe weiß ich gar nicht mehr. Habe aber nach jedem (Fehl)versuch die wp-config wieder auf den Ursprungszustand gebracht.

    Gruß und Danke!
    Benjamin

    Moderator Bego Mario Garde

    (@pixolin)

    Hm, nur durch Beauftragung des SSL-Zertifikats wird die Website eigentlich nicht auf SSL umgestellt. Dazu musst du normalerweise auch unter Einstellungen > Allgemein die URLs umstellen und mit einem Plugin die Links zu Mediendateien ersetzen. Ich weiß aber nicht, ob Strato inzwischen sogar ein Script hat, dass diese Änderungen für 1-Click-Installationen automatisch durchführt.

    Wenn du die wp-config.php „immer mal wieder […] angefasst“ hast, kann es sein, dass du sie mit einem ungeeigneten Editor bearbeitet hast, der die Datei im falschen Zeichenformat speichert – deshalb meine Frage nach dem Editor, auf die du leider nicht eingegangen bist. Versuch doch mal, die Datei mit Notepad++ oder dem Atom Editor abzuspeichern und achte darauf, dass die Zeichencodierung UTF-8 ohne Byte Order Mark (BOM) ist und vor dem einleitenden <?php keine Zeichen oder Leerzeilen enthält.

    Mit „ich hab nichts gemacht, aber alles was ich gemacht hab, hat nichts gebracht und eigentlich hab ich schon alles versucht, kann mich aber nicht erinnern, was das war“ ist es ein wenig schwierig, dir zu helfen. 😉

    Filmfreek

    (@filmfreek)

    Ich habe bis dato mit der App FTPManager gearbeitet. War die besten Möglichkeit, da leider kein Laptop in der Nähe war. Werde es aber nun mal mit Notepad++ versuchen und auf die Zeichencodierung achten

    Filmfreek

    (@filmfreek)

    Also ich habe nun Filezilla und Notepad++ genutzt um die UTF-8 Kodierung zu prüfen.
    Die steht bei wp-config, wp-login, wp-settings, admin und functions auf UTF-8. So wie es sein soll.

    Darüber hinaus habe ich die Ordner „plugins“ und „themes“ unabhängig voneinander umbenannt und jedes Mal einen Loginversuch gestartet.

    Ich komme jedoch immer noch nicht rein.

    Ich bin die letzten Tage durch diverse Foren durch und habe eben immer wieder die verschiedenen Lösungsansätze ausprobiert. Diese habe ich leider nicht dokumentiert und nun fehlt mir ein bisschen der Überblick.

    Moderator Bego Mario Garde

    (@pixolin)

    Hast du mal in der wp-config.php den Debug-Modus aktiviert?
    (Zeile define( 'WP_DEBUG', true ); oberhalb von oberhalb von /* That's all, stop editing! Happy blogging. */) Vielleicht werden dann hilfreiche Fehlermeldungen ausgegeben.

    Wenn du das Verzeichnis wp-content/plugins umbenannt hast und dich anmeldest, werden die Plugins alle deaktiviert. Die aktivieren sich aber nicht von selbst, wenn du dem Verzeichnis wieder den ursprünglichen Namen gibst. Wieso sind sie dann trotzdem aktiviert? Oder hast du wp-content/languages/plugins umbenannt? Das ist das Sprachverzeichnis für die Plugin-Übersetzungen.

    Filmfreek

    (@filmfreek)

    Habe es nun gelöst! In einem anderen Forum stand noch als Tipp in der wp-config.php das
    ?>
    am Ende und die darunter folgenden Leerzeichen zu entfernen.
    Das habe ich gemacht. Nochmal hochgeladen und komme nun wieder rein!

    Vielen Dank dennoch für deine Hilfe und schnelle Reaktion!

    Moderator Bego Mario Garde

    (@pixolin)

    Bliebe noch die Frage, wie es wohl da rein gekommen ist. 😉
    Dennoch vielen Dank für deine Rückmeldung. Ich markiere den Thread dann mal als „gelöst“.

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „Login funktioniert nicht mehr nach SSL Umstellung“ ist für neue Antworten geschlossen.