Support » Allgemeine Fragen » Login in Adminbereich nicht möglich

  • Gelöst sebastianmonzel

    (@sebastianmonzel)


    Hallo,

    ich habe hier das Problem, dass ein Login in den Adminbereich nicht möglich ist. Ich habe mittlerweile soweit durchdebuggt, dass ich weiß, dass der Username und das Passwort richtig verifiziert werden. An der Stelle jedoch versucht wird das SessionToken zu verifizieren, scheitert der Loginversuch.

    Hat jemand eine Idee?

    Debugging hochdrehen hat leider kein Licht ins Dunkel gebracht.
    Plugins haben wir bereits einmal alle deaktiviert.

    Gruß und dank,
    Sebastian

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Moderator PraetorIM

    (@praetorim)

    Hallo,

    hast Du kontrolliert, ob dein Browser so eingestellt ist, dass er Cookies akzeptiert?

    Ansonsten post einmal deine config.php-Datei (natürlich ohne die Passwörter etc. am Anfang).

    Hallo,

    dank dir für deine Antwort. Cookies werden grundsätzlich akzeptiert, jedoch mit der Prüfung des Sessiontokens direkt wieder gelöscht.

    Ich hab jetzt herausgefunden, dass das Sessiontoken beim Login nicht in die User-Metadaten-Tabelle persistiert wird. Warum kann ich jedoch noch nicht sagen. Die Datenbankverbindung funktioniert grundlegend. Ich hab öfter Deadlocks im Log gesehen im Zusammenhang mit den Cronjobs. Daraufhin habe diese in der wp-config deaktiviert. Das hat jedoch nichts gebracht.

    Wenn ich Debugging für die SQL-Statements aktiviere sehe ich auch dass versucht wird das Sessiontoken zu schreiben. Ich bin mir gerade nicht sicher ob es kurz davor scheitert, oder beim Einfügen des Sessiontokens.

    Gruß,
    Sebastian

    Ok. Ich hab die Lösung gefunden. Bei der Datenbank hat sich die Konfiguration geändert. Das autocommit wurde deaktiviert und somit wurden die Session-Tokens nicht mehr persistiert, da ein abschließendes COMMIT; gefehlt hat.

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Das Thema „Login in Adminbereich nicht möglich“ ist für neue Antworten geschlossen.