Support » Allgemeine Fragen » Login klappt nicht

  • Hallo

    Auf meiner Webseite https://minnerop.de/ steht seit einiger Zeit oben auf der Seite: WP_AUTO_UPDATE_CORE . Wenn ich versuche mit einzuloggen kommt er der Hinweis: Fehler: Cookies sind wegen einer unerwarteten Ausgabe gesperrt. Hilfe findest du in dieser Dokumentation oder wende dich an die Support-Foren.
    Wenn ich mich dann versuche von der Webseite (wp-login.php inzuloggen: FEHLER: Falscher Benutzername oder falsches Passwort.
    Wenn ich direkt über wp-admin.php kommt direkt eine leere Seite mit der Überschrift: WP_AUTO_UPDATE_CORE

    Ich vermute, dass ist passiert als ich vor längerer Zeit die automatischen Updates installiert habe. Damals wollte ich etwas abwarten, ob die Meldung weggeht. Leider habe ich das dann aus dann aus den Augen verloren.
    Auf meiner anderen Seite: wandern.minnerop.de klappt alles wunderbar.

    Kann mir jemand helfen?

    LG … Rainer

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Cookies sind wegen einer unerwarteten Ausgabe gesperrt.

    … bedeutet hier sowas wie „ich wollte für die Anmeldung einen Cookie setzen, aber statt dessen kam so eine blöde Fehlermeldung (oder sonst irgendein Text, der da nicht hingehört) dazwischen“. In deinem Fall ist das die Ausgabe von WP_AUTO_UPDATE_CORE. Das ist eigentlich eine Konstante, der in der wp-config.php ein Wert zugewiesen wird, um automatische Updates zu (de-)aktivieren.

    Poste doch mal den Inhalt deiner wp-config.php. Vor dem Absenden aber bitte im Beitrag die Zugangsdaten zur Datenbank und die SALT-Keys (diesen Zeichen-Salat) entfernen. Vielleicht können wir dann mehr dazu sagen.

    Thread-Ersteller rainerminnerop

    (@rainerminnerop)

    Hi

    Vielen Dank für die Antwort. Hier die wp-config.php

    ——————– cops ————————

    WP_AUTO_UPDATE_CORE<?php
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'DB*****90');
    
    /** MySQL database username */
    define('DB_USER', 'U******90');
    
    /** MySQL database password */
    define('DB_PASSWORD', '************');
    
    /** MySQL hostname */
    define('DB_HOST', 'rdbms.strato.de');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    'define('AUTH_KEY',         gelöscht
    'SECURE_AUTH_KEY',  '
    'LOGGED_IN_KEY',
    'NONCE_KEY',
    'AUTH_SALT',        
    'SECURE_AUTH_SALT', 
    'LOGGED_IN_SALT',   
    'NONCE_SALT',
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the Codex.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define('WP_DEBUG', false);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    
    define( 'WP_ALLOW_MULTISITE', true );
    
    define ('FS_METHOD', 'direct');
    
    /*define( 'WP_AUTO_UPDATE_CORE', 'minor' );*/

    ——————- copy ende —————————

    LG … Rainer

    Hallo,
    schau mal bitte in die erste Zeile von der wp-config.php:
    WP_AUTO_UPDATE_CORE<?php
    Die Zeile sollte mit
    <?php
    beginnen.
    Sichere bitte die wp-config.php lokal auf deinem Rechner und ändere das mit einem geeigneten Programmier-Editor (z. B. Notepad++)

    Noch ein Hinweis: Alle zusätzlichen Angaben in der wp-config.php müssen oberhalb von /* That’s all, stop editing! Happy blogging. */ eingegeben werden.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller rainerminnerop

    (@rainerminnerop)

    🙂

    Jau, vielen Dank, das war es. Ich musste allerdings auch das „WP_AUTO_UPDATE_CORE“ komplett rausnehmen. Wenn ich das <?php vorne anstelle, dann kommt : Diese Seite funktioniert nichtminnerop.de kann diese Anfrage momentan nicht verarbeiten.
    HTTP ERROR 500

    Ich habe dann auch das fehlende ?> ans Ende gemacht, half aber auch nichts. Erst als ich die Zeile mit dem auto_update komplett rausgenommen habe, lies sich die Seite wieder aufbauen. Wird die für irgendwas benötigt? In meinem anderen Web ist das nicht drin.

    Vielen Dank für die schnelle Hilfe! 🙂

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)